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Introduction

Welcome, and thank you for selecting Fortinet products.

The FortiVoice Enterprise Phone System enables you to completely control your organization’s
telephone communications. Easy to use and reliable, the FortiVoice phone system delivers
everything you need to handle calls professionally, control communication costs, and stay
connected everywhere.

The FortiVoice system includes all the fundamentals of enterprise-class voice communications,
with no additional cards to install. Auto attendants, voice messaging, ring groups, conferencing
and much more are built-in. In addition, the FortiVoice personal web portal lets your staff view
their call logs, configure and manage their own messaging, and access other features, such as
the operator console and the agent console.

This document describes how to configure and use the FortiVoice phone system. Only the
configuration procedures through the web-based manager are provided. For configuration
procedures through the CLI, see the FortiVoice CLI Reference.

This topic includes:

¢ Registering your Fortinet product
e Training

¢ Documentation

e Scope

e Conventions

Registering your Fortinet product

Before you begin, take a moment to register your Fortinet product at the Fortinet Technical
Support web site, https://support.fortinet.com.

Many Fortinet customer services, such as firmware updates and technical support,
require product registration.

For more information, see the Fortinet Knowledge Base article Registration Frequently Asked
Questions.

Customer service & technical support

Training

Fortinet Technical Support provides services designed to make sure that you can install your
Fortinet products quickly, configure them easily, and operate them reliably in your network.

To learn about the technical support services that Fortinet provides, visit the Fortinet Technical
Support web site at https://support.fortinet.com.

You can dramatically improve the time that it takes to resolve your technical support ticket by
providing your configuration file, a network diagram, and other specific information. For a list of
required information, see the Fortinet Knowledge Base article Technical Support Requirements.

Fortinet Training Services provides classes that orient you quickly to your new equipment, and
certifications to verify your knowledge level. Fortinet provides a variety of training programs to
serve the needs of our customers and partners world-wide.
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To learn about the training services that Fortinet provides, visit the Fortinet Training Services
web site at http://training.fortinet.com, or email them at training@fortinet.com.

Documentation

The Fortinet Technical Documentation web site, http://docs.fortinet.com, provides the most
up-to-date versions of Fortinet publications, as well as additional technical documentation such
as technical notes.

In addition to the Fortinet Technical Documentation web site, you can find Fortinet technical
documentation on the Fortinet Tools and Documentation CD, and on the Fortinet Knowledge
Base.

Fortinet Tools & Documentation CD

Many Fortinet publications are available on the Fortinet Tools and Documentation CD shipped
with your Fortinet product. The documents on this CD are current at shipping time. For current
versions of Fortinet documentation, visit the Fortinet Technical Documentation web site,
http://docs.fortinet.com.

Fortinet Knowledge Base

The Fortinet Knowledge Base provides additional Fortinet technical documentation, such as
troubleshooting and how-to-articles, examples, FAQs, technical notes, a glossary, and more.
Visit the Fortinet Knowledge Base at http://kb.fortinet.com.

Comments on Fortinet technical documentation

Please send information about any errors or omissions in this document to
techdoc@fortinet.com.

Scope
This document describes how to connect the FortiVoice unit to its web-based manager and CLI
and use the web-based manager to configure the FortiVoice unit.
This document does not cover commands for the command line interface (CLI).
Conventions

Fortinet technical documentation uses the following conventions:

¢ |P addresses

e (Cautions and notes

¢ Typographical conventions

e Command syntax conventions

IP addresses

To avoid publication of public IP addresses that belong to Fortinet or any other organization, the
IP addresses used in Fortinet technical documentation are fictional and follow the
documentation guidelines specific to Fortinet. The addresses used are from the private IP
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address ranges defined in RFC 1918: Address Allocation for Private Internets, available at
http://ietf.org/rfc/rfc1918.ixt?number-1918.

Cautions and notes

Fortinet technical documentation uses the following guidance and styles for cautions and notes.

A Warns you about commands or procedures that could have unexpected or undesirable results
including loss of data or damage to equipment.

Highlights useful additional information, often tailored to your workplace activity.

Typographical conventions

Fortinet documentation uses the following typographical conventions:

Table 1: Typographical conventions in Fortinet technical documentation

Convention Example

Button, menu, text From Minimum log level, select Notification.

box, field, or check

box label

CLI input config system dns

set primary <address_ipv4>
end

CLI output FGT-602803030703 # get system settings
comments > (null)
opmode > nat

Emphasis HTTP connections are not secure and can be
intercepted by a third party.

File content <HTML><HEAD><TITLE>Firewall
Authentication</TITLE></HEAD>
<BODY><H4>You must authenticate to use
this service.</H4>

Hyperlink Visit the Fortinet Technical Support web site,
https://support.fortinet.com.

Keyboard entry Type a name for the remote VPN peer or client, such as
Central_Office_1.

Fortinet Technologies Inc. Page 11 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/
http://ietf.org/rfc/rfc1918.txt?number-1918
https://support.fortinet.com

Table 1: Typographical conventions in Fortinet technical documentation

Navigation Go to Monitor > Status > DHCP.

Publication For details, see the FortiGate Administration Guide.

Command syntax conventions

The command line interface (CLI) requires that you use valid syntax, and conform to expected
input constraints. It will reject invalid commands.

Brackets, braces, and pipes are used to denote valid permutations of the syntax. Constraint
notations, such as <address_ipv4>, indicate which data types or string patterns are
acceptable value input.

Table 2: Command syntax notation

Convention Description

Square brackets [ ] |A non-required word or series of words. For example:
[verbose {1 | 2 | 3}]

indicates that you may either omit or type both the verbose
word and its accompanying option, such as:

verbose 3
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Table 2: Command syntax notation

Angle brackets < >

A word constrained by data type.

To define acceptable input, the angled brackets contain a
descriptive name followed by an underscore (_) and suffix
that indicates the valid data type. For example:

<retries_int>
indicates that you should enter a number of retries, such as 5.
Data types include:

e <xxx_name>: A name referring to another part of the
configuration, such as policy_A.

o <xxx_index>: An index number referring to another part
of the configuration, such as O for the first static route.

o <xxx_pattern>: A regular expression or word with wild
cards that matches possible variations, such as
*@example.com to match all email addresses ending in
@example.com.

o <xxx_TFqdn>: A fully qualified domain name (FQDN), such
as mail .example.com.

e <xxx_email>: An email address, such as
admin@mai l _.example.com.

e <xxx_url>: A uniform resource locator (URL) and its
associated protocol and host name prefix, which together
form a uniform resource identifier (URI), such as
http://www.fortinet.com/.

e <xxX_1ipv4>: An IPv4 address, such as 192.168.1.99.

e <xxx_v4dmask>: A dotted decimal IPv4 netmask, such as
255.255.255.0.

e <xxx_ipvdmask>: A dotted decimal IPv4 address and
netmask separated by a space, such as
192.168.1.99 255.255.255.0.

o <xxx_ipv4/mask>: A dotted decimal IPv4 address and
CIDR-notation netmask separated by a slash, such as such
as 192.168.1.99/24.

e <XXX_1IpVv6>: A colon( : )-delimited hexadecimal IPv6
address, such as
3f2e:6a8b:78a3:0d82:1725:6a2f:0370:6234.

e <xxx_v6mask>: An IPv6 netmask, such as /96.

o <xxx_ipv6émask>: An IPv6 address and netmask
separated by a space.

® <xxx_str>: A string of characters that is not another data
type, such as P@sswOrd. Strings containing spaces or
special characters must be surrounded in quotes or use
escape sequences.

e <xxx_int>: An integer number that is not another data
type, such as 15 for the number of minutes.
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Table 2: Command syntax notation

Curly braces { } A word or series of words that is constrained to a set of
options delimited by either vertical bars or spaces.

You must enter at least one of the options, unless the set of
options is surrounded by square brackets [ ].

Options Mutually exclusive options. For example:
delimited by | o Jble | disable}

vertical bars |
indicates that you must enter either enable or disable, but
must not enter both.

Options Non-mutually exclusive options. For example:
delimited by _
spaces {http https ping snmp ssh telnet}
indicates that you may enter all or a subset of those options, in

any order, in a space-delimited list, such as:
ping https ssh

To change the options, you must re-type the entire list. For
example, to add snmp to the previous example, you would

type:
ping https snmp ssh
If the option adds to or subtracts from the existing list of

options, instead of replacing it, or if the list is
comma-delimited, the exception will be noted.
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Connecting to the FortiVoice System

After physically installing the FortiVoice unit, you need to connect to its management tools to
configure, maintain, and administer the unit. You also need to inform your phone users on how
to access the user web portal and use the FortiVoice features.

This topic includes:

¢ Connecting to the web-based manager or CLI
e Setting up the system using the wizard

e Testing the setup

¢ Configuring setups for phone users

Connecting to the web-based manager or CLI

There are two methods to connect to the FortiVoice unit:

¢ use the web-based manager, a graphical user interface (GUI), from within a web browser

e use the command line interface (CLI), an interface similar to DOS or UNIX commands, from a
Secure Shell (SSH) or Telnet terminal

Access to the CLI and/or web-based manager is not yet configured if:

* you are connecting for the first time
¢ you have just reset the configuration to its default state
* you have just restored the firmware

In these cases, you must access either interface using the default settings.

If the above conditions do not apply, access the web Ul using the IP address, administrative
access protocol, administrator account and password already configured, instead of the
default settings.

After you connect, you can use the web-based manager or CLI to configure basic network
settings and access the CLI and/or web-based manager through your network. However, if you
want to update the firmware, you may want to do so before continuing. See “System
Information widget” on page 23.

Until the FortiVoice unit is configured with an IP address and connected to your network, you
may prefer to connect the FortiVoice unit directly to your management computer, or through a
switch, in a peer network that is isolated from your overall network. However, isolation is not
required.

This topic includes:

¢ Connecting to the web-based manager
¢ Connecting to the CLI
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Connecting to the web-based manager

To

connect to the web-based manager using its default settings, you must have:

a computer with an RJ-45 Ethernet network port

a web browser such as Microsoft Internet Explorer version 6.0 or greater, or a recent version
of Mozilla Firefox

a crossover network cable

Table 3: Default settings for connecting to the web-based manager

Network Interface port1

URL https://192.168.1.99/admin

Administrator Account admin

Password (none)

To
1.

Fortinet Technologies Inc.

connect to the web-based manager

On your management computer, configure the Ethernet port with the static IP address
192.168.1.2 with a netmask of 255.255.255.0.

Using the Ethernet cable, connect your computer’s Ethernet port to the FortiVoice unit’s
port1.

Start your browser and enter the URL https://192.168.1.99/admin. (Remember to include the
“s” in https://.)

To support HTTPS authentication, the FortiVoice unit ships with a self-signed security
certificate, which it presents to clients whenever they initiate an HTTPS connection to the
FortiVoice unit. When you connect, depending on your web browser and prior access of the
FortiVoice unit, your browser might display two security warnings related to this certificate:

¢ The certificate is not automatically trusted because it is self-signed, rather than being
signed by a valid certificate authority (CA). Self-signed certificates cannot be verified with
a proper CA, and therefore might be fraudulent. You must manually indicate whether or
not to trust the certificate.

¢ The certificate might belong to another web site. The common name (CN) field in the
certificate, which usually contains the host name of the web site, does not exactly match
the URL you requested. This could indicate server identity theft, but could also simply
indicate that the certificate contains a domain name while you have entered an IP
address. You must manually indicate whether this mismatch is normal or not.

Both warnings are normal for the default certificate.

Verify and accept the certificate, either permanently (the web browser will not display the
self-signing warning again) or temporarily. You cannot log in until you accept the certificate.

For details on accepting the certificate, see the documentation for your web browser.

In the Name field, type admin, then click Login. (In its default state, there is no password for
this account.)

Login credentials entered are encrypted before they are sent to the FortiVoice unit. If your
login is successful, the web Ul appears. To continue by updating the firmware, see “System
Information widget” on page 23. Otherwise, to continue by following the configuration
wizard.
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Connecting to the CLI

Using its default settings, you can access the CLI from your management computer in two
ways:

¢ alocal serial console connection
e an SSH connection, either local or through the network
To connect to the CLI using a local serial console connection, you must have:

e a computer with a serial communications (COM) port

¢ the RJ-45-t0-DB-9 serial or null modem cable included in your FortiVoice package
¢ terminal emulation software, such as HyperTerminal for Microsoft Windows

To connect to the CLI using an SSH connection, you must have:

¢ a computer with an RJ-45 Ethernet port

e acrossover Ethernet cable

e an SSH client, such as PuTTY

Table 4: Default settings for connecting to the CLI by SSH

Network Interface port1

IP Address 192.168.1.99
SSH Port Number 22
Administrator Account admin
Password (none)

_ If you are not connecting for the first time, nor have you just reset the configuration to its
\ | default state or restored the firmware, administrative access settings may have already been
VY configured. In this case, access the CLI using the IP address, administrative access protocol,
administrator account and password already configured, instead of the default settings.

For more information on available CLI commands, see the FortiVoice CLI Reference.

| The following procedure uses Microsoft HyperTerminal. Steps may vary with other terminal
VY emulators.

To connect to the CLI using a local serial console connection

1. Using the RJ-45-t0-DB-9 or null modem cable, connect your computer’s serial
communications (COM) port to the FortiVoice unit’s console port.

Verify that the FortiVoice unit is powered on.
On your management computer, start HyperTerminal.
On Connection Description, enter a Name for the connection and select OK.

a s Db

On Connect To, from Connect using, select the communications (COM) port where you
connected the FortiVoice unit.

Select OK.
Select the following Port settings and select OK.

No
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10.

To
1.
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Bits per second 9600

Data bits 8
Parity None
Stop bits 1
Flow control None

Press Enter.
The terminal emulator connects to the CLI and the CLI displays a login prompt.

Type admin and press Enter twice. (In its default state, there is no password for this
account.)

The CLI displays a prompt, such as:
FortiVoice #

Type admin and press Enter twice. (In its default state, there is no password for this
account.)

The CLI displays the following text:
Type ? for a list of commands.

You can now enter commands. For information about how to use the CLI, including how to
connect to the CLI using SSH or Telnet, see the FortiVoice CLI Reference.

/  The following procedure uses PuTTY. Steps may vary with other SSH clients.

connect to the CLI using an SSH connection

On your management computer, configure the Ethernet port with the static IP address
192.168.1.2 with a netmask of 255.255.255.0.

Using the Ethernet cable, connect your computer’s Ethernet port to the FortiVoice unit’s
port1.

Verify that the FortiVoice unit is powered on.

On your management computer, start your SSH client.
In Host Name (or IP Address), type 192.168.1.99.

In Port, type 22.

From Connection type, select SSH.

Select Open.

The SSH client connects to the FortiVoice unit.

The SSH client may display a warning if this is the first time you are connecting to the
FortiVoice unit and its SSH key is not yet recognized by your SSH client, or if you have
previously connected to the FortiVoice unit but it used a different IP address or SSH key. If
your management computer is directly connected to the FortiVoice unit with no network
hosts between them, this is normal.

Click Yes to verify the fingerprint and accept the FortiVoice unit’s SSH key. You cannot log in
until you accept the key.

The CLI displays a login prompt.
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10.Type admin and press Enter twice. (In its default state, there is no password for this
account.)

The CLI displays the following text:
Type ? for a list of commands.

You can now enter commands. For information about how to use the CLI, including how to
connect to the CLI using SSH or Telnet, see the FortiVoice CLI Reference.

Setting up the system using the wizard

Y

The FortiVoice unit’s Configuration Wizard leads you through required configuration steps,
helping you to quickly set up your FortiVoice system. Once the setup is complete, you can make
phone calls through the FortiVoice unit.

While all settings configured by the Configuration Wizard can also be configured through the
web-based manager, the wizard presents each setting in the necessary order.

The wizard is a reusable tool and you can modify the configuration settings. Each time you click
the Next button, the configuration is saved.

To start the wizard, open the web-based manager in a browser and click Wizard in the
top-right button row.

Testing the setup

Y

After a configuration through the Configuration Wizard, you can connect a SIP phone to your
VolP network and make an internal, external, or office peer test call.

If the SIP phone and the FortiVoice unit (PBX) are on different subnets, proper routing should
be set to make them reachable

If you make a office peer test call, make sure that your FortiVoice unit and the peer office PBX
are mutually registered. For more information, see “Configuring office peers” on page 192.

Depending on the phone you use, the procedure to connect the phone may vary. Refer to the
phone user manuals for instructions.

Generally, you need to configure the following on the phone after powering it up and connecting
it to the network:

¢ Enter the IP address of the phone if it is not DHCP-enabled.

e Enter the SIP server IP address and port number (5060 by default) of the FortiVoice unit. You
can find the SIP serve IP by the Configuration Wizard and going to System Setting > Network
Setting.

e Enter the extension number and SIP password you have configured and make sure the
extension is enabled. You can find the information by opening the Configuration Wizard and
going to Extension > Import/Add/Edit and double-click an extension.

If you have not imported or added any extensions, do it first. For more information, see
“Configuring IP extensions” on page 135. The extension number on the FortiVoice unit and
your phone should match.
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Configuring setups for phone users

The FortiVoice system provides a user web portal where phone users can view their call logs,
configure and manage their own messaging, and access other features.

This section contains information that you may need to inform or assist your phone users so
that they can use the FortiVoice features.

This information is not the same as what is included in the help for FortiVoice user web portal. It
is included in this guide because:

Phone users need to know how to access the FortiVoice user web portal and its online help.
Phone users need to know the feature codes they can use on the phones.

Phone users need to know how to change the voicemail password on the web portal and on
the phone.

Phone users may be confused if they try to enable a feature that you disabled (such as call
waiting or do not disturb).

You may need to tailor some information to your network or phone users.

This topic includes:

Accessing the user web portal
Changing the user PIN

Receiving and sending fax

Using the operator console

Setting user privileges and preferences
Setting the feature codes

Accessing the user web portal

FortiVoice user web portal is a special web site located on a FortiVoice unit. This web portal
allows a phone user to:

check your voicemail including playing, deleting, or saving the voicemails
receive and send fax

Use the agent console to manage queue calls

Use the operator console to process company calls

check your call record for received, placed, or missed calls

check your recorded calls including playing, deleting, or saving the voicemails
view your corporate phone directory

check the feature codes that you can dial on your phone keypad
configure your extension according to your preferences

manage calls

configure phone profiles

customize sound files

Several modern, popular web browsers are supported, so you can use FortiVoice user web
portal through the web browser of your choice.

Fortinet Technologies Inc.
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For the phone users to access the web portal, you need to inform phone users of:

¢ the web portal URL (same with that of the FortiVoice unit except without Zadmin in the end)
¢ their extension numbers, and
e the default user PINs.

With this information, a user can enter the URL in the browser’s location or address bar. The
user can then log into the portal using the extension number as user name and the user PIN as
password.

Once they access the web portal, phone users can click the Help button to learn how to use the
portal.

For information on adding extension numbers and user PINs, see “Configuring IP extensions”
on page 135.

Changing the user PIN

Inform the phone users how to change the default user PIN on the phone. The information for
changing the user PIN on the web portal is in the online help of the portal.

Receiving and sending fax

Inform the phone users that they can receive and send faxes on the user web portal. For more
information, see “Configuring fax” on page 262.

Using the operator console

If you have enabled the operator role for an extension, inform the extension user so that the user
can process corporate calls on the user web portal. For more information, see “Operator role”
on page 246.

Setting user privileges and preferences

The call features each phone user can use is controlled by the user privilege and preferences
settings associated with the user’s extension. You may need to inform users of the features that
they can use.

For information, see “Configuring user privileges” on page 245 and “Setting extension user
preferences” on page 156.

Setting the feature codes

By default, the FortiVoice unit has feature codes for users to access certain features by dialing
the codes. You can go to Service > Feature Code > Feature Code and double-click a feature
name to modify its code and description, but that does not change the mapping between the
code and the feature.

For details, see “Modifying feature access codes” on page 273.
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Monitoring the FortiVoice System

The Status menu displays system usage, log messages, reports, and other status-indicating
items.

This topic includes:

¢ Viewing overall system status
¢ Viewing phone system status
¢ Viewing call/fax storage

¢ Viewing call records

¢ \iewing generated reports

¢ Viewing log messages

¢ Viewing phone directories

Viewing overall system status

The Status menu displays system status, most of which pertain to the entire system, such as
service status and system resource.

This topic includes:

¢ Viewing the dashboard
¢ Viewing the Call Statistics
¢ Using the CLI Console

Viewing the dashboard
Status > Dashboard displays first after you log in to the web-based manager. It contains a
dashboard with widgets that each indicates performance level or other statistics.

By default, widgets display the serial number and current system status of the FortiVoice unit,
including uptime, system resource usage, license information, service status, firmware version,
system time, and statistics history.

To view the dashboard, go to Status > Dashboard > Dashboard.
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Figure 1: Monitor system status

Iuodate kenze.. ]

WM kst

@
]

Hatel fanagement
Breore [ 10 dowed

Statistics History [-[]e]=]x]

.
Cal by By = | ® BwOwn %

Call bry Dy (Pumber Of Calls)

(I
i
|
ii I l
N LW % N U fe W T
LI T T L T T

The dashboard is customizable. You can select which widgets to display, where they are
located on the tab, and whether they are minimized or maximized.

To move a widget, position your mouse cursor on the widget’s title bar, then click and drag the
widget to its new location.

To show or hide a widget, in the upper left-hand corner, click Add Content, then mark the check
boxes of widgets that you want to show.

Options vary slightly from widget to widget, but always include options to close or
minimize/maximize the widget.

Figure 2: A minimized widget on the dashboard
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System Information widget

The System Information widget displays the serial number and basic system statuses such as
the firmware version, system time, and up time.

In addition to displaying basic system information, the System Information widget lets you
change the firmware. To change the firmware, click Update for Firmware version. For more
information, see “Installing firmware” on page 294.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add
Content, and mark the check box for the widget.

License Information widget

The License Information widget displays the last queried license statuses for the number of
extensions supported (if you use FortiVoice VM), hotel management, and call center (if you have
purchased these options).

Depending on the license you have purchased, when you first access the FortiVoice web-based
manager, you need to upload the license to enable the functions you need.
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To upload the license file, first place the license file to your management computer, then click
Update license and browse for the license file.

A full VMware license is required to upload a hotel management license onto the FortiVoice VM.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add
Content, and mark the check box for the widget.

Service Status widget

The Service Status widget displays the number of current calls, extension status, trunk status,
and device connection status.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add
Content, and mark the check box for the widget.

Device (200D-T and 2000E-T2 models only) displays the connection status of the FortiVoice
physical ports:

e Connected: The port is connected to a device.

e Disconnected: The port is not connected to any device and is ready for use.
e Alarmed: The port has an error and is not usable.

e QOccupied: The port is being used.

System Resource widget

The System Resource widget displays the CPU, memory, and disk space usage. It also displays
the system load and current number of IP sessions.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add
Content, and mark the check box for the widget.

The system resources history can also be viewed in this widget by clicking History. The system
resources history contains four graphs. Each graph displays readings of one of the system
resources: CPU, memory, IP sessions, and network bandwidth usage. Each graph is divided by
a grid.

Statistics History widget

The Statistics History widget contains charts that summarize the number of calls in each time
period that the FortiVoice unit recorded.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add
Content, and mark the check box for the widget.

Also see “Viewing the Call Statistics” on page 25.

System Command widget

The System Command widget lets you restart, shut down, or reload the configuration of the
FortiVoice unit.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add
Content, and mark the check box for the widget.

Before rebooting or halting the FortiVoice unit, consider notifying your phone users, as it could
result in temporary interruptions to connectivity.
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Reloading allows the FortiVoice unit to reload its configuration from its last saved version, and
log you out. Any changes that were in progress but not yet saved, such as GUI pages that were
not applied or CLI commands where you had not yet entered next or end, are lost. If you want
to continue configuring the FortiVoice unit, refresh your browser and log in again.

Recent Calls widget

The Recent Calls widget displays the calls processed by the FortiVoice unit, including phone
numbers, call directions, call starting time and duration, and call status.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add
Content, and mark the check box for the widget.

The maximum call records shown is 8.

Viewing the Call Statistics
The Call Statistics tab contains summaries of the number of calls by time and direction that the
FortiVoice unit recorded.

To view call statistics, go to Status > Dashboard > Call Statistics.

Using the CLI Console

Go to Status > Dashboard > Console to access the CLI without exiting from the web-based
manager.

You can click the Open in New Window at the bottom of the page to move the CLI Console into
a pop-up window that you can resize and reposition.

For more information about CLI commands, see the FortiVoice CLI Reference.

Viewing phone system status

Status > Phone System displays all the ongoing phone calls, parked calls, conference calls,
extensions, trunks, call queues, DHCP clients, and unassigned phones.

This topic includes:

¢ Viewing active calls

¢ Viewing parked calls

¢ Viewing conference calls

¢ Viewing extension status

¢ Viewing hot desking configurations
¢ Viewing trunk status

¢ Viewing unassigned phones

¢ Viewing DHCP client list

Viewing active calls

Status > Phone System > Active Calls displays all the ongoing phone calls in realtime, including
the callers and receivers, the trunks through which phone calls are connected, the call status,
and the call duration.

You can stop a phone call by clicking the Hang up icon.
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The call statuses include:

* Ringing: The receiver’s phone is ringing.

e Connected: Callers are connected. The voice channel is established.
e Voicemail: The call goes to the voicemail.

Viewing parked calls

A parked call is similar to a call that is on hold, except that the parked call can then be picked
up from any extension.

To view parked calls, go to Status > Phone System > Parked Calls.

For more information on call parking, see “Configuring call parking” on page 261.

Viewing conference calls

Status > Phone System > Conference displays the conference call records, including the name
of the conference call, the extension number of the call, the displayed name of the caller, and
the call duration.

You can stop a caller from attending the conference call by selecting the caller and clicking the
Kick icon.

For more information, see “Configuring conference calls” on page 250.

Viewing extension status

Status > Phone System > Extensions displays all the extensions in realtime, including their

statuses, IDs, numbers, display names, types, IPs for SIP extensions, phone information, and if
it has any auxiliary devices.

For more information, see “Configuring Extensions” on page 135.

GUI field Description

Category/Status Select to view the extensions by categories. Each category has its
corresponding statuses.

e All: Displays extensions in all statuses.

e Active: Can display extensions in each of the following statuses once
selected:

¢ [dle: The extension is not in use.

® |n Use: The extension is in use.

¢ Busy: The extension is busy.

* Ringing: The extension is ringing.

® On Hold: The extension has an on-hold call.
e Other: The status other than the above.

¢ Jnactive: Can display extensions in each of the following statuses once
selected:

* Not registered: The extension is not registered with the FortiVoice
unit and is not in service.

e Unavailable: The extension is not reachable.
e Disable: Displays all disabled extensions.
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Deregister

Status
User ID
Number

Display Name

Type

IP

Phone Info

Auxiliary device

Select an extension and click this icon to remove the extension assigned to
the phone.

The status of the extension. See “Category/Status” on page 26.
This is the system-generated ID based on the extension number.
The extension number.

The name displaying on the extension. This is usually the name of the
extension user.

The type for this extension, such as SIP or analog (for the FortiVoice
200D-T and 2000E-T2 models).

The link to the IP address of the phone using the extension number. Click
to interface with the extension and configure it remotely by entering the
login information. See “IP” on page 142.

The phone brand and model.

Devices added to the extension. This is known as SIP forking. For more
information, see “Configuring IP extensions” on page 135.

Viewing hot desking configurations

Status > Phone System > Hot Desking displays all of the extensions configured for hot desking,

including:

e Status: the status of the hot desking extension: logged in or logged out.

e User ID: the system-generated ID for the hot desking extension.

e Number: the hot desking extension number.

¢ Display Name: the name displayed on the hot desking extension.

e Host Device: the extension number or MAC address (for a unassigned phone) of the phone
that a hot desking user logs into.

e [ast Login: the last login time at the host device.

e Expiry: the login expiry time.

Hot desking enables users to log into another phone. However, unlike using Follow Me or Call
Forwarding which simply redirect a user's calls to another user’s phone, hot desking takes total
control of another phone by applying all of the user's own phone settings to that phone until the
user logs out. Each user can log into another phone by pressing *11 and enter his extension
number and user PIN following the prompts. To log out, a user can press *12.

If the two phones use different programmable phone keys, the host phone will reboot. For
information on programmable phone keys, see “Configuring phone profiles” on page 121.

For information on configuring hot desking, see “Hot-desking” on page 248.

Viewing trunk status

Status > Phone System > Trunks displays all the trunks in realtime, including their names, IP
addresses, types, status, and registration/connection status with the VolP or PSTN service

provider.
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The trunk statuses include:

e Not registered: The trunk is not registered with the VoIP or PSTN service provider and is not
in service.

* In service: The trunk is registered with the VolP or PSTN service provider and is in service.
® Unavailable: The trunk is not reachable.

e Alarm detected: There is a problem with the trunk.

e  Admin down: The trunk is disabled.

® Unmonitored: The trunk is not monitored.

When you click the IP address of a SIP extension, you can interface with the extension and
configure it remotely.

Registration/Connection indicates if a trunk has been registered with or connected to the VolP
or PSTN service provider.

You can stop a phone call by clicking the Hang up icon.

For more information, see “Configuring Trunks” on page 177.

Viewing unassigned phones

Status > Phone System> Unassigned Phone lists the supported phones auto-discovered by the
FortiVoice unit but not assigned to any extensions yet.

Once an unassigned phone connects to the FortiVoice unit and is auto-discovered, the
FortiVoice unit assigns an IP address to the phone and sends the basic PBX setup information
to it.

After assigning an extension to the phone, the extension’s full configuration file will be sent to
the phone if the auto-provisioning option is selected in the user privilege applied to the
extension. For details, see “Setting up local extensions” on page 135 and “Configuring user
privileges” on page 245.

Fortinet Technologies Inc. Page 28 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Figure 3: Unassigned phones
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Description

Assign to new extension: Select an unassigned phone and click this
option to add an extension and assign this client to the user at the
same time. The phone record disappears from the Unassigned
Phone list. For more information, see “To assign a new extension
user to an unassigned phone” on page 29.

Assign to FortiFone-870i device: Select an unassigned FortiFone
870i and click this option to add an extension and assign this client
to the user at the same time. The phone record disappears from the
Unassigned Phone list. For more information, see “To assign a new
extension user to an unassigned phone” on page 29.

Apply to existing extension: Select an unassigned phone and click
this option to assign this client to an existing user. The phone record
disappears from the Unassigned Phone list. For more information,
see “To assign an existing extension user to an unassigned phone”
on page 29.

Select to save the unassigned phone list in csv format.

The Media Access Control address (MAC address) of the unassigned
phone.

The IP address of the unassigned phone assigned by the FortiVoice unit.

The brand name of the unassigned phone.

The phone brand and model.

To assign a new extension user to an unassigned phone

1. Go to Status > Phone System > Unassigned Phone.

. Select an unassigned phone.

2
3. Click Action and select Assign to new extension.
4

. Configure the extension associated with the unassigned phone following “Configuring IP
extensions” on page 135.

5. Click Create.

To assign an existing extension user to an unassigned phone

1. Go to Status > Phone System > Unassigned Phone.

2. Select an unassigned phone.

o o
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Click Action and select Assign to existing extension.
Select the extension to associate with the unassigned phone.
Click Apply to existing extension.
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Viewing DHCP client list

Status > Phone System > DHCP displays all the DHCP-enabled devices connected to the
FortiVoice unit in realtime.

Once a DHCP-enabled phone connects to the FortiVoice unit and is auto-discovered, the
FortiVoice unit assigns an IP address to the phone and sends the basic PBX setup information
to it.

For the supported DHCP-enabled phone to connect to the FortiVoice unit:

¢ In the FortiVoice DHCP server configuration, select DHCP option 66 (an advanced option on
the web-based manager) and include the IP address of the FortiVoice interface connected to
the same network as the SIP phones to be auto-provisioned. For more information, see
“Configuring DHCP server” on page 47.

DHCP server option 66 identifies a TFTP server and includes the IP address of the TFTP
server and downloads the TFTP server identity to the device that gets an IP address from the
DHCP server. DHCP option 66 is defined in RFC 2132.

e |f using your own DHCP server, set the DHCP server option 66 to the FortiVoice unit's TFTP
server (Opt66) value. For more information, see “Configuring DHCP server” on page 47.

e |f the FortiVoice unit and the SIP phone with an IP assigned by a DHCP server are on
different subnets, proper route should be set to make them reachable.

Figure 4: DHCP client list

E# Export =)
o Page 1 /2| » M | Records per page: 25 w
Interface Vendor Extension Configuration Status
00:30:47:74:5d: 11 port1 172.20.180.172 2014-02-26 08:21:03 FortiFone-110 7508 Not assigned
00:0f:81.4a:29:c5 port1 172.20.190.229 2014-02-2519:16:37 Generic 7528 Mot assigned
00:0f:34:ec:b.cf porti 172.20.190.228 2014-02-25 180723 Generic 7819 Misconfigured
00:0b:82:0e:f8:b4 port1 17220190218 2014-02-25 05:20:01 Grandstream 7417 OK
GUI field Description
Export Select to save the DHCP client list in csv format.
MAC The Media Access Control address (MAC address) of the DHCP client.
Interface The FortiVoice unit port to which the DHCP client connects. For
information on FortiVoice interfaces, see “Configuring network settings”
on page 39.
IP The IP address of the DHCP client assigned by the FortiVoice DHCP
server.
Expired The expiration time of the DHCP client IP address.
Vendor The brand names of the DHCP clients.
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Extension When a DHCP-enabled device connects to the FortiVoice unit, the
FortiVoice unit assigns a temporary ID to the device if it is a supported
device. If an extension number is assigned to the phone, the extension
number appears. For information on assigning extensions, see “Viewing
unassigned phones” on page 28.

Configuration * OK: The DHCP client is assigned to a new or an existing extension
Status user.

¢ Not assigned: The DHCP client is not assigned to a new or an
existing extension user.

e Misconfigured: The DHCP client’s configuration has errors.

Viewing call/fax storage

Status > Storage displays the recorded calls, faxes, archived faxes, and faxes in queue.
This topic includes:

¢ Playing recorded calls

¢ Viewing current fax accounts
¢ Viewing archived faxes

¢ Viewing fax queues

Playing recorded calls

The Recorded Calls tab lists the calls recorded by the FortiVoice unit.

To listen to a call, go to Status > Storage > Recorded Calls and select a call record folder to
open the archived call files. Select a call file and click the Play button.

To save a recorded call, go to Status > Storage and select a call record folder to open the
archived call files. Select a call file and click the Download button.

To search the locally archived calls, click Search.

For information on configuring recording calls, see “Recording calls” on page 252.

Viewing current fax accounts

The Fax tab lists the fax accounts created on the FortiVoice unit. For more information about
creating fax accounts, see “Configuring fax” on page 262.

To view fax accounts, go to Status > Storage > Fax. The fax accounts are listed with their
names, numbers, display names, storage sizes, and faxes stored.

You can double-click a fax account and view the detailed information on the faxes it stores. You
can also click Download PDF to save a fax.

Viewing archived faxes

The Fax Archive tab lists the faxes sent and received through the FortiVoice unit. For more
information about fax, see “Configuring fax” on page 262.

To view fax configurations, go to Status > Storage > Fax Archive. The fax configurations are
listed with their names, numbers, storage sizes, and faxes stored.
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You can double-click a fax configuration and view the detailed information on the faxes it stores.
To search the locally archived faxes, click Search.

Viewing fax queues

The Fax Queue tab lists the faxes waiting to be sent on the FortiVoice unit. For more information
about fax, see “Configuring fax” on page 262.

Viewing call records

Status > Call Detail Records (CDR) displays all the phone calls made during a certain time
period, including time of the call, caller and receiver, call duration, call status, call direction,
trunks used, and call type.

Double-clicking a record displays the detailed call information, including the CDR flow.

You can filter the call records display by clicking the Search button and enter criteria that
records must match in order to be visible. You can also save the call records by clicking the
Download button.

Viewing generated reports

The Call Reports tab displays the call reports and call center reports generated by the FortiVoice
unit. You can delete, view, and/or download generated reports.

FortiVoice units can generate reports automatically according to the report schedules that you
configure. For more information, see “Configuring report profiles and generating call reports” on
page 284.

To reduce the amount of hard disk space consumed by reports, regularly download then
delete generated reports from the FortiVoice unit.

To view call or call center reports
1. Go to Status > Call Reports> Reports/Call Center Reports.
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Figure 5: Reports tab
i | Download

(o Page 1 /1 Records per page: | 25 w

[l | Report File Name

& TestReport-2014-01-14-1726

@ TestReport-2014-01-14-1725

GUI field Description
Download Click to create a PDF or HTML version of the report.

Report File Name Lists the name of the generated report, and the date and time at
which it was generated.

For example, Report 1-2012-03-31-2112 is a report named
Report 1, generated on March 31, 2012 at 9:12 PM. To view an
individual section of the report in HTML format, click + next to the
report name to expand the list of HTML files that comprise the
report, then double-click one of the file names.

Last Access Time  Lists the date and time when the FortiVoice unit completed the
generated report.

Size Lists the file size of the report in HTML format, in bytes.

2. To view the report in PDF file format, mark the check box in the corresponding row and click
Download. On the pop-up menu, select Download PDF.

3. To view the report in HTML file format, you can view all sections of the report together, or you
can view report sections individually.

e To view all report sections together, mark the check box in the row corresponding to the
report, such as 1-2012-03-31-2112, then click Download and select Download HTML.
Your browser downloads a file with an archive (. tgz.gz) file extension to your
management computer. To view the report, first extract the report files from the archive,
then open the HTML files in your web browser.

e Each Query Selection in the report becomes a separate HTML file. You can view the
report as individual HTML files. In the row corresponding to the report that you want to
view, click + next to the report name to expand the list of sections, then double-click the
file name of the section that you want to view, such as reportl.html. The report
appears in a new browser window.

4. To view the report in CSV (comma-separated value) file format that can be viewed in a
spreadsheet application such as Microsoft Excel or OpenOffice Calc, mark the check box in
the corresponding row and click Download. On the pop-up menu, select Download CSV.

Viewing log messages

The Logs submenu displays locally stored log files. If you configured the FortiVoice unit to store
log messages locally (that is, to the hard disk), you can view the log messages currently stored
in each log file.

Logs stored remotely cannot be viewed from the web-based manager of the FortiVoice unit. If
you want to view logs from the web-based manager, also enable local storage. For details, see
“Configuring Logs and Reports” on page 278.
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Status > Logs displays the logs of administrator activities and system events as well as voice,
fax, queue, hotel management, and call center.

To
1.

Fortinet Technologies Inc.

view the list of log files and their contents
Go to Status > Logs > Event/Voice/Fax/Queue/Hotel/Call center.

The list of log files appears with the beginning and end of a log file’s time range and the size
of a log file in bytes. The queue log files display more information.

To download an event, voice, fax, and call center log file, select it and click Download to
save it in one of the three formats:

e Normal Format for a log file that can be viewed with a plain text editor such as Microsoft
Notepad.

e (CSV Format for a comma-separated value (.csv) file that can be viewed in a spreadsheet
application such as Microsoft Excel or OpenOffice Calc.

e Compressed Format for a plain text log file like Normal Format, except that it is
compressed and stored within a .gz archive.

To search the log files, click the Search button and enter criteria that records must match in
order to be visible.

Unlike the search when viewing the contents of an individual log file, this search displays
results regardless of which log file contains them. For more information, see “Searching log
messages” on page 37.

To view messages contained in logs, double-click a log file.

To view the current page’s worth of the log messages as an HTML table, right-click and
select Export to Table. The table appears in a new tab. To download the table, click and drag
to select the whole table, then copy and paste it into a rich text editor such as Microsoft
Word or OpenOffice Writer.

Log messages can appear in either raw or formatted views.
¢ Raw view displays log messages exactly as they appear in the plain text log file.

¢ Formatted view displays log messages in a columnar format. Each log field in a log
message appears in its own column, aligned with the same field in other log messages,
for rapid visual comparison.

By default, log messages always appear in columnar format, with one log field per column.
However, when viewing this columnar display, you can also view the log message in raw
format by hovering your mouse over the index number of the log message, in the # column,
as shown in Figure 6.
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Figure 6: Log message view

Level: | Information ~ || Go to line: Search... Back

C Fage 1 /3| » M | Records per page: | 25 w || Save View

# Date Time Message

1 2014-02-20 10:39:35 Fax from"hao operatord <6003="to 6136881237 "sent success

2 2014-02-20 10:04:11 Fax from ™ to ™: 'sending failed. Extra Info: {Status String = The c

3 2014-02-20 10:04:11 Fax fromhao operatord <6003>"to '6136881237": "'sending failec

4 2014-02-20 10:01:10 Fax from "Fortinet Techno® <8132255381>" to 'freephoned423™ 'r

5 2014-02-20 09:55:5 Fax from™ <8132258381>" to "freephoned423". 'receiving FAX fz

6 2014-02-20 05:00:01 Expired "2" faxs from ‘inbox” folder for extension 6003
Date=2014-02-20, Time=02:55:51, Message=Fax from ™ - . . L .

7 ! . d2f fi it folder for ext '5002°
<6132259381>' to 'freephoned423' receiving FAX failed. 2%s Trem sent Tolder for extension

g Extra Info: {Status String = Disconnected after permitted  pm"hao operatord <6003>"to 61365881237 'sent success

9 retriesECM = yesError Code = Disconnected after om "Fortinet Techno' 6132258381} to 'freephoneB423: T
permitted retrfesFilenames = fvar/spool /fax_gueue

10 fincoming om “Fortinet Techno' <6132258381¢" to "freephoned423" r

" éi:ﬁ:%ljg ;3;2:?;‘5’423' EEEINR AT bm ™ <6132259381" to "freephonep423” receiving FAX fe

12 014-02-19 1591743 Fax from "hao operatord <6003>"to '6134881237": 'sent success

Log message in raw format Log message in columnar format

The log messages vary by levels. For more information, see “Configuring Logs and Reports”
on page 278.

The log messages are also filtered by subtypes:

e Configuration: Display only log messages containing subtype=config.
¢ Administration: Display only log messages containing subtype=admin.
e System: Display only log messages containing subtype=system.

You can click the Save View button to save the customized view. Future log message reports
appear in this view.

Displaying and arranging log columns

When viewing logs, you can display, hide, sort and re-order columns.

For most columns, you can also filter data within the columns to include or exclude log
messages which contain your specified text in that column. For more information, see
“Searching log messages” on page 37.

By default, each page’s worth of log messages is listed with the log message with the lowest
index number towards the top.

To sort the page’s entries in ascending or descending order
1. Click the column heading by which you want to sort.
The log messages are sorted in ascending order.
2. To sort in descending order, click the column heading again.
Depending on your currently selected theme:

¢ the column heading may darken in color to indicate which column is being used to sort
the page

¢ asmall upwards-or downwards-pointing arrow may appear in the column heading next to
its name to indicate the current sort order.
To display or hide columns
1. Go to Status > Logs > Event/Voice/Fax/Queue/Call center.
2. Double-click the row corresponding to time period whose log messages you want to view.

3. Position your mouse cursor over a column heading to display the down arrow on its
right-hand side, click the down arrow and move your cursor over Columns to display the list
of available columns, then mark the check boxes of columns that you want to display.
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Figure 7: Hiding and showing log columns

Level: | Information ~ || Subtype: Al v || Go toline: Search... | Back

] Page 1 [13| B M| |Recordsperpage: 25 ||| SaveView

1 2014-02-20 User admin logo 'IN Sort Ascending
2 2014-02-20 admin User admin login ii Sort Descending 20,140 117)
3 2014-02:20 admin GUI session tim / Make ViSible
4 2014-02-20 admin GUI session timg (=4 Columns e
5 2014-02-20 smtp to=pengzhang@oti-fortimail. com haoxcheny Date lay=00:00:01, x
6 2014-02-20 smtp 8963 STARTTLS=client, relay=mail.ott-fortin M)WSSLV} veri
7 2014.02.20 manitor call recording monitor - (system) start at: 21 mr,-y\ . ..
e 2 o sbtpe | . Make invisible
8 2014-02-20 smip from=+>, size=1688, class=0, nrcpls=2, ms| 5 $1KAGZNr00;
Message
9 2014-02-20 system DNS server 172.20.140.122 response time. \ds for the pasti
10 2014-02-20 admin User admin login successfully from GUI(173 Level
1 2014-02-20 smip to=pengzhang@ott-fortimail. com haoxchen( Log ID lay=00:00:00, x

4. Click Save View.

To change the order of the columns
1. Go to Status > Logs > Event/Voice/Queue/Call center.
2. Double-click the row corresponding to time period whose log messages you want to view.

3. For each column whose order you want to change, click and drag its column heading to the
left or right.

4. Click Save View.

Using the right-click pop-up menus
When you right-click on a log message, a context menu appears.

Figure 8: Using the right-click menus on log reports

Level: | Information w || Sub type: | Al v || Gotoline: Search... Back
¢ Page 1 /13| b M | Records per page: | 25 w || Save View
# Meszage
1 2014-02-20 admin User admin logout from ssh(172.20.140.117).
rd 2014 Select All User admin login successfully from GUI172.20.140.117)
3 2014 Clear Selection GUl session timeout from (172.20.140.117)
4 2014 Gl zession timeout from (172.20.140.117)
5 2014 to=pengzhang@ott-fortimail. com haoxchen@ott-fortimail.

Right-click pop-up menus
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Table 5: Log report right-click menu options

Select All Select to select all log messages in the current page, so that you can
export all messages to a table.

Clear Selection Select to deselect one or multiple log messages.

Export to Table Select to export the selected log messages to a table format. A new tab

named Exported Table appears, displaying the exported information.
The table format allows you to copy the information and paste it
elsewhere.

Searching log messages

You can search logs to quickly find specific log messages in a log file, rather than browsing the
entire contents of the log file.

To search log messages

1. Go to Status > Logs > Event/Voice/Fax/Queue/Call center.

2. To search all log files, click Search.

3. To search one of the log files, first double-click the name of a log file to display the contents
of the log file, then click Search.

Figure 9: Log search dialog

FortiVoice
Event Log Search

Keywaord:

Message:

Log ID:

Time: Zero day ~ and |12 v | hour(s) before
02/20/14 i 12 v

Match condition: | Contain -4

Apply Cancel
4. Enter your search criteria by configuring one or more of the following:
GUI field Description

Keyword Enter any word or words to search for within the log messages.

For example, you might enter GUI session to locate all log messages
containing that exact phrase in any log field.

Message Enter all or part of the Message log field.

Log ID Enter all or part of the log ID in the log message.
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Time Select the time span of log messages to include in the search
results.

For example, you might want to search only log messages that were
recorded during the two weeks and 8 hours previous to the current
date. In that case, you would specify the current date, and also
specify the size of the span of time (two weeks and 8 hours) before
that date.

Match condition e Contain: searches for the exact match.

e Wildcard: supports wildcards in the entered search criteria.

5. Click Apply.

The FortiVoice unit searches your currently selected log file for log messages that match
your search criteria, and displays any matching log messages.

Viewing phone directories

The Directory tab displays the local, remote, and peer office extensions. It also shows the virtual
numbers and ring groups.

To display the peer office extensions, you need to enable fetching office directory on the local
and peer office FortiVoice units. For more information, see “Configuring office peers” on
page 192.

To view or download the phone directory, go to Status > Directory.

Figure 10: Viewing directory

Search: I:I Clear Type: —All- v || Location: —All—- v || Department: v
C Page 1 /1 Records per page: 50 v Download *
Display Name Location Department
7701 Operator Local Sip
7702 Administrator Local Sip
470 470 Local Sip
GUI field Description
Download Select to save all directories or search result.
Number The extension number. For information on creating extension numbers,

see “Setting up local extensions” on page 135.

Display Name The name displaying on the extension. This is usually the name of the
extension user.

Location The extension location.
Department The department to which the extension belongs.
Type The extension type.
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Configuring System Settings

The System menu lets you set up configurations of the FortiVoice operation system, including
administrator accounts, network settings, system time, SIP settings, system maintenance, and
more.

This topic includes:

¢ Configuring network settings
e Configuring administrator accounts and access profiles
¢ Using high availability

¢ Configuring system time, system options, SNMP, email setting, GUI appearance, and call
data storage

¢ Managing certificates
* Maintaining the system

Configuring network settings

The Network submenu provides options to configure network connectivity and administrative
access to the web-based manager or CLI of the FortiVoice unit through each network interface.

This topic includes:

e About IPv6 Support

¢ About the management IP

¢ About FortiVoice logical interfaces
¢ Configuring the network interfaces
¢ Configuring static routes

e Configuring DNS

¢ Configuring DHCP server

e Capturing voice and fax packets

About IPv6 Support

IP version 6 (IPv6) handles issues that were not around decades ago when IPv4 was created
such as running out of IP addresses, fair distributing of IP addresses, built-in quality of service
(QoS) features, better multimedia support, and improved handling of fragmentation. A bigger
address space, bigger default packet size, and more optional header extensions provide these
features with flexibility to customize them to any needs.

IPv6 has 128-bit addresses compared to IPv4’s 32-bit addresses, effectively eliminating
address exhaustion. This new very large address space will likely reduce the need for network
address translation (NAT) since IPv6 provides more than a billion IP addresses for each person
on Earth. All hardware and software network components must support this new address size,
an upgrade that may take a while to complete and will force IPv6 and IPv4 to work side-by-side
during the transition period.
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The FortiVoice unit supports the following IPv6 features:

¢ Network interface
¢ Network routing

e DNS

e DHCP

* Phone extension
e Trunk

About the management IP

The FortiVoice unit has an IP address for administrators to configure it through a network
connection rather than a local console. The management IP address enables administrators to
connect to the FortiVoice unit through port1 or other network ports, even when they are
currently bridging.

By default, the management IP address is indirectly bound to port? through the bridge. If other
network interfaces are also included in the bridge with port1, you can configure the FortiVoice
unit to respond to connections to the management IP address that arrive on those other
network interfaces.

You can access the web-based manager and the FortiVoice user account using the
management IP address. For details, see “Connecting to the web-based manager” on page 16.

About FortiVoice logical interfaces

In addition to the FortiVoice physical interfaces, you can create the following types of logical
interfaces on the FortiVoice unit:

e VLAN subinterfaces
¢ Redundant interfaces
e | oopback interfaces

VLAN subinterfaces

A Virtual LAN (VLAN) subinterface, also called a VLAN, is a virtual interface on a physical
interface. The subinterface allows routing of VLAN tagged packets using that physical interface,
but it is separate from any other traffic on the physical interface.

Virtual LANs (VLANS) use ID tags to logically separate devices on a network into smaller
broadcast domains. These smaller domains forward packets only to devices that are part of that
VLAN domain. This reduces traffic and increases network security.

One example of an application of VLANs is a company’s accounting department. Accounting
computers may be located at both main and branch offices. However, accounting computers
need to communicate with each other frequently and require increased security. VLANs allow
the accounting network traffic to be sent only to accounting computers and to connect
accounting computers in different locations as if they were on the same physical subnet.

For information about adding VLAN subinterfaces, see “Configuring the network interfaces” on
page 41.

Redundant interfaces

On the FortiVoice unit, you can combine two or more physical interfaces to provide link
redundancy. This feature allows you to connect to two or more switches to ensure connectivity
in the event one physical interface or the equipment on that interface fails.
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In a redundant interface, traffic is only going over one interface at any time. This differs from an
aggregated interface where traffic is going over all interfaces for increased bandwidth. This
difference means redundant interfaces can have more robust configurations with fewer possible
points of failure. This is important in a fully-meshed high availability (HA) configuration.

A physical interface is available to be in a redundant interface if:
¢ itis a physical interface, not a VLAN interface

¢ it is not already part of a redundant interface

¢ it has no defined IP address and is not configured for DHCP
¢ it does not have any VLAN subinterfaces

¢ it is not monitored by HA

When a physical interface is included in a redundant interface, it is not listed on the System >
Network > Network page. You cannot configure the interface anymore.

For information about adding redundant interfaces, see “Configuring the network interfaces” on
page 41.

Loopback interfaces

A loopback interface is a logical interface that is always up (no physical link dependency) and
the attached subnet is always present in the routing table.

The FortiVoice’s loopback IP address does not depend on one specific external port, and is
therefore possible to access it through several physical or VLAN interfaces. In the current
release, you can only add one loopback interface on the FortiVoice unit.

For information about adding a loopback interface, see “Configuring the network interfaces” on
page 41.

Configuring the network interfaces

The System > Network > Network tab displays the FortiVoice unit’s network interfaces.

You must configure at least one network interface for the FortiVoice unit to connect to your
network. Depending on your network topology and other considerations, you can connect the
FortiVoice unit to your network using two or more of the network interfaces. You can configure
each network interface separately. You can also configure advanced interface options, including
VLAN subinterfaces, redundant interfaces, and loopback interfaces. For more information, see
“About FortiVoice logical interfaces” on page 40, and “Editing network interfaces” on page 42.

To view the list of network interfaces, go to System > Network > Network.

Figure 11: Network tab

=g Mew... ) T
IPMNetmask IPvi/Netmask Status
portt Physical 172.20.140.61/24 ol ] HTTPS,PING,55H, SHMP,HTTRTE... L] .
port2 Physical 192.168.100.1/24 el HTTPS, PING, 55H [+] .
& port3 Physical 192.168.101.1/24 ] HTTPS,PING TELNET [+] °
portd Physical 0.0.0.0:0 =i HTTPS,PING 4] .
GUI field Description
Name Displays the name of the network interface, such as port1.
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Type

IP/Netmask

IPv6/Netmask

Access

Status

Displays the interface type: physical, VLAN, redundant, or loopback. For
details, see “About FortiVoice logical interfaces” on page 40.

Displays the IP address and netmask of the network interface.

Displays the IPv6 address and netmask of the network interface. For
more information about IPv6 support, see “About IPv6 Support” on
page 39.

Displays the administrative access and phone user access that are
enabled on the network interface, such as HTTPS for the web-based
manager.

Indicates the up (available) or down (unavailable) administrative status
for the network interface.

e Green up arrow: The network interface is up and can receive traffic.

e Red down arrow: The network interface is down and cannot receive
traffic.

To change the administrative status (that is, bring up or down a network
interface), see “Editing network interfaces” on page 42.

Editing network interfaces

You can edit FortiVoice’s physical network interfaces to change their IP addresses, netmasks,
administrative access protocols, and other settings. You can also create or edit logical
interfaces, such as VLANSs, redundant interfaces and the loopback interface.

networks or directly to your management computer. If possible, enable only secure

2 Enable administrative access only on network interfaces connected to trusted private

administrative access protocols such as HTTPS or SSH. Failure to restrict administrative
B access could compromise the security of your FortiVoice unit.

You can restrict which IP addresses are permitted to log in as a FortiVoice administrator through
network interfaces. For details, see “Configuring administrator accounts” on page 51.

To create or edit a network interface

1. Go to System > Network > Network.

2. Double-click a network interface to modify it or select the interface and click Edit. If you want
to create a logical interface, click New.

The Edit Interface dialog appears.

3. Configure the following:

Fortinet Technologies Inc.
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Figure 12: Edit Interface dialog
Edit Interface

Interface name: port1 (50:e5:49:e8:23:92)

Addressing Mode

@ Manual
IPiMetmask: | 172.20.140.61 124
IPvEiNetmask:

) DHCP

Access HTTPS PING HTTP

58H SMNMP TELMET
MTU [T owverride default MTU value (1500)
(bytes)
Administrative status @ Up = Down
ij Cancel

Figure 13: Creating logical interfaces
Edit Interface

Interface name:

Type: VLAN et
Interfaca: portl . d
VLAM ID: a

Addressing Mode

@ Manual
IPMNetmask: | 0.0.0.0 fo
IPvG/Metmask:
I DHCP
Access [C] HTTPS [] PING [C] HTTP
[[] asH [C] SNMP [] TELNET
MTU [T] Override default MTU value (1500)
(bytes)
Administrative status @ Up 1 Down
Create Cancel
GUI field Description

Interface Name

If you are editing an existing interface, this field displays the name

(such as port2) and media access control (MAC) address for this

network interface.

If you are creating a logical interface, enter a name for the interface.
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Type

Addressing Mode

If you are creating a logical interface, select which type of interface
you want to create. For information about logical interface types, see
“About FortiVoice logical interfaces” on page 40.

VLAN: If you want to create a VLAN subinterface, select the
interface for which you want to create the subinterface. Then
specify a VLAN ID. Valid VLAN ID numbers are from 1 to 4094,
while 0 is used for high priority frames, and 4095 is reserved.

Redundant: If you want to create a redundant interface, select the
interface members from the available interfaces. Usually, you
need to include two or more interfaces as the redundant interface
members.

Loopback: If you want to add a loopback interface, select the
Loopback type and the interface name will be automatically reset
to “loopback”. You can only add one loopback interface on the
FortiVoice unit.

Manual: Select to enter the IP address or IPv6 address and
netmask for the network interface in IP/Netmask or
IPv6/Netmask.

DHCP: Select and click Update request to retrieve a dynamic IP
address using DHCP.
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Access

MTU

Enable protocols that this network interface should accept for
connections to the FortiVoice unit itself. (These options do not affect
connections that will travel through the FortiVoice unit.)

e HTTPS: Enable to allow secure HTTPS connections to the
web-based manager, and extension user account through this
network interface.

e HTTP: Enable to allow HTTP connections to the web-based
manager, and extension user account through this network
interface.

Enable this option if you select Centralized phonebook when
configuring programmable phone key. For more information, see
“Set Programmable Phone Key” on page 124.

e PING: Enable to allow ICMP ECHO (ping) responses from this
network interface.

For information on configuring the network interface from which
the FortiVoice unit itself will send pings, see the FortiVoice CLI
Reference.

e SSH: Enable to allow SSH connections to the CLI through this
network interface.

e SNMP: Enable to allow SNMP connections (queries) to this
network interface.
For information on further restricting access, or on configuring the
network interface that will be the source of traps, see
“Configuring the network interfaces” on page 41.

e TELNET: Enable to allow Telnet connections to the CLI through
this network interface.

Caution: HTTP and Telnet connections are not secure, and can
be intercepted by a third party. If possible, enable this option only
for network interfaces connected to a trusted private network, or
directly to your management computer. Failure to restrict
administrative access through this protocol could compromise
the security of your FortiVoice unit. For information on further
restricting access of administrative connections, see “Configuring
administrator accounts” on page 51.

Override default MTU value (1500): Enable to change the maximum
transmission unit (MTU) value, then enter the maximum packet or
Ethernet frame size in bytes.

If network devices between the FortiVoice unit and its traffic
destinations require smaller or larger units of traffic, packets may
require additional processing at each node in the network to
fragment or defragment the units, resulting in reduced network
performance. Adjusting the MTU to match your network can improve
network performance.

The default value is 1500 bytes. The MTU size must be between 576
and 1500 bytes. Change this if you need a lower value; for example,
RFC 2516 prescribes a value of 1492 for the PPPoE protocol.
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Administrative Select either:

status e Up: Enable (that is, bring up) the network interface so that it can

send and receive traffic.

e Down: Disable (that is, bring down) the network interface so that
it cannot send or receive traffic.

Configuring static routes

The System > Network > Routing tab displays a list of routes and lets you configure static
routes and gateways used by the FortiVoice unit.

Static routes direct traffic exiting the FortiVoice unit. You can specify through which network
interface a packet will leave, and the IP address of a next-hop router that is reachable from that
network interface. The router is aware of which IP addresses are reachable through various
network pathways, and can forward those packets along pathways capable of reaching the
packets’ ultimate destinations.

A default route is a special type of static route. A default route matches all packets, and defines
a gateway router that can receive and route packets if no other, more specific static route is
defined for the packet’s destination IP address.

You should configure at least one static route, a default route, that points to your gateway.
However, you may configure multiple static routes if you have multiple gateway routers, each of
which should receive packets destined for a different subset of IP addresses.

To determine which route a packet will be subject to, the FortiVoice unit compares the packet’s
destination IP address to those of the static routes and forwards the packet to the route with the
large prefix match.

When you add a static route through the web-based manager, the FortiVoice unit evaluates the
route to determine if it represents a different route compared to any other route already present
in the list of static routes. If no route having the same destination exists in the list of static
routes, the FortiVoice unit adds the static route.

To view or configure static routes
1. Go to System > Network > Routing.

Figure 14: Static routes

= Mew... By i}

Destination IP/Netmask Gateway Interface

0.0.0.0;0 172.20.180.245

192.188.110.0424 192.168.110.5

172.16.100.0/24 192.168.110.5

10.2.2.0/24 172.20.180.245

GUI field Description

Destination Displays the destination IP address and subnet of packets subject to
IP/Netmask the static route. A setting of 0.0.0.0/0.0.0 indicates that the route

matches all destination IP addresses.

Interface The interface that this route applies to.
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Gateway Displays the IP address of the next-hop router to which packets
subject to the static route will be forwarded.

2. Either click New to add a route or double-click a route to modify it.
A dialog appeatrs.

3. In Destination IP/netmask, enter the destination IP address and netmask of packets that will
be subject to this static route.

To create a default route that will match all packets, enter 0.0.0.0/0.0.0.0.
4. Select the interface that this route applies to.

5. In Gateway, type the IP address of the next-hop router to which the FortiVoice unit will
forward packets subject to this static route. This router must know how to route packets to
the destination IP addresses that you have specified in Destination IP/netmask. For an
Internet connection, the next hop routing gateway routes traffic to the Internet.

6. Click Create or OK.

Configuring DNS

FortiVoice units require DNS servers for features such as reverse DNS lookups. Your ISP may
supply IP addresses of DNS servers, or you may want to use the IP addresses of your own DNS
servers.

For improved FortiVoice unit performance, use DNS servers on your local network.

The DNS tab lets you configure the DNS servers that the FortiVoice unit queries to resolve
domain names into IP addresses.

To configure the primary and secondary DNS servers
1. Go to System > Network > DNS.
2. In Primary DNS server, enter the IP address of the primary DNS server.

3. In Secondary DNS server, enter the IP address of the secondary DNS server.
4. Click Apply.

Configuring DHCP server

A DHCP server provides an address to a client on the network, when requested, from a defined
address range.

You can configure one or more DHCP servers on any FortiVoice interface. A DHCP server
dynamically assigns IP addresses to the clients on the network connected to the interface.
These clients must be configured to obtain their IP addresses using DHCP.

To configure the DHCP server

1. Go to System > Network > DHCP.

2. Click New and configure the following:
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Figure 15:DHCP server configuration

Metwork Interface Setting

D

Enabled:

Interface: portl
Gateway: 192.168.2.99
DNS options: Default

Primary DNS server:
Secondary DNS server:
Domain:

Netmask: 255.255.255.0

Advanced Setting

TFTP server (Opt66): portl
Lease time (Seconds): 604800

Vender Class Identifier option: [7]
VCI string:

- | DHCP IP Range

ﬁ New... B il |

Start End
« | DHCP Excluded IP Range

~| Reserved IP Address

Create Cancel

GUI field

Network Interface
Setting
ID

Enabled

Interface

Gateway

DNS options

Domain

Netmask

Advanced Setting

~ | (@ Please make sure slave mode has the same interfaces

Description

The system will generate an ID for this configuration. This is view
only.

Select to enable the DHCP server.

Select an interface for the DHCP server from the drop-down list.

If this FortiVoice is in HA mode, make sure that the slave unit has
the same interface as the master unit. For information on HA,
see “Using high availability” on page 54.

Enter the IP address of the default gateway that the DHCP
server assigns to DHCP clients.

Select to use either a specific DNS server or the system’s DNS
settings.

If you select a specific DNS server, enter the Primary DNS server
and the Secondary DNS server fields.

For more information, see “Configuring DNS” on page 47.
Enter the domain that the DHCP server assigns to its clients.

Enter the netmask of the addresses that the DHCP server
assigns.
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3.

TFTP server (Opt66) The default TFTP server (192.168.2.99) is where the

Lease time
(Seconds)

Vender Class
Identifier option

VCI string

DHCP IP Range

DHCP Excluded IP

Range

Reserved IP Address

Click Create.

configuration files for the supported phones are stored. This is
also the IP address of the default gateway that the DHCP server
assigns to the DHCP clients. If you have your own TFTP server
for such information, enter its IP address in this field. However,
SIP phone auto-provisioning will not work in this case. For more
information, see “Configuring SIP phone auto-provisioning” on
page 111.

Enter the length of time an IP address remains assigned to a
client. Once the lease expires, the address is released for
allocation to the next client request for an IP address. The
default time is 604800 seconds.

Select this option to apply the DHCP configuration to the
phones of a specific vendor identified by the VCI string supplied
by the vendor or by checking Monitor > PBX Status > DHCP >
VCI.

Enter the phone VCI string supplied by the vendor.

Click New to enter the start and end for the range of IP
addresses that this DHCP server assigns to the DHCP clients.

Click New to enter a range of IP addresses that this server
should not assign to the DHCP clients.

Click New to enter an IP address from the DHCP server to
match it to a specific client using its MAC address.

In a typical situation, an IP address is assigned ad hoc to a
client, and that assignment times out after a specific time of
inactivity from the client, known as the lease time. To ensure a
client always has the same IP address, that is, there is no lease
time, use this option.

Capturing voice and fax packets

When troubleshooting networks, it helps to look inside the contents of the packets. This helps
to determine if the packets, route, and destination are all what you expect. Traffic capture can
also be called packet sniffing, a network tap, or logic analyzing.

Packet sniffing tells you what is happening on the network at a low level. This can be very useful
for troubleshooting problems, such as:

finding missing traffic

seeing if sessions are setting up properly

locating ARP problems such as broadcast storm sources and causes

confirming which address a computer is using on the network if they have multiple
addresses or are on multiple networks

confirming routing is working as you expect

intermittent missing PING packets.

If you are running a constant traffic application such as ping, packet sniffing can tell you if the
traffic is reaching the destination, how the port enters and exits the FortiVoice unit, if the ARP

Fortinet Technologies Inc.
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resolution is correct, and if the traffic is returning to the source as expected. You can also use
packet switching to verify that NAT or other configuration is translating addresses or routing
traffic the way that you want it to.

Bef

ore you start sniffing packets, you need to have a good idea of what you are looking for.

Sniffing is used to confirm or deny your ideas about what is happening on the network. If you try
sniffing without a plan to narrow your search, you could end up with too much data to effectively
analyze. On the other hand, you need to sniff enough packets to really understand all of the
patterns and behavior that you are looking for.

To
1.

Fortinet Technologies Inc.

capture voice and fax packets
Go to System > Network > Traffic Capture.

Figure 16: Traffic capture list

Ef New..; | B i § | | =

. Page 1 T Records per page: | 25 -

Size(Byte)

vk2_172.20.190.194 or 74.114.208.34_Feb_18_2014_14_13.pcap Stopped 441088

61_call_172.20.190.194 or 74.114.208.34_Feb_18_2014_14_02. pcap Stopped 26261
vE61_74.114.208.34_Feb_18_2014_11_36.pcap Stopped 2207435
vE1_74.114.208.34_Feb_13_2014_11_28.pcap Stopped 24

GUI field Description

Stop Click to stop the packet capture.

Download When the capture is complete, click Download to save the packet

capture file to your hard disk for further analysis.

Name The name of the packet capture file.

Status The status of the packet capture process, Complete or Running.
Size The size of the packet capture file.

Click New.

Enter a prefix for the file generated from the captured traffic. This will make it easier to
recognize the files.

Enter the time period for performing the packet capture.

If you choose SIP or Use protocol for Filter, from the Available peers field, select the
extension or trunk of which you want to capture the voice packets and click -> to move them
into the Selected peers field. You can select up to 3 peers.

If you want to limit the scope of traffic capture, in the IP/HOST field, enter a maximum of 3 IP
addresses or host names for the extensions and trunks you selected. Only traffic on these IP
addresses or host names is captured.

Select the filter for the traffic capture:

e SIP: Only SIP traffic of the peers you select will be captured.

e Use protocol: Only UDP or TCP traffic of the peers you select will be captured.
e Capture all: All network traffic will be captured.

For Exclusion, enter the IP addresses/host names and port numbers of which you do not
want to capture voice traffic.

Click Create.
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Configuring administrator accounts and access profiles

The Admin submenu configures administrator accounts and access profiles.
This topic includes:

e Configuring administrator accounts
e Configuring administrator profiles

Configuring administrator accounts

The Administrators tab displays a list of the FortiVoice unit’s administrator accounts and the
trusted host IP addresses administrators use to log in (if configured).

By default, FortiVoice units have a single administrator account, admin. For more granular
control over administrative access, you can create additional administrator accounts with
restricted permissions.

To view and configure administrator accounts
1. Go to System > Admin > Administrators.

Figure 17: Administrators tab

Ef New... | B o
(o Page 1 /1 Records per page: 50 v
Extension Authentication Type Authentication Profile Trusted Hosts Admin Profile
= admin - Local 0.0.0.0/0,2/0 super_admin_prof
] admin_temp - Local 0.0.0.0/0,2/0 super_admin_prof
) akaye - LDAP corp |dap otiawa 0.0.0.0/0,:10 read only
] doodnariuc - LDAP corp ldap _ottawa 0.0.0.0/0,2/0 super_admin_prof
GUI field Description
Name Displays the name of the administrator account.
Extension Displays the extension associated with the administrator account.

Authentication Type The administrator authentication type: Local or LDAP.

Authentication The LDAP authentication profile. For more information, see

Profile “Configuring LDAP profiles” on page 125.

Trusted Hosts Displays the IP address and netmask from which the administrator
can log in.

Admin Profile The administrator profile that determines which functional areas the

administrator account may view or affect.

2. Either click New to add an account or double-click an account to modify it.
A dialog appeatrs.
3. Configure the following:
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Figure 18: New Administrator dialog

Administrator:
Single sign-on manager:
Managed departments:
Authentication type:

P Create password

Trusted hosts:

Admin profile:

Select language:

Select theme:

Create Cancel

GUI field

Administrator

Single sign-on
manager

Managed
departments

New Administrator

470 (470) (sip) ¥ || New Edit... (@)
>
Local i3
0.0.0.0 1o HE
monitor_prof ¥ | New... Edit...
~-Default-- i
Red Grey v || Use Current

Description

Enter the name for this administrator account.

The name can contain numbers (0-9), uppercase and lowercase
letters (A-Z, a-z), hyphens ( - ), and underscores ( _). Other special
characters and spaces are not allowed.

Select the extension for the administrator account.

If you add an extension, a User portal icon appears at the top of the
web-based manager when you log into the FortiVoice unit. Clicking
the icon opens the user web portal.

Click Edit to modify the selected extension or click New to configure
a new one. For more information on extensions, see “Configuring IP
extensions” on page 135.

This option appears after you select an extension for the
administrator account.

If you want to configure an administrator to manage call center
departments, click >> and select the departments for the
administrator. Click Done when you are finished.

For information on setting up call center departments, see
“Configuring agents” on page 218.

With this configuration, an administrator can log into the FortiVoice
unit and view the following information of the managed departments:

e recorded calls

e call center reports
e call queues

e call queue reports

The administrator can also click User Portal to go to the user web
portal and click Administrator to return to the administration page.

Note that in the administrator’s Admin profile, Call center
management and Storage recorded calls must be Read Only or
Read-Write. For details, see “Configuring administrator profiles” on
page 54.
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Authentication type Select an administrator authentication type: Local or LDAP.

Create password

LDAP profile

Trusted Hosts

Admin profile

Select language

Click to configure account login information.

e Password: Enter this account’s password.
The password can contain any character except spaces.
This field does not appear if Authentication type is LDAP.

Caution: Do not enter a FortiVoice administrator password less
than six characters long. For better security, enter a longer
password with a complex combination of characters and
numbers, and change the password regularly. Failure to provide a
strong password could compromise the security of your
FortiVoice unit.

e Confirm password: Enter this account’s password again to
confirm it.

This field does not appear if Authentication type is LDAP.

If you select LDAP for Authentication type, select an LDAP
authentication profile. For more information, see “Configuring LDAP
profiles” on page 125.

Enter an IPv4 or IPv6 address or subnet from which this
administrator can log in.

If you want the administrator to access the FortiVoice unit from any
IP address, use 0.0.0.0/0.0.0.0.

Enter the IP address and netmask in dotted decimal format. For
example, you might permit the administrator to log in to the
FortiVoice unit from your private network by typing
192.168.1.0/255.255.255.0.

Note: For additional security, restrict all trusted host entries to
administrative hosts on your trusted private network. For example, if
your FortiVoice administrators log in only from the 10.10.10.10/24
subnet, to prevent possibly fraudulent login attempts from
unauthorized locations, you could configure that subnet in the
Trusted Host #1, Trusted Host #2, and Trusted Host #3 fields.

Note: For information on restricting administrative access protocols
that can be used by these hosts, see “Editing network interfaces” on
page 42.

Click the + sign to add additional IP addresses or subnets from
which the administrator can log in.

Select the name of an admin profile that determines which functional
areas the administrator account may view or affect.

Click New to create a new profile or Edit to modify the selected
profile. For details, see “Configuring administrator profiles” on
page 54.

Select this administrator account’s preference for the display
language of the web-based manager.
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Select theme Select this administrator account’s preference for the display theme
or click Use Current to choose the theme currently in effect.

The administrator may switch the theme at any time during a session
by clicking Next Theme.

4. Click Create.

Configuring administrator profiles

The Admin Profile tab displays a list of administrator access profiles.

Administrator profiles govern which areas of the web-based manager and CLI that an
administrator can access, and whether or not they have the permissions necessary to change
the configuration or otherwise modify items in each area.

To configure administrator access profiles

1. Go to System > Admin > Admin Profile.

2. Either click New to add an account or double-click an access profile to modify it.

3. In Profile name, enter the name for this access profile.
4

. In the Configure the privileges table, for each access control option, select the permissions
to be granted to administrator accounts associated with this access profile:

* None

e Read Only

* Read-Write
5. Click Create.

Using high availability

Go to System > High Availability to configure the FortiVoice unit to act as a high availability (HA)
member in order to increase availability.

For the general procedure of how to enable and configure HA, see “How to use HA” on page 57.
This section contains the following topics:

¢ About high availability

e About the heartbeat and synchronization

e How to use HA

* Monitoring the HA status

¢ Configuring service-based failover

e Example: Failover scenarios

Fortinet Technologies Inc. Page 54 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

About high availability

FortiVoice units operate in active-passive HA mode which has the following features:
e 2 FortiVoice units in the HA group

e Both configuration and data synchronized (For exceptions to synchronized configuration
items, see “Configuration settings that are not synchronized” on page 56.

e Only primary unit processes phone calls

¢ No data loss when hardware fails although active calls are disconnected and line
appearance and extension appearance take time to restore

¢ Has failover protection, but no increased processing capacity.

Figure 19:Active-passive HA group

Internal
network

Internet

S EFoRTIEATE.

Active

Passive

FortiVoice

Active-passive
HA Group

Same FortiVoice models must be used in the same HA group. All units in the HA group must
have the same firmware version with the same hardware.

Communications between HA members occur through the heartbeat and synchronization
connection. For details, see “About the heartbeat and synchronization” on page 56.

To configure FortiVoice units operating in HA mode, you usually connect only to the primary unit
(master). The primary unit’s configuration is almost entirely synchronized to secondary units
(slave), so that changes made to the primary unit are propagated to the secondary units.

Exceptions to this rule include connecting to a secondary unit in order to view log messages
recorded about the secondary unit itself on its own hard disk, and connecting to a secondary
unit to configure settings that are not synchronized. For details, see “Configuration settings that
are not synchronized” on page 56.

For instructions of how to enable and configure HA, see “How to use HA” on page 57.
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About the heartbeat and synchronization

Heartbeat and synchronization traffic consists of TCP packets transmitted between the
FortiVoice units in the HA group through the primary and secondary heartbeat interfaces.

Service monitoring traffic can also, for short periods, be used as a heartbeat. For details, see
“Remote services as heartbeat” on page 64.

Heartbeat and synchronization traffic has three primary functions:

¢ to monitor the responsiveness of the HA group members
¢ to synchronize configuration changes from the primary unit to the secondary units

For exceptions to synchronized configuration items, see “Configuration settings that are not
synchronized” on page 56.

¢ to synchronize system and user data from the primary unit to the secondary unit

Call data consists of the FortiVoice call detailed records, recorded calls, voicemail, call
directories, fax, and voice prompts.

When the primary unit’s configuration changes, it immediately synchronizes the change to the
secondary unit through the primary heartbeat interface. If this fails, or if you have inadvertently
de-synchronized the secondary unit’s configuration, you can manually initiate synchronization.
For details, see “click HERE to start a configuration/data sync” on page 60. You can also use
the CLI command diagnose system ha sync on either the primary unit or the secondary
unit to manually synchronize the configuration. For details, see the FortiVoice CLI Reference.

During normal operation, the secondary unit expects to constantly receive heartbeat traffic from
the primary unit. Loss of the heartbeat signal interrupts the HA group and generally triggers a
failover. For details, see “Failover scenario 1: Temporary failure of the primary unit” on page 69.

Exceptions include system restarts and the execute reload CLI command. In case of a
system reboot or reload of the primary unit, the primary unit signals the secondary unit to wait
for the primary unit to complete the restart or reload. For details, see “Failover scenario 2:
System reboot or reload of the primary unit” on page 70.

Periodically, the secondary unit checks with the primary unit to see if there are any configuration
changes on the primary unit. If there are configuration changes, the secondary unit will pull the
configuration changes from the primary unit, generate a new configuration, and reload the new
configuration. In this case, both the primary and secondary units can be configured to send
alert email. For details, see “Failover scenario 3: System reboot or reload of the secondary unit”
on page 71 and “Configuring alert email” on page 291.

Configuration settings that are not synchronized
All configuration settings on the primary unit are synchronized to the secondary unit, except the
following:

Table 6: HA settings not synchronized

Host name The host name distinguishes members of the cluster.

Static route Static routes are not synchronized because the HA units may be in
different networks (see “Configuring static routes” on page 46).
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Table 6: HA settings not synchronized

Interface Each FortiVoice unit in the HA group must be configured with different
configuration network interface settings for connectivity purposes. For details, see
“Configuring the network interfaces” on page 41.

Exceptions include some active-passive HA settings which affect the
interface configuration for failover purposes. These settings are
synchronized.

Main HA The main HA configuration, which includes the HA mode of operation

configuration (such as master or slave), is not synchronized because this configuration
must be different on the primary and secondary units. For details, see
“Configuring the HA mode and group” on page 61.

HA service In active-passive HA, the HA service monitoring configuration is not
monitoring synchronized. The remote service monitoring configuration on the
configuration secondary unit controls how the secondary unit checks the operation of

the primary unit. The local services configuration on the primary unit
controls how the primary unit tests the operation of the primary unit. For
details, see “Configuring service-based failover” on page 67.

Note: You might want to have a different service monitoring configuration
on the primary and secondary units. For example, after a failover you
may not want service monitoring to operate until you have fixed the
problems that caused the failover and have restarted normal operation of
the HA group.

System The appearance settings you configured under System > Configuration >
appearance Appearance are not synchronized.

Synchronization after a failover

During normal operation, extensions are in one of two states:
e registered and idle
¢ active call

When a failover occurs, active calls are interrupted and users have to reinitiate the calls.
However, registered idle extensions can still make and receive phone calls without being
affected.

When a failover is corrected, one of the following occurs automatically:

1. The secondary unit detects the failure of the primary unit, and becomes the new primary
unit.

2. The former primary unit restarts, detects the new primary unit, and becomes a secondary
unit.

You may have to manually restart the failed primary unit.

®

How to use HA

In general, to enable and configure HA, you should perform the following:
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1. Physically connect the FortiVoice units that will be members of the HA group.

You must connect at least one of their network interfaces for heartbeat and synchronization
traffic between members of the group. For reliability reasons, Fortinet recommends that you
connect both a primary and a secondary heartbeat interface, and that they be connected
directly or through a dedicated switch that is not connected to your overall network.

2. On each member of the group:

¢ Enable the HA mode that you want to use and select whether the individual member will
act as a primary unit or secondary unit. For information about the differences between
the HA modes, see “About high availability” on page 55.

e Configure the local IP addresses of the primary and secondary heartbeat and
synchronization network interfaces.

e Configure a virtual IP address that is shared by the HA group and remains the same after
a failover. The virtual IP address is used to auto-provision the server IP address and the
SIP trunk client IP address.

¢ Configure the behavior on failover, and how the network interfaces should be configured
for whichever FortiVoice unit is currently acting as the primary unit.

3. If you want to trigger failover when hardware or a service fails, even if the heartbeat
connection is still functioning, configure service monitoring. For details, see “Configuring
service-based failover” on page 67.

4. Monitor the status of each group member. For details, see “Monitoring the HA status” on
page 58. To monitor HA events through log messages and/or alert email, you must first
enable logging of HA activity events. For details, see “Configuring logging” on page 280.

Monitoring the HA status

The Status tab in the High Availability submenu shows the configured HA mode of operation of
a FortiVoice unit in an HA group. You can also manually initiate synchronization and reset the HA
mode of operation. A reset may be required if a FortiVoice unit’s effective HA mode of operation
differs from its configured HA mode of operation, such as after a failover when a configured
primary unit is currently acting as a secondary unit.

For FortiVoice units operating as secondary units, the Status tab also lets you view the status
and schedule of the HA synchronization daemon.

Before you can use the Status tab, you must first enable and configure HA. For details, see
“How to use HA” on page 57.

To view the HA mode of operation status, go to System > High Availability > Status.

Figure 20:Active-passive HA status (primary unit)

Mone e Refresh

Mode Status

Configured QOperating Mode: master
Effective Operating Mode:  master

Actions

click HERE to start a configuration/data sync...
click HERE to switch to SLAVE mode...
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Table 7: Viewing HA status

GUI item

Mode Status

Daemon
Status

Fortinet Technologies Inc.

Configured
Operating
Mode

Effective
Operating
Mode

Description

Displays the HA operating mode that you configured, either:

master: Configured to be the primary unit of an
active-passive group.

slave: Configured to be the secondary unit of an
active-passive group.

For information on configuring the HA operating mode, see
“Mode of operation” on page 63.

After a failure, the FortiVoice unit may not be acting in its
configured HA operating mode. For details, see “Effective
Operating Mode” on page 59.

Displays the mode that the unit is currently operating in, either:

master: Acting as primary unit.
slave: Acting as secondary unit.

off: For primary units, this indicates that service/interface
monitoring has detected a failure and has taken the
primary unit offline, triggering failover. For secondary units,
this indicates that synchronization has failed once; a
subsequent failure will trigger failover. For details, see “On
failure” on page 63.

failed: Service/network interface monitoring has detected a
failure and the diagnostic connection is currently
determining whether the problem has been corrected or
failover is required. For details, see “On failure” on page 63.

The configured HA operating mode matches the effective
operating mode unless a failure has occurred.

For example, after a failover, a FortiVoice unit configured to
operate as a secondary unit could be acting as a primary unit.

For explanations of combinations of configured and effective
HA modes of operation, see Table 8.

For information on restoring the FortiVoice unit to an effective
HA operating mode that matches the configured operating
mode, see “click HERE to restore configured operating mode”
on page 60.

This option appears only for secondary units in active-passive HA groups.
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Table 7: Viewing HA status

GUI item

Actions

Fortinet Technologies Inc.

Monitor

Configuration

Data

click HERE to
start a
configuration/
data sync

click HERE to
restore
configured
operating
mode

Description

Displays the time at which the secondary unit’s HA daemon
will check to make sure that the primary unit is operating
correctly, and, if monitoring has detected a failure, the number
of times that a failure has occurred.

Monitoring occurs through the heartbeat link between the
primary and secondary units. If the heartbeat link becomes
disconnected, the next time the secondary unit checks for the
primary unit, the primary unit will not respond. If the maximum
number of consecutive failures is reached, and no secondary
heartbeat or remote service monitoring heartbeat is available,
the secondary unit will change its effective HA operating mode
to become the new primary unit.

For details, see “HA base port” on page 64.

Displays the time at which the secondary unit’s HA daemon
will synchronize the FortiVoice configuration from the primary
unit to the secondary unit.

The message slave unit is currently
synchronizing appears when the HA daemon is
synchronizing the configuration.

For information on items that are not synchronized, see
“Configuration settings that are not synchronized” on page 56.

Displays the time at which the secondary unit HA daemon will
synchronize mail data from the primary unit to the secondary
unit.

The message slave unit is currently
synchronizing appears when the HA daemon is
synchronizing data.

Click to manually initiate synchronization of the configuration
and call data. For information on items that are not
synchronized, see “Configuration settings that are not
synchronized” on page 56.

Click to reset the FortiVoice unit to an effective HA operating
mode that matches the FortiVoice unit’s configured operating
mode.

For example, for a configured primary unit whose effective HA
operating mode is now slave, after correcting the cause of the
failover, you might click this option on the primary unit to
restore the configured primary unit to active duty, and restore
the secondary unit to its slave role.

Note: Before selecting this option, if the effective HA operating
mode changed due to failover, you should resolve any issues
that caused the failover.
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Table 8: Combinations of configured and effective HA modes of operation

Configured Effective
operating

operating
mode

master
slave

master

slave

master

master

slave

mode
master
slave

off

off

failed

slave

master

Description

Normal for the primary unit of an active-passive HA group.
Normal for the secondary unit of an active-passive HA group.

The primary unit has experienced a failure, or the FortiVoice unit is in
the process of switching to operating in HA mode.

HA processes and call processing are stopped.

The secondary unit has detected a failure, or the FortiVoice unit is in
the process of switching to operating in HA mode.

After the secondary unit starts up and connects with the primary unit
to form an HA group, the first configuration synchronization may fail
in special circumstances. To prevent both the secondary and
primary units from simultaneously acting as primary units, the
effective HA mode of operation becomes off.

If subsequent synchronization fails, the secondary unit’s effective
HA mode of operation becomes master.

The remote service monitoring or local network interface monitoring
on the primary unit has detected a failure, and will attempt to
connect to the other FortiVoice unit. If the problem that caused the
failure has been corrected, the effective HA mode of operation
switches from failed to slave, or to match the configured HA mode of
operation, depending on the On failure setting.

The primary unit has experienced a failure but then returned to
operation. When the failure occurred, the unit configured to be the
secondary unit became the primary unit. When the unit configured
to be the primary unit restarted, it detected the new primary unit and
so switched to operating as the secondary unit.

The secondary unit has detected that the FortiVoice unit configured
to be the primary unit failed. When the failure occurred, the unit
configured to be the secondary unit became the primary unit.

Configuring the HA mode and group

The Configuration tab in the System > High Availability submenu lets you configure the high
availability (HA) options, including:

¢ enabling HA

¢ whether this individual FortiVoice unit will act as a primary unit or a secondary unit in the

group

e network interfaces that will be used for heartbeat and synchronization and virtual IP

e service monitor

HA settings, with the exception of Virtual IP Address settings, are not synchronized and must be
configured separately on each primary and secondary unit.

Fortinet Technologies Inc.
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You must maintain the physical link between the heartbeat and synchronization network
interfaces. These connections enable a group member to detect the responsiveness of the
other member, and to synchronize data. If they are interrupted, normal operation will be
interrupted and a failover will occur. For more information on heartbeat and synchronization, see
“About the heartbeat and synchronization” on page 56.

You can directly connect the heartbeat network interfaces of the two FortiVoice units using a
crossover Ethernet cable.

To

configure HA options

1. Go to System > High Availability > Configuration.

Figure 21: Active-passive HA (primary unit)

3.

4 | HA Configuration

Mode of operation: | master
On failure: switch off
Shared password: | change_me

P Advanced options
Apply Cancel

+ | Interface

Port Monitor

)
Heartbeat Status
port1 Dizable
port2 Primary
& port3 Disable
portd Dizable

= | Service Monitor

Remote IP

Peer IP Address

[IPvd] 172.20.140.35
[IPvE] ::

[IPv4] 192.168.100.2
[IPvE] ::

[IPv4] 0.0.0.0

[IPvE] ::

[IPv4] 0.0.0.0
[IPvE] ::

Virtual IP Action

Use

Use

Use

Ignore

Virtual IP Address

[IPv4] 172.20.140.110/24
[IPvE] /0

[IPv4] 192.168.100.100/24
[IPvE] /0

[IPv4] 192.168.101.100/24
[IPvE] /0

[IPv4] 0.0.0.0/0
[IPvE] /0

Retries

6 e ©

Enabled

Remote HTTP 0.0.0.0

SIP UDP 0.0.0.0

Interface monitor

Local hard drives

Configure the following sections, as applicable:

80

5060

30
30

“Configuring the primary HA options” on page 62

“Configuring the advanced options” on page 63

“Configuring interface monitoring” on page 64

“Configuring service-based failover” on page 67

Click Apply.

Configuring the primary HA options

120 3
120 3
120 3
120 3

Go to System > High Availability > Configuration and click the arrow to expand the HA

Configuration section, if needed.
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Table 9: HA main options

GUI item

Mode of
operation

On failure

Shared
password

Description

Enables or disables HA, and selects the initial configured role this FortiVoice
unit in the HA group.

e off: The FortiVoice unit is not operating in HA mode.

e master: The FortiVoice unit is the primary unit in an active-passive HA
group.

® slave: The FortiVoice unit is the secondary unit in an active-passive HA
group.

Select one of the following behaviors of the primary unit when it detects a
failure, such as on a power failure or from service/interface monitoring.

e switch off: Do not process phone calls or join the HA group until you
manually select the effective operating mode (see “click HERE to start a
configuration/data sync” on page 60 and “click HERE to restore configured
operating mode” on page 60).

e wait for recovery then restore original role: On recovery, the failed primary
unit‘s effective HA mode of operation resumes its configured master role.
This also means that the secondary unit needs to give back the master role
to the primary unit. This behavior may be useful if the cause of failure is
temporary and rare, but may cause problems if the cause of failure is
permanent or persistent.

® wait for recovery then restore slave role: On recovery, the failed primary
unit’s effective HA mode of operation becomes slave, and the secondary
unit continues to assume the master role. The primary unit then
synchronizes with the current master unit. The new master unit can then
deliver phone calls. For information on manually restoring the FortiVoice
unit to acting in its configured HA mode of operation, see “click HERE to
restore configured operating mode” on page 60.

In most cases, you should select the wait for recovery then restore slave role
option.

For details on the effects of this option on the Effective Operating Mode, see
Table . For information on configuring service/interface monitoring, see
“Configuring service-based failover” on page 67.

This option appears only if “Mode of operation” is master.

Enter an HA password for the HA group. You must configure the same Shared
password value on both the primary and secondary units.

Configuring the advanced options

Go to System > High Availability > Configuration to configure the advanced options.

Fortinet Technologies Inc.
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Table 10:HA advanced options

GUI item

HA base port

Heartbeat lost
threshold

Remote
services as
heartbeat

Description

Keep the default TCP port number (20000) that will be used for:

¢ the heartbeat signal

e synchronization control

e data synchronization

¢ configuration synchronization

Note: In addition to configuring the heartbeat, you can configure service
monitoring. For details, see “Configuring service-based failover” on page 67.

Note: In addition to automatic immediate and periodic configuration
synchronization, you can also manually initiate synchronization. For details,
see “click HERE to start a configuration/data sync” on page 60.

Enter the total span of time, in seconds, for which the primary unit can be
unresponsive before it triggers a failover and the secondary unit assumes the
role of the primary unit.

The heartbeat will continue to check for availability once per second. To
prevent premature failover when the primary unit is simply experiencing very
heavy load, configure a total threshold of three (3) seconds or more to allow
the secondary unit enough time to confirm unresponsiveness by sending
additional heartbeat signals.

Note: If the failure detection time is too short, the secondary unit may falsely
detect a failure when during periods of high load.

Caution: If the failure detection time is too long the primary unit could fail and
a delay in detecting the failure could mean that call is delayed or lost.
Decrease the failure detection time if email is delayed or lost because of an HA
failover.

Enable to use remote service monitoring as a secondary HA heartbeat. If
enabled and both the primary and secondary heartbeat links fail or become
disconnected, if remote service monitoring still detects that the primary unit is
available, a failover will not occur.

Note: The remote service check is only applicable for temporary heartbeat link
fails. If the HA process restarts due to system reboot or HA daemon reboot,
physical heartbeat connections will be checked first. If the physical
connections are not found, the remote service monitoring does not take effect
anymore.

Note: Using remote services as heartbeat provides HA heartbeat only, not
synchronization. To avoid synchronization problems, you should not use
remote service monitoring as a heartbeat for extended periods. This feature is
intended only as a temporary heartbeat solution that operates until you
reestablish a normal primary or secondary heartbeat link.

Configuring interface monitoring

Interface monitor checks the local interfaces on the primary unit. If a malfunctioning interface is
detected, a failover will be triggered.

Fortinet Technologies Inc.
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To configure interface monitoring

1. Go to System > High Availability > Configuration.
2. Select master or slave as the mode of operation.
3. Expand the Interface area, if required.
4

. Click on the port/interface name to configure the interface. For details, see “Configuring the
network interfaces” on page 41.

: The interface IP address must be different from, but on the same subnet as, the IP address of
( | the other heartbeat network interface of the other member in the HA group.

Y When configuring the other FortiVoice unit in the HA group, use this value as the remote peer IP.

5. Select a row in the table and click Edit to configure the following HA settings on the

interface.
GUI item Description
Port Displays the interface name you’re configuring.

Enable port  Enable to monitor a network interface for failure. If the port fails, the primary
monitor unit will trigger a failover.
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GUI item Description

Heartbeat Specify if this interface will be used for HA heartbeat and synchronization.

status e Disable

Do not use this interface for HA heartbeat and synchronization.
e Primary

Select the primary network interface for heartbeat and synchronization
traffic. For more information, see “About the heartbeat and
synchronization” on page 56.

This network interface must be connected directly or through a switch to
the Primary heartbeat network interface of the other member in the HA
group.

e Secondary

Select the secondary network interface for heartbeat and
synchronization traffic. For more information, see “About the heartbeat
and synchronization” on page 56.

The secondary heartbeat interface is the backup heartbeat link between
the units in the HA group. If the primary heartbeat link is functioning, the
secondary heartbeat link is used for the HA heartbeat. If the primary
heartbeat link fails, the secondary link is used for the HA heartbeat and
for HA synchronization.

This network interface must be connected directly or through a switch to
the Secondary heartbeat network interfaces of the other member in the
HA group.

Caution: Using the same network interface for both HA
synchronization/heartbeat traffic and other network traffic could result in
issues with heartbeat and synchronization during times of high traffic load,
and is not recommended.

Note: In general, you should isolate the network interfaces that are used for
heartbeat traffic from your overall network. Heartbeat and synchronization
packets contain sensitive configuration information, are latency-sensitive,
and can consume considerable network bandwidth.

Peer IP Enter the IP address of the matching heartbeat network interface of the
address other member of the HA group.

For example, if you are configuring the primary unit’s primary heartbeat
network interface, enter the IP address of the secondary unit’s primary
heartbeat network interface.

Similarly, for the secondary heartbeat network interface, enter the IP
address of the other unit’s secondary heartbeat network interface.

For information about configuration synchronization and what is not
synchronized, see “About the heartbeat and synchronization” on page 56.
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GUI item Description

Virtual IP Select whether and how to configure the IP addresses and netmasks of the
action FortiVoice unit whose effective HA mode of operation is currently master.

For example, a primary unit might be configured to receive phone call traffic
through port1 and receive heartbeat and synchronization traffic through
port3 and port4. In that case, you would configure the primary unit to set
the IP addresses or add virtual IP addresses for port1 of the secondary unit
on failover in order to mimic that of the primary unit.

¢ [gnore: Do not change the network interface configuration on failover,
and do not monitor. For details on service monitoring for network
interfaces, see “Configuring the network interfaces” on page 41.

e Use: Add the specified virtual IP address and netmask to the network
interface on failover. Normally, you will configure your network so that
clients use the virtual IP address. This option results in the network
interface having two IP Addresses: the actual and the virtual.

Virtual IP Enter the virtual IPv4 address for this interface.
address

Configuring service-based failover

Go to System > High Availability > Configuration to configure remote service monitoring, local
network interface monitoring, and local hard drive monitoring.

HA service monitoring settings are not synchronized and must be configured separately on
each primary and secondary unit.

With remote service monitoring, the secondary unit confirms that it can connect to the primary
unit over the network using SIP and HTTP connections.

With local network interface monitoring and local hard drive monitoring, the primary unit
monitors its own network interfaces and hard drives.

If service monitoring detects a failure, the effective HA operating mode of the primary unit
switches to off or failed (depending on the On failure setting).A failover then occurs, and the
effective HA operating mode of the secondary unit switches to master. For information on the
On failure option, see “Configuring the HA mode and group” on page 61. For information on the
effective HA operating mode, see “Monitoring the HA status” on page 58.

To configure service monitoring

1. Go to System > High Availability > Configuration.

Select master or slave as the mode of operation.

Expand the service monitor area, if required.

Select a row in the table and click Edit to configure it.

For Remote HTTP, configure the following:

A S A

GUI item Description

Enable Select to enable connection responsiveness tests for SMTP.
Name Displays the service hame.

Remote IP Enter the peer IP address.

Port Enter the port number of the peer SMTP service.
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GUI item Description

Timeout Enter the timeout period for one connection test.
Interval Enter the frequency of the tests.
Retries Enter the number of consecutively failed tests that are allowed before the

primary unit is deemed unresponsive and a failover occurs.

6. For SIP UDP, configure the following:

GUI item Description
Enable Select to enable SIP UDP service.
Name Displays the service hame.

Remote IP Enter the peer IP address.

Port Enter the port number of the peer SIP UDP service.

Timeout Enter the timeout period for one connection test.

Interval Enter the frequency of the tests.

Retries Enter the number of consecutively failed tests that are allowed before the

primary unit is deemed unresponsive and a failover occurs.

7. For Interface monitor and Local hard drives, configure the following:

GUI item Description

Enable Select to enable local hard drive monitoring. Interface monitoring is enabled
when you configure interface monitoring. See “Configuring interface
monitoring” on page 64.

Network interface monitoring tests all active network interfaces whose:

e “Virtual IP action” setting is not Ignore
e “Configuring interface monitoring” setting is enabled

For details, see “Configuring interface monitoring” on page 64 and “Virtual
IP action” on page 67.

Interval Enter the frequency of the test.

Retries Specify the number of consecutively failed tests that are allowed before the
local interface or hard drive is deemed unresponsive and a failover occurs.

Example: Failover scenarios

This section describes basic FortiVoice active-passive HA failover scenarios. For each scenario,
refer to the HA group shown in Figure 22. To simplify the descriptions of these scenarios, the
following abbreviations are used:

¢ P1 is the configured primary unit.
e S2 is the configured secondary unit.
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Figure 22:Example active-passive HA group
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This section contains the following HA failover scenarios:

Failover scenario 1: Temporary failure of the primary unit

Failover scenario 2: System reboot or reload of the primary unit

Failover scenario 3: System reboot or reload of the secondary unit

Failover scenario 4: System shutdown of the secondary unit

Failover scenario 5: Primary heartbeat link fails

Failover scenario 6: Network connection between primary and secondary units fails (remote

service monitoring detects a failure)

Failover scenario 1: Temporary failure of the primary unit

In this scenario, the primary unit (P1) fails because of a software failure or a recoverable
hardware failure (in this example, the P1 power cable is unplugged). HA logging and alert email
are configured for the HA group.

When the secondary unit (S2) detects that P1 has failed, S2 becomes the new primary unit and
continues processing phone calls.

There is no data loss when failover happens although active calls are disconnected and line
appearance and extension appearance take time to restore. Call data consists of the FortiVoice
call detailed records, recorded calls, voicemail, call directories, fax, and voice prompts. The
user web portal is not affected.

Here is what happens during this process:

1.
2.
3.

Fortinet Technologies Inc.

The FortiVoice HA group is operating normally.

The power is accidentally disconnected from P1.

S2’s heartbeat test detects that P1 has failed.

How soon this happens depends on the HA daemon configuration of S2.

The effective HA operating mode of S2 changes to master.

S2 sends an alert email similar to the following, indicating that S2 has determined that P1
has failed and that S2 is switching its effective HA operating mode to master.

This is the HA machine at 172.16.5.11.
The following event has occurred

‘MASTER heartbeat disappeared’
The state changed from ‘SLAVE’ to ‘MASTER’
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6.

Re

S2 records event log messages (among others) indicating that S2 has determined that P1
has failed and that S2 is switching its effective HA operating mode to master.

covering from temporary failure of the primary unit

After P1 recovers from the hardware failure, what happens next to the HA group depends on

P1’

Fig

Fa

If y

s HA On failure settings under System > High Availability > Configuration.

ure 23: HA On Failure settings

4 | HA Configuration

Maode of operation: | master a
On failure: switch off A

Shared password: | change_me

switch off

P1 will not process calls or join the HA group until you manually select the effective HA
operating mode (see “click HERE to restore configured operating mode” on page 60).

wait for recovery then restore original role

On recovery, P1’s effective HA operating mode resumes its configured master role. This also
means that S2 needs to give back the master role to P1. This behavior may be useful if the
cause of failure is temporary and rare, but may cause problems if the cause of failure is
permanent or persistent.

In the case, the S2 will send out another alert email similar to the following:
This is the HA machine at 172.16.5.11.

The following event has occurred
‘SLAVE asks us to switch roles (recovery after a restart)
The state changed from ‘MASTER’ to ‘SLAVE’

After recovery, P1 also sends out an alert email similar to the following:

This is the HA machine at 172.16.5.10.

The following critical event was detected
The system was shutdown!

wait for recovery then restore slave role

On recovery, P1’s effective HA operating mode becomes slave, and S2 continues to assume
the master role. P1 then synchronizes with the current master unit, S2. For information on
manually restoring the FortiVoice unit to acting in its configured HA mode of operation, see
“click HERE to restore configured operating mode” on page 60.

ilover scenario 2: System reboot or reload of the primary unit

ou need to reboot or reload (not shut down) P1 for any reason, such as a firmware upgrade

or a process restart, by using the CLI commands execute reboot or execute reload, or

by

Fortinet Technologies Inc.

clicking the Restart button under Status > Dashboard > System Command on the GUI:

P1 will send a holdoff command to S2 so that S2 will not take over the master role during
P1’s reboot.

P1 will also send out an alert email similar to the following:
This is the HA machine at 172.16.5.10.
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The following critical event was detected
The system is rebooting (or reloading)!

e S2 will hold off checking the services and heartbeat with P1. Note that S2 will only hold off
for about 5 minutes. In case P1 never boots up, S2 will take over the master role.

e S2 will send out an alert email, indicating that S2 received the holdoff command from P1.
This is the HA machine at 172.16.5.11.

The following event has occurred
‘peer rebooting (or reloading)’
The state changed from ‘SLAVE’ to ‘HOLD_OFF’

After P1 is up again:

e P1 will send another command to S2 and ask S2 to change its state from holdoff to slave
and resume monitoring P1’s services and heartbeat.

e S2 will send out an alert email, indicating that S2 received instruction commands from P1.
This is the HA machine at 172.16.5.11.

The following event has occurred
‘peer command appeared’
The state changed from ‘HOLD_OFF’ to ‘SLAVE’

¢ 52 logs the event in the HA logs.

Failover scenario 3: System reboot or reload of the secondary unit

If you need to reboot or reload (not shut down) S2 for any reason, such as a firmware upgrade

or a process restart, by using the CLI commands execute reboot or execute reload, or

by clicking the Restart button under Monitor > System Status > Status on the GUI, the behavior
of P1 and S2 is as follows:

¢ P1 will send out an alert email similar to the following, informing the administrator of the
heartbeat loss with S2.

This is the HA machine at 172.16.5.10.

The following event has occurred
‘ha: SLAVE heartbeat disappeared’

e S2 will send out an alert email similar to the following:
This is the HA machine at 172.16.5.11.

The following critical event was detected
The system is rebooting (or reloading)!

e P1 will also log this event in the HA logs.
Failover scenario 4: System shutdown of the secondary unit

If you shut down S2:

¢ No alert email is sent out from either P1 or S2.
¢ P1 will log this event in the HA logs.
Failover scenario 5: Primary heartbeat link fails

If the primary heartbeat link fails, such as when the cable becomes accidentally disconnected,
and if you have not configured a secondary heartbeat link, the FortiVoice units in the HA group
cannot verify that other units are operating and assume that the other has failed. As a result, the
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secondary unit (S2) changes to operating as a primary unit, and both FortiVoice units are acting
as primary units.

Two primary units connected to the same network may cause address conflicts on your
network. Additionally, because the heartbeat link is interrupted, the FortiVoice units in the HA
group cannot synchronize configuration changes or voice data changes.

Even after reconnecting the heartbeat link, both units will continue operating as primary units.
To return the HA group to normal operation, you must connect to the web-based manager of S2
to restore its effective HA operating mode to slave (secondary unit).

1. The FortiVoice HA group is operating normally.
2. The heartbeat link Ethernet cable is accidently disconnected.
3. S2’s HA heartbeat test detects that the primary unit has failed.
How soon this happens depends on the HA daemon configuration of S2.
4. The effective HA operating mode of S2 changes to master.

5. S2 sends an alert email similar to the following, indicating that S2 has determined that P1
has failed and that S2 is switching its effective HA operating mode to master.

This is the HA machine at 172.16.5.11.

The following event has occurred
‘MASTER heartbeat disappeared’
The state changed from ‘SLAVE’ to ‘MASTER’

6. S2 records event log messages (among others) indicating that S2 has determined that P1
has failed and that S2 is switching its effective HA operating mode to master.

Recovering from a heartbeat link failure

Because the hardware failure is not permanent (that is, the failure of the heartbeat link was
caused by a disconnected cable, not a failed port on one of the FortiVoice units), you may want
to return both FortiVoice units to operating in their configured modes when rejoining the failed
primary unit to the HA group.

To return to normal operation after the heartbeat link fails

1. Reconnect the primary heartbeat interface by reconnecting the heartbeat link Ethernet
cable.

Even though the effective HA operating mode of S2 is master, S2 continues to attempt to
find the other primary unit. When the heartbeat link is reconnected, S2 finds P1 and
determines that P1 is also operating as a primary unit. So S2 sends a heartbeat signal to
notify P1 to stop operating as a primary unit. The effective HA operating mode of P1
changes to off.

2. P1 sends an alert email similar to the following, indicating that P1 has stopped operating as
the primary unit.

This is the HA machine at 172.16.5.10
The following event has occurred
'SLAVE asks us to switch roles (user requested takeover)'
The state changed from 'MASTER' to 'OFF'
3. P1 records event log messages (among others) indicating that P1 is switching to off mode.

The configured HA mode of operation of P1 is master and the effective HA operating mode
of P1 is off.

The configured HA mode of operation of S2 is slave and the effective HA operating mode of
S2 is master.

4. Connect to the web-based manager of P1, go to System > High Availability > Status.
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5. Check for synchronization messages.
Do not proceed to the next step until P1 has synchronized with S2.

6. Connect to the web-based manager of S2, go to System > High Availability > Status and
select click HERE to restore configured operating mode.

The HA group should return to normal operation. P1 records the event log message (among
others) indicating that S2 asked P1 to return to operating as the primary unit.

P1 and S2 synchronize again. P1 processes phone calls normally.

Failover scenario 6: Network connection between primary and secondary units
fails (remote service monitoring detects a failure)

Depending on your network configuration, the network connection between the primary and
secondary units can fail for a number of reasons. In the network configuration shown in

Figure 22 on page 69, the connection between port1 of primary unit (P1) and port1 of the
secondary unit (S2) can fail if a network cable is disconnected or if the switch between P1 and
S2 fails.

A more complex network configuration could include a number of network devices between the
primary and secondary unit’s non-heartbeat network interfaces. In any configuration, remote
service monitoring can only detect a communication failure. Remote service monitoring cannot
determine where the failure occurred or the reason for the failure.

In this scenario, remote service monitoring has been configured to make sure that S2 can
connect to P1. The On failure setting located in the HA main configuration section is wait for
recovery then restore slave role. For information on the On failure setting, see “On failure” on
page 63. For information about remote service monitoring, see “Configuring service-based
failover” on page 67.

The failure occurs when power to the switch that connects the P1 and S2 port1 interfaces is
disconnected. Remote service monitoring detects the failure of the network connection
between the primary and secondary units. Because of the On failure setting, P1 changes its
effective HA operating mode to failed.

When the failure is corrected, P1 detects the correction because while operating in failed mode
P1 has been attempting to connect to S2 using the port1 interface. When P1 can connect to S2,
the effective HA operating mode of P1 changes to slave and the voice data on P1 will be
synchronized to S2. S2 can now deliver the calls. The HA group continues to operate in this
manner until an administrator resets the effective HA modes of operation of the FortiVoice units.

1. The FortiVoice HA group is operating normally.

2. The power cable for the switch between P1 and S2 is accidently disconnected.

3. S2’s remote service monitoring cannot connect to the primary unit.

How soon this happens depends on the remote service monitoring configuration of S2.
Through the HA heartbeat link, S2 signals P1 to stop operating as the primary unit.
The effective HA operating mode of P1 changes to failed.

The effective HA operating mode of S2 changes to master.

N o o

S2 sends an alert email similar to the following, indicating that S2 has determined that P1
has failed and that S2 is switching its effective HA operating mode to master.

This is the HA machine at 172.16.5.11.

The following event has occurred
‘MASTER remote service disappeared’
The state changed from ‘SLAVE’ to ‘MASTER’

8. S2 logs the event (among others) indicating that S2 has determined that P1 has failed and
that S2 is switching its effective HA operating mode to master.
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P1 sends an alert email similar to the following, indicating that P1 has stopped operating in
HA mode.

This is the HA machine at 172.16.5.10.

The following event has occurred
'SLAVE asks us to switch roles (user requested takeover)'

The state changed from 'MASTER' to 'FAILED'

10.P1 records the log messages (among others) indicating that P1 is switching to Failed mode.

Recovering from a network connection failure

Because the network connection failure was not caused by failure of either FortiVoice unit, you
may want to return both FortiVoice units to operating in their configured modes when rejoining
the failed primary unit to the HA group.

To return to normal operation after the heartbeat link fails

1.

Reconnect power to the switch.

Because the effective HA operating mode of P1 is failed, P1 is using remote service
monitoring to attempt to connect to S2 through the switch.

When the switch resumes operating, P1 successfully connects to S2.

P1 has determined the S2 can connect to the network and process calls.
The effective HA operating mode of P1 switches to slave.

P1 logs the event.

P1 sends an alert email similar to the following, indicating that P1 is switching its effective
HA operating mode to slave.

This is the HA machine at 172.16.5.10.

The following event has occurred
'SLAVE asks us to switch roles (user requested takeover)'

The state changed from 'FAILED' to 'SLAVE'

Connect to the web-based manager of P1 and go to System > High Availability > Status.
Check for synchronization messages.

Do not proceed to the next step until P1 has synchronized with S2.

Connect to the web-based manager of S2, go to System > High Availability > Status and
select click HERE to restore configured operating mode.

Connect to the web-based manager of P1, go to System > High Availability > Status and
select click HERE to restore configured operating mode.

P1 should return to operating as the primary unit and S2 should return to operating as the
secondary unit.

P1 and S2 synchronize again. P1 can now process phone calls normally.

Configuring system time, system options, SNMP, email setting, GUI
appearance, and call data storage

The System > Configuration submenu lets you configure the system time, system options,
SNMP, email setting, GUI appearance, and call data storage.
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This topic includes:

¢ Configuring the time and date

¢ Configuring system options

¢ Configuring SNMP queries and traps

¢ Configuring email settings

e Customizing the GUI appearance

¢ Selecting the call data storage location

Configuring the time and date

The System > Configuration > Time tab lets you configure the system time and date of the

FortiVoice unit.

You can either manually set the FortiVoice system time or configure the FortiVoice unit to
automatically keep its system time correct by synchronizing with Network Time Protocol (NTP)

servers.

For many features to work, including scheduling, logging, and certificate-dependent features,
the FortiVoice system time must be accurate.

FortiVoice units support daylight savings time (DST), including recent changes in the USA,
Canada and Western Australia.

To configure the system time

1. Go to System > Configuration > Time.

2. Configure the following:

Figure 24: Time Settings tab

Time Settings
System time: 02/24/2014 11:21:26 Refresh
Time zone (GMT-5:00)Eastern Time(US & Canada) .t

Automatically adjust clock for daylight saving time changes

@ Synchronize with NTP Server (may take up to several minutes)

Senver.

Sync Interval: | 60

) Setdate

Apply Cancel

GUI field

System time
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pool.ntp.org

3]

(minutes)

“ Time 7 w7 7

Description
Displays the date and time according to the FortiVoice unit’s clock at

the time that this tab was loaded, or when you last selected the
Refresh button.
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Time zone

Synchronize with
NTP Server

Set date

3. Click Apply.

Select the time zone in which the FortiVoice unit is located.

Automatically adjust clock for daylight saving time changes:
Enable to adjust the FortiVoice system clock automatically when
your time zone changes to daylight savings time (DST) and back
to standard time.

When selecting time zone in CLI, use the command config
system time manual and enter the code before the time zone in
Table 11 on page 76.

Select to use a network time protocol (NTP) server to automatically
set the system date and time, then configure Server and Sync
Interval.

Server: Enter the IP address or domain name of an NTP server.

You can add a maximum of 10 NTP servers. The FortiVoice unit
uses the first NTP server based on the selection mechanism of
the NTP protocol.

Click the + sign to add more servers.

Click the - sign to remove servers. Note that you cannot remove
the last server.

To find the NTP servers that you can use, see http://www.ntp.org.

Sync Interval: Enter how often, in minutes, the FortiVoice unit
should synchronize its time with the NTP server. For example,
entering 1440 causes the FortiVoice unit to synchronize its time
once a day.

Depending on your network traffic, it may take some time for the
FortiVoice unit to synchronize its time with the NTP server.

Select this option to manually set the date and time of the FortiVoice
unit’s clock, then select the Year, Month, Day, Hour, Minute, and
Second fields before you click Apply.

Alternatively, configure Synchronize with NTP server.

Table 11:Time zone codes for CLI configuration

Code Time Zone

0 (GMT-12:00) Eniwetok, Kwajalein

1 (GMT-11:00) Midway Island, Samoa

2 (GMT-10:00) Hawaii

3 (GMT-9:00) Alaska

4 (GMT-8:00) Pacific Time (US&amp; Canada)

5 (GMT-7:00) Arizona

6 (GMT-7:00) Mountain Time (US&amp; Canada)
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Table 11:Time zone codes for CLI configuration

Code Time Zone

7 (GMT-6:00) Central America

8 (GMT-6:00) Central Time

9 (GMT-6:00) Mexico City

10 (GMT-6:00) Saskatchewan

11 (GMT-5:00) Bogota, Lima, Quito

12 (GMT-5:00) Eastern Time (US &amp; Canada)

13 (GMT-5:00) Indiana (East)

14 (GMT-4:30) Venezuela Standard Time

15 (GMT-4:00) Atlantic Time (Canada)

16 (GMT-4:00) Caracas, La Paz

17 (GMT-4:00) Santiago

18 (GMT-3:30) Newfoundland

19 (GMT-3:00) Brasilia

20 (GMT-3:00) Buenos Aires, Georgetown

21 (GMT-3:00) Greenland

22 (GMT-2:00) Mid-Atlantic

23 (GMT-1:00) Azores

24 (GMT-1:00) Cape Verde lIs.

25 (GMT) Casablanca, Monrouia

26 (GMT) Greenwich Mean Time: Dublin, Edinburgh, Lisbon, London
27 (GMT+1:00) Amsterdam, Berlia, Bern, Rome, Stockholm, Vienna
28 (GMT+1:00) Belgrade, Bratislava, Budapest, Ljubljana, Prague
29 (GMT+1:00) Brussels, Copenhagen, Madrid, Paris

30 (GMT+1:00) Sarajevo, Skopje, Sofija, Vilnius, Warsaw, Zagreb
31 (GMT+1:00) West Central Africa

32 (GMT+2:00) Athens, Istanbul, Minsk

33 (GMT+2:00) Bucharest

34 (GMT+2:00) Cairo

35 (GMT+2:00) Harare, Pretoria
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Table 11:Time zone codes for CLI configuration

Code Time Zone

36 (GMT+2:00) Helsinki, Riga, Tallinn

37 (GMT+2:00) Jerusalem

38 (GMT+3:00) Baghdad

39 (GMT+3:00) Kuwait, Riyadh

40 (GMT+3:00) Moscow, St.Petersburg, Volgograd
41 (GMT+3:00) Nairobi

42 (GMT+3:30) Tehran

43 (GMT+4:00) Abu Dhabi, Muscat

44 (GMT+4:00) Baku, Thilisi, Yerevan

45 (GMT+4:30) Kabul

46 (GMT+5:00) Ekaterinburg

a7 (GMT+5:00) Islamabad, Karachi, Tashkent

48 (GMT+5:30) Calcutta, Chennai, Mumbai, New Delhi
49 (GMT+5:45) Kathmandu

50 (GMT+6:00) Almaty, Novosibirsk

51 (GMT+6:00) Astana, Dhaka

52 (GMT+6:00) Sri Jayawardenepara

53 (GMT+6:30) Rangoon

54 (GMT+7:00)B angkok, Hanoi, Jakarta

55 (GMT+7:00) Krasnoyarsk

56 (GMT+8:00) Beijing, Chong Qing, Hong Kong, Urumgi
57 (GMT+8:00) Irkutsk, Ulaan Bataar

58 (GMT+8:00) Kuala Lumpur, Singapore

59 (GMT+8:00) Perth

60 (GMT+8:00) Taipei

61 (GMT+9:00) Osaka, Sapporo, Tokyo, Seoul

62 (GMT+9:00) Yakutsk

63 (GMT+9:30) Adelaide, Darwin

64 (GMT+10:00) Brisbane
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Table 11:Time zone codes for CLI configuration

Code Time Zone

65 (GMT+10:00) Canberra, Melbourne, Sydney

66 (GMT+10:00) Guam, Port Moresby, Hobart, Vladivostok
67 (GMT+11:00) Magadan, Solomon Is., New Caledonia
68 (GMT+12:00) Auckland, Wellington

69 (GMT+12:00) Fiji, Kamchatka, Marshall Is.

70 (GMT+13:00) Nuku'alofa

71 (GMT-3:00) Montevideo

72 (GMT+3:00) Minsk

Configuring system options

The System > Configuration > Options tab lets you set the following global settings:
¢ system idle timeout

e password enforcement policy

¢ administration ports on the interfaces

To view and configure the system options
1. Go to System > Configuration > Options.
2. Configure the following:
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Figure 25: Options tab
Configuration Options
ldle imeout: | 45 (1-480 minutes)
~|Password [ PIN Policy

Enable

Uppercase letter
Lowercase letter

Mumber (0-3)

Mon alphanumeric character
Administrators

SIP users

Mumber (0-3)
FIM special
Woicemail users

+ | Administration Ports

HTTP port number: 80
HTTPS port number. 443
S5H port number: 22
TELMNET port number: 23

Web action hostiIP:

Apply Cancel

GUI field Description

Idle timeout Enter the amount of time that an administrator may be inactive
before the FortiVoice unit automatically logs out the administrator.

For better security, use a low idle timeout value.
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Password / PIN Displays the SIP password and user PIN policy for administrators
Policy and extension users. For information on setting SIP password and
user PIN, see “Configuring IP extensions” on page 135.
e Enable: Select to enable the password/PIN policy.

e  Minimum password length: Set the minimum acceptable length
(8) for passwords.

e Password must contain: Select any of the following special
character types to require in a password. Each selected type
must occur at least once in the password.

e Uppercase letters — A, B, C, ... Z

e [owercase letters — a, b, ¢, ...z

e Number —0...9

e Non alphanumeric character — punctuation marks, @,#, ... %

e Apply password policy to: Select where to apply the password
policy:
e Administrators — Apply to administrator passwords. If any

password does not conform to the policy, require that
administrator to change the password at the next login.

e SIP users — Apply to FortiVoice SIP phone users’ passwords.
If any password does not conform to the policy, require that
user to change the password at the next login.

e  Minimum PIN length: Set the minimum acceptable length (6) for
the user PIN.

* PIN must contain:
e Number: Select to include a number (0-9) in the PIN.
* PIN special: Select to include * or # or both in the PIN.

e Apply PIN policy to: Select Voicemail users to apply the policy to
FortiVoice phone users’ user PIN. If any PIN does not conform to
the policy, require that user to change the PIN at the next login.

Administration Specify the TCP ports for administrative access on all interfaces.
Ports Default port numbers:

HTTP: 80

HTTPS: 443

SSH: 22

TELNET: 23

Web action host/IP Enter the host name or IP address from where a email notification is
sent to you when a voice mail or fax is delivered to your extension.
This IP address is included in the email notification. You can open
the link to view or manage the voice mail or fax. If you leave this field
empty, port1 IP will be used instead.
The value entered here replaces the default Url host variable for
customizing messages. See “Customizing call report and notification
email templates” on page 108.

3. Click Apply.
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Configuring SNMP queries and traps
Go to System > Configuration > SNMP to configure SNMP to monitor FortiVoice system events
and thresholds, or a high availability (HA) configuration for failover messages.

To monitor FortiVoice system information and receive FortiVoice traps, you must compile
Fortinet proprietary MIBs as well as Fortinet-supported standard MIBs into your SNMP
manager. RFC support includes support for most of RFC 2665 (Ethernet-like MIB) and most of
RFC 1213 (MIB Il). For more information, see “FortiVoice MIBs” on page 86.

The FortiVoice SNMP implementation is read-only. SNMP v1, v2c¢, and v3 compliant SNMP
managers have read-only access to FortiVoice system information and can receive FortiVoice
traps.

The FortiVoice SNMP v3 implementation includes support for queries, traps, authentication, and
privacy. Before you can use its SNMP queries, you must enable SNMP access on the network
interfaces that SNMP managers will use to access the FortiVoice unit. For more information, see
“Editing network interfaces” on page 42.

This topic includes:

¢ Configuring an SNMP threshold

¢ Configuring email settings

e Configuring an SNMP v3 user
Configuring an SNMP threshold

Configure under what circumstances an event is triggered.

To set SNMP thresholds
1. Go System > Configuration > SNMP.

SHMP System Information

SNMP agent enable:

Description: foritvoice

Location: ottawa

Contact: fvc_ga@ott-fortimail.com

4 | SNMP Threshold

Sample Period (s) | Sample Freq (s)

CPU Usage 5% 1 500 30
Memory Usage 10% 3 500 30
Log Disk Usage 10% 1 7200 3500
Voice Disk Usage 10% 1 7200 3500
Apply Cancel
Community
E:: Mew... ﬁ W
Queries
fortivoice 0 0 0
|
User
E:: Mew... ﬁ W

Queries Security Level

yong @ @ [} Authentication, privacy

2. Configure the following:
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GUI field
SNMP agent
enable
Description
Location
Contact

SNMP Threshold

Trap Type

Trigger

Threshold

Sample
Period(s)

Sample
Freq(s)

Community

Name

Status
Queries

Traps

Description

Enable to activate the FortiVoice SNMP agent. This must be enabled
to accept queries from SNMP managers or send traps from the
FortiVoice unit.

Enter a descriptive name for the FortiVoice unit.
Enter the location of the FortiVoice unit.
Enter administrator contact information.

To change a value in the four editable columns, select the value in any
row. It becomes editable. Change the value and click outside of the
field. A red triangle appears in the field’s corner and remains until you
click Apply.

Displays the type of trap, such as CPU Usage.

You can enter either the percent of the resource in use or the number
of times the trigger level must be reached before it is triggered.

For example, using the default value, if the mailbox disk is 90% or
more full, it will trigger.

Sets the number of triggers that will result in an SNMP trap.

For example, if the CPU level exceeds the set trigger percentage once
before returning to a lower level, and the threshold is set to more than
one, an SNMP trap will not be generated until that minimum number

of triggers occurs during the sample period.

Sets the time period in seconds during which the FortiVoice unit
SNMP agent counts the number of triggers that occurred.

This value should not be less than the Sample Freq(s) value.

Sets the interval in seconds between measurements of the trap
condition. You will not receive traps faster than this rate, depending
on the selected sample period.

This value should be less than the Sample Period(s) value.

Displays the list of SNMP communities (for SNMP v1 and v2c) added
to the FortiVoice configuration. For information on configuring a
community, see either “Configuring email settings” or “Configuring an
SNMP v3 user” on page 85.

Displays the name of the SNMP community. The SNMP Manager
must be configured with this name.

A green check mark icon indicates that the community is enabled.
A green check mark icon indicates that queries are enabled.

A green check mark icon indicates that traps are enabled.
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User

Name

Status
Queries

Traps

Displays the list of SNMP v3 users added to the FortiVoice
configuration. For information on configuring a v3 user, see
“Configuring an SNMP v3 user” on page 85.

Displays the name of the SNMP v3 user. The SNMP Manager must be
configured with this name.

A green check mark icon indicates that the user is enabled.
A green check mark icon indicates that queries are enabled.

A green check mark icon indicates that traps are enabled.

Security Level The security level of the SNMP v3 user.

Configuring an SNMP v1 and v2c community

An SNMP community is a grouping of equipment for SNMP-based network administration
purposes. You can add up to three SNMP communities so that SNMP managers can connect to
the FortiVoice unit to view system information and receive SNMP traps. You can configure each
community differently for SNMP traps and to monitor different events. You can add the IP
addresses of up to eight SNMP managers to each community.

To configure an SNMP community

1. Go to System > Configuration > SNMP.

2. Under Community, click New to add a community or select a community and click Edit.

Fortinet Technologies Inc.

The SNMP Community page appears.

Configure the following:

GUI field

Name

Enable

Community
Hosts

IP Address
Delete
(button)

Create
(button)

Description

Enter a name to identify the SNMP community. If you are editing an
existing community, you cannot change the name.

You can add up to 16 communities.

Enable to send traps to and allow queries from the community’s SNMP
managers.

Lists SNMP managers that can use the settings in this SNMP
community to monitor the FortiVoice unit. Click Create to create a new
entry.

You can add up to 16 hosts.

Enter the IP address of an SNMP manager. By default, the IP address is
0.0.0.0, so that any SNMP manager can use this SNMP community.

Click to remove this SNMP manager.

Click to add a new default entry to the Hosts list that you can edit as
needed.
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Queries

Traps

SNMP Event

4. Click Create.

Enter the Port number (161 by default) that the SNMP managers in this
community use for SNMP v1 and SNMP v2c¢ queries to receive
configuration information from the FortiVoice unit. Mark the Enable
check box to activate queries for each SNMP version.

Enter the Local Port and Remote Port numbers (162 local, 162 remote by
default) that the FortiVoice unit uses to send SNMP v1 and SNMP v2c¢
traps to the SNMP managers in this community. Enable traps for each
SNMP version that the SNMP managers use.

Enable each SNMP event for which the FortiVoice unit should send traps
to the SNMP managers in this community.

Note: Since FortiVoice checks its status in a scheduled interval, not all
the events will trigger traps. For example, FortiVoice checks its hardware
status every 60 seconds. This means that if the power is off for a few
seconds but is back on before the next status check, no system event
trap will be sent.

Configuring an SNMP v3 user

SNMP v3 adds more security by using authentication and privacy encryption. You can specify
an SNMP v3 user on FortiVoice so that SNMP managers can connect to the FortiVoice unit to
view system information and receive SNMP traps.

To configure an SNMP v3 user

1. Go to System > Configuration > SNMP.

2. Under User, click New to add a user or select a user and click Edit.

The SNMPv3 User page appears.

You can add up to 16 users.

3. Configure the following:

GUI field

User name

Enable

Security level

Fortinet Technologies Inc.

Description

Enter a name to identify the SNMP user. If you are editing an existing
user, you cannot change the name.

Enable to send traps to and allow queries from the user’'s SNMP
managers.

Choose one of the three security levels:

e No authentication, no privacy: This option is similar to SNMP v1 and
V2.

e Authentication, no privacy: This option enables authentication only.
The SNMP manager needs to supply a password that matches the
password you specify on FortiVoice. You must also specify the
authentication protocol (either SHA1 or MD5).

e Authentication, privacy: This option enables both authentication
and encryption. You must specify the protocols and passwords.
Both the protocols and passwords on the SNMP manager and
FortiVoice must match.
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Authentication For Security level, if you select either Authentication option, you must

Protocol specify the authentication protocol and password. Both the
authentication protocol and password on the SNMP manager and
FortiVoice must match.

Privacy For Security level, if you select Privacy, you must specify the
protocol encryption protocol and password. Both the encryption protocol and
password on the SNMP manager and FortiVoice must match.

Notification Hosts Lists the SNMP managers that FortiVoice will send traps to. Click
Create to create a new entry. You can add up to 16 host.

IP Address Enter the IP address of an SNMP manager. By default, the IP address
is 0.0.0.0, so that any SNMP manager can use this SNMP user.

Delete Click to remove this SNMP manager.
(button)
Create Click to add a new default entry to the Hosts list that you can edit as
(button) needed.
Queries Enter the Port number (161 by default) that the SNMP managers use

for SNMP v3 queries to receive configuration information from the
FortiVoice unit. Select the Enable check box to activate queries.

Traps Enter the Local Port and Remote Port numbers (162 local, 162 remote
by default) that the FortiVoice unit uses to send SNMP v3 traps to the
SNMP managers. Select the Enable check box to activate traps.

SNMP Event Enable each SNMP event for which the FortiVoice unit should send
traps to the SNMP managers.

Note: Since FortiVoice checks its status in a scheduled interval, not all
the events will trigger traps. For example, FortiVoice checks its
hardware status every 60 seconds. This means that if the power is off
for a few seconds but is back on before the next status check, no
system event trap will be sent.

4. Click Create.

FortiVoice MIBs

The FortiVoice SNMP agent supports Fortinet proprietary MIBs as well as standard RFC 1213
and RFC 2665 MIBs. RFC support includes support for the parts of RFC 2665 (Ethernet-like
MIB) and the parts of RFC 1213 (MIB lI) that apply to FortiVoice unit configuration.

The FortiVoice MIBs are listed in Table 12. You can obtain these MIB files from Fortinet technical
support. To communicate with the SNMP agent, you must compile these MIBs into your SNMP
manager.

Your SNMP manager may already include standard and private MIBs in a compiled database
that is ready to use. You must add the Fortinet proprietary MIB to this database. If the standard
MIBs used by the Fortinet SNMP agent are already compiled into your SNMP manager you do
not have to compile them again.
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Table 12:FortiVoice MIBs

MIB file name Description

FortiVoice.mib Displays the proprietary Fortinet MIB includes detailed FortiVoice
system configuration information. Your SNMP manager requires this
information to monitor FortiVoice configuration settings. For more
information, see “MIB fields” on page 87.

FortiVoice traps

The FortiVoice unit’s SNMP agent can send traps to SNMP managers that you have added to
SNMP communities. To receive traps, you must load and compile the FortiVoice trap MIB into
the SNMP manager.

All traps sent include the trap message as well as the FortiVoice unit serial number and host

name.

MIB fields

Trap Description

fvTrapStorageDiskHighThreshold Trap sent if log disk usage and mailbox disk usage
become too high.

fvTrapSystemEvent Trap sent when system shuts down, reboots,
upgrades, etc.

fmiTrapHAEvent Trap sent when an HA event occurs.

The Fortinet MIB contains fields reporting current FortiVoice unit status information. The tables
below list the names of the MIB fields and describe the status information available for each.
You can view more details about the information available from all Fortinet MIB fields by
compiling the MIB file into your SNMP manager and browsing the MIB fields.
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Table 13:System session MIB fields

MIB field Description

fvSysModel FortiVoice model number, such as 400 for the FortiVoice-400.
fvSysSerial FortiVoice unit serial number.

fvSysVersion The firmware version currently running on the FortiVoice unit.
fvSysCpuUsage The current CPU usage (%).

fvSysMemUsage The current memory utilization (%).

fvSysLogDiskUsage The log disk usage (%).

fvSysStorageDiskUsa The storage disk usage (%).

ge
fvSysEventCode System component events.
fvSysload Current system load.
fvSysHA e fvHAMode: Configured HA operating mode.
o fvHAEffectiveMoce: Effective HA operating mode.
fmIHAEventid HA event type ID.
fmIHAUnitlp Unit IP address where the event occurs.

fmiHAEventReason The reason for the HA event.

Configuring email settings

You can configure the FortiVoice unit to send email notifications to phone users when they miss
a phone call or receive a voicemail or fax.

| For phone users to receive the notifications, you need to add their email addresses when
VY configuring the extensions. See “Configuring Extensions” on page 135.

To configure email settings
1. Go to System > Configuration > Mail Settings.
2. Configure the following:

Fortinet Technologies Inc. Page 88 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Fortinet Technologies Inc.

Figure 26: Mail server settings

= | Local Host

Host name: fecel-callcenter

Local domain name: | fortivoice.com

Mail Queue

Maximum time for email in queue (1-240 hours): | 24

Time interval for retry (10-120 minutes):

Relay Server

Relay server name: | mail.ott-fo-rtimail.com

Relay server port: | 465
Use SMTPs W
V ~ | Authentication Required

Customize email template

Applhy Cancel

GUI field
Local Host

Host name

Local domain name

Mail Queue

Maximum time for
email in queue
(1-240 hours)

Time interval for
retry (10-120
minutes)

Relay Server

Relay server name

Relay server port

10

Description

Enter the host name of the FortiVoice unit, such as
fortivoice-200D.

Enter the local domain name of the FortiVoice unit, such as
example.com.

Enter the maximum number of hours that deferred email
messages can remain in the deferred email queue, during
which the FortiVoice unit periodically retries to send the
message. After it reaches the maximum time, the FortiVoice
unit sends a final delivery status notification (DSN) email
message to notify the sender that the email message was
undeliverable.

Enter the number of minutes between delivery retries for email
messages in the deferred mail queues.

Configure an SMTP relay, if needed, to which the FortiVoice
unit will relay outgoing email. This is typically provided by your
Internet service provider (ISP), but could be a mail relay on
your internal network.

Enter the domain name of an SMTP relay.

Enter the TCP port number on which the SMTP relay listens.
This is typically provided by your Internet service provider
(ISP).
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Use SMTPs Enable to initiate SSL- and TLS-secured connections to the
SMTP relay if it supports SSL/TLS. When disabled, SMTP
connections from the FortiVoice unit’s built-in MTA or proxy to
the relay will occur as clear text, unencrypted.

This option must be enabled to initiate SMTPS connections.

Authentication Select the checkbox and click the arrow to expand the section
Required: and configure:

e User name: Enter the name of the FortiVoice unit’s account
on the SMTP relay.

e Password: Enter the password for the FortiVoice unit’s user
name.

e Authentication type: Available SMTP authentication types
include:

e AUTO (automatically detect and use the most secure
SMTP authentication type supported by the relay server)

e PLAIN (provides an unencrypted, scrambled password)
e [OGIN (provides an unencrypted, scrambled password)

e DIGEST-MD5 (provides an encrypted hash of the
password)

e CRAM-MDS5 (provides an encrypted hash of the
password, with hash replay prevention, combined with a
challenge and response mechanism)

Customize email template View and reword the default email history report and
notification email templates. For more information, see
“Customizing call report and notification email templates” on
page 108.

3. Click Apply.

Customizing the GUI appearance

The System > Configuration > Appearance tab lets you customize the default appearance of the
web-based manager and voicemail interface with your own product name, product logo,
corporate logo, and language.

To customize the GUI appearance

1. Go to System > Configuration > Appearance.

2. Click the arrow to expand Administration interface and Voicemail interface.

3. Configure the following to change appearance:

Fortinet Technologies Inc. Page 90 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Figure 27: Appearance tab
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+ | Administration interface

Product name: Fortivoice

New Appearance

Product icon: The icon should be in ico format, and 16*16 in size. | Change... Reset

Top logo (460*36): FortiVOice Enterprise 500 E- T2 Changg___ Reset

Default Ul language: | English

+|Voicemail interface

Voicemail login: Login
Login user name hint: | name
Voicemail theme: Red Grey

Voicemail Ul language: English

~

Veicemail top logo weozey: | - OrtiVoice Entel‘prise 500E-T2 Change... | | Reset

(Maximum image file size is 512 KB)

Apphy I Reset Cancel J

GUI field
Administration interface

Product name

Product icon

Top logo

Default Ul language

Voicemail interface

Description

Enter the name of the product. This name will precede
Administrator Login in the title on the login page of the
web-based manager.

Click Change to browse for the product icon. The icon should
be in .ico format, and 16 pixels wide x16 pixels tall in size.

Click Change to upload a graphic that will appear at the top of
all pages in the web-based manager. The image’s dimensions
must be 460 pixels wide by 36 pixels tall.

For best results, use an image with a transparent background.
Non-transparent backgrounds will not blend with the underlying
theme graphic, resulting in a visible rectangle around your logo
graphic.

Note: Uploading a graphic overwrites the current graphic. The
FortiVoice unit does not retain previous or default graphics. If
you want to revert to the current graphic, use your web browser
to save a backup copy of the image to your management
computer, enabling you to upload it again at a later time.

Click Reset to return to the default setting.
Select the default language for the display of the web-based
manager.

You can configure a separate language preference for each
administrator account. For details, see “Configuring
administrator accounts” on page 51.
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Voicemail login Enter a word or phrase that will appear on top of the voicemail
login page, such as Voicemail Login.

Login user name Enter a hint for the user name, such as Your Email Address. This

hint hint will appear as a mouse-over display on the login name
field.

Voicemail theme Select a theme for the voicemail GUL.

Voicemail Ul Select the language in which voicemail pages will be displayed.

language By default, the FortiVoice unit will use the same language as the

web-based manager

Voicemail top logo Click Change to upload a graphic that will appear at the top of
all webmail pages. The image’s dimensions must be 460 pixels
wide by 36 pixels tall.

For best results, use an image with a transparent background.
Non-transparent backgrounds will not blend with the underlying
theme graphic, resulting in a visible rectangle around your logo
graphic.

Note: Uploading a graphic overwrites the current graphic. The
FortiVoice unit does not retain previous or default graphics. If
you want to revert to the current graphic, use your web browser
to save a backup copy of the image to your management
computer, enabling you to upload it again at a later time.

Click Reset to return to the default setting.

4. Click Apply to save changes or Reset to return to the default settings.

Selecting the call data storage location

The System > Configuration > Storage tab lets you configure local or remote storage of call data
such as the recorded calls, faxes, and voice mails.

FortiVoice units can store call data either locally or remotely. FortiVoice units support remote
storage by a network attached storage (NAS) server using the network file system (NFS)
protocol.

NAS has the benefits of remote storage which include ease of backing up the call data and
more flexible storage limits. Additionally, you can still access the call data on the NAS server if

your FortiVoice unit loses connectivity.

If the FortiVoice unit is a member of an active-passive HA group, and the HA group stores call
data on a remote NAS server, disable call data synchronization to prevent duplicate call data

y traffic. For details, see “Configuring the HA mode and group” on page 61.

If you store the call data on a remote NAS device, you cannot back up the data. You can only
back up the call data stored locally on the FortiVoice hard disk. For information about backing

y up call data, see “Backing up configuration” on page 102.
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Tested and Supported NFS servers

e Linux NAS (NFS v3/v4)

Red Hat 5.5

Fedora 16/17/18/19

Ubuntu 11/12/13

OpenSUSE 13.1

e FreeNAS

¢ Openfiler

e EMC VNXe3150 (version 2.4.2.21519(MR4 SP2))
e EMC Isilon S200 (OneFS 7.1.0.3)

Untested NFS servers

e Buffalo TeraStation

¢ (Cisco Linksys NAS server

Non-Supported NFS Servers

¢ Windows 2003 R2 /Windows 2008 Service for NFS
To configure call data storage

1. Go to System > Configuration > Storage.
2. Configure the following:

GUI field Description
NAS section
Local Select to store call data on the FortiVoice unit’s local disk or RAID.

NAS server Select to store call data on a remote network attached storage (NAS)
server.

Test Click to verify the NAS server settings are correct and that the
FortiVoice unit can access that location. The test action basically

(button) : . . )
tries to discover, login, mount, and unmount the remote device.

This button is available only when NAS server is selected.
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Protocol

Refresh
(button)

Click here to
format this
device

Click here to
check file
system on
this device

Select a type of the NAS server:

e NFS: To configure a network file system (NFS) server. For this
option, enter the following information:

e Hostname/IP address: the IP address or fully qualified domain
name (FQDN) of the NFS server.

e Port: the TCP port number on which the NFS server listens for
connections.

e Directory: the directory path of the NFS export on the NAS
server where the FortiVoice unit will store call data.

e SCSI Server: To configure an Internet SCSI (Small Computer
System Interface) server. For this option, enter the following
information:

e Username: the user name of the FortiVoice unit’s account on
the iSCSI server.

e Password: the password of the FortiVoice unit’s account on
the iISCSI server.

e Hostname/IP address: the IP address or fully qualified domain
name (FQDN) of the iISCSI server.

e Port: the TCP port number on which the iISCSI server listens
for connections.

® Encryption key: the key that will be used to encrypt data
stored on the iSCSI server. Valid key lengths are between 6
and 64 single-byte characters.

e SCSI ID: the iSCSI identifier in the format expected by the
iISCSI server, such as an iSCSI Qualified Name (IQN),
Extended Unique Identifier (EUI), or T11 Network Address
Authority (NAA).

Status: When available, it indicates if the iISCSI share was
successfully mounted on the FortiVoice unit’s file system. This field
appears only after you configure the iSCSI share and click Apply.
Status may take some time to appear if the iSCSI server is slow to
respond.

If Not mounted appears, the iSCSI share was not successfully
mounted. Verify that the iSCSI server is responding and the
FortiVoice unit has both read and write permissions on the iSCSI
server.

This button appears when you configure an iSCSI server. Click it to
update the information in the Status field.

These two links appear when you configure an iSCSI server and click
Apply.

Click a link to initiate the described action (that is, format the device
or check its file system). A message appears saying the action is
being executed. Click OK to close the message and click Refresh to
see a Status update.

Note: If the ISCSI disk has never been formatted, the FortiVoice unit
needs to format it before it can be used. If the disk has been
formatted before, you do not need to format it again. unless you
want to wipe out the data on it.
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Managing certificates

This section explains how to manage X.509 security certificates using the FortiVoice web-based
manager. Using the Certificate submenu, you can generate certificate requests, install signed
certificates, import CA root certificates and certificate revocation lists, and back up and restore
installed certificates and private keys.

The FortiVoice unit uses certificates for PKI authentication in secure connections. PKI
authentication is the process of determining if a remote host can be trusted with access to
network resources. To establish its trustworthiness, the remote host must provide an
acceptable authentication certificate by obtaining a certificate from a certification authority (CA).

You can manage the following types of certificates on the FortiVoice unit:

Table 14:Certificate types

Certificate type |Usage

Server certificates | The FortiVoice unit must present its local server certificate for the
following secure connections:

¢ the web-based manager (HTTPS connections only)
e phone user web interface (HTTPS connections only)

e phone and FortiVoice unit (TLS and SRTP connections only), see
“Configuring SIP profiles” on page 118.

For details, see “Managing local certificates” on page 95.

CA certificates The FortiVoice unit uses CA certificates to authenticate the PKI users,
including administrators and phone users. For details, see “Managing
certificate authority certificates” on page 101.

Personal Phone users’ personal certificates are used for S/MIME encryption.
certificates

This section contains the following topics:

¢ Managing local certificates

¢ Obtaining and installing a local certificate
¢ Managing certificate authority certificates
¢ Managing the certificate revocation list

Managing local certificates
System > Certificate > Local Certificate displays both the signed server certificates and
unsigned certificate requests.

On this tab, you can also generate certificate signing requests and import signed certificates in
order to install them for local use by the FortiVoice unit.

FortiVoice units require a local server certificate that it can present when clients request secure
connections, including:

¢ the web-based manager (HTTPS connections only)
e phone user web interface (HTTPS connections only)

To view local certificates, go to System > Certificate > Local Certificate.
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Figure 28: Local Certificate tab
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Description

Select a certificate and click View to display its issuer, subject, and
range of dates within which the certificate is valid.

Click to generate a local certificate request. For more information, see
“Generating a certificate signing request” on page 97.

Click the row of a certificate file or certificate request file in order to
select it, then click this button and select either:

¢ Download: Download a certificate (.cer) or certificate request (.csr)
file. You can send the request to your certificate authority (CA) to
obtain a signed certificate for the FortiVoice unit. For more
information, see “Downloading a certificate signing request” on
page 99.

e Download PKCS12 File: Download a PKCS #12 (.p12) file. For
details, see “Downloading a PKCS #12 certificate” on page 101.

Click the row of a certificate in order to select it, then click this button to
use it as the “default” (that is, currently chosen for use) certificate. The
Status column changes to indicate that the certificate is the current
(Default) certificate.

This button is not available if the selected certificate is already the
“default.”

Click to import a signed certificate for local use. For more information,
see “Importing a certificate” on page 100.

Obtaining and installing a local certificate

There are two methods to obtain and install a local certificate:

¢ If you already have a signed server certificate (a backup certificate, a certificate exported
from other devices, and so on), you can import the certificate into the FortiVoice unit. For
details, see “Importing a certificate” on page 100.

¢ Generate a certificate signing request on the FortiVoice unit, get the request signed by a CA,
and import the signed certificate into the FortiVoice unit.

For the second method, follow these steps:

e Generating a certificate signing request

¢ Downloading a certificate signing request

¢ Submitting a certificate request to your CA for signing

e |mporting a certificate

Fortinet Technologies Inc.
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Generating a certificate signing request

You can generate a certificate request file, based on the information you enter to identify the
FortiVoice unit. Certificate request files can then be submitted for verification and signing by a
certificate authority (CA).

For other related steps, see “Obtaining and installing a local certificate” on page 96.

To generate a certificate request
1. Go to System > Certificate > Local Certificate.
2. Click Generate.
A dialog appeatrs.
3. Configure the following:

Figure 29: Generate Certificate Signing Request dialog
Generate Certificate Signing Request

Certification name:

Subject Information
ID type: | Host IP >

IP:

Optional Information

Organization unit: =

Organization:

Locality(City):

State/Province:

Country: Afghanistan e

E-mail:

Key type: i
Key size:| 512 Bit v

oK Cancel

GUI field Description
Certification name Enter a unique name for the certificate request, such as fvlocal.

Subject Information Information that the certificate is required to contain in order to
uniquely identify the FortiVoice unit.
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ID type

Domain name

E-mail

Optional
Information

Organization
unit

Organization

Fortinet Technologies Inc.

Select the type of identifier to be used in the certificate to identify the
FortiVoice unit:

e HostIP
e Domain name
e E-mail

Which type you should select varies by whether or not your
FortiVoice unit has a static IP address, a fully-qualified domain name
(FQDN), and by the primary intended use of the certificate.

For example, if your FortiVoice unit has both a static IP address and
a domain name, but you will primarily use the local certificate for
HTTPS connections to the web-based manager by the domain name
of the FortiVoice unit, you might prefer to generate a certificate
based on the domain name of the FortiVoice unit, rather than its IP
address.

e Host IP requires that the FortiVoice unit have a static, public IP
address. It may be preferable if clients will be accessing the
FortiVoice unit primarily by its IP address.

e Domain name requires that the FortiVoice unit have a
fully-qualified domain name (FQDN). It may be preferable if clients
will be accessing the FortiVoice unit primarily by its domain name.

e [E-mail does not require either a static IP address or a domain
name. It may be preferable if the FortiVoice unit does not have a
domain name or public IP address.

Enter the static IP address of the FortiVoice unit.

This option appears only if ID type is Host IP.

Type the fully-qualified domain name (FQDN) of the FortiVoice unit.

The domain name may resolve to either a static or, if the FortiVoice
unit is configured to use a dynamic DNS service, a dynamic IP
address. For more information, see “Configuring the network
interfaces” on page 41 and “Configuring DNS” on page 47.

If a domain name is not available and the FortiVoice unit subscribes
to a dynamic DNS service, an unable to verify certificate
message may appear in the user’s browser whenever the public IP
address of the FortiVoice unit changes.

This option appears only if ID type is Domain name.

Type the email address of the owner of the FortiVoice unit.

This option appears only if ID type is E-mail.

Information that you may include in the certificate, but which is not
required.

Type the name of your organizational unit, such as the name of your
department. (Optional)

To enter more than one organizational unit name, click the + icon,
and enter each organizational unit separately in each field.

Type the legal name of your organization. (Optional)
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Locality (City) Type the name of the city or town where the FortiVoice unit is
located. (Optional)

State/Province Type the name of the state or province where the FortiVoice unit is
located. (Optional)

Country Select the name of the country where the FortiVoice unit is located.
(Optional)
E-mail Type an email address that may be used for contact purposes.
(Optional)
Key type Displays the type of algorithm used to generate the key.

This option cannot be changed, but appears in order to indicate that
only RSA is currently supported.

Key size Select a security key size of 5712 Bit, 1024 Bit, 1536 Bit or 2048 Bit.
Larger keys are slower to generate, but provide better security.

4. Click OK.

The certificate is generated, and can be downloaded to your management computer for
submission to a certificate authority (CA) for signing. For more information, see
“Downloading a certificate signing request” on page 99.

Downloading a certificate signing request

After you have generated a certificate request, you can download the request file to your
management computer in order to submit the request file to a certificate authority (CA) for
signing.

For other related steps, see “Obtaining and installing a local certificate” on page 96.

To download a certificate request
1. Go to System > Certificate > Local Certificate.
2. Click the row that corresponds to the certificate request in order to select it.
3. Click Download, then select Download from the pop-up menu.
Your web browser downloads the certificate request (.csr) file.

Submitting a certificate request to your CA for signing
After you download the certificate request file, you can submit the request to you CA for
signing.

For other related steps, see “Obtaining and installing a local certificate” on page 96.

To submit a certificate request
1. Using the web browser on the management computer, browse to the web site for your CA.

2. Follow your CA’s instructions to place a Base64-encoded PKCS #12 certificate request,
uploading your certificate request.

3. Follow your CA’s instructions to download their root certificate and Certificate Revocation
List (CRL), and then install the root certificate and CRL on each remote client.

4. When you receive the signed certificate from the CA, install the certificate on the FortiVoice
unit. For more information, see “Importing a certificate” on page 100.
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Importing a certificate

You can upload Base64-encoded certificates in either privacy-enhanced email (PEM) or public
key cryptography standard #12 (PKCS #12) format from your management computer to the
FortiVoice unit.

DER encoding is not supported in FortiVoice version 2.0 GA.
Importing a certificate may be useful when:

® restoring a certificate backup
¢ installing a certificate that has been generated on another system

¢ installing a certificate, after the certificate request has been generated on the FortiVoice unit
and signed by a certificate authority (CA)

If you generated the certificate request using the FortiVoice unit, after you submit the certificate
request to CA, the CA will verify the information and register the contact information in a digital
certificate that contains a serial number, an expiration date, and the public key of the CA. The
CA will then sign the certificate and return it to you for installation on the FortiVoice unit. To
install the certificate, you must import it. For other related steps, see “Obtaining and installing a
local certificate” on page 96.

If the FortiVoice unit’s local certificate is signed by an intermediate CA rather than a root CA,
before clients will trust the FortiVoice unit’s local certificate, you must demonstrate a link with
trusted root CAs, thereby proving that the FortiVoice unit’s certificate is genuine. You can
demonstrate this chain of trust either by:

¢ installing each intermediate CA’s certificate in the client’s list of trusted CAs
¢ including a signing chain in the FortiVoice unit’s local certificate

To include a signing chain, before importing the local certificate to the FortiVoice unit, first open
the FortiVoice unit’s local certificate file in a plain text editor, append the certificate of each
intermediate CA in order from the intermediate CA who signed the FortiVoice unit’s certificate to
the intermediate CA whose certificate was signed directly by a trusted root CA, then save the
certificate. For example, a local certificate which includes a signing chain might use the
following structure:

<FortiVoice unit’s local server certificate>

<certificate of intermediate CA 1, who signed the FortiVoice
certificate>

<certificate of intermediate CA 2, who signed the certificate of
intermediate CA 1 and whose certificate was signed by a trusted
root CA>

To import a local certificate
1. Go to System > Certificate > Local Certificate.
2. Click Import.
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3. From Type, select the type of the import file or files:

e [Local Certificate: Select this option if you are importing a signed certificate issued by your
CA. For other related steps, see “Obtaining and installing a local certificate” on page 96.

e PKCS12 Certificate: Select this option if you are importing an existing certificate whose
certificate file and private key are stored in a PKCS #12 (.p12) password-encrypted file.

e Certificate: Select this option if you are importing an existing certificate whose certificate
file (.cert) and key file (.key) are stored separately. The private key is password-encrypted.

The remaining fields vary by your selection in Type.
4. Configure the following:

¢ Certificate file: Enter the location of the previously .cert or .pem exported certificate (or,
for PKCS #12 certificates, the .p12 certificate-and-key file), or click Browse to locate the
file.

¢ Key file: Enter the location of the previously exported key file, or click Browse to locate
the file.

This option appears only when Type is Certificate.

e Password: Enter the password that was used to encrypt the file, enabling the FortiVoice
unit to decrypt and install the certificate.

This option appears only when Type is PKCS12 certificate or Certificate.
5. Click OK.

Downloading a PKCS #12 certificate

You can export certificates from the FortiVoice unit to a PKCS #12 file for secure download and
import to another platform, or for backup purposes.

To download a PKCS #12 file

1. Go to System > Certificate > Local Certificate.

2. Click the row that corresponds to the certificate in order to select it.

3. Click Download, then select Download PKCS12 File on the pop-up menu.
A dialog appears.

4. In Password and Confirm password, enter the password that will be used to encrypt the
exported certificate file. The password must be at least four characters long.

5. Click Download.
6. If your browser prompts you for a location to save the file, select a location.

7. Your web browser downloads the PKCS #12 (.p12) file. For information on importing a PKCS
#12 file, see “Importing a certificate” on page 100.

Managing certificate authority certificates
Go to System > Certificates > CA Certificate to view and import certificates for certificate
authorities (CA).

Certificate authorities validate and sign other certificates in order to indicate to third parties that
those other certificates may be trusted to be authentic.

CA certificates are required by connections that use transport layer security (TLS), and by
S/MIME encryption. Depending on the configuration of each PKI user, CA certificates may also
be required to authenticate PKI users.

To view a the list of CA certificates, go to System > Certificate > CA Certificate. You can remove,
view, download, or import a CA certificate.
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Managing the certificate revocation list

The Certificate Revocation List tab lets you view and import certificate revocation lists.

To ensure that your FortiVoice unit validates only valid (not revoked) certificates, you should
periodically upload a current certificate revocation list, which may be provided by certificate
authorities (CA).

To view remote certificates, go to System > Certificate > Certificate Revocation List. You can
remove, view, download, or import a certificate revocation list.

Maintaining the system

The System > Maintenance submenu allows you to perform scheduled maintenance.
This topic includes:

¢ Maintaining the system configuration

¢ Downloading a trace file

Maintaining the system configuration

The System > Maintenance > Configuration tab contains features for use during scheduled
system maintenance: updates, backups, restoration, and centralized administration.

Backing up configuration

Before installing FortiVoice firmware or making significant configuration changes, back up your
FortiVoice configuration. Backups let you revert to your previous configuration if the new
configuration does not function correctly. Backups let you compare changes in configuration.

You can back up system configuration or user configuration. System configuration includes the
configurations that make the FortiVoice unit work. User configuration includes user-configured
settings, such as voicemail greetings, in addition to system configuration.

In addition to backing up your configuration manually, you can also configure a schedule to
back up the configuration automatically to the FortiVoice local hard drive or a remote FTP/SFTP
server.

To back up the configuration file
1. Go to System > Maintenance > Configuration.
2. In the Backup Configuration area, select System configuration or User data.

If you choose to back up user data and the user data files are not updated, select the files to
be updated and click Prepare first before proceeding to the next step.

3. Click Backup.

Your management computer downloads the configuration file. Time required varies by the
size of the file and the speed of your network connection. You can restore the backup
configuration later when required. For details, see “Restoring the configuration” on

page 103.

To schedule a configuration backup

1. Go to System > Maintenance > Configuration.

2. Under Scheduled Backup, configure the schedule time and the maximum backup number.
When the maximum number is reached, the oldest version will be overwritten.

3. Enable Local backup if you want to back up locally.
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4. Enable Remote backup and configure the FTP/SFTP server credentials if you want to back
up remotely.

5. Click Apply.

Restoring the configuration

In the Restore Configuration area under System > Maintenance > Configuration, you can restore
the backup FortiVoice configuration from your local PC. For details, see “Restoring the
configuration” on page 299.

Restoring the firmware

In the Restore Firmware area under System > Maintenance > Configuration, you can install a
FortiVoice firmware from your local PC. For details, see “Installing firmware” on page 296.

Downloading a trace file
If Fortinet Technical Support requests a trace log for system analysis purposes, you can
download one using the web-based manager.
Trace logs are compressed into an archive (.gz), and contain information that is supplementary
to debug-level log files.
To download a trace file
1. Go to System > Maintenance > Configuration.
2. At the bottom of the tab, click Download trace log.
Your web browser downloads trace.log.gz.
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Configuring Phone System

The Phone System menu lets you configure the FortiVoice PBX settings and other features for
managing phone calls.

This topic includes:

¢ Configuring phone system settings

e Configuring advanced phone system settings
¢ Managing sound files and music on hold

¢ Working with FortiVoice profiles

e Configuring FortiFone 870i

¢ Reviewing system configuration

Configuring phone system settings

Phone System > Settings let you configure the FortiVoice unit’s location, number management,
speed dial, and email notification templates.

You need to inform the users about some of the settings that affect them, such as number
settings and speed dial settings.

This topic includes:

e Setting PBX location and contact information
¢ Configuring PBX options
e Customizing call report and notification email templates

Setting PBX location and contact information

Identify the FortiVoice unit’s location and its number.

To set the PBX location
1. Go to Phone System > Settings > Location.
2. Configure the following:

GUI field Description

Country Select the country where the FortiVoice unit is in.

Emergency number Click the default number (911) to enter the emergency call number of
the selected country.

Long-distance Click the default number (1) to enter the prefix for dialing
prefix long-distance calls.

International prefix Click the default number (011) to enter the prefix for dialing
international calls.
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Outside line prefix

Area code

Area code is
required when
dialing local
numbers

Main display name

Main number

Default prompt
language

Contact Information

Emergency setting

3. Click Apply.

Configuring PBX options

Click the default number (9) to enter the prefix for making outbound
calls.

Click the default number (613) to enter the Area code for the main
number of the FortiVoice unit. This code is provided by your PSTN
service provider.

Select this option if the area code needs to be dialed for local phone
calls.

Enter the name displaying on the FortiVoice unit. This name is
provided by your PSTN service provider.

Enter the main number of the FortiVoice unit. This number is
provided by your PSTN service provider.

Select a new default prompt language for the FortiVoice unit. The
default is English.

This setting affects all of the FortiVoice unit’s voice prompts, such as
auto attendant and voice mail. However, if you change the sound file
for an individual component, such as auto attendant, to use a
different language, it will override the default prompt language for
this component.

For information on adding prompt languages, see “Adding prompt
languages” on page 113.

Optionally, enter your contact information.

Configure to send an alert email when an emergency call is made.

Select Do nothing if you don’t want the FortiVoice unit to send an
alert email. Otherwise, select Send alert email and enter the email
address.

The Phone System > Settings > Options tab lets you configure the pattern and number of digits
you want the FortiVoice unit to use for phone numbers, speed dials, and prefixes as well as the
default FortiVoice system settings. These settings apply to all extensions unless you change
them when configuring the extensions. For details, see “Setting up local extensions” on

page 135.

The FortiVoice unit supports the following pattern-matching syntax:

Table 15:Pattern-matching syntax

Syntax |Description

X

Matches any single digit from 0 to 9.

z

Matches any single digit from 1 to 9.

N

Matches any single digit from 2 to 9.
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Table 15:Pattern-matching syntax

Syntax |Description

[15-7] |Matches a single character from the range of digits specified. In this case, the
pattern matches a single 1, as well as any number in the range 5, 6, 7.

Wildcard match; matches one or more characters, no matter what they are.

! Wildcard match; matches zero or more characters, no matter what they are.

;or

(space)

, These pattern delimiters allow you to enter multiple pattern strings at a time. For
example, you can enter NXXX,6XXXX;[3-5]X

Table 16:Pattern-matching examples

Pattern Description

NXXX Matches any four-digit number, as long as the first digit is 2 or higher.

NXXNXXXXXX | This pattern matches with areas with 10-digit dialing.

TNXXNXXXXXX | Matches the number 1, followed by an area code between 200 and 999,
then any seven-digit number. In the North American Numbering Plan calling
area, you can use this pattern to match any long-distance number.

011. Matches any number that starts with 011 and has at least one more digit.

To configure PBX options

1. Go to Phone System > Settings > Options.

2. Configure the following:

Number Management

Extension number pattern: X,

Speed dial pattern: 3K
System prohibited prefix:
¥ P P 300 EHE
System unrestricted prefic:
4 P 800 EE
866
877
888
Operator extension: 7000

Supporting extension:

Default Setting

Default SIP user password: 'Specified @ Generated

Default user PIN: @Specified Generated
User PIN: |123123

User ID prefic:

Default ring duration: 18

Apply Cancel
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GUI field
Number Management

Extension number
pattern

Speed dial pattern

System prohibited
prefix

System unrestricted
prefix

Operator extension

Supporting
extension

Default Setting

Default SIP user
password

Default user PIN

Fortinet Technologies Inc.

Description

Enter the extension number pattern. For example, NXXX is any
four-digit number as long as the first digit is 2 or higher and 7XXX
is a four-digit number that always starts with 7. This pattern will
be followed when creating extensions. See “Configuring IP
extensions” on page 135.

Enter the speed dial number pattern. For example, *3XX is any
three-digit number that starts with 3. This pattern will be
followed when configuring speed dials. See “Mapping speed
dials” on page 249.

Enter the phone number prefix that you want to ban, such as
900. Click the + sign to add up to 10.

Enter the allowed phone number prefix, such as 800. Click the +
sign to add up to 10.

Enter the extension for the operator of the FortiVoice unit.

Enter the extension for technical support of the FortiVoice unit.

Enter your own password or let the FortiVoice unit generate one
for you. This password is used for configuring your SIP phone
from the phone or the Web. You need the phone's IP to access it
from the Web. This password appears when you add an
extension. For details, see “Configuring IP extensions” on

page 135.

e Specified: Enter the password. The password cannot be
blank, must be 8 or more characters, must contain at least
one uppercase character, one lowercase character and one
number. Non-alphanumeric characters, like (- $, are not
supported in the password field.

The default password is voice#321.

e Generated: Select to have a system-generated password.

Enter your own password or let the FortiVoice unit generate one
for you. This password is for the extension user to access voice
mail and the user web portal. This password appears when you
add an extension. For details, see “Configuring IP extensions”
on page 135.

If you select Specified, the default password is 123123.

Page 107 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

3.

User ID prefix Enter the prefix for the extension user ID. When you add a new
extension, the FortiVoice unit will generate a user ID with this
prefix plus the extension number. For details, see “Configuring IP
extensions” on page 135.

Default ring Enter the time, in seconds, for a phone connected to the
duration FortiVoice unit to ring before the call is processed (for example,
the call is sent to voice mail). The default is 20.

Click Apply.

Customizing call report and notification email templates

Go

to Phone System > Settings > Custom Message to view and reword the default call report

and notification email templates.

The FortiVoice unit sends out call reports based on your call report configuration (see
“Configuring report email notifications” on page 288) and notification email when, for example,
you have a new voicemail or fax in your mailbox or missed a call. You can customize the email
templates for the call report and email notifications.

You can change the content of the email template by editing the text and HTML codes and by
working with email template variables. For descriptions of the default email template variables,
open a template and select Edit Variable.

To
1.

2
3.
4
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customize call report and email templates
Go to Phone System > Settings > Custom Message.

. Open Report or Email templates to display the default templates.

To edit a template, double-click it or select it and click Edit.

. To format template in HTML, use HTML tags, such as <b>some bold text</b>.

There is a limit of 250 characters for the Subject field, 60 characters for the From field, and
4000 characters for Htmlbody and Textbody messages each in the Content body field.

To add a variable:

e Select Insert Variables next to the area to insert a variable. A pop-up window appears.
¢ Place your mouse cursor in the text message at the insertion point for the variable.

¢ (Click the name of the variable to add. It appears at the insertion point.

¢ To add another variable, click the message area first, then click the variable name.

¢ (Click the Close (X) icon to close the window.

To insert a color:

e Click Insert Color Code. A pop-up window of color selection appears.

¢ Place your mouse cursor in the text at the insertion point for the color code, or highlight
an existing color code to change.

¢ (Click a color in the color selection pop-up window.

For example, to replace the color code in the HTML tag <tr bgcolor="#3366Tf">,
you can highlight ""#3366FT"*, then select the color you want from the color palette.

To add a new color code, include it with HTML tags as applicable, such as <tr
bgcolor="#3366Ff">.

To determine if your HTML and color changes are correct, click Preview. The replacement
message appears in HTML format.

Click OK, or click Reset To Default to revert the replacement message to its default text.
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Configuring advanced phone system settings

The Phone System > Advanced Settings submenu lets you configure SIP setting, SIP phone
auto-provisioning, prompt languages, phone management, and system capacity.

This topic includes:

Configuring SIP settings

Configuring SIP phone auto-provisioning

Adding prompt languages

Managing phone configurations

Configuring system capacity

Configuring SIP settings

FortiVoice units support SIP communications.

To configure FortiVoice SIP settings
1. Go Phone System > Advanced Settings > SIP.

2.

Fortinet Technologies Inc.

Configure the following:

GUI field

Transport Setting

Registration Interval

Extension
registration interval
range

Internal extension
registration interval

Description

SIP communication commonly uses TCP or UDP port 5060
and/or 5061. Port 5060 is used for nonencrypted SIP signaling
sessions and port 5061 is typically used for SIP sessions
encrypted with Transport Layer Security (TLS).

Enable the ports as required.

To keep the extensions’ registration status with the FortiVoice
unit, enter the range of extension registration time interval as
required by the FortiVoice unit in minutes. An extension’s
registration timeout setting is overridden by the FortiVoice unit’s
extension registration time interval range if it is out of the range.

The default range is 1-480.

The start of the range is 1-60 and the end of the range is
30-1440.

Enter the default registration time interval for the extensions on
your subnet as required by the FortiVoice unit in minutes. The
default is 30 and the range is 10-480.

Set a proper value for this option. If it is too low, the performance
of the FortiVoice unit is compromised due to frequent
registration. If it is too high, the connection between the
FortiVoice unit and the extension may terminate.
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External extension
registration interval

Networks

External static
Host/IP

RTP Setting

RTP port start

RTP port end

RTP timeout

RTP hold timeout

TLS Client Setting

Security

Advanced Setting

3. Click Apply.

Fortinet Technologies Inc.

Enter the default registration time interval for the extensions on
other subnets as required by the FortiVoice unit in seconds. The
default is 30 and the range is 10-1800.

Set a proper value for this option. The FortiVoice unit requires
that external extensions register more frequently with it to keep
the connection. However, if the value is set too low, the
performance of the FortiVoice unit is compromised due to
frequent registration. If it is too high, the connection bewteen the
FortiVoice unit and the extension may terminate.

Enter the FortiVoice unit’s external static IP address to which the
external extensions register. Also enter the port number.

Enter the starting Real-time Transport Protocol (RTP) port that
the FortiVoice unit will use for phone call sessions. If the unit is
behind a firewall, these ports should be open. Ensure there is a
reasonable port range so that you have enough ports for all open
calls. The default port is 5000.

Enter the end RTP port that the FortiVoice unit will use for phone
call sessions. Ensure there is a reasonable port range so that you
have enough ports for all open calls. The default port is 30000.

Enter the amount of time in seconds during an active call that the
extension will wait for RTP packets before hanging up the call. 0
means no time limit. The default is 60.

Enter the amount of time in seconds that the extension will wait
on hold for RTP packets before hanging up the call. 0 means no
time limit. The default is 300.

If you have enabled TLS, configure the following:

e Server certificate verification: Select this option for the TLS
clients to confirm the validity of a server’s credentials with a
trusted root certification authority’s (CA’s) certificates. For
information on uploading a CA certificate, see “Managing
certificate authority certificates” on page 101.

e TLS protocol: Select the TLS protocol version.

By default, the FortiVoice unit screens out incoming calls from
unauthenticated source. If you want to change this default
setting, select Accept unauthenticated incoming call.

Select Enable early media if you want the FortiVoice unit to relay
a ring tone to the caller of an incoming call before the
establishment of a call connection. A ring tone or a busy tone is
early media.

If you select this option, you also need to configure a specific
trunk to send the ring tone. See “Inband ringtone” on page 180.
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Configuring SIP phone auto-provisioning

Phone System > Advanced Settings > Auto Provisioning allows the FortiVoice unit to discover
the SIP phones on your network and send the configuration files to them.

With auto-provisioning configured, when a supported FortiFone is connected to the network
and powered on, it is automatically discovered and receives the configuration file from the
FortiVoice unit. The FortiFone will then reboot with the pushed-in configuration file and register
with the FortiVoice unit.

The FortiVoice unit can only auto provision the supported FortiFones.

To configure auto-provisioning settings

1. Go to Phone System > Advanced Settings > Auto Provisioning and configure the following:

Auto Provisioning Setting

V| Enabled

Figure 30: Auto-provisioning settings

V| Generate default configuration for unassigned phone

Administrator PIN: 326326

Server Settings for Phone Configuration

Standard (apply to all server settings)

“lUse IP address of interface: hd

Use static IP or host name:

@ Advanced
SIP Server:

Q@Use IP address of interface: | portl 172.20.140.126 (VIP) 7

Use static IP or host name:

TFTP Server:

Q@Use IP address of interface: | portl 172.20.140.126 (VIP) 7

Use static IP or host name:

NTP Server:

Q@Use IP address of interface: | portl 172.20.140.126 (VIP) )

Use static IP or host name:

Apply Cancel

GUI field

Auto Provisioning
Setting

Fortinet Technologies Inc.

Enabled

Generate
default
configuration
for unassigned
phone

Description

Select to activate the SIP phone auto-provisioning function for auto
discovering the phones.

Select to generate phone configuration files for the supported
unassigned SIP phones. For details, see “Viewing unassigned phones”
on page 28.

With this option selected, once a supported SIP phone connects to the
FortiVoice unit and is auto-discovered, the FortiVoice unit assigns an IP
address to the phone and sends the basic PBX setup information to it.

If you want to upgrade your phone system and keep the current phone
configuration, do not select this option. Otherwise your existing phone
configuration will be overridden by the upgraded FortiVoice
configuration.
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Administrator Click and enter a global password to be used by an administrator to

PIN connect a FortiFone to the FortiVoice unit to set mobile extension
number. This password is also used by the administrator to override
schedules. For details, see “Configuring system capacity” on page 116.

For example, you can press the default Configure Phone feature code
*17 (See “Modifying feature access codes” on page 273) on any
FortiFone that connects to the FortiVoice unit and enter this password.
You can then enter an existing extension to set it as the extension of this

phone.
Click Apply and then Auto Provisioning to return to the Auto Provisioning
page.
Server Settings for
Phone
Configuration
Standard Select to configure the server settings for the supported phones. The
(apply to all same settings apply to the SIP server, TFTP server, and NTP server.

server settings) e Use IP address of interface: Select the interface for the server. The

SIP phones connect to this server to register and receive the PBX
setup information and use it as the NTP server. For information on
interface configuration, see “Configuring the network interfaces” on
page 41.

e Use static IP or host name: Enter the current public IP address or
public domain name of the server. The SIP phones connect to this
server to register and receive the PBX setup information and use it as
the NTP server.

Advanced If you use different servers for SIP, TFTP, and NTP, select to configure the
settings of each server for the supported phones.

e SIP server

e Use IP address of interface: Select the interface for the server. The
SIP phones connect to this server to register.

e Use static IP or host name: Enter the current public IP address or
public domain name of the server. The SIP phones connect to this
server to register.

TFTP server

e Use IP address of interface: Select the interface for the server. The
SIP phones connect to this server to receive the PBX setup
information.

e Use static IP or host name: Enter the current public IP address or
public domain name of the server. The SIP phones connect to this
server to receive the PBX setup information.

NTP server

e Use IP address of interface: Select the interface for the server. The
SIP phones connect to this server to synchronize time.

e Use static IP or host name: Enter the current public IP address or
public domain name of the server. The SIP phones connect to this
server to synchronize time.

2. Click Apply.

Fortinet Technologies Inc. Page 112 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Adding prompt languages

The prompt language affects all of the FortiVoice unit’s voice prompts, such as auto attendant
and voicemail. Prompt languages are used when configuring the PBX settings. For more
information, see “Setting PBX location and contact information” on page 104.

However, if you change the sound file for an individual component, such as auto attendant, to
use a different language, it will override the default prompt language for this component.

The default prompt language is English.

For information on generating a prompt language file, see “Recording in FortiVoice audio
format” on page 113.

To add a prompt language
1. Go to Phone System > Advanced Settings > Prompt Languages.
2. Click New.

3. In the Upload field, click Browse to upload the language file provided by Fortinet Technical
Support.

4. Click OK.

Recording in FortiVoice audio format

A prompt language file must be recorded in the FortiVoice language package format. This can
be accomplished by using the free and robust audio program called Audacity which can be
downloaded from http://audacity.sourceforge.net and a microphone.

Once this program has been installed, and the microphone connected, then the file can be
recorded.

Audacity cannot natively record in the format that FortiVoice unit requires. Therefore, some
adjustments need to be made in the software as described in the following procedure.

To generate a prompt language file

1. On Audacity, go to Edit > Preferences.

2. Click the Devices menu and select 71(Mono) for Channels.

Preferences: Devices RS
—Devices > Interface
~Playback Host: [MME -]
- Recording
. Quality Using: PortAudio V19-devel (built Jan 18 2013 20:58:19)
- Interface Playback
""Tram . - L
. Import / Export Device: [Speakers (Realtek High Definiti v]
- Extended Import Recording
- Projects
.. Libraries Device: [Microphone (Webcam 200) v]

- Spectrograms M
- Directories

- Warnings

- Keyboard

- Mouse

- Modules

OK ] [ Cancel
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3. Click the Quality menu and set the Default Sample Rate to 8000 Hz and the Default Sample
Format to 16 bit.

Preferences: Quality Py

- Devices Sampliny
 Playback Default Sample Rate: 44100
ing
<:Zﬁ$ D& Sample Format: [16-bit
- Interface
Tracks Real-time Conversion
- Import [ Export Sample Rate Converter: [Medium Quality ']
- Extended Import )
. Projects Dither: [None v]
- Libraries High-quality Conversion
- Spectrograms
. Directories Sample Rate Converter: [Best Quality (Slowest) v]
- \Warnings . -
. Effects Dither: [Shaped ]
- Keyboard
- Mouse
- Modules
[ OK ] [ Cancel ]
4. Click OK.
5. Click the Record button when ready to start recording the file. When finished recording, click

Stop.
The completed recording can now be saved in a format to work with the FortiVoice unit.

6. Go to File > Export.
7. For Save As Type, select Other compressed files.
@ Export File LX)
Save in: Audacity - 02 mE-
D MName £ Date modified Type
ke help 21/03/201310:13 ... File folder
kecent Blaces Languages 21/03/20131013 .. File folder
! MNyquist 21/03/201310:13 ... File folder
Plug-Ins 21/03/201310:13 ... File folder
Desktop
=l
Libraries
Computer

- 7 1 3
‘”k File name: - Save ]
MNetwork

e as type: | Cther uncompressed files - | Cancel |

| Options...

8. Click Options.

9. For Encoding, select U-law. Click OK.

10.. Select the directory in which to save the recording and then click Save.
The recording is now in a format that can be loaded into the FortiVoice unit.

Managing phone configurations

The FortiVoice unit provides the default configuration templates for the phone types with
Limited support level. In most cases, there is no need to modify the templates. If you do need to
make changes to a template (for example, change the IP address of the NTP server), make sure
the format matches that of the default template. Otherwise, phone auto-provisioning will not be
possible. This is because the template is part of the configuration file generated for the phone
type and will be sent to a phone of this type through auto provisioning. For details, see
“Configuring SIP phone auto-provisioning” on page 111.

Fortinet Technologies Inc. Page 114 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

The phones with Comprehensive support level do not display their configuration templates
because the FortiVoice unit fully supports the phones.

You can also manage the phone firmwares on the FortiVoice unit.

Once you have modified the templates or uploaded a new firmware, they are saved on the
FortiVoice unit. To send them to the phones, choose a low traffic time and reboot the phones.
For information on rebooting the phones, see “Setting up local extensions” on page 135.

If your organization adds new FortiFones that use a different range of MAC addresses than your
current ones and you want to add them to the FortiVoice unit in order to auto-provision them,
you can do so by adding the new phones’ MAC address.

If your phones are not FortiFone, you can upload the third party phone configuration files to the
FortiVoice TFTP server and migrate the files to your phones without using an external TFTP
server.

To manage a phone firmware
1. Go to Phone System > Advanced Settings > Phone Management.
Select the phone type of which you want to manage the firmware.

Click Manage.
In the pop-up window, double-click a firmware folder under Name.

a Db

Remove or save an existing firmware, or upload a new firmware in .zip format. You can also
activate or deactivate a firmware.

To configure a phone profile

1. Go to Phone System > Advanced Settings > Phone Management.

2. Click Phone Profile.

3. See “Configuring phone profiles” on page 121.

To add new FortiFones MAC address

1. Go to Phone System > Advanced Settings > Phone Management.
2. Click Additional Phone/MAC.

3. Click New.
4

. For MAC address, enter the FortiFone MAC address in the following format:
AA:BB:CC:00:00:00.

Leave the Phone Type field as is. Currently, this feature only supports FortiFone.

o o

Select Status.
7. Click Create.

The new FortiFones are recognized by the FortiVoice unit. You can auto-provision them now.
For more information, see

To upload third party configuration to FortiVoice TFTP server

1. Go to Phone System > Advanced Settings > Phone Management.
2. Click TFTP Service.

3. Click Upload and browse for the file.

4. Click Upload.
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Configuring system capacity

The Phone System > Advanced Settings > Miscellaneous tab lets you set the PIN used by the
administrator to override schedules, configure voicemail greeting and message length, set
phone directory options, and configure CDR settings.

To configure system capacity
1. Go to Phone System > Advanced Settings > Miscellaneous.

2. Under Administrator PIN, enter the password used by the administrator to override
schedules.

This global password is also used by an administrator to connect a FortiFone to the
FortiVoice unit to set mobile extension number. For details, see “Configuring SIP phone
auto-provisioning” on page 111.

3. Under Schedule Override, select Allow admin user to override schedule if required.

An administrator with the privilege can dial *821, *822, or *823 followed by the administrator
PIN to temporarily replace the original schedule with one of the three default ones. You may
also modify the temporary schedule. Dial *820 to go back to the original schedule.

4. Under Voicemail, enter the maximum message and greeting length you want.
5. Configure Directory to set phone directory options:
¢ For Dial-by-name option, select how a caller can check the directory by dialing a name.

¢ For Dial-by-name digits, enter the number of letters allowed for a caller to dial someone
by name. The range is 3-9. This feature enables a caller to reach a specific person quickly
by dialing, for example, the first three letters of their first or last name from any phone.

e For Read back number, select if you want a person’s extension number to be read out
after you check the directory by dialing the person’s first or last name.

6. Under CDR, enter the time in month that you want to keep the call log/call detail record and
the maximum number of CDR records. For information about call log/CDR, see “Viewing call
records” on page 32.

7. Click Apply.

Managing sound files and music on hold

The Phone System > Audio > Prompts/Music On Hold menu lets you upload, record, and play
phone sound files such as voicemail greetings and announcements. It also lets you choose the
sound files to play while a call is on hold.

There are default sound files ready to use.

The sound files can be used when configuring music on hold, conference calls, and auto
attendants. See “To configure music on hold” on page 117 and “Configuring Call Features” on
page 239.

To manage a sound file
1. Go to Phone System > Audio > Prompts.

2. Click New.
Enter a name for the file.

ol

Select a profile type.

o

Optionally, enter a description for the file.
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6. For Voice language, configure the following:

If you select Prompt sound file for the profile type, you can click Upload to get an existing
sound file, Record to make a sound file, Download to save a a sound file, and Play to listen
to an uploaded or recorded file (with speakers or earphones) for the language you select.

i. To record a sound file, click Record.

ii. On the Send Voice Recording Call dialog box, enter the extension that you will use to
record the file, and click Send to dial the extension. You can edit the extension or add
a new one. For details, see “Configuring IP extensions” on page 135.

iiil. When the extension rings, record the sound file and hang up.

iv. On the FortiVoice web-based manager, click Yes on the Voice recording request sent
to specified extension dialog box.

If you select Music on hold for the profile type, you can click Upload to get an existing sound
file, Record to make a sound file, Download to save a a sound file, and Play to listen to a
uploaded or recorded file (with speakers or earphones).

7. Click OK.

To configure music on hold

1. Go to Phone System > Audio > Music On Hold.

2. Click New.
3. Configure the following:

GUI field
Name
Mode

Files

Stream

Volume

Description

4. Click Create.
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Description

Enter a name for the music on hold file.

If you select to use existing sound files, do the following:

e For Sound files, select the Available sound files and click
-> to move them into the Selected field. You can use the
Up and Down buttons to reorder the files.

e For Play mode, if you want to play the selected sound files
randomly, select Random. If you want to play the files
according to the order in the Selected field, select
Sequential.

e For Volume, Set the music sound volume.

If you select to use streaming files, in the Stream URL field,
enter the URL where the streaming music is, such as a radio
station. This way, the music is delivered to the FortiVoice unit
and played virtually straight away. You can click Test stream
to see if the URL is added successfully.

Before doing so, make sure to only use the legal stream
sources.

Set the music sound volume.

Optionally, enter a description for the file.
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Working with FortiVoice profiles

The Phone System > Profiles tab lets you create user privileges and SIP profiles for configuring
extensions and SIP trunks. It also allows you to modify caller IDs, schedule the FortiVoice unit,
and configure phone and LDAP profiles.

This topic includes:

e Configuring SIP profiles

¢ Modifying caller IDs

¢ Configuring phone profiles

e Configuring LDAP profiles

¢ Configuring user privileges

¢ Configuring location profile

e Scheduling the FortiVoice unit

Configuring SIP profiles

Configure the supported phone features and codecs and apply them to the extensions and SIP
trunks.

Communicate with your VolIP service provider because the profile settings are subject to the
capabilities of the VoIP service provider. For example, if some of your features and codecs are
not supported by your VolP service provider, they will not work even if they are enabled or
selected in the SIP profile.

The default SIP profiles can be edited but not be deleted.
For information on extensions, see “Configuring Extensions” on page 135.

For information on SIP trunks, see “Configuring Trunks” on page 177.

To configure a SIP profile
1. Go to Phone System > Profiles > SIP and click New.
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2. Configure the following:

GUI field
SIP

Transport

Codec

3. Click Create.

Fortinet Technologies Inc.

Description

e Name: Enter a name for this profile.

e DTMF: Select the dual-tone multi-frequency (DTMF) method used
by the VolP provider. Options are RFC2833, Inband, Info,
Shortinfo, and Auto.

Auto means the VolP provider’s server and the FortiVoice unit will
negotiate to select a DTMF method. You could also select a
specific DTMF method if required.

e NAT: Select if the VoIP service provider supports SIP NAT
translation.

e Video: Select if the service provider supports video calling over
SIP.

e T.38: Select if the VolP service provider supports fax over VolP
network.

e Monitor/Keep alive (SIP notify) interval: Enter the time interval in
seconds for the FortiVoice unit to talk to the SIP server of your
service provider to keep the connectivity and check its capability.
0 means no checking by the FortiVoice unit.

Encryption: Select TLS to encrypt the system connection between
an extension and the FortiVoice unit. Select TLS and SRTP to
encrypt both the system connection and voice communication
between an extension and the FortiVoice unit.

To make this option work, you need to select a SIP profile with TLS
or TLS and SRTP selected for Encryption when configuring an
extension. You also need to enable TLS on the FortiVoice unit by
going to Phone System > Advanced Settings > SIP.

Transport: SIP commonly uses TCP or UDP port 5060 and/or 5061.
Port 5060 is used for non-encrypted SIP signaling sessions and port
5061 is typically used for SIP sessions encrypted with Transport
Layer Security (TLS).

Enable the protocols as required.

This option, if applied to a user, overrides the system-wide transport
settings. For more information, see “Configuring SIP settings” on
page 109.

Secure RTP: Select to provide encryption, message authentication
and integrity, and replay protection to the FortiVoice Real-time
Transport Protocol data.

Select the codecs supported by the VolIP service provider. Among
the selected ones, choose the preferred one for the VolP provider.
The preferred codec is usually the most used one in your area and
provides the best quality of communication.

If your preferred codec is different from that of your VolP service
provider, the service provider’s codec will be used as long as it is one
of your supported codecs.
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Modifying caller IDs

You can change the phone number, caller’s name, or both that will appear on the destination
phone.

Caller ID modifications are used when configuring dial plans. For more information, see
“Configuring Call Routing” on page 195.

To modify a caller ID

1. Go to Phone System > Profiles > Caller ID Modification.

2. Click New and configure the following:

Fortinet Technologies Inc.

GUI field
Name

Match option

Match number

Description

Enter the name for this caller ID modification record.

Select the way to match a call with caller name and number in order
to modify call number or caller ID.

Match number or name: If the number is matched, modifications
will be done based on Number Modification configuration. If the
name is matched, modifications will be done based on Map to
new caller ID name configuration.

Match number then name: If the number is matched,
modifications will be done based on Number Modification
configuration. If both the number and name are matched,
modifications will be done based on Map to new caller ID name
configuration.

Match name then number: If the Name is matched, modification
will be done based on Map to new caller ID name configuration. If
both the name and number are matched, modifications will be
done based on Number Modification configuration.

Match number and name: If both the number and name are
matched, modifications will be done based on Number
Modification and Map to new caller ID name configurations.

Enter the extension number or number pattern you want to modify.

For example, you can enter 8134 to modify a single extension, or
81xx to modify all the four-digit numbers starting with 81.
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Number
Modification

Match caller ID
name

Map to new caller
ID name

Advanced Setting

3. Click Create.

If you have entered a Match number, configure the following values
to modify it:

Strip: Enter a number to hide the starting part of an extension
from displaying. 0 means no action.

For example, if your Match number is 8134 and Strip is 2, only 34
will be displayed as caller ID.

Truncate: Enter a number to hide the ending part of an extension
from displaying. 0 means no action.

For example, if your Match number is 8134 and Truncate is 2,
only 81 will be displayed as caller ID.

Prefix: Add a number before an extension.

For example, if your Match number is 8134 and Prefix is 5, the
caller ID will be 58134.

Postfix: Add a number after an extension.

For example, if your Match number is 8134 and Postfix is 5, the
caller ID will be 81345.

Enter the caller ID that you want to map to another one.

Caller IDs are created when configuring SIP extensions. See
“Configuring IP extensions” on page 135.

Enter the new caller ID name to which you want to map the one
entered in the Match caller ID name field.

Select Block caller ID to stop your caller ID from displaying on the
destination phone.

Mapping a group of extensions to a caller ID name

If you want to map a group of extensions to a caller ID name, you can use the pattern for the

extensions to do so.

For example, if you have a technical support team that has 10 extensions (8100-8110), instead
of displaying each extension when making calls, you can just display one caller ID name
“Support” for the whole team.

To map a group of extensions to a caller ID name
1. Go to PBX > Profile > Caller ID Modlification.

. Click New.

2
3. In the Match number field, enter the pattern of the extensions, such as 81xx in the example.
4

. In the Map to new caller ID name field, enter the caller ID name to which you want to map,

such as “Support”.
5. Click Create.

Configuring phone profiles

Phone profiles contain the phone configurations that are mostly used and customized, such as
the programmable phone keys. Phone profiles make extension configuration more flexible
because phone users are allowed to choose the profile they want. In addition, any changes the
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administrator makes to a profile is automatically applied to the extensions that use the profile.
For more information, see “Configuring IP extensions” on page 135.

The phone profiles configured here appear as Admin defined profiles when you configure a SIP
extension.

To configure a phone profile

1. Go to Phone System > Profiles > Phone.

2. Click New and configure the following:

Fortinet Technologies Inc.

Figure 31: Configuring a phone profile

Phone profile

Name:

Fhone type: FortiFone-350i/360i

Description:

Configuration mode: @ Automatic

Vian

Option: | None

Automatic Configuration

Display option: Mame and number

Provisioning lines: 2

Digit map pause timer: | 3

X T|x+#

Digit map:

~|Set Programmable Phone Key

Create Cancel

GUI field

Phone profile
Name
Phone type

Time format

Description

Manual

Description

Enter a name for the profile.
Select a phone model for the profile.

Select the time display format on the phone.

e North American: mm/dd/yyyy
e [nternational: dd/mm/yyyy

Enter any notes you have for this profile.
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Configuration mode Select the profile mode.

Vian

Option

Automatic Configuration

Display option

Provisioning lines

e Automatic: the FortiVoice unit will generate a phone
configuration file based on the information you provide.
See “Automatic Configuration” on page 123.

This option is only available for FortiFone-260i and above.

* Manual: This option allows you to manually edit the phone
configuration file. See “Manual Configuration” on
page 124

You may need to deploy phones using the existing IT
infrastructure which only has one network drop for each
employee. The network switch supports 802.1Q VLAN
tagging and LLDP-MED. Some phones such as FortiFones
have two network ports: LAN and PC. The recommended
solution is to connect FortiFones to the switch using LAN
port and connect the computer to the PC port of FortiFones.
VLAN tag needs to be enabled to segregate FortiFone voice
network and PC data network.

If you select Manual, configure the following:
ID for voice: Enter your organization’s VLAN ID for voice.
ID for data: Enter your organization’s VLAN ID for data.

Priority for voice/data: Enter the traffic service level
recommended by the IEEE. Each number represents a traffic
type. The range is from 0-7, with 7 being the highest.

e 0: Background

1: Best Effort

2: Excellent Effort

e 3: Critical Applications
4

: Video, < 100 ms latency and jitter
e 5:Voice, < 10 ms latency and jitter
¢ 6: Internetwork Control

e 7: Network Control

If you select LLDP (Link Layer Discovery Protocol), the
FortiVoice unit automatically generates the configuration file.
You need to enable LLDP support on your network switch.

This option is only available if you select Automatic for
Configuration mode.

Select what to display on the extension: the extension user’s
name only or name and number.

Enter the number of phone lines to which this profile applies.
The maximum lines that you can provision is 4.
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Digit map pause
timer

Digit map

Set Programmable
Phone Key

Manual Configuration

3. Click Create.
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Enter the digit map timeout in seconds which defines the
waiting time between the completion of dialing number
entering and initiating the call.

For example, if you enter 5 and use the default digit map
syntax, the phone will initiate a call 5 seconds after you finish
entering the dialing number.

The FortiVoice unit uses digit map syntax definition to define
the FortiFone dialing behavior. A phone needs to know when
number entering is complete and therefore to initiate the call.

You can enter the syntax or use the default syntax x. T | x+#
where:

¢ X.T means you can dial any number and the call is
initiated after the digit map pause timeout is reached.

¢ | isachoice operator that matches the expression before
or after the operator. For example, abc|def matches
"abc" or "def".

® X+# means you can enter any number and then press the
# key to initiate the call.

For more information about digit map syntax definitions, see
Section 2.1.5 of RFC 3435.

Allows you to program the phone keys for FortiFone-260i to
675i. For FortiFones with expansion modules, you can select
the module to program the keys.

After completing programing the keys, you can click
Download printable label to save and print out the
configuration and label it on the phone.

Note that keys 1 and 2 are reserved and cannot be
programmed.

If you select One key dial or User Assigned function for a key,
you need to enter the information in the Resource field based
on your phone configuration. For example, if you select User
defined for key 3 and you want to map this key to your
voicemail code such as *78, enter *78 in the Resource field.

Selecting Centralized phonebook allows you to browse the
phone book from a FortiFone. You can also search on
FortiFones by name or number. Please note that this feature
works on top of HTTP protocol which is disabled by default in
system interface settings. If you want to use this feature,
enable HTTP under System > Network > Network.

If you select Line Appearance, the peer office will appear in
the Resource field. Line appearance for peer office is to monitor
analog lines connected through FXO gateway.

If you select Manual configuration mode, edit the phone
configuration file.
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Configuring LDAP profiles

The LDAP submenu lets you configure LDAP profiles which can query LDAP servers for
authentication.

Before using an LDAP profile, verify each LDAP query and connectivity with your LDAP server.
When LDAP queries do not match with the server’s schema and/or contents, unintended phone
call processing behaviors can result.

LDAP profiles each contains one or more queries that retrieve specific configuration data, such
as user groups, from an LDAP server. The LDAP profile list indicates which queries you have
enabled in each LDAP profile.

To view the list of LDAP profiles, go to Phone System > Profiles > LDAP.

Figure 32:Viewing the list of LDAP profiles

=g New.. 7] i}
Page 1 /1 Records per page: | 25
I_Il
ldap16% 172.20.140.169
qq 172.20.140.193 389 .;J) .3 .
GUI field Description
Clone Click the row corresponding to the profile whose settings you want

to duplicate when creating the new profile, then click Clone. A
single-field dialog appears. Enter a name for the new profile. Click

OK.
Profile Name The name of the profile.
Server The domain name or IP address of the LDAP server.
Port The listening port of the LDAP server.
Auth Indicates whether User Authentication Options is enabled.
Cache Indicates whether query result caching is enabled.

(Green dot in column  Indicates whether the entry is currently referred to by another item in
heading) the configuration. If another item is using this entry, a red dot
appears in this column, and the entry cannot be deleted.

You can add an LDAP profile to define a set of queries that the FortiVoice unit can use with an
LDAP server. You might create more than one LDAP profile if, for example, you have more than
one LDAP server, or you want to configure multiple, separate query sets for the same LDAP
server.

After you have created an LDAP profile, LDAP profile options will appear in other areas of the
FortiVoice unit’s configuration. These options let you to select the LDAP profile where you might
otherwise create a reference to a configuration item stored locally on the FortiVoice unit itself.
These other configuration areas will only allow you to select applicable LDAP profiles — that is,
those LDAP profiles in which you have enabled the query required by that feature. For example,
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if a feature requires a definition of user groups, you can select only from those LDAP profiles
where Group Query Options are enabled.

To configure an LDAP profile

1. Go to Phone System > Profiles > LDAP.

2. Click New to add a profile or double-click a profile to modify it.
A multisection dialog appears.

Figure 33: Configuring an LDAP profile

Edit LDAP Profile

Profile name:

Server name/IP: Port: | 389
Fallback server name/IP: Port: | 389
Use secure connection: |None e

Base DN:

Bind DM:

Bind password:
« | User Authentication Options

Try common name with base DN as bind DN
Common name [D:
@ Search user and try bind DN

Schema: InetOrgPerson e
LDAP user query:

Scope: Subtree -t

Derefer: MNever e

« | Advanced Options

Timeout (seconds): 20

Protocol version: LDAP Version 3 -l
Enable cache

TTL (minutes): 1440

Enable user password change
Password schema: OpenLDAP -l

Create Cancel

GUI field Description

Profile name For a new profile, enter its name.

Server name/IP Enter the fully qualified domain name (FQDN) or IP address of the
LDAP server.

Port: Enter the port number where the LDAP server listens.

The default port number varies by your selection in Use secure
connection: port 389 is typically used for non-secure connections,
and port 636 is typically used for SSL-secured (LDAPS) connections.
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Fallback server Optional. Enter the fully qualified domain name (FQDN) or IP address
name/IP of an alternate LDAP server that the FortiVoice unit can query if the
primary LDAP server is unreachable.

Port: Enter the port number where the fallback LDAP server listens.

The default port number varies by your selection in Use secure
connection: port 389 is typically used for non-secure connections,
and port 636 is typically used for SSL-secured (LDAPS) connections.

Use secure Select whether to connect to the LDAP servers using an encrypted
connection connection.

e none: Use a non-secure connection.
e SSL: Use an SSL-secured (LDAPS) connection.

Click Test LDAP Query to test the connection. A pop-up window
appears. For details, see “Testing LDAP profile queries” on
page 130.

Base DN Enter the distinguished name (DN) of the part of the LDAP directory
tree within which the FortiVoice unit will search for user objects, such
as ou=People,dc=example,dc=com.

User objects should be child nodes of this location.

Bind DN Enter the bind DN, such as
cn=FortiVoiceA,dc=example,dc=com, of an LDAP user
account with permissions to query the Base DN.

This field may be optional if your LDAP server does not require the
FortiVoice unit to authenticate when performing queries.

Bind password Enter the password of the Bind DN.

Click Browse to locate the LDAP directory from the location that you
specified in Base DN, or, if you have not yet entered a Base DN,
beginning from the root of the LDAP directory tree.

Browsing the LDAP tree can be useful if you need to locate your
Base DN, or need to look up attribute names. For example, if the
Base DN is unknown, browsing can help you to locate it.

Before using, first configure Server name/IP, Use secure connection,
Bind DN, Bind password, and Protocol version, then click Create or
OK. These fields provide minimum information required to establish
the directory browsing connection.

Configure the following sections:

e “Configuring authentication options” on page 128
e “Configuring advanced options” on page 129
Click Create, OK or Apply.

The LDAP profile appears in the LDAP profile list. To apply it, select the profile in features
that support LDAP queries, such as protected domains and policies.

Before using the LDAP profile in other areas of the configuration, verify the configuration of
each query that you have enabled in the LDAP profile. Incorrect query configuration can
result in unexpected phone processing behavior. For information on testing queries, see
“Testing LDAP profile queries” on page 130.

Page 127 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Configuring authentication options

The following procedure is part of the LDAP profile configuration process. For general
procedures about how to configure an LDAP profile, see “Configuring LDAP profiles” on
page 125.

1. Go to Phone System > Profiles > LDAP.

2. Click New to create a new profile or double click on an existing profile to edit it.
3. Click the arrow to expand the User Authentication Options section.

4. Configure the following:

Figure 34: Configuring user authentication LDAP options

4 | User Authentication Options

_ Try common name with base DN as bind DN
Common name [D:
@ Search user and try bind DN

Schema: InetOrgPerson e

LDAP user query:

Scope: Subtree -t

Derefer: Hever i
GUI field Description
Try common name Select to form the user’s bind DN by prepending a common name to
with base DN as the base DN. Also enter the name of the user objects’ common
bind DN name attribute, such as cn or uid into the field.
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Search user and try Select to form the user’s bind DN by using the DN retrieved for that
bind DN user by configuring the following:

Schema: If your LDAP directory’s user objects use a common
schema style:

¢ InetOrgPerson
e Active Directory

Select the schema style. This automatically configures the query
string to match that schema style.

If your LDAP server uses any other schema style, select User
Defined, then manually configure the query string.

LDAP user query: Enter an LDAP query filter that selects a set of
user objects from the LDAP directory.

The query string filters the result set, and should be based upon
any attributes that are common to all user objects but also
exclude non-user objects.

For example, if user objects in your directory have two
distinguishing characteristics, their objectClass and
extension attributes, the query filter might be:

(& (objectClass=inetOrgPerson) (telephonenumber=$u))
where $u is the FortiVoice variable for a user's extension.

This option is preconfigured and read-only if you have selected
from Schema any schema style other than User Defined.

Scope: Select which level of depth to query, starting from
Base DN.

® One level: Query only the one level directly below the Base DN
in the LDAP directory tree.

e Subtree: Query recursively all levels below the Base DN in the
LDAP directory tree.

Derefer: Select the method to use, if any, when dereferencing
attributes whose values are references.

¢ Never: Do not dereference.

¢ Always: Always dereference.

e Search: Dereference only when searching.

¢ Find: Dereference only when finding the base search object.

Configuring advanced options

The following procedure is part of the LDAP profile configuration process. For general
procedures about how to configure an LDAP profile, see “Configuring LDAP profiles” on
page 125.

1.

2
3.
4
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. Configure the following:

Go to Phone System > Profiles > LDAP.
. Click New to create a new profile or double click on an existing profile to edit it.
Click the arrow to expand the Advanced Options section.
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GUI field Description

Timeout (seconds) Enter the maximum amount of time in seconds that the FortiVoice
unit will wait for query responses from the LDAP server.

Protocol version Select the LDAP protocol version used by the LDAP server.

Enable cache Enable to cache LDAP query results.

Caching LDAP queries can introduce a delay between when you
update LDAP directory information and when the FortiVoice unit
begins using that new information, but also has the benefit of
reducing the amount of LDAP network traffic associated with
frequent queries for information that does not change frequently.

If this option is enabled but queries are not being cached, inspect
the value of TTL. Entering a TTL value of 0 effectively disables
caching.

TTL (minutes) Enter the amount of time, in minutes, that the FortiVoice unit will
cache query results. After the TTL has elapsed, cached results
expire, and any subsequent request for that information causes the
FortiVoice unit to query the LDAP server, refreshing the cache.

The default TTL value is 1440 minutes (one day). The maximum
value is 10080 minutes (one week). Entering a value of O effectively
disables caching.

This option is applicable only if Enable cache is enabled.

Enable user Enable if you want to allow FortiVoice web portal users to change
password change their password.

Password schema Select your LDAP server’s user schema style, either OpenLDAP or
Active Directory.

Testing LDAP profile queries

After you have created an LDAP profile, you should test each enabled query in the LDAP profile
to verify that the FortiVoice unit can connect to the LDAP server, that the LDAP directory
contains the required attributes and values, and that the query configuration is correct.

When testing a query in an LDAP profile, you may encounter error messages that indicate failure
of the query and how to fix the problem.

To verify user authentication options

Go to Phone System > Profiles > LDAP.

Double-click the LDAP profile whosequery you want to test.
Click Test LDAP Query.

A pop-up window appears allowing you to test the query.
From Select query type, select Authentication.

o a0 prDd 2

In User name, enter the user name or extension of a user on the LDAP server, such as jdoe
or 1234, depending your selection of User Authentication Options.

7. In Password, enter the current password for that user.
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8. Click Test.

The FortiVoice unit performs the query, and displays either success or failure for each
operation in the query, such as the search to locate the user record, or binding to
authenticate the user.

Clearing the LDAP profile cache

You can clear the FortiVoice unit’s cache of query results for any LDAP profile.

This may be useful after, for example, you have updated parts of your LDAP directory that are
used by that LDAP profile, and you want the FortiVoice unit to discard outdated cached query
results and reflect changes to the LDAP directory. After the cache is emptied, any subsequent
request for information from that LDAP profile causes the FortiVoice unit to query the updated
LDAP server, refreshing the cache.

To clear the LDAP query cache

1. Go to Phone System > Profiles > LDAP.

2. Double-click the LDAP profile whose query cache you want to clear.

3. Click Test LDAP Query.

4. From Select query type, select Clear Cache.

A warning appears at the bottom of the window, notifying you that the cache for this LDAP
profile will be cleared if you proceed. All queries will therefore be new again, resulting in
decreased performance until the query results are again cached.

5. Click Ok.

The FortiVoice unit empties cached LDAP query responses associated with that LDAP
profile.

Configuring user privileges

A user privilege includes a collection of phone services and restrictions that can be applied to
each extension user.

For more information, see “Configuring user privileges” on page 245.

Configuring location profile

Location profiles group phones into internal and external numbers based on their locations.

The external and internal profiles are system defined and can be modified but not be deleted.

To configure a location profile
1. Go to Phone System > Profiles > Location.
2. Click New and configure the following:

GUI field Description
Name For a new profile, enter its name.
Type Select the profile type: internal or external phones.

Emergency Enter the caller ID to display on the destination phone when you dial the
caller ID emergency number, such as 911.

If an extension in this profile already has an emergency caller ID, this ID is
overidden by the extension’s own ID. See “Emergency caller ID” on page 157.
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3.

Members  Select the extensions to include in the profile.
Description Enter any notes you have for this profile.

Contact Enter the contact information for the profile.
Information

Emergency Configure to send an alert email when an emergency call is made.

setting Select Do nothing if you don’t want the FortiVoice unit to send an alert email.

Otherwise, select Send alert email and enter the email address.

Click Create.

Scheduling the FortiVoice unit

You can schedule the FortiVoice operation time and use the schedules when configuring dial
plans, virtual numbers, or call management. The default schedules, namely after_hour,
any_time, business_hour, and holiday, can be modified but cannot be deleted.

Depending on your preference, you can create either a standard or a calendar-based schedule.

For information on dial plan, see “Configuring Call Routing” on page 195.

For information on virtual numbers, see “Working with virtual numbers” on page 174.

For information on call management, see “Setting extension user preferences” on page 156.

To
1.

a Db

7.

To

oo prDd 2

configure a standard schedule

Go to Phone System > Profiles > Schedule and click New.
Enter a profile name and select Standard for Mode.

Click Create.

In the schedule list, select the profile name you created.

For Week Day, select the days to include in the schedule and set the AM and PM time or
select Full Day.

For Holiday, click New to set the holidays. For example, select 01/01/12 in the Date field and
enter New Year’s Day in the Description field, and click Create.

Click OK.

configure a calendar-based schedule

Go to Phone System > Profiles > Schedule and click New.
Enter a profile name and select Calendar for Mode.

Click Create.

In the schedule list, select the profile name you created.
Double-click a date to schedule an event.

Click OK.

Configuring FortiFone 870i

Each base FortiFone 870i can support up to 15 handsets. You can configure a FortiFone 870i to
work with the FortiVoice unit by adding a primary phone (base) and multiple secondary phones
(bases). For detailed information, see FortiFone 870i Multi-Cell Deployment with FortiVoice
Enterprise Technical Note.

Fortinet Technologies Inc.
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The following prerequisites must be met for the configuration to work:

FortiVoice v5.0 build 136 or later

FortiVoice auto provisioning is enabled (see “Configuring SIP phone auto-provisioning” on
page 111)

FortiFone 870i firmware 3.23 or later
Network connectivity available between FortiFone870i and the FortiVoice unit

Follow the FortiFone 870i guide and the technical note to configure the phone first. Once you
connect the phone to the network, you can configure it on the FortiVoice unit.

To configure the FortiFone 870i

1.

9.

Go to Status > Phone System > Unassigned Phone and find the MAC address of the
intended primary station.

Select the intended primary station, click Action, and select Assign to 870i device.

In Device role, set the station as primary with chain ID. The chain ID should be numbers up
to 5 digits. Type any description as needed. Then click Create.

Go to Phone System > Device > 870i Phone to add extensions to the primary station. Note
that we only need to add the extension configuration to the primary. All secondary stations
can obtain the extension information from the primary.

Select the primary station just created, click Action, and select Assign new extension or
Apply existing extension.

For Assign new extension, configure the extension information and enter Handset ID which
should start with 1. Leave Base MAC address field empty and click Create.

Add more extensions as needed with a different handset IDs. Upon completion, you should
see all the extensions listed for the primary station.

Since the primary station is provisioned now, we can proceed to provision the secondary
stations. Factory reset the intended secondary station and connect it to the network. If the
network and the FortiVoice unit are configured properly, it should show up under Status >
Phone System > Unassigned Phone.

Select the unassigned FortiFone 870i station, click Action > Assign to 870i device.

10.1n Device role, set the base station as secondary and select Prime (primarystation) from the

drop down list. Type any description as needed.

11.Click Create.
12.0n the secondary phone configuration, remove the temporary extension setting and reboot

Fortinet Technologies Inc.

the station. See the phone guide for more information.

Note that the temporary extension is used for initial configuration of the base and has to be
removed for the phone to work with the FortiVoice unit.
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Reviewing system configuration

Phone System > Review provides a snapshot of the FortiVoice system configuration, including:
e extension numbers

e extension numbers in conflict

e phone MAC addresses in conflict

e extension password check

* new voice mail check

e network summary

¢ DID handling information

You can double click a record to modify or view the information.
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Configuring Extensions

The Extensions menu lets you configure local and remote extensions, virtual numbers, and
extension department.

This topic includes:

e Setting up local extensions

¢ (Creating extension groups

e Setting up general voice mailboxes
¢  Working with virtual numbers

Setting up local extensions

You can configure IP phone extensions, edit analog extension, and choose extension
preferences.

This topic includes:

e Configuring IP extensions

¢ Modifying analog extension (200D-T, 1000E-T, and 20E2 models only)
e Setting up remote extensions

¢ Configuring fax extensions

e Setting extension user preferences

¢ Resetting voice messages

Configuring IP extensions

An IP extension is an IP phone connected through a network to a system. An internal IP
extension is a phone connected on the same LAN as the system. An external IP extension is a
phone connected outside the LAN.

To view the local IP extensions, go to Extensions > Extensions > IP Extensions.

GUI field Description

Batch Edit If you want to apply the same changes to multiple extensions, select the
extensions and click this option. Make the changes and click Apply To
All.

Export Select to save a copy of the extension list in CSV format.

Import Select to upload a copy of the extension list in CSV format. For details,

see “Importing a list of extensions” on page 143.

Save Click an extension’s Display name or Phone Type to modify them and
click this button to save the changes.
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Other actions e Apply phone configuration: If you have edited an extension
configuration and want to apply it to the phone associated with this
extension, select the extension and click this option.

The selected phones will reboot and only the phones that meet the
following conditions will receive the new configuration:

* Phones supported by and registered to the FortiVoice unit. For
the list of supported phones and auto provisioning prerequisites,
see “Configuring SIP phone auto-provisioning” on page 111.

¢ Phone type and MAC address is correctly configured. See “To
create or edit an IP extension” on page 137.

e Auto-provisioning is enabled for the extension associated with
the phone through the user privilege applied to it. See
“Configuring user privileges” on page 245.

e Maintenance: Select an extension and click this button to manage a
user’s voicemail box. You can check the size of the box and empty
the box.

Click Back to return to the SIP tab.

¢ View phone configuration file: Select a FortiFone extension and click
this option to view the phone’s configuration file.

When a phone is associated with an extension, the FortiVoice unit
generates a configuration file for the phone. For details, see “To
create or edit an IP extension” on page 137.

e Check the password strength of SIP accounts: See “Auditing SIP
extension password” on page 142.

e Download programmable phone key labels: If you need a copy of the
programmable phone key labels of your users, select All extensions
or Selected extensions, click Yes and then open or save the file.

Enabled Select to activate an extension.
Number The extension number.
Display Name The name displaying on the extension. This is usually the name of the

extension user.

Status The extension statuses, including:
¢ [dle: The extension is not in use.
® |n Use: The extension is in use.
® Busy: The extension is busy.
* Ringing: The extension is ringing.
® On Hold: The extension has an on-hold call.
* Admin down: The trunk of the extension is disabled

* Not registered: The extension is not registered with the FortiVoice
unit and is not in service.

e Unavailable: The extension is not reachable.
e Alarm detected: There is a problem with the phone line.
e Other: The status other than the above.

IP The link to the IP address of the phone using the extension number. See
“IP” on page 142.
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Department The link to the department of which this extension is a member.

For information on creating departments, see “Creating extension
departments” on page 166.

Disk Usage (KB) Displays the size of disk space used by voicemails for the user in
kilobytes (KB).

Phone Type The type of phone for this extension.

Phone Profile Displays the phone profile applied to the user. For information on phone
profile, see “Configuring phone profiles” on page 121.

Phone Info The model of the phone for this extension.

To create or edit an IP extension

1. Go to Extensions > Extensions > IP Extensions.

2. Click New or double-click an existing extension.

3. Configure the following:

GUI field
Extension Setting

Number

Show suggested
numbers

User ID

Enabled

Display name

Fortinet Technologies Inc.

Description

Enter the extension number following the extension number
pattern. See “Configuring PBX options” on page 105.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the
Number field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and
fixing duplicate or missing numbers. Missing numbers are the
extensions that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can
click the icon and fix the numbers. For more information, see
“Fixing duplicate or missing numbers” on page 142.

This is the system-generated ID based on the user ID prefix
you set (see “User ID prefix” on page 108) and the extension
number.

This option is view only and only appears when you edit an
extension. You can add a new user ID through the CLI. For
more information, see the FortiVoice CLI Reference.

Select to activate the extension.

Enter the name displaying on the extension. This is usually the
name of the extension user.
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External caller ID

SIP password

User PIN

Authentication type

LDAP profile

Authentication ID
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If you want to display a particular caller ID on a called phone
instead of the FortiVoice main number (see “Main number” on
page 105) or the trunk phone number (see “Phone Number”
on page 182), enter it here. The format must be name<phone
number>, such as HR<2221111234>.

If this extension is mapped to a DID number and the
Outbound option is also selected in DID mapping
configuration, the external caller ID entry has priority. For
information on DID mapping, see “Mapping DIDs” on
page 199.

Password policy warnings may appear above this field
depending on your password/PIN policy configuration. You
can click the warning notice to configure the policy. For
details, see “Configuring system options” on page 79.

Enter the password used for configuring your SIP phone from
the phone or the Web. You need the phone's IP to access it
from the Web.

Click Generate to generate a strong password automatically.
Select View password to display the password. This option is
only available when you edit an extension.

If you have configured the default SIP user password (see
“Default SIP user password” on page 107), the password
appears here. However, you can change it.

Enter the password for the extension user to access voicemail
and the user web portal.

Click Generate to generate a strong password automatically.
Select View PIN to display the password. This option is only
available when you edit an extension.

If you have configured the default user PIN (see “Default user
PIN” on page 107), the password appears here. However, you
can change it.

Select the extension’s authentication type: Local or LDAP.

If you select LDAP for Authentication type, select an LDAP
profile to apply to this extension. For information on LDAP
profile, see “Configuring LDAP profiles” on page 125.

You can click New to create a new profile or Edit to modify the
selected one.

If you select Try common name with base DN as bind DN as
the user authentication option in the authentication profile you
select, enter the authentication ID based on the user objects’
common name attribute you entered in the Common name ID
field of the profile, such as jdoe.

If you select Search user and try bind DN as the user
authentication option in the authentication profile you select,
leave this field blank.

This option is only available if you select LDAP for
Authentication type.
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Phone language

Preference

Advanced Setting

Location

SIP setting

User privilege

Account code

Department

Phone type
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Select the voice prompts for the extension, such as auto
attendant and voicemail. The default is English.

For information on adding prompt languages, see “Adding
prompt languages” on page 113.

Select Edit preference to configure the extension user
preferences. See “Setting extension user preferences” on
page 156.

This option is only available when you edit an extension.

Select Internal if the extension does not traverse through
Network Address Translation (NAT) to connect to the
FortiVoice unit, and External if the extension does. These are
system defined locations.

You can also choose other customized locations.

Select the SIP profile for the extension. Click Edit to modify
the current profile or New to configure a new one. For more
information, see “Working with FortiVoice profiles” on

page 118.

Select the services for the extension. Click Edit to modify the
current user privilege or click New to configure a new one. For
more information on user privilege, see “Configuring user
privileges” on page 245.

Enter the extension specific account code that can be used to
restrict calls. You can click Generate to get a code.

Select the department that the extension belongs to. Click
Edit to modify the current department or click New to
configure a new one. For more information on extension
department, see “Configuring agents” on page 218.

Select a supported phone type for the extension.

If you cannot find your phone type in the list, select Generic.
This phone will not receive the PBX setup information from the
FortiVoice unit.

When you edit an extension assigned to a phone that does
not match what you entered in this field, an orange
exclamation mark icon appears. Clicking this icon enters the
actual phone type into this field.

If you select FortiFone-870i and want it to join the multi-cell
configuration, select Multi-Cell. For more information, see
“Configuring FortiFone 870i” on page 132.
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MAC address

Handset ID

Base MAC address

Phone profile

Configure User
Defined Profile

Enter the MAC address of the SIP phone using the extension
number. This option does not apply to
FortiFone-850i/860i/870i.

When you edit an extension assigned to a FortiFone that does
not match what you entered in the Phone type field, an orange
exclamation mark icon appears. Clicking this icon enters the
FortiFone into the Phone type field. An orange exclamation
mark icon also appears beside the MAC address field.
Clicking this icon enters the FortiFone MAC address into the
MAC address field.

If your Phone type is FortiFone-850i/860i/870i, you can enter
the handset ID range (1-8) because these models support
multiple handset and each handset is assigned an extension
number.

If your Phone type is FortiFone-850i/860i/870i, enter the MAC
address of the base supporting the handsets.

When you edit an extension assigned to a FortiFone that does
not match what you entered in the Phone type field, an orange
exclamation mark icon appears. Clicking this icon enters the
FortiFone into the Phone type field. An orange exclamation
mark icon also appears beside the Base MAC address field.
Clicking this icon enters the base MAC address into the field.

Select a profile type if your phone type is FortiFone 260i and
above:

e Admin defined: This type allows you to choose a system
level phone profile. You can also create a new profile or
modify the selected one.

e User defined: This type allows phone users to set the
programmable phone keys on the user web portal when
the profile is applied to their extensions. There is no need
to choose a profile.

Select an Admin defined profile if your phone type is other
than FortiFone 260i and above. You can also create a new
profile or modify the selected one.

For details on phone profiles, see “Configuring phone
profiles” on page 121.

The phone profile settings you select here synchronize with
the same settings in extension preferences. For details, see
“Phone profile” on page 162.

This option is only available if you select the User defined
profile type, save the extension configuration and re-open the
extension.

Click to configure the user defined phone profile. For details,
see “Configuring phone profiles” on page 121.
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Auxiliary device

Call Center

Agent

Configure

Voice Mailbox

Main voice mailbox

Notify message
waiting light to

Extra Information

This option is only available when you edit an extension.

Click to add SIP devices to the extension. This is known as
SIP forking.

SIP forking allows you to have your desk phone ring at the
same time as your softphone or a SIP phone on your mobile.
For example, you can use SIP forking to ring your desk phone
and your Android SIP phone at the same time, allowing you to
take the call from either device easily. No forwarding rules
would be necessary as both devices would ring. In the same
manner, SIP forking can be used in an office and allow the
secretary to answer calls to the extension of his/her boss
when he is away or unable to take the call.

For more information, see “Configuring SIP forking” on
page 144.

Enable or disable this extension as a call center agent. For
more information about call center agents, see “Setting up a
Call Center” on page 208.

If you enabled the agent, click to configure it. For more
information, see “Configuring call center agent” on page 145.

Configure the extension’s voice mailbox.

In some cases, you may want other users or groups to share
this voice mailbox. For example, a supervisor wants his/her
co-workers to access his/her voice mailbox while he/she is
away.

Select the extension’s own voice mailbox (Default) or that of
another extension as the voice mailbox of this extension.

Typically, you use the default mailbox.

If you select the voice mailbox of another extension, you can
click Edit to modify that extension.

You can let the FortiVoice unit turn on the message waiting
light on the phones of a user or user group if you want to
notify the user or group of a new voice message stored in the
voice mailbox associated with this extension.

To notify a user or user group, click User(s)/Group(s) and
select the users/groups from the Available field and click -> to
move them to the Selected field.

To listen to the message after being notified, the user can dial
*97 or the code you set (see “Modifying feature access
codes” on page 273) and enter the user’s own voicemail PIN.

For information on creating user groups, see “Creating
extension groups” on page 165.

This option is only available when you edit an extension.
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IP The link to the IP address of the phone using the extension
number. This address is retrieved from a SIP phone after it is
registered with the FortiVoice unit. Clicking the link opens the
login page of the web interface of the phone. You need the
user name and password of the phone to log in.

4. Click Create (for new extension) or OK (for editing extension).

Auditing SIP extension password

You can verify the strength of SIP extension passwords. For information on setting SIP
extension password, see “Configuring IP extensions” on page 135.
To audit a SIP extension password
1. Go to Extensions > Extensions > IP Extensions.
2. Under Other actions, click Check the password strength of SIP accounts.
The Audit SIP Passwords page opens.

3. If a password policy warning appears, click the warning to view the password policy. To set
the policy, see “Configuring system options” on page 79.

4. If the Password Strength of an extension shows the Weak or Very weak icon, you can click
the password and change it based on the policy until the Password Strength shows the
Strong icon.

5. Click Save.

To modify the configuration of an extension
1. Go to Extensions > Extensions > IP Extensions.
2. Under Other actions, click Check the password strength of SIP accounts.
The Audit SIP Passwords page opens.
3. Select the extension that you want to modify.
4. Click Edit and follow the steps in “To create or edit an IP extension” on page 137.

Fixing duplicate or missing numbers

When there are duplicate, missing, or conflicting extensions, an orange exclamation mark icon
appears beside Show suggested numbers. You can click the icon and fix the numbers.

Duplicate numbers occur when there are more than one extension with the same number.

Missing numbers happen when you create an extension without assigning it a number. This
rarely happens and can only be done through the CLI.

Conflicting numbers happen when the number assigned to an extension conflict with the same
number used for other purposes, such as call parking, conference, or ring groups.

For information on the Show suggested numbers field, see “Show suggested numbers” on
page 175.
To fix duplicate, missing, or conflicting numbers

1. On any page that has Show suggested numbers, click the orange exclamation mark icon
beside it.

The Fix Numbers Issues in FortiVoice System page displays.
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Figure 35: Fixing numbers

Fix Number Issues in FortiVoice System
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To fix a duplicate number:
¢ C(Click the Duplicate Number sub-menu.

e Click the duplicate number’s user ID (duplicate object) you want to remove. The duplicate
number’s configuration page displays.

¢ Remove the duplicate number in the Number field and click OK. For information on
configuring extensions, see “Setting up local extensions” on page 135.

To fix a missing number:
¢ Click the Missing Number submenu.
¢ Double-click a missing number. The missing number’s configuration page displays.

e Enter an extension number in the Number field and click OK. For information on
configuring extensions, see “Setting up local extensions” on page 135.

To fix a conflicting number:
¢ Click the Conflict Number submenu.
¢ Double-click a conflicting number. The conflicting number’s configuration page displays.

e Enter an extension number in the Number field and click OK. For information on
configuring extensions, see “Setting up local extensions” on page 135.

Close the Fix Numbers Issues in FortiVoice System page.

porting a list of extensions

The import feature provides a simple way to add a list of new extensions in one operation. You
can create a CSV file in any spreadsheet and import the data as long as the columns match the
FortiVoice format.

Your CSV file must have a headline containing the column names such as User ID, Extension,
.g Display name, Phone type, Mac address, and Phone profile. Otherwise, the import will fail.

To
1.
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import extension records
On the IP Extensions tab, click Import.
The Import SIP extension from CSV file page opens.

Select Update existing extensions if you want to overwrite the existing extensions with the
matching imported records.

If you do not select this option, the uploaded extensions will be skipped if they already exist
on the FortiVoice unit.

Select The import CSV file contains ‘User ID’ field if you want to import extension records
with the User ID column.

Click Browse to locate the CSV file to import and click Open.

Optionally, click Download sample to see if the columns of your CSV file match those of the
FortiVoice format.
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6. Click OK.
A field appears showing the percentage of import completion.
A dialog appears showing the number of imported records.

Configuring SIP forking

SIP forking allows you to have your desk phone ring at the same time as your softphone or a
SIP phone on your mobile.

When a device is added, it inherits your master phone’s user privileges except hot-desking and
fax.

You can add two SIP extensions and one external phone number.

To add a SIP device

1. Go to Extensions > Extensions > IP Extensions.
2. Click an extension and go to Advanced Setting.
3. Click Auxiliary device to add a device.

4. Click New and configure the following:

GUI field Description

Status Select to enable the device.

Type Select SIP for the type of device to add.

User ID This is the system-generated ID based on the user ID prefix

you set (see “User ID prefix” on page 108) and the master
extension number.

This option is view only. You can add a new user ID through
the CLI. For more information, see the FortiVoice CLI
Reference.

Password Password policy warnings may appear above this field
depending on your password/PIN policy configuration. You
can click the warning notice to configure the policy. For
details, see “Configuring system options” on page 79.

Enter the password used for configuring your SIP phone from
the phone or the Web. You need the phone's IP to access it
from the Web.

Click Generate to generate a strong password automatically.
Select View password to display the password. This option is
only available when you edit an extension.

If you have configured the default SIP user password (see
“Default SIP user password” on page 107), the password
appears here. However, you can change it.

SIP setting Select the SIP profile for the device. Click Edit to modify the
current profile or New to configure a new one. For more
information, see “Working with FortiVoice profiles” on
page 118.
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5.

Phone type

MAC address

Click Create.

Select a supported phone type for the extension.

If you cannot find your phone type in the list, select Generic.
This phone will not receive the PBX setup information from the
FortiVoice unit.

When you edit an extension assigned to a phone that does
not match what you entered in this field, an orange
exclamation mark icon appears. Clicking this icon enters the
actual phone type into this field.

Enter the MAC address of the SIP device.

To add an external phone number

® No o o dh=

Go to Extensions > Extensions > IP Extensions.

Click an extension and go to Advanced Setting.

Click Auxiliary device to add a device.

Click New.

Select Status to enable the device.

For Type, select External number.

Enter the external number.

Click Create.

Configuring call center agent

Configure the departments that a call center agent manages, queues that the agent belongs to,
skill sets, and skill levels. For more information on call center, see “Setting up a Call Center” on
page 208.

To

configure an agent

1. Go to Extensions > Extensions > IP Extensions> Call Center.

2.

Select Enable for Agent.

3. Click Configure and do the following:

Fortinet Technologies Inc.

GUI field

Agent profile

Managed departments

Description

Select the profile for the agent. You can also create a new one
or modify an existing one. For more information about agent
profiles, see “Configuring agent profiles” on page 226.

An agent manager may need to monitor call queues in certain
departments. For information on setting up departments, see
“Creating extension departments” on page 166.

Click >> to select the departments to be monitored and then
click Done.

Page 145 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Member of Queues Click to select the call queues to join.

¢ Main/Outgoing queue: This option is for collecting the
outgoing calls from all queues by this agent and displaying
them in “Working with call queue statistics” on page 227.
You can select any queue of which this agent is a member
for that purpose except None which will not collect agent’s
outgoing call information.

* Queues: Select the queues of which you want the
extension/agent to be a member, and click Apply.

Skill Sets Click New to select the skill set for the agent, including skill
and level, and click Create. For more information about agent
skills and levels, see “Adding agent skill sets” on page 225
and “Creating agent skill levels” on page 225.

4. Click OK.

Modifying analog extension (200D-T, 1000E-T, and 20E2 models only)

The FortiVoice 200D-T and 1000E-T each has one analog port and a default analog extension.
The FortiVoice 20E2 has two analog ports and two default analog extensions.You can edit the
extensions’ default configuration.

Analog lines, also referred to as POTS (Plain Old Telephone Service), are used for standard
phones, fax machines, and modems.

To view the default analog extension, go to Extensions > Extensions > Analog Extensions.

Figure 36: Viewing analog extension

= = )
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GUI field Description

Batch Edit If you want to apply the same changes to multiple extensions, select the
extensions and click this option. Make the changes and click Apply To
All.

Maintenance Select an extension and click this button to manage its voicemail box.

You can check the size of the box and empty the box.

Click Back to return to the Analog tab.

Enabled Select to activate the extension.

User ID This is the system-generated ID for the analog extension.
Number The analog extension number.

Display Name The name displaying on the extension.
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Phone Type The type of phone for this extension.

Disk Usage (KB) Displays the size of disk space used by voicemails for the user in
kilobytes (KB).

To edit the default analog extension

1. Go to Extensions > Extensions > Analog Extensions.

2. Select the default extension and click Edit.

3. Configure the following:

Figure 37: Analog extension configuration

Extension Setting

User ID:

Mumber: 7561
Enabled: ¥
Display name: extl

External caller ID:
@ Password policy is disabled

User PIM: ssssce

Authentication type: | Local

Language: —Default—
Preference: [ Edit preference... ]

| Advanced Setting

User priviege: | —None-—-
Department: | -None—

Analog port: | fisl
Enable fax:

oK Cancel

GUI field
Extension Setting

User ID

Number

Show suggested
numbers

Enabled
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Show suggested numbers

e.g, Jim <612223>

'J Generate View PIN

7 New...

7 New...

R Edit...

Description

This is the system-generated ID for the extension and is
read-only.

Enter the extension number following the extension number
pattern. See “Configuring PBX options” on page 105.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the
Number field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and
fixing duplicate or missing numbers. Missing numbers are
the extensions that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can
click the icon and fix the numbers. For more information, see
“Fixing duplicate or missing numbers” on page 142.

Select to activate the extension.

Page 147 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Display name Enter the name displaying on the extension. This is usually
the name of the extension user.

External caller ID If you want to display a particular caller ID on a called phone
instead of the FortiVoice main number (see “Main number”
on page 105) or the trunk phone number (see “Phone
Number” on page 182), enter it here. The format must be
name<phone number>, such as HR<2221111234>.

If this extension is mapped to a DID number and the
Outbound option is also selected in DID mapping
configuration, the external caller ID entry has priority. For
information on DID mapping, see “Mapping DIDs” on
page 199.

User PIN Password policy warning icon may appear beside this field
depending on your password/PIN policy configuration. You
can click the warning icon to configure the policy. For
details, see “Configuring system options” on page 79.

Enter the password for the user to access voicemail (by
dialing *98 or the customized code. See “Modifying feature
access codes” on page 273) and the user web portal.

Click Generate to generate a strong password automatically.
Select View PIN to display the password.

If you have configured the default user PIN (see “Default
user PIN” on page 107), the password appears here.
However, you can change it.

Authentication type Select the extension’s authentication type: Local or LDAP.

LDAP profile If you select LDAP for Authentication type, select an LDAP
profile to apply to this extension. For information on LDAP
profile, see “Configuring LDAP profiles” on page 125.
You can click New to create a new profile or Edit to modify
the selected one.

Authentication ID If you select Try common name with base DN as bind DN as
the user authentication option in the authentication profile
you select, enter the authentication ID based on the user
objects’ common name attribute you entered in the
Common name ID field of the profile, such as jdoe.

If you select Search user and try bind DN as the user
authentication option in the authentication profile you select,
leave this field blank.

This option is only available if you select LDAP for
Authentication type.
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Language

Preference

Advanced Setting

User privilege

Department

Analog port

Enable fax

4. Click OK.

Setting up remote extensions

Select the prompt language for the FortiVoice unit. The
default is English.

This setting affects all of the FortiVoice unit’s voice prompts,
such as auto attendant and voicemail. However, if you
change the sound file for an individual component, such as
auto attendant, to use a different language, it will override
the default prompt language for this component.

For information on adding prompt languages, see “Adding
prompt languages” on page 113.

Select Edit preference to configure the extension user
preferences. See “Setting extension user preferences” on
page 156.

Select the services for the extension. Click Edit to modify
the current user privilege or click New to configure a new
one. For more information on user privileges, see
“Configuring user privileges” on page 245.

Select the department that the extension belongs to. Click
Edit to modify the current department or click New to
configure a new one. For more information on extension
department, see “Creating extension departments” on
page 166.

Enter the analog port number. By default, it is fxs7.

Select to activate facsimile function for the extension.

A remote extension reaches an external phone by automatically selecting a line from a trunk and
dialing the phone number. For example, a remote extension could reach an employee’s cell
phone or home phone, or a phone at a branch office.

A caller can connect to a remote extension through the auto attendant, or can be transferred to
a remote extension by a call cascade. A user at a local extension can manually transfer a caller
to a remote extension, or can dial a remote extension directly. If the remote extension is busy or
unanswered, the system can route the call using the remote extension’s call cascade.

For example, a caller reaches the auto attendant and dials a local extension. The user is not
there, so the call is unanswered. The call cascade of the local extension can be configured to
transfer unanswered calls to a remote extension. The remote extension can be configured to
dial the user’s cellular phone. This way the user is available outside the office.

Remote extensions are designed to operate with local major telephone service providers. The
feature may not function correctly with some telephone and mobile operator’s networks,
especially for international phone numbers and mobile phones roaming internationally.

To configure a remote extension

1. Go to Extensions > Extensions > Remote Extensions.

2. Click New.
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3. Configure the following:

Fortinet Technologies Inc.

Figure 38: Adding a remote extension

Extension Setting

Number:

Remote number:
Enabled:
Display name:
External caller ID:
User PIN: 123123

Authentication type: | Local

+|Voice Mailbox

Main voice mailbox: | —Default—

Mofify message waiting light to:

L= )| Group(s)

[F] Show suggested numbers

e.q, Jim <612223=

(] Generate

Available : (9/10)

Selected : (1/10)

290 (gv290) (mailbox)
360 (360) (sip)

675 (6751 Yong) (sip)
7701 (Operator) (sip)
7702 (Administrator) (sip)
7711 (John Doe) (sip)
7810 (QA) (sip)

810 (hao 670i) (sip)

870 (870) (sip)

- - A70 (470) (sip) -
<

Search:

Create Cancel

GUI field
Extension Setting

Number

Show suggested

numbers

Description

Enter the local extension number from which calls are transferred
to a remote extension.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the
Number field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and fixing
duplicate or missing numbers. Missing numbers are the
extensions that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can click
the icon and fix the numbers. For more information, see “Fixing
duplicate or missing numbers” on page 142.
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Remote number

Enabled

Display name

External caller ID

User PIN

Authentication type

LDAP profile
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Enter the remote phone number to which a call to the local
extension is transferred. You can enter digits 0-9, space, dash,
comma, # and *.

If you want to enter an auto attendant number followed by an
extension, you can use comma (,) or semicolon (;) to pause the
automatic dialing.

A comma pauses dialing for two seconds, for example,
1-123-222-1234, 5678#. In this case, once auto attendant
1-123-1234 is dialed, and after two seconds, extension 5678 is
automatically dialed.

A semicolon pauses dialing for one second, for example,
1-123-222-1234; 5678#. In this case, once auto attendant
1-123-1234 is dialed, and after one second, extension 5678 is
automatically dialed.

Select to activate the remote extension.

The name displaying on the remote extension when a call is
transferred.

You can choose to display the name differently than the one you
entered here. See “Modifying caller IDs” on page 120.

If you want to display a particular caller ID on a called phone
instead of the FortiVoice main number (see “Main number” on
page 105) or the trunk phone number (see “Phone Number” on
page 182, enter it here. The format must be name<phone
number>, such as HR<2221111234>.

If this extension is mapped to a DID number and the Outbound
option is also selected in DID mapping configuration, the
external caller ID entry has priority. For information on DID
mapping, see “Mapping DIDs” on page 199.

Password policy warnings may appear above this field
depending on your password/PIN policy configuration. You can
click the warning notice to configure the policy. For details, see
“Configuring system options” on page 79.

Enter the password for the user to access voicemail (by dialing
*98 or the customized code. See “Modifying feature access
codes” on page 273) and the user web portal.

Click Generate to generate a strong password automatically.
Select View PIN to display the password. This option is only
available when you edit an extension.

If you have configured the default user PIN (see “Default user
PIN” on page 107), the password appears here. However, you
can change it.

Select the extension’s authentication type: Local or LDAP.

If you select LDAP for Authentication type, select an LDAP profile
to apply to this extension. For information on LDAP profile, see
“Configuring LDAP profiles” on page 125.

You can click New to create a new profile or Edit to modify the
selected one.
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Authentication ID

Voice Mailbox

Main voice mailbox

Notify message
waiting light to

Search

4. Click Create.

Configuring fax extensions

If you select Try common name with base DN as bind DN as the
user authentication option in the authentication profile you
select, enter the authentication ID based on the user objects’
common name attribute you entered in the Common name ID
field of the profile, such as jdoe.

If you select Search user and try bind DN as the user
authentication option in the authentication profile you select,
leave this field blank.

This option is only available if you select LDAP for Authentication
type.

Configure the extension’s voice mailbox.

In some cases, you may want other users or groups to share this
voice mailbox. For example, a supervisor wants his/her
co-workers to access his/her voice mailbox while he/she is
away.

Select the extension’s own voice mailbox (Default) or that of
another extension as the voice mailbox of this extension.

Typically, you use the default mailbox.

If you select the voice mailbox of another extension, you can
click Edit to modify that extension.

You can let the FortiVoice unit turn on the message waiting light
on the phones of a user or user group if you want to notify the
user or group of a new voice message stored in the voice
mailbox associated with this extension.

To notify a user or user group, click User(s)/Group(s) and select
the users/groups from the Available field and click -> to move
them to the Selected field.

To listen to the message after being notified, the user can dial *97
or the code you set (see “Modifying feature access codes” on
page 273) and enter the user’s own voicemail PIN.

For information on creating user groups, see “Creating extension
groups” on page 165.

Enter an extension and look for it in the User(s)/Group(s) fields.

If you want to continue using your fax machine with the VolP phone system, connect the fax
machine to an adapter (such as OBIHAI OBi 200, Cisco SPA 112, or Grandstream HT 702) that
supports T38 first before connecting it to the FortiVoice unit. T38 is a protocol designed to allow
fax to travel over a VoIP network.

In this case, the fax machine is treated like an extension. The FortiVoice unit receives faxes and
relays them to the fax machine. Faxes sent from the fax machine will follow the fax sending dial

plans.

To use this option, you need to create and enable the fax extensions first. You then need to
configure the FortiVoice unit to receive and relay the faxes to the fax machine.
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For information on fax configuration, see “Configuring fax” on page 262.

To view the list of fax extensions, go to Extensions > Extensions > Fax Extensions.

Figure 39: Fax extensions

ﬁ: Mew... By T =
C Page 1 /1 Records per page: 25 v
Enabled Number Dizplay Name
7009 joetest
GUI field Description
Enabled Select to activate this fax extension.
Number The fax extension number.
Display Name The name displaying on the fax extension.

To create or edit a fax extension

1. Go to Extensions > Extensions > Fax Extensions.
2. Click New or double-click an existing extension.
3. Configure the following:

Figure 40: Fax extension configuration

Extension Setting

MNumber: [F] Show suggested numbers
User 1D:

Enabled:

Display name:

External caller I1D: e.q, Jim =§12223=

@ Password policy is disabled @

SIP password: 480v+G0o0 @ Generate

User PIN: 123123 @ Generate
Authentication type: | Local .4

Phone language: | —-Default— .4

+ | Advanced Setting

Location: Internal .4
SIP setting: —-Maone-- R New...
User privilege: —-None— R New...
Account code: Generate
Department. | —None-— R New...
MAC address:
Create Cancel
GUI field Description
Extension Setting
Number Enter the extension number following the extension number

pattern. See “Configuring PBX options” on page 105.
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User ID

Show suggested
numbers

Enabled

Display name

External caller ID

SIP password

This is the system-generated ID based on the user ID prefix
you set (see “User ID prefix” on page 108) and the extension
number.

This option is view only and only appears when you edit an
extension. You can add a new user ID through the CLI. For
more information, see the FortiVoice CLI Reference.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the
Number field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and
fixing duplicate or missing numbers. Missing numbers are the
extensions that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can
click the icon and fix the numbers. For more information, see
“Fixing duplicate or missing numbers” on page 142.

Select to enable this extension to receive and send faxes that
support T38 protocol. This applies to using a fax machine
connected to the FortiVoice unit via an adapter that supports
T38 protocol. For more information, see “Configuring fax” on
page 262.

Enter the name displaying on the extension.

If you want to display a particular caller ID on a called phone
instead of the FortiVoice main number (see “Main number” on
page 105) or the trunk phone number (see “Phone Number”
on page 182), enter it here. The format must be name<phone
number>, such as HR<2221111234>.

If this extension is mapped to a DID number and the
Outbound option is also selected in DID mapping
configuration, the external caller ID entry has priority. For
information on DID mapping, see “Mapping DIDs” on
page 199.

Password policy warnings may appear above this field
depending on your password/PIN policy configuration. You
can click the warning notice to configure the policy. For
details, see “Configuring system options” on page 79.

Enter the password used for configuring your SIP phone from
the phone or the Web. You need the phone's IP to access it
from the Web.

Click Generate to generate a strong password automatically.
Select View password to display the password. This option is
only available when you edit an extension.

If you have configured the default SIP user password (see
“Default SIP user password” on page 107), the password
appears here. However, you can change it.
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User PIN

Authentication type

LDAP profile

Authentication ID

Phone language

Preference

Advanced Setting

Location

SIP setting

User privilege
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Enter the password for the extension user to access voicemail
and the user web portal.

Click Generate to generate a strong password automatically.
Select View PIN to display the password. This option is only
available when you edit an extension.

If you have configured the default user PIN (see “Default user
PIN” on page 107), the password appears here. However, you
can change it.

Select the extension’s authentication type: Local or LDAP.

If you select LDAP for Authentication type, select an LDAP
profile to apply to this extension. For information on LDAP
profile, see “Configuring LDAP profiles” on page 125.

You can click New to create a new profile or Edit to modify the
selected one.

If you select Try common name with base DN as bind DN as
the user authentication option in the authentication profile you
select, enter the authentication ID based on the user objects’
common name attribute you entered in the Common name ID
field of the profile, such as jdoe.

If you select Search user and try bind DN as the user
authentication option in the authentication profile you select,
leave this field blank.

This option is only available if you select LDAP for
Authentication type.

Select the voice prompts for the extension, such as auto
attendant and voicemail. The default is English.

For information on adding prompt languages, see “Adding
prompt languages” on page 113.

Select Edit preference to configure the extension user
preferences. See “Setting extension user preferences” on
page 156.

This option is only available when you edit an extension.

Select Internal if the extension does not traverse through
Network Address Translation (NAT) to connect to the
FortiVoice unit, and External if the extension does.

Select the SIP profile for the extension. Click Edit to modify
the current profile or New to configure a new one. For more
information, see “Working with FortiVoice profiles” on

page 118.

Select the services for the extension. Click Edit to modify the
current user privilege or click New to configure a new one. For
more information on user privilege, see “Configuring user
privileges” on page 245.
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Account code

Department

Phone type

MAC address

Extra Information

IP

Enter the extension specific account code that can be used to
restrict faxes. You can click Generate to get a code.

Select the department that the extension belongs to. Click
Edit to modify the current department or click New to
configure a new one. For more information on extension
department, see “Creating extension departments” on
page 166.

Select a supported phone type for the extension.

If you cannot find your phone type in the list, select Generic.
This phone will not receive the PBX setup information from the
FortiVoice unit.

When you edit an extension assigned to a phone that does
not match what you entered in this field, an orange
exclamation mark icon appears. Clicking this icon enters the
actual phone type into this field.

Enter the MAC address of the adapter through which the fax
machine connects to the FortiVoice unit.

This option is only available when you edit an extension.

The link to the IP address of the fax adapter using the
extension number. This address is retrieved from the adapter
after it is registered with the FortiVoice unit. Clicking the link
opens the login page of the web interface of the adapter. You
need the user name and password of the adapter to log in.

4. Click Create (for new extension) or OK (for editing extension).

Setting extension user preferences

Each SIP and analog extension comes with its default user preferences, including voicemail
settings and phone display preference. You can modify these settings.

Phone users can modify the preferences on the web user portal.

To view the list of extensions, go to Extensions > Extensions > Preferences.
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Figure 41: Extension preferences
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ext1
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GUI field

Maintenance

Number
User ID

Display Name

Records per page: 25 w =]

Display Mame

190
Operator_test
Operator
Operator

Description

Select an extension and click this option to reset the user preferences to

the default values.

The extension number.
The system-generated ID based on the extension number.

The name displaying on the extension. This is usually the name of the

extension user.

To edit extension user preferences

1.
2.
3.
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Go to Extensions > Extensions > Preferences.

Select an extension and click Edit.

Configure the following:

GUI field
Voicemail Setting

User ID

Number

Display name

Emergency caller ID

Description

This is the system-generated ID based on the extension
number. This is not editable. You can add a new user ID
through the CLI. For more information, see the FortiVoice CLI
Reference.

The extension number. This is not editable.

Enter the name displaying on the extension. This is usually
the name of the extension user.

Enter the caller ID to display on the destination phone when
you dial the emergency number, such as 911.

If you also enter an external caller ID (see “External caller ID”
on page 158), that ID will not override the emergency caller ID
when dialing the emergency number.

If this extension is part of a phone group in a location profile
which also has an emergency caller ID, this ID overides the

emergency caller ID in the location profile. See “Emergency
caller ID” on page 131.
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External caller ID

Ring duration

Call forward

Call waiting

Do not disturb

Message waiting
indication

Voicemail handling
(Caller press 0
during
announcement)
Notification Options

Voicemail

Fax

Missed call

The caller ID you want to display on a called phone instead of
the FortiVoice main number (see “Main number” on

page 105) or the trunk phone number (see “Phone Number”
on page 182). This is not editable.

For details, see “External caller ID” on page 138 and
“External caller ID” on page 148.

Enter the phone ringing duration in seconds before an
incoming call goes to voicemail.

Select to forward phone calls and enter the phone number to
forward the calls. This function only works if call forwarding is
enabled in the extension’s user privilege. See “Configuring
user privileges” on page 245.

Select to enable call waiting. This function only works if call
waiting is enabled in the extension’s user privilege. See
“Configuring user privileges” on page 245.

Select to enable DND. This function only works if DND is
enabled in the extension’s user privilege. See “Configuring
user privileges” on page 245.

Select to enable phone indication that a message is received.

Select to enable reaching the operator by pressing 0 when
you hear the announcement of a callee’s voicemail.

Select the type of email notification when this extension has a
voicemail:

e None: Do not send any notification.
e Simple: Send an email notification.

e With attachment: Send an email notification with the
voicemail attached.

Select the type of email notification when this extension has a
fax:

e None: Do not send any notification.

e Simple: Send an email notification.

e With attachment: Send an email notification with the fax
attached.

Select On if you want to send an email notification when an
incoming call is missed.
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Voicemail Options

Display Preference

Configure greeting, unavailable, and busy messages.
Name: Your name of the voicemail. For example, John Doe.

e Standard: Use the system default name for the voicemail.
This will be the extension number.

e Personal: Use your own name for the voicemail.

¢ Click Call me to ring your extension and record a name
using the phone, such as your name or extension
number.

e (Click Upload to import a name, such as your name or
extension number.

¢ Click Play to listen to a recorded name.
¢ C(Click Erase to delete a recorded name.
e (Click Download to save a recorded name.

Greeting: Select the voicemail greeting mode and greeting
content.

e Standard: The system defined greeting.

e Simple: The customer-recorded greeting that applies to
any time except when the line is busy and extension is
unavailable.

e Scheduled: The customer-recorded greeting that comes
with a schedule.

e Conditional: The customer-recorded greeting that only
applies to occasions when the line is busy or extension is
unavailable.

¢ Audio file: Click to configure the greeting. This option is
only available when you select Simple, Scheduled or
Conditional.

¢ Click Call me to ring your extension and record a
message such as a greeting, unavailable, or busy
message using the phone. This applies to the Simple
and Scheduled modes.

e (Click Upload to import a message such as a greeting,
unavailable, or busy message.

¢ Click Play to listen to a message such as a greeting,
unavailable, or busy message.

¢ Click Erase to delete a message such as a greeting,
unavailable, or busy message.

e (Click Download to save a message such as a greeting,
unavailable, or busy message.

If you select Scheduled for Greeting, click New to add a
system schedule or create a new one. You can also add a
greeting which is the audio file you configured when clicking
Audio file.

The purpose of having a separate voicemail name file is for
occasions that you just want to change the name without
touching the greeting file.
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Default portal

Phone language

Web language
Theme

Time zone
Idle timeout

Account Management

Agent

PIN required to
login/logout from
phone

PIN required to
pause/unpause
from phone

Auto-Pause after
agent login queue

Select the default user web portal interface.

If User portal is disabled, it means that the user portal
function in the user privilege for this extension is not enabled.
For more information, see “Configuring user privileges” on
page 245.

If Operator console is disabled, it means that the operator
mode function in the user privilege for this extension is not
enabled. For more information, see “Configuring user
privileges” on page 245.

If Agent console is disabled, it means that the extension
agent for this extension is not enabled. For more information,
see “Call Center” on page 141.

Select the prompt language for the extension. The default is
English.

For information on adding prompt languages, see “Adding
prompt languages” on page 113.

Select the language for the FortiVoice user web portal.
Select the display theme for the FortiVoice user web portal.
Select the time zone for the FortiVoice user web portal.

Set the timeout for the FortiVoice user web portal.

Click Change PIN number to change the password for
accessing the voice mailbox and the FortiVoice user web
portal.

Select to enable an agent to log into/log out of a queue from
the extension using the user PIN.

For information on feature access codes, see “Configuring
account codes” on page 249.

Select to enable an agent to pause/unpause a queue from
the extension using the user PIN. To pause means the agent
is not answering calls.

For information on feature access codes, see “Configuring
account codes” on page 249.

Select to automatically put the agent in pause (not ready)
status after the agent logs into a queue. The agent can
unpause a queue to answer calls.

For information on feature access codes, see “Configuring
account codes” on page 249.
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Speed Dial Setting

Follow Me

Black list

Call Handling

Twinning Setting

Map a phone key to a phone number for speed dialing by
clicking Number and enter the phone number.

You can enter digits 0-9, space, dash, comma, # and *.

If you want to enter an auto attendant number followed by an
extension, you can use comma (,) or semicolon (;) to pause
the automatic dialing.

A comma pauses dialing for two seconds, for example,
1-123-222-1234, 5678#. In this case, once pressing the
speed dial code you set, auto attendant 1-123-1234 is
reached, and after two seconds, extension 5678 is
automatically dialed.

A semicolon pauses dialing for one second, for example,
1-123-222-1234; 5678#. In this case, once pressing the
speed dial code you set, auto attendant 1-123-1234 is
reached, and after one second, extension 5678 is
automatically dialed.

See “Configuring follow me settings” on page 162.

Click New to enter the phone number you want to block from
calling this extension.

This configuration serves as a profile for use in managing
calls. See “Handling calls” on page 163.

For more information, see “Handling calls” on page 163.

This option is only available if Twinning is selected in the user
privileges of the extension. For more information, see
“Twinning” on page 246.

Setting: Select the twinning method.

¢ Disabled: Select to disable twinning.

e Simple: Select to configure a basic twinning by adding
a phone number.

e Scheduled: Select to configure a twinning by adding
phone numbers based on a schedule.

Operation status: If you choose to configure a twinning,
select to turn it on or off.

Number: If you choose to configure a simple twinning, enter
the phone (twin) number.

Schedule: If you choose to configure a scheduled twinning,
select up to 3 time schedules (see “Scheduling the FortiVoice
unit” on page 132), and enter a phone (twin) number for each
schedule.
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Phone profile

Configure User
Defined Profile

FortiFone Call Preference

Direct call

Direct call number

Direct call timer

Auto answer

4. Click OK.

For details on phone profiles, see “Configuring phone
profiles” on page 121.

Select a profile type if your phone type is FortiFone 260i and
above:

e Admin defined: This type allows you to choose a system
level phone profile. You can also create a new profile or
modify the selected one.

e User defined: This type allows phone users to set the
programmable phone keys on the user web portal when
the profile is applied to their extensions. There is no need
to choose a profile.

Select an Admin defined profile if your phone type is other
than FortiFone 260i and above. You can also create a new
profile or modify the selected one.

The phone profile settings you select here synchronize with
the same settings in extension configuration. For details, see
“Phone profile” on page 140.

This option is only available if you select the User defined
profile type, save the extension configuration and re-open the
extension.

Click to configure the user defined phone profile. For details,
see “Configuring phone profiles” on page 121.

If this extension is for a FortiFone, you can configure its call
preferences.

Select to add direct call function to this phone, that is, as
soon as you pick up the phone, it dials the number you set
automatically.

If you select Direct call, enter the number to call. For
example, the number of your paging system.

Enter the time in seconds to wait before the number dialing
starts after the phone is picked up.

You can enter a different number to call before the set time
expires.

Select to enable this phone to automatically answer phone
calls without being picked up.

Configuring follow me settings

Follow me allows a call to an extension to be transferred to another destination when you are

not available.

This configuration serves as a profile for use in managing calls. See “Handling calls” on

page 163.

To configure follow me settings:

1. Go to Extensions > Extensions > Preferences > Follow Me.

Fortinet Technologies Inc.
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Click New.

Enter a Name for this setting.

Under Follow Me Numbers, click New.

Enter a phone number to which the call to your extension can be transferred.

o0 k0N

Enter the phone ringing duration, in seconds, before the call goes to voicemail or next
number in the sequence.

7. Click Create.

Repeat steps 4 to 7 of this procedure to add more numbers if you want to transfer a follow
me call to multiple numbers in a sequence. The numbers will be dialed according to the
sequence in the follow me setting.

Handling calls

Extensions > Extensions > Preferences > Call Handling allows you to manage the call process.
For example, you can configure the process to forward a call to another number on a specific
schedule.

You can manage a normal call handling by configuring the call process for different situations.
You can also manage quick call handling by dialing a code to enter into a default mode and
configure the call process for that particular mode if required.

If the extension with configured call handling action is part of another FortiVoice function that
also has configured call handling action (for example, a member of a ring group or used for a
virtual number), then the call handling action of the other FortiVoice function overrides the
extension call handling action.

To handle a normal call
1. Go to Extensions > Extensions > Preferences > Call Handling.
2. Click Normal call handling.

Figure 42: Call management configuration

Busy | Unavailable | Voicemail

Configure how to handle cals when in status: hd

Call Process

_System default action (Voicemail)
JUser defined

Ef New... | B - |

Schedule Action

oK Cancel

3. Select a call status at the top of the page.
Each status can only be used for one call management configuration.
4. For Call Process, select System default action or User defined action.

The System default action (action shows in brackets) changes depending on the status
selection.
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5.

If you select User defined, click New to define a call process according to a schedule.

Select a pre-configured Schedule for the call action. You can click View to display the
schedule details. For information on configuring schedules, see “Scheduling the
FortiVoice unit” on page 132.

Add an Action for the call process.

For some call handling processes that may require further actions, you need to add one
or more call processes to complete the call handling. For example, after adding a process
that contains a Forward action, you can add another process with a Go voicemail action
to complete the call handling. In this case, the call will be forwarded to the phone
specified and if the phone is not picked up, a voicemail will be left on this extension.

Default action is equal to the action when you select System default action under Call
Process.

e If you select Follow me, select a follow me profile. For information on configuring
follow me, see “Follow Me” on page 161.
This option is available only if call forwarding is enabled in the extension’s user
privilege. See “Configuring user privileges” on page 245.

¢ If you select Play announcement, select a sound file. For information on configuring
sound files, see “Managing sound files and music on hold” on page 116.

¢ If you select Auto attendant, select an auto attendant profile. For information on
configuring auto attendant, see “Configuring auto attendants” on page 239.

e If you select Forward, enter the number to which you want to forward the call.
This option is available only if call forwarding is enabled in the extension’s user
privilege. See “Configuring user privileges” on page 245.

Click Create.

6. Click OK.

To handle a quick call

1.
2.
3.

Fortinet Technologies Inc.

Go to Extensions > Extensions > Preferences > Call Handling.
Click Quick call handling.
Select a call status at the top of the page.

Each status can only be used for one call management configuration.

For Call Process, select System default action or User defined action except for the Out of
office status.

If you select System default action, the three quick call modes are the same as listed.

If you select User defined, click New to define a call process according to a schedule.

Select a pre-configured Schedule for the call action. You can click View to display the
schedule details. For information on configuring schedules, see “Scheduling the
FortiVoice unit” on page 132.

Add an Action for the call process. You can add multiple actions to process a call in
sequence. For example, you can add Play announcement and then Auto attendant. In this
case, an incoming call will be transferred to the auto attendant after an announcement is
played.

Default action is equal to the action when you select System default action under Call
Process.

¢ If you select Follow me, select a follow me profile. For information on configuring
follow me, see “Follow Me” on page 161.
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This option is available only if call forwarding is enabled in the extension’s user
privilege. See “Configuring user privileges” on page 245.

¢ If you select Play announcement, select a sound file. For information on configuring
sound files, see “Managing sound files and music on hold” on page 116.

e If you select Auto attendant, select an auto attendant profile. For information on
configuring auto attendant, see “Configuring auto attendants” on page 239.

¢ If you select Forward, enter the number to which you want to forward the call.
This option is available only if call forwarding is enabled in the extension’s user
privilege. See “Configuring user privileges” on page 245.

e C(Click Create.
7. Click OK.

Resetting voice messages

Extensions > Extensions > Voice Messages lets you view the voice message count in each
extension. You can also delete the voice messages for an extension by selecting the extension
and click Maintenance > Reset. This action only deletes the messages, not the extension itself.

Creating extension groups

Extensions > Groups lets you configure extension groups including extension departments, ring
groups, page groups, and pickup groups.

This section contains the following topics:
¢ (Creating user groups

¢ Creating extension departments

¢ Creating ring groups

¢ (Creating page groups

e Creating pickup groups

Creating user groups

You can create a user group and use it to simplify the configuration of an IP extension voice
mailbox, a general voice mailbox, a ring group, a page group, or a pickup group. For example,
when creating a ring group, you can select the name of a user group rather than entering each
user name individually.

For information on creating IP extension voice mailboxes, see “Configuring IP extensions” on
page 135.

For information on creating general voice mailboxes, see “Setting up general voice mailboxes”
on page 170.

To create a user group

1. Go to Extension > Groups > User Group.

2. Click New.

3. Enter a name for the group.

4

. Select the available users or user groups that you want to include in the group and click -> to
move them into the Selected field.

5. Click Create.
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Creating extension departments

You can create department profiles for applying to the extensions. For example, you can create
a department profile called HR and apply it to extension 1111 to indicate that this extension
belongs to the HR department.

For information on applying department profiles, see “Setting up local extensions” on page 135.

To create an extension department

1.

a Db

Go to Extension > Groups > Department.

Click New.

In the Name field, enter the name of the department.

In the Comment field, enter any notes you have for this department.

If you have call center license, the Call Center section appears. For configuration
information, see “Configuring agents” on page 218.

Click Create.

Creating ring groups

A ring group is a group of local extensions and external numbers that can be called using one
number. Local extensions and auto attendants can dial a ring group.

A ring group can reach a group of extensions. For example, ring group 301 can ring the sales
group at extensions 111, 112, 113, and 114. When a customer calls the sales group, the first
available salesperson answers for the group.

To create a ring group

1. Go to Extension > Groups > Ring Group.
2. Click New.
3. Configure the following:
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Figure 43: Creating a ring group

Ring Group

Mame:

Mumber: [7] Show suggested numbers

Display name:

Enabled:

Ring mode: @Al ©Sequential

Members: Available : (9/9) Selected : (0/9)
290 (870i_290) (sip) - -
F707 (new user) (sip) =
7702 (=ip)
7711 (sip) LJ

7816 (test 7216) (sip)

7820 (test 7820) (sip)

7821 (TLS_SRTP 7821} (sip)

7822 (QA Ysun) (sip)

1390 (office_public) (virtual number)

External numbers:
Ef New... | T

Call Handling

| Advanced setting

Create Cancel

GUI field
Name

Number

Show suggested
numbers

Display Name

Enabled
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Description
Enter the name for the ring group.

Enter the ring group number following the extension number pattern.
See “Configuring PBX options” on page 105.

Clicking in the field displays a list of crossed-out extensions. These
numbers are already used and cannot be used as ring group
numbers.

The ring group number, once dialed, will ring all the extensions in the
group.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the Number
field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and fixing
duplicate or missing numbers. Missing numbers are the extensions
that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can click the
icon and fix the numbers. For more information, see “Fixing
duplicate or missing numbers” on page 142.

Enter the name displaying on the extensions of the ring group, such
as “HR”.

Select to activate the ring group.
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Ring mode

Members

External numbers

Call Handling

Advanced setting

4. Click Create.

Select how you want the ring group to be called.

e All: All extensions in the group will ring when the ring group
number is dialed.

e Sequential: Each extension in the group is called one at a time in
the order in which they have been added to the group. You can
set a timeout period for each ring.

Select the available extensions or user groups that you want to
include in the ring group and click -> to move them into the Selected
field.

For information on creating extensions and user groups, see “Setting
up local extensions” on page 135 and “Creating extension groups”
on page 165.

Click New to add an external phone number to the ring group. For
example, you can add the number of a remote employee to a ring

group.

Use this option to configure the call handling for the ring group. For
more information, see “Configuring ring group call handling” on
page 168.

® Ring Pattern: Select a ring pattern for the group.

* Ring duration: Set the amount of time in seconds allowing all
extensions or each one to ring before going to voicemail.

e Farly media: Select the ring tone for the group. For creating new
sound files, see “Managing sound files and music on hold” on
page 116.

e Caller ID option: Select how you want the caller ID to display.
e (Call waiting: Select to enable call waiting.

e Emergency call option: Select Display emergency caller ID to
show the emergency caller’s ID, or Disconnect ongoing call to
stop a call that uses the line for emergency call.

Configuring ring group call handling

Use the Call Handling option to configure the call automation. For example, you can configure
the process to forward a call to another number on a specific schedule.

If the ring group with configured call handling action is part of another FortiVoice function that
also has configured call handling action (for example, a member of another ring group or the
ring group extension is used for a virtual number), then the call handling action of the other
FortiVoice function overrides the ring group call handling action.

For information on the Call Handling option, see “Call Handling” on page 168.

To configure the call process

1. On the Ring Group page, click Configure call handling under Call Handling.
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2.

4,

Select a call status at the top of the page.
Each status can only be used for one call management configuration.

For the Busy status, if you set the ring group’s ring mode to All, the FortiVoice unit will
declare the ring group busy only if all extensions in the group are busy; if you set the ring
group’s ring mode to Sequential, the FortiVoice unit will declare the ring group busy only if
the last extension in the group is busy after ringing the extensions sequentially and each one
is busy at the time of being rung.

For Call Process, select System default action or User defined action.
The System default action changes depending on the status selection.
If you select User defined, click New to define a call process according to a schedule.

¢ Select a pre-configured Schedule for the call action. You can click View to display the
schedule details. For information on configuring schedules, see “Scheduling the
FortiVoice unit” on page 132.

e Add an Action for the call process. You can add multiple actions to process a call in
sequence. For example, you can add Play announcement and then Auto attendant. In this
case, an incoming call will be transferred to the auto attendant after an announcement is
played.

Default action is equal to the action when you select System default action under Call
Process.

e If you select Voicemail, enter the extension number of the voice mail.

¢ If you select Play announcement, select a sound file. For information on configuring
sound files, see “Managing sound files and music on hold” on page 116.

¢ |[f you select Auto attendant, select an auto attendant profile. For information on
configuring auto attendant, see “Configuring auto attendants” on page 239.

¢ If you select Forward, enter the number to which you want to forward the call.
This option is available only if call forwarding is enabled in the extension’s user
privilege. See “Configuring user privileges” on page 245.

e C(Click Create.

Creating page groups

A page group is a group of extensions that can be paged using one number. Page groups
require telephones that support group paging.

A page group can reach a group of extensions. For example, page group 301 can ring the sales
group at extensions 111, 112, 113, and 114. When a call reaches 301, all extensions in the
group can pick up and answer the call.

To
1.

2
3.
4
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create a page group
Go to Extensions > Groups > Paging Group.

. Click New.

Enter a name for the group.

. Enter the page group number following the extension number pattern. See “Configuring PBX

options” on page 105.
This is the number that, once paged, will ring all the extensions in the group.
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5. For Show suggested numbers, select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the Number field displays the
extension numbers already in use.

This option also serves as a diagnostic tool for finding and fixing duplicate or missing
numbers. Missing numbers are the extensions that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange exclamation mark icon appears
beside this option. You can click the icon and fix the numbers. For more information, see
“Fixing duplicate or missing numbers” on page 142.

6. Enter the name displaying on the extensions of the group, such as “HR”.

7. Select Enabled to activate this group.

8. For Caller ID option, select how you want to display the ID of a caller to the group.
e No change: the caller ID will display as is.
¢ Replace: the caller ID will be replaced by the Display name you set.
* Prefix: the caller ID will be prefixed with the Display name you set.

©

For Emergency call option, do the following:
e Select Display emergency caller ID to show the caller ID.

e Select Disconnect ongoing call to interrupt a page in progress when an emergency page
comes in.

10.Select the available extensions or extension groups that you want to include in the page
group and click -> to move them into the Selected field.

11.Click Create.

Creating pickup groups

Some organizations cannot afford to miss phone calls on any extensions. Pickup groups allow
some members in a group to answer incoming calls that ring on other extensions while the
users are away.

Pickup groups can press the feature codes to pick up incoming calls that ring on other
extensions. For more information, see “Modifying feature access codes” on page 278.
To create a pickup group

1. Go to Extensions > Groups > Pickup Group.

Click New.

Enter a name for the group.

Select Enabled to activate this group.

a Db

For Members, select the Available extensions or user groups that you want to include in the
pickup group and click -> to move them into the Selected field.

For information on creating extensions and user groups, see “Setting up local extensions”
on page 135 and “Creating extension groups” on page 165.

6. For Pickup by members, select the Available extensions or user groups that are allowed to
answer incoming calls that ring on other extensions and click -> to move them into the
Selected field.

7. Click Create.

Setting up general voice mailboxes

Some organizations, such as the sales team of a company, may have the need to share voice
mails within multiple users or a user group for better service and efficiency. With a general voice
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mailbox, when there is a new voice mail, the entire group is copied or notified. Any member of
the group can access the voice mail and once this is done, the notification is gone and others
know that the voice mail has been taken care of.

To view the group voice mailbox, go to Extensions > General Voicemail > General Voicemail.
Figure 44: Viewing general voice mails

= New... B i =

Page 1 /1 Records per page: | 25 7

|m Display Name Disk Usage (KB)
111 18

GUI field Description
Enabled Select to activate the mailbox.
Number The extension number for the mailbox. This number is for the mailbox

only and not associated with any phone.
Display Name The name displaying on the extension.

Disk Usage (KB) Displays the size of disk space used by the general voice mails in
kilobytes (KB).

To set up a general voice mailbox

1. Go to Extensions > General Voicemail > General Voicemail.
2. Click New or double-click an existing record.

3. Configure the following:
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Figure 45: Adding a general voice mailbox

General Voicemail
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87005 (Yong Test 7005) (sip)
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87007 (ZhiQiang Huang) (sip)
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Create Cancel

GUI field
General Voicemail

User ID

Number

Show suggested
numbers

Enabled
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Description

This is the system-generated ID based on the mailbox
extension number.

This option is view only. You can add a new user ID through
the CLI. For more information, see the FortiV/oice CLI
Reference.

Enter the mailbox extension number following the extension
number pattern. See “Configuring PBX options” on page 105.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the
Number field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and
fixing duplicate or missing numbers. Missing numbers are the
extensions that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can
click the icon and fix the numbers. For more information, see
“Fixing duplicate or missing numbers” on page 142.

Select to activate the mailbox extension.
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Display name

User PIN

Authentication type

LDAP profile

Authentication ID

Phone language

Group Voice Mailbox

Enter the name of the mailbox extension.

Password policy warning icon may appear beside this field
depending on your password/PIN policy configuration. You
can click the warning icon to configure the policy. For details,
see “Configuring system options” on page 79.

Enter the password for the user to access voicemail (by
dialing *98 or the customized code. See “Modifying feature
access codes” on page 273) and the user web portal.

Click Generate to generate a strong password automatically.
Select View PIN to display the password. This option is only
available when you edit an extension.

If you have configured the default user PIN (see “Default user
PIN” on page 107), the password appears here. However, you
can change it.

Select the mailbox extension’s authentication type: Local or
LDAP.

If you select LDAP for Authentication type, select an LDAP
profile to apply to this extension. For information on LDAP
profile, see “Configuring LDAP profiles” on page 125.

You can click New to create a new profile or Edit to modify the
selected one.

If you select Try common name with base DN as bind DN as
the user authentication option in the authentication profile you
select, enter the authentication ID based on the user objects’
common name attribute you entered in the Common name ID
field of the profile, such as jdoe.

If you select Search user and try bind DN as the user
authentication option in the authentication profile you select,
leave this field blank.

This option is only available if you select LDAP for
Authentication type.

Select the voice prompts for the mailbox extension, such as
auto attendant and voicemail. The default is English.

For information on adding prompt languages, see “Adding
prompt languages” on page 113.

Configure the users for sharing this extension’s mailbox.
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Mode Select the way to deliver the voicemail from this mailbox
extension to the users sharing this mailbox.

¢ (Centralized: Select to copy or notify the entire group when
a new voicemail comes in. Any member of the group can
access the voicemail and once this is done, the notification
is gone and others know that the voicemail has been taken
care of.

¢ Notify message waiting light: If you select this option,
the FortiVoice unit turns on the message waiting light
on a user’s phone when a new voice message is left on
this voice mailbox.

e [jst as mailbox: Users can listen to a centralized
voicemail by dialing *97 or the customized code (see
“Modifying feature access codes” on page 273) from
their own extensions and enter the user PIN for this
general voicemail box.

® Broadcast: If you select this option, the voicemail is sent to
the voicemail boxes of the users. Users can access the
voicemail by dialing *98 or the customized code (see
“Modifying feature access codes” on page 273) from any
extensions and enter the personal user PIN.

Participants Select the users or groups to notify when a voicemail is left in
this mailbox extension.

To select the users to share this mailbox, click User(s) and
from the Available field, select the users and click -> to move
them to the Selected field.

To select the groups to share this mailbox, click Group(s) and
from the Available field, select the groups and click -> to move
them to the Selected field.

For information on creating user groups, see “Creating
extension groups” on page 165.

4. Click Create or OK.

Working with virtual numbers

A virtual number is an extension that is not assigned to a phone. Unlike auto attendants, when a
call goes to a virtual number, the caller does not need to manually select any options by
pressing the phone keys. The call process is automated based on time schedules. For example,
for after business hour phone calls, you can configure a virtual number to play an
announcement, then transfer the call to the voice mailbox. You can also transfer the calls to the
auto attendant where the callers can manually select the options based on the auto attendant
configuration.

If the virtual number with configured call handling action is part of another FortiVoice function
that also has configured call handling action (for example, a member of a ring group), then the
call handling action of the other FortiVoice function overrides the virtual number call handling

action.

To configure a virtual number
1. Go to Extensions > Virtual Number > Virtual Number and click New.
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2. Configure the following:

Figure 46: Configuring virtual numbers

Virtual Number

Mame:
Number:
Display name:

Enabled:
Comment:

Call Handling

Ef New... | B

[7] Show suggested numbers

Create Cancel

GUI field
Name
Number

Show suggested
numbers

Display name

Enabled
Comment

Call Handling

Description
Enter a name for the virtual number.
Enter the virtual number which is not assigned to any phone.

Select and click in the Number field to display the virtual numbers
available for use. If it is deselected, clicking in the Number field
displays the virtual numbers already in use.

This option also serves as a diagnostic tool for finding and fixing
duplicate or missing numbers. Missing numbers are the extensions
that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can click the
icon and fix the numbers. For more information, see “Fixing
duplicate or missing numbers” on page 142.

Enter the name displaying on the extension. This is usually the name
of the extension user.

Select to activate this virtual number.
Enter any notes you have for the virtual number.

Use this option to configure the call handling for the virtual number.
For more information, see “Configuring virtual number call handling”
on page 175.

Configuring virtual number call handling

Use the Call Handling option to configure the call automation. For example, you can configure
the process to forward a call to another number on a specific schedule.

For information on the Call Handling option, see “Call Handling” on page 175.

To configure the call process

1. On the Virtual Number page, click New under Call Handling.

The Call Handling Setting page displays.
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Figure 47: Call handling setting
Call Handling Setting

Schedule: | —MNone— ¥ || New..

Action: Dial extension -t

Extension: | 5230 (FortiVoiceTrunk5230) (sip | | | MNew... Edit...
Create Cancel

2. Select a pre-configured Schedule for the call action. You can also click New to create a
schedule or Edit to modify the selected one. For information on configuring schedules, see
“Scheduling the FortiVoice unit” on page 132.

3. Select an Action for the call handling.

Some actions require that you enter further information to complete the call process, such as
Dial extension and General mailbox.

For some call handling processes that may require further actions, you need to add one or
more call processes to complete the call handling. For example, after adding a process that
contains a Set call queue priority action, you can add another process with a Call queue
action to complete the call handling. In this case, the call will be processed again with new
priority after it is transferred to the queue.

4. Click Create.
5. Click OK.
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Configuring Trunks

Setting up trunks enables the FortiVoice unit to connect to the outside world. You can configure
trunks that go to your VolIP service provider for long-distance calls, trunks for your PSTN
circuits, and trunks that connect your various offices together.

Trunks are applied to user extensions and dial plans. For more information, see “Configuring
Extensions” on page 135 and “Configuring Call Routing” on page 195.

This topic includes:

e Setting up VolIP trunks
¢ Modifying PSTN/PRI trunks
e Configuring office peers

Setting up VolIP trunks

You can add one or more VolIP service providers to the FortiVoice unit trunk configuration. The
VolIP service providers deliver your telephone services to customers equipped with SIP-based
PBX (IP-PBX).

To view the list of VoIP service providers, go to Trunks > VolP > SIP.

Figure 48: SIP trunks

Ef Mew... | B Edit... | T pelete | # Test # FortiCall
Fage 1 /1 Records per page: 25
|—
to_140_81 172.20.140.110 5060 sip trunk default In service
oxter - - sip setting default Unmonitored
GUI field Description
Test Select to test if the trunk is created successfully.

For more information, see “Testing SIP trunks” on page 182.

FortiCall Select to create a SIP trunk with Fortinet’s FortiCall service.

You can only create one trunk with FortiCall and use it free for 30 days
or 300 minutes, whichever comes first. Note that the trial account only
allows outbound calling and no international calling is available.

If you sign up for the service during a trial, the trial is closed and billing
will start.

For more information, see “Creating a SIP trunk with FortiCall service”

on page 183.
Enabled Select to activate this trunk.
Name The name of the VolIP service provider.
Server The VolP provider’s domain name or IP address. For example,

172.20.120.11 or voip.-example.com.
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Port The port for SIP sessions.

SIP Setting The SIP profile applied to this trunk.

Status The status of the SIP trunk.

To

Fortinet Technologies Inc.

* Not registered: The trunk is not registered with the VolIP service
provider and is not in service.

* |n service: The trunk is registered with the VolP service provider and
is in service.

e Unavailable: The trunk is not reachable.

e Alarm detected: There is a problem with the phone line.
* Admin down: The trunk is disabled.

e Unmonitored: The trunk is unknown.

create a VoIP trunk

. Go to Trunks > VoIP > SIP.

Click New.
Configure the following:

Figure 49: New VolIP trunk
sIp

Name:
Enabled: &
Display name

Main number:

«|SIP Setting

SIF server:

SIP port: 5060
Using SRV record: ]
User name:

Password:

Auth. user name:
Realm/domain:

SIP setting —None— > | | New..

Max channel: 1 [T overflow check

Max outgoing channel: |0
User=Phone in SIP URI: [
Caller ID modification: [T

P Registration
P Outbound Proxy

* | Fax

Phone Number
B new... | B gdr.. |

Phone Number

GUI field Description

SIP
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Name
Enabled

Display name

Main number

SIP Setting

SIP server

SIP port

Using SRV record

User name

Password

Auth. user name

Realm/domain

SIP setting

Fortinet Technologies Inc.

Enter the name of the VoIP service provider.
Select to activate the SIP trunk.

Enter your caller ID that will appear on the called phone, such
as Example Company.

Enter the phone number that will appear on the called phone.

If you entered the external caller ID in “External caller ID” on
page 138 or “External caller ID” on page 158, this trunk phone
number will be overridden by the external caller ID.

Enter the VolIP provider’s IP address or domain name. For
example, 172.20.120.11 or voip.example.com.

Most SIP configurations use TCP or UDP port 5060 for SIP
sessions. If your VolIP service provider uses a different port for
SIP sessions, enter the port number.

If you select the Using DNS record option, this field is greyed
out.

If you entered the VoIP provider’s domain name in the SIP
server field, select this option to translate the domain name
and obtain the SIP port.

You can only select this option if your VoIP provider uses the
same setting.

Enter the user name provided by the VolP service provider for
the FortiVoice unit to register with the SIP server.

Enter the password provided by the VolIP service provider for
the FortiVoice unit to register with the SIP server.

Some VolIP providers may provide you with an authentication
user name that is different from your user name for the
FortiVoice unit to register with the SIP server. If tat is the case,
enter the authentication user name here.

Some VolIP service providers’ SIP servers authenticate the
PBXes that register with them by requesting the name of the
host performing the authentication. If this is the case with your
VolP service provider, enter the name of the host performing
the authentication provided by your VoIP service provider.

Select the SIP profile to apply the supported phone features
and codecs for the trunk. To match the information of the VolP
service provider, you can edit the existing profile or click New
to add a new one. For more information, see “Configuring SIP
profiles” on page 118.
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Max channel

Max outgoing
channel

User=Phone in SIP
URI

Caller ID
modification

Inband ringtone

Each trunk contains multiple channels. The number of
channels you can have in a trunk is controlled by your VolP
service provider. This number displays under line appearance
option when you configure programmable phone keys for
phone profiles. See “Configuring phone profiles” on page 121.

Consult your VolIP service provider for the maximum of
channels that you can set to limit the number of concurrent
calls. For example, if you want to allow six calls at a time,
enter 6.

With known max channels, if you need to reserve incoming
channels, you may enter the number of outgoing channels
allowed and the remaining channels are for incoming calls.

For example, the max channel number is 10 and you want to
reserve 4 channels for incoming calls, you can enter 6 for Max
outgoing channel.

Select if your service provider requires this option to make the
FortiVoice unit to be compatible with the VolP service
provider’s configurations.

Select if you want the trunk main number to appear on the
called phone. See “Main number” on page 179.

Otherwise, the user name provided by the VolP service
provider for the FortiVoice unit to register with the SIP server
will appear on the called phone. See “User name” on

page 179.

Select to enable the FortiVoice unit to send ring tone to the
caller of an incoming call before the establishment of a call
connection.

This option is only editable if you enable early media in
“Advanced Setting” on page 110.
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Fax

Registration

Outbound Proxy

Enter the SIP registration information from the VolIP service
provider by selecting a registration method. You can receive
calls after registering with the SIP server of the VolP service
provider.

Enable registration: Select to activate the registration with
the VolIP service provider. This trunk is ready to use.

Standard: Select to use the standard registration method
which automatically registers with the SIP server of the
VolP service provider.

Registrar: Select to enter the registration information from
the VolIP service provider:

® Registrar host/IP: Enter the VolIP service provider’s SIP
registration server domain name or IP address. For
example, 172.20.120.11 or voip.example.com.

® Registrar port: Most SIP configurations use TCP or
UDP port 5060 for SIP sessions. If your VoIP service
provider uses a different port for SIP sessions, enter the
port number.

e Transport protocol: Select the transport protocol used
for the registration.

Registration URI: Enter the registration string provided by
the VoIP service provider in the Registration URI field.

The string usually has the following formats:

register => user[:secret[:authuser]]@host
[:port][/extension]

or
register => fromuser@fromdomain:secret@host
or

register => fromuser@fromdomain:secret:
authuser@host:port/extension

For example, a string could be: register =>
2345:password@mysipprovider.com/1234

Some VolIP service providers use proxy servers to direct its
traffic. If this is the case, your registration request will go to
the proxy server first before reaching the registration server.
Configure the following:

Enable proxy: Select to activate the proxy server settings.

Proxy host/IP: Enter the proxy server’s domain name or IP
address. For example, 172.20.120.11 or
voip.example.com.

Proxy port: Enter the port number of the proxy server.

Transport protocol: Select the transport protocol used for
the registration.

Configure fax signal automatic detection and fax handling.
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Automatic fax Select for the FortiVoice unit to detect incoming fax signal on
detection this trunk automatically.

Selecting this option may delay the call response time on this
trunk.

Forward fax to eFax Some incoming faxes’ numbers do not match those of your

account eFax accounts. Selecting this option and a fax receiving
account will send the faxes to the fax account. See “eFax
account” on page 187.

This option is only selectable if Automatic fax detection is
selected.

Phone Number Click New to add the phone number provided by your VolP
service provider. The VolP service provider SIP server will
direct calls from external callers directly to this number. You
can add multiple numbers.

4. Click Create.

Testing SIP trunks

After you create a SIP trunk, you can select the trunk and click Test to see if the trunk works.

For more information, see “Test” on page 177.

To test a SIP trunk

1. Go to Trunks > VoIP > SIP.

2. Select the trunk that you want to test and click Test.
The System Configuration Test page appears.

3. Configure the following:

Figure 50: Testing SIP trunk

System Configuration Test

Test Call - Dry Run  |IRr=Eges|

Destination number:

From number:
Test result:

Test Reset

GUI field Description
Test Dry Run Run a system SIP trunk test without making a real phone call.

Destination number Enter a destination number to call.
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From number

Test
Reset
Test Call

Destination number

After call is
established
Test

Reset

See also

Enter the number from which you want to call the destination
number. The FortiVoice unit will connect this number with the
destination number for the test.

Click to start the dry run test and check the Test result.
Click to remove the test result in order to start a new test.
Test the SIP trunk by making a real phone call.

Enter a destination number to call.

Select the FortiVoice action once it calls the destination
number:

* Play welcome message: The FortiVoice unit will play a
message to the destination number.

e Connect test call to number: In the Number field, enter the
number from which you want to call the destination
number. The FortiVoice unit will connect this number with
the destination number to test the trunk.

Click to start the test and check the Test result.

Click to remove the test result in order to start a new test.

¢ Creating a SIP trunk with FortiCall service

Creating a SIP trunk with FortiCall service

You can create one trunk with FortiCall and use it free for 30 days or 300 minutes, whichever
comes first. Note that the trial account only allows outbound calling and no international calling

is available.

If you sign up for the service during a trial use, the trial is closed and billing will start.

To create a SIP trunk with FortiCall service

1. Go to Trunks > VoIP > SIP.
2. Click FortiCall.

The Create SIP Trunk dialog box displays.

Figure 51: Creating a SIP trunk with FortiCall service

Create SIP Trunk

Would you like to create SIP trunk utilzing our FortiCall service?

@ FortiCall

MAC Address:
System ID:

000C25F6A08B
FO-5YMO000000091

Enjoy our reliable enterprise service tailor-made for your FortiVoice systems

Followr this link for maore information: More...

Intemet access & required to create FortiCall account. Please make sure the default gateway and DNS are correctly configured.

V| Create dialplans for this trunk

_Yes | [ Mo |

3. Note down the MAC Address and System ID for use if you decide to sign up for the service
later. See “To sign up for the FortiCall service” on page 184.
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To
1.

2
3.
4

To
1.

2
3.
4

Keep Create dialplans for this trunk selected unless you want to create the dialplans by
yourself.

The auto-generated dialplans will replace the default inbound, outbound, and emergency
call dialplans. You can delete them if you do not choose to use the FortiCall service.

Click Yes.

Enter your name and email address and click Create.
Click OK.

The FortiCall trunk is created.

sign up for the FortiCall service
Go to Trunks > VoIP > SIP.

. Double-click the trunk named FortiCall.

Under Account, click Sign Up.

. On the FortiCall sign up page, fill out the sign-up form and click Submit.

For the System ID and MAC Address fields, use the noted-down information when you
created the FortiCall trunk. See “To create a SIP trunk with FortiCall service” on page 183.

You will receive an email containing your SIP user name and password for logging into and
manage your FortiCall account.

log into the FortiCall account
Go to Trunks > VoIP > SIP.

. Double-click the trunk named FortiCall.

Under Account, click Login.

. Enter the login information you received after signing up for the service. See “To sign up for

the FortiCall service” on page 184.
Click Login.

Modifying PSTN/PRI trunks

PSTN (Public Switched Telephone Network)/PRI (Primary Rate Interface) trunks connect your
PBX or VolP network to your PSTN service providers and through them to the outside world.
These trunks can be analog or digital phone lines.

This option is only available on the FVE 200D-T, FVE 300E-T, FVE 500E-T2, FVE 1000E-T, and
FVE 2000E-T2 models.

You can modify the default trunks or create new ones.

To

Fortinet Technologies Inc.

view the PSTN trunks, go to Trunks > PRI > PRI.
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Figure 52: PRI trunks (200D-T)

& =
C Page 1 /1 Records per page: | 25 v
Enabled Name Status Type
prit In service Digital
GUI field Description
Enabled Select to activate the trunk.
Name The name of the trunk.
Status The trunk statuses, including:
* |n service: The trunk is currently in use.
e Not activated: The trunk is not enabled.
e [dle: The trunk is not in use.
e Unavailable: The trunk is not reachable.
e Conflict: The trunk conflicts with another one.
e Alarm detected: There is a problem with the trunk.
e  Admin down: The trunk is disabled.
Type The trunk type: digital or analog.

To add a T1/E1 voice circuit trunk

1.
2.
3.

Fortinet Technologies Inc.

Go to Trunks > PRI > PRI.
Click New.
Configure the following:

Figure 53: Adding a T1/E1 trunk
Trunk Setting

Name:
Enabled:
Display name:

Number:

Hardware Property
Span == spani span?

~|Share D-Channel(NFAS)

Max channel: 46

Max outgoing channel- | 0

| Fax

Phone Number

= New... e w

Phone Number

M Cancel
GUI field Description
PRI Setting
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Name The name of this trunk. This is view only.

Display name Enter your caller ID that will appear on the called phone, such as
Example Company.

Number Enter the phone number that will appear on the called phone.

If you entered the external caller ID in “External caller ID” on
page 138 or “External caller ID” on page 158, this trunk phone
number will be overridden by the external caller ID.

Enabled Select to activate the trunk.

Hardware Property Use this option to configure the T1/E1 span.

Spans represent trunks (spans) of T1/E1 PSTN lines. The
FortiVoice unit supports T1/E1 lines according to the installed
voice card. You can add a span name using the CLI.

Click a span name to configure the settings of the T1/E1 span to
match the same settings of your PSTN service provider. Click OK
after finishing the configuration. For more information, see
“Configuring the T1/E1 span” on page 188.

Share For FVE 2000E-T2 that supports two T1/E1 voice circuit trunks -
D-Channel pri1 and pri2, you can efficiently use your B channels on both
(NFAS) spans by sharing the D channel to save one D channel which can

be used as a B channel.
To do so:

¢ In the D-Channel span field, select the span of which you want
to share the D channel.

e Enter the channel number of Backup D-channel if required. 0
means no backup D channel.

This is useful when you have more than 3 spans.
Once you set the backup D channel, click span2 and enter the
backup D channel number in the D-channel field under
Advanced Options. Make sure that this backup D channel
number is not included in the channel range in the B-channel
field.
Max channel Indicates the total number of B channels on both spans.
This option is only available for FVE 2000E-T2.
Max outgoing Enter the number of outgoing channels out of the maximum
channel number of B channels.
This option is only available for FVE 2000E-T2.

Fax Configure fax and phone signal automatic detection and fax
handling.

Automatic fax Select for the FortiVoice unit to detect incoming fax signal on this
detection trunk automatically.
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4,

Forward faxto Some extensions have DID mappings. See “Mapping DIDs” on

DID mapping
extension

eFax account

Phone Number

Click Create.

page 199. When an incoming fax reaches an extension with DID
mapping, selecting this option will send the fax to the DID
mapping extension.

This option is only selectable if Automatic fax detection is
selected.

Select the fax receiving account for the detected faxes. This does
not include the faxes sent to DID mapping extensions if you
selected Forward fax to DID mapping extension.

Click New to add the phone number provided by your PSTN
service provider. This is your DID number. Your PSTN service
provider will direct calls from external callers directly to this
number. You can add multiple numbers, including numbers from
full or fractional PRI (T1/E1).

To add a analog CO trunk for 200D-T

1.
2.
3.

Fortinet Technologies Inc.

Go to Trunks > Analog > Analog.

Click New.
Configure the following:

Figure 54: Adding an analog CO trunk

Analog Setting

Name:
Display name: | Fortinet Technologies

Nurber: 6136881230
Enabled:

Hardware Property

analogl | Edit..

port: Avaiable ports: (0/4)

Selacted ports: (4/4)

fxol
fxo2
fxo3
fxo4

di

=
=]
=
Iew

“|Fax

Automatica fax detection

eFax account:

Phone Humber

B New... | B4 i |

Phone Number

oK Cancel

GUI field

Analog Setting

Description
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Name

Display name

Number

Enabled
Hardware Property

analog1i

Port

Fax

Automatic fax
detection

eFax account

Phone Number

4. Click Create.

Configuring the T1/E1 span

The name of this trunk. This is view only.

Enter your caller ID that will appear on the called phone,
such as Example Company.

Enter the phone number that will appear on the called
phone.

If you entered the external caller ID in “External caller ID” on
page 138 or “External caller ID” on page 158, this trunk
phone number will be overridden by the external caller ID.

Select to activate the trunk.

Use this option to configure the analog trunk.

Click Edit to configure the PSTN analog settings to match

the same settings of your PSTN service provider. Click OK
after finishing the configuration. For more information, see
“Configuring the analog voice trunk” on page 192.

Select the FXO ports you want for this trunk and click -> to
move them into the Selected ports field. Each FXO port
provides an analog phone line for a FXO device, such as a
phone or fax.

Configure fax and phone signal automatic detection and fax
handling.

Select for the FortiVoice unit to detect incoming fax signal
on this trunk automatically.

Select the fax receiving account for the detected faxes.

Click New to add the phone number provided by your PSTN
service provider. Your PSTN service provider will direct calls
from external callers directly to this number. You can add
multiple numbers.

You can configure the settings of the T1/E1 span, including full or fractional PRI (T1/E1), to
match the same settings of your PSTN service provider.

( | For 2000E-T2, if a PRI trunk includes two spans, the configuration of the second span is much

y simpler as the spans share many configurations.

For more information, see “Hardware Property” on page 186.
To configure the T1/E1 span
1. On the PRI page, click a span name under Hardware Property.
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2. Configure the following:

Figure 55: Editing T1/E1 card

Standard Options

Mame:
Type: PRI T1 i
Signaling: | PRI R2 signaling —

« | Advanced Options

Framing and coding option: ESF/BBZS —
Clocking options: Clock sourcing from PSTN network 4
Receive sensitivity: 36dB bt
D-channel signalling forrmat: hd
Line build out: 0dB(Csu) ==
D-channel: 24

B-channel: 1-23

- | PRI R2 Settings

Country: ITu s
Max AMI digits: 20

Max DNIS digits: 7

Caller category: Mationalsubscriber .
Incoming digits mode: | DMIS .
DTMF dialing:

DTMF answering:
Allow collect calls:

0K Cancel

GUI field Description
Standard Options
Name The name of this span. This is view-only.

Type Select the span type: PRI T1 or PRI E1.

A T1 span usually supports 23+1 channels, while an E1 span
supports 30 channels in CAS (Channel Associate Signaling)
mode and 30 B channels and one D channel in ISDN mode.

Signalling Select the signaling type of the ISDN PRI:
* PRI signalling, CPE (Customer Premises Equipment) side
* PRI signalling, Network Side
* PRI R2 signalling

Hardware Select to enable the FortiVoice echo cancellation function to
echo improve the quality of voice communications.
cancellation
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Hardware
DTMF
detection

Advanced Options

Framing and
coding option

Clocking
options

Receive
sensitivity

D-channel
signalling
format

Line build out

D-channel

Select to enable the FortiVoice unit to detect dual-tone
multi-frequency signals, such as touch-tone signals, from the
incoming calls.

This option does not need to match that of your PSTN service
provider.

Specify the type of framing and coding to provision the PRI with
your PSTN service provider.

Select the FortiVoice unit’s clock synchronization:

¢ Clock sourcing from PSTN network
¢ |Internal clocking source

This option does not need to match that of your PSTN service
provider.

Select the level of receiver sensitivity which is the ability of the
phone receiver to pick up the required level of phone signals to
make it operate more effectively within its application.

This option does not need to match that of your PSTN service
provider.

Select a signalling method for the D channel which is a signalling
channel and carries the information needed to connect or
disconnect calls and to negotiate special calling parameters (for
example, automatic number ID, call waiting, data protocol). The D
channel can also carry packet-switched data using the X.25
protocol.

Select the line build out (LBO).

LBO settings are an inherent part of T1 and T3 network element
transmission circuitry.

Since cable lengths between network elements and digital signal
cross-connect (DSX) vary in the central office, LBO settings are
used to adjust the output power of the transmission signal to
achieve equal level point (ELP) at the DSX.

By default, depending on your selection of “Type” on page 189,
the typical channel numbers are:

e FullT1:24
e FullE1:16

You can also set the channel numbers to others such as 1.

The settings you configure must match the same settings of your
PSTN service provider.
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3. Click OK.
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B-channel

PRI R2 Settings

Country

Max ANI digits

Max DNIS
digits

Caller
category

Incoming
digits mode

DTMF dialing

DTMF
answering

Allow collect
calls

By default, depending on your selection of “Type” on page 189,
the typical channel settings are:

e FullT1:1-23
e Full E1: 1-15, 17-31

You can also configure the fractional channel numbers. For
example, for T1/E1, the channels can be:

e 1-12

e 2,3,4,9-15

e 2-4,9-15

The settings you configure must match the same settings of your
PSTN service provider.

Since there is no single signaling standard for R2, the FortiVoice
unit addresses this challenge by supporting many localized
implementations of R2 signaling.

This option is active only if you select PRI R2 signalling for
“Signalling” on page 189.
Select the country for PRI R2 settings.

ANI (Automatic Number Identification) is a system used by
telephone companies to identify the DN (Directory Number) of a
calling subscriber. It allows subscribers to capture or display
caller’s telephone number.

Enter the number of digits of a caller's phone number to be
captured.

Dialed Number Identification Service (DNIS) is a service provided
by telephone companies that lets the subscribers determine
which telephone number was dialed by a caller.

Enter the number of digits of a dialed call to be sent by the
telephone company.

Select the caller type.

Select the incoming digits mode by consulting your telephone
company.

Select to enable dual-tone multi-frequency signaling (DTMF)
dialing.

Select to enable dual-tone multi-frequency signaling (DTMF)
answering.

Select to allow collect calls.
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Configuring the analog voice trunk
You can configure the settings of the analog CO trunk to match the same settings of your PSTN
service provider except the TX/RX gain settings.

For more information, see “Hardware Property” on page 186.

To configure the analog CO trunk

1. On the Analog page, click Edit under Hardware Property.
2. Configure the following:

Figure 56: Editing analog CO trunk
PSTN Analog Setting

MName

Codec: ULAW .4
Caller ID signaling: BELL -t
oK Cancel
GUI field Description

PSTN Analog Setting

Name The name of this configuration. This is view-only.
Codec Select the Codec for the trunk.
Caller ID Select the caller ID signalling standard per your phone company’s
signalling request.
3. Click OK.

Configuring office peers

If you have remote offices equipped with VolP network, you can set up office peer trunks so that
offices can call each other as if they are local extensions.

For the office peers to call each other, make sure that your FortiVoice unit and the peer office
PBX are mutually registered with each other’s IP address and SIP port number.

To view the list of office peer trunks, go to Trunks > Office Peers > Office Peers.
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Figure 57: Office peer trunks

Ef New.., | i | ol "
G Page 1 /1 Records per page: 25 »
Enabled Display name . SIP Setting Statuz
[ Dttasterisk sIP 172.20.190.254 5060 Admin down
|_F_| Off140_60 sP 172.20.140.64 5060 zip sefting default Unmenitored
|ﬂ Ott2Van Vancouver &2 172.16.100.95 4569 sip trunk default Unmenitored
GUI field Description
Fetch Office Select a trunk and click this button to obtain the phone directory from
Directory this office peer.
This option only works if the PBX of the remote office is a FortiVoice unit
and Fetch directory (see “Fetch Directory” on page 194) is selected on
the remote unit.
You can view the directory by going to Status > Directory and selecting
this office in the Office field. For more information, see “Viewing phone
directories” on page 38.
Enabled Select to activate this trunk.
Name The name of the office peer.

Display name

Type

Server

Port
SIP Setting

Status

The caller ID that will appear on the called phone, such as Example
Company.

The type of the trunk.

The domain name or IP address of the remote office’s PBX. For
example, 172.20.120.11 or peer.example.com.

The port number for VolP network on the remote office’s PBX.
The SIP profile applied to this trunk.

The status of the SIP trunk.

e Not registered: The trunk is not registered with the VolP service
provider and is not in service.

¢ In service: The trunk is registered with the VolIP service provider and
is in service.

® Unavailable: The trunk is not reachable.

e Alarm detected: There is a problem with the phone line.
e  Admin down: The trunk is disabled.

e Unmonitored: The trunk is unknown.

To set up an office peer

1. Go to Trunks > Office Peers> Office Peers.

2. Click New.
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3. Configure the following:

GUI field Description
Office Peer
Name Enter a name for the trunk.
Enabled Select to activate the trunk.
Display name Enter the caller ID that will appear on the called phone, such as

Example Company.

Type Select the trunk type: SIP or IAX2.

Remote server Enter the domain name or IP address of the remote office’s PBX.

Remote port Enter the port number for VolP network on the remote office’s
PBX.

SIP setting Select the SIP profile for the trunk. You can edit the existing

profile or click New to add a new one. For more information, see
“Configuring SIP profiles” on page 118.

Max channel Enter the maximum voice channels for the trunk.

Fetch Directory Select this option and click Fetch now to obtain the phone
directory from this office peer.

This option only works if the PBX of the remote office is a
FortiVoice unit and the same option is selected on the remote
unit.

You can view the directory by going to Monitor > Directory and
selecting this office in the Office field. For more information, see
“Viewing phone directories” on page 38.

Authentication Settings If you want to authenticate incoming and outgoing calls, enable
Incoming authentication and Outgoing authentication and enter
the Inbound name, Outbound name, and Shared password.
These settings must be the same on both PBXs forming the
office peer trunk.

The PBX on each end will use the settings to authenticate
incoming and outgoing calls.

4. Click Create.

After setting up the peer office, create outgoing and incoming dial plans for the local and
peer offices. For more information, see “Configuring Call Routing” on page 195.
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Configuring Call Routing

Dial plans define how calls flow into and out of the FortiVoice unit. Without dial plans, telephone
communications among PBXs are impossible.

This topic includes:

¢ Configuring inbound dial plans
e Configuring outbound dial plans
e Configuring direct inward dialing

Configuring inbound dial plans

The Call Routing > Inbound > Inbound submenu lets you configure dial plans for incoming calls
to the FortiVoice unit.

When the FortiVoice unit receives a call, the call is processed according to the inbound dial
plan. To process the call, the FortiVoice unit selects the dial plan rule that best matches the
dialed number and processes the call using the settings in the dial plan rule. For example, if
your main line is 123-4567, you can set a dial plan rule that sends all incoming calls dialing
123-4567 to the auto attendant. Once the auto attendant is reached, the callers can follow the
instructions, for instance, to dial an extension.

To view the inbound dial plans, go to Call Routing > Inbound > Inbound.

Figure 58: Viewing inbound dial plans

EF New.., | B (1) - | T = | d
C Page 1 11 Records per page: | 25 »
Call Handling Handling Description From Trunk Match DID Match CIDY
|E from_forticall Endpoint action Endpoint action: any_time : Auto attendant -= 'OttMain’,  FortiCall X
|E hriax Endpoint action Endpoint action: any_time : Dial extension -= 7361, prit 6136881239
|E fromAlTrunk Endpoint action Endpoint action: any_time : Auto attendant -= 'OttMain’, FortiGuardVoice;line1;pri1
& from\Vanta TS Call Routing = Ott2Van B
& fromTS2others Call Routing = Ott2TakSwitch BEXX
GUI field Description
Enabled Select to activate this dial plan.
Name The name of the dial plan.
Call handling The actions to process the incoming calls with matched dialed numbers

and/or caller IDs. For details, see “Call Handling” on page 196.

Handling The specific call handling actions. For details, see “Action” on

Description page 197.

From Trunk The trunks of the incoming calls that are subject to this dial plan.

Match DID The phone number pattern in your dial plan that matches many different
numbers. For details, see “Dialed Number Match” on page 196.

Match CID The caller ID pattern for this dial plan. For details, see “Caller ID Match”
on page 196.
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To set up an inbound dial plan

1. Go to Call Routing > Inbound > Inbound.
2. Click New.
3. Configure the following:

Fortinet Technologies Inc.

GUI field
Name
Enabled

From Trunk

Dialed Number Match

Caller ID Match

Caller ID modification

Call Handling

Action type

Description
Enter a name for this plan.
Select to activate this dial plan.

Select the trunks of the incoming calls that are subject to this dial
plan.

Select the trunks in the Available field and click -> to move them
into the Selected field.

With dialed number pattern matching, you can create one phone
number pattern in your dial plan that matches many different
numbers.

The called numbers matching this pattern will follow this dial plan
rule.

Create the number match following “Pattern-matching syntax” on
page 204 and “Pattern-matching examples” on page 204.

Click New to set the caller ID pattern following “Pattern-matching
syntax” on page 204 and “Pattern-matching examples” on
page 204 for this dial plan, and click Create.

You can enter an incoming call’s display name string or the caller’s
phone number string as the pattern.

Caller IDs under this pattern are subject to this plan.

Select one or more caller ID modification configurations. You can
associate multiple caller ID modification configurations with a dial
plan. Click Edit to modify the selected configuration or click New
to configure a new one. For more information on caller ID
modification, see “Modifying caller IDs” on page 120.

Select the actions to process the incoming calls with matched
dialed numbers and/or caller IDs.

Select the type of action for the plan and configure the actions
accordingly. See “Action” on page 197.

e Endpoint action: Select if you want to send incoming calls to
the local destinations according to operation schedules. For
example, send calls to the voicemail after business hours.

e Dial local number: Select if you want to send incoming calls to
the local destinations at any time. For example, you can enter
222xxxx as a pattern and strip 222. The FortiVoice unit will only
dial the last four digits for all called numbers matching the
pattern.

e Call routing: Select if you want to route incoming calls (to the
FortiVoice unit) to an external phone system using an outbound
dial plan.
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Action

4. Click Create.

Fortinet Technologies Inc.

Depending on the selected Action type, click New to configure the
actions:

¢ |f you select the Endpoint action type:

a.

Select the FortiVoice operation schedule for the action.
Click Edit to modify the selected schedule or click New to
configure a new one. For more information on PBX
schedule, see “Scheduling the FortiVoice unit” on page 132.

Select an action for the incoming calls under this plan.

For some actions, you need to enter the extension (such as
Go voicemail) or select a profile (such as Play
announcement).

Click Create.

. Repeat this procedure if you need more actions for this

action type.

Do not use the same schedule for more than one action to
avoid schedule conflict.

¢ If you select the Dial local number type:

a.

e.

Click New to add the number pattern in the Value field
following “Pattern-matching syntax” on page 204 and
“Pattern-matching examples” on page 204 for this dial plan.
Repeat to add more patterns.

For Strip, enter a number to omit dialing the starting part of
a pattern. 0 means no action.

For example, if your Match Pattern is 222XXXX and Strip is
3, the FortiVoice unit will only dial the last four digits for all
called numbers matching the pattern.

For Prefix, add a number before a pattern.

For example, if your Match Pattern is 9XXX and the numbers
under this pattern have been upgraded to have an
additional digit 5 at the beginning, you can enter 5 for the
Prefix. When an incoming call matches the pattern, the
FortiVoice unit will add a 5 before the number.

. For Postfix, add a number after a pattern.

For example, if your Match Pattern is 9XXX and the numbers
under this pattern have been upgraded to have an
additional digit 5 at the end, you can enter 5 for the Postfix.
When an incoming call matches the pattern, the FortiVoice
unit will add a 5 after the number.

Click Create.

¢ If you select the Call routing type, select the available outbound
dial plans and click -> to move them into the Selected member
field. This means that the FortiVoice unit will route incoming
calls to an external phone system using the selected outbound
dial plans.

Page 197 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Configuring direct inward dialing

The Call Routing > Inbound > DID Mapping submenu lets you configure how to map Direct
Inward Dialing (DID) numbers.

Local phone companies offer DID service to provide a block of telephone numbers for calling
into a company’s PBX system over limited rented physical lines (also called “trunk lines”). The
phone numbers you rent may not be enough to provide a DID number for each workstation,
because each DID can only be mapped to one extension. With the FortiVoice unit, you have 2
options to address this issue:

e only map the DID numbers to the extensions you want.
¢ map a DID number to one or more extensions based on the callers’ phone numbers.
For more information, see “Mapping DIDs” on page 199.

To view the DIDs, go to Call Routing > Inbound > DID Mapping.

Figure 59: Viewing DID mappings

ET New... | E - | e

C, Page 1 T1 Records per page: 50 o

Enabled | Mame Mumber Mapping Incoming Trunk Caller 1D Modification Fallback Fallback Target
& test250 22222:6003; 11111: 211...  fongoB133668423 cidAsteriskLocal Auto attendant OttMain
GUI field Description

Enabled Select to activate this DID.

Name The name of the DID.

Number Mapping The DID number and the extension it is mapped to. For details, see
“Mapping DIDs” on page 199.

Incoming Trunk The trunk used for dialing the DIDs.

Caller ID The caller ID modification configuration. For more information, see
modification “Inbound caller ID modification” on page 199.

Fall back The action to take if a caller not in the caller list dialed the DID number

mapped to the extensions.

Fallback Target The extension to dial for the Action you choose. For details, see
“Inbound fallback action” on page 199.

To configure a DID

1. Go to Call Routing > Inbound > DID Mapping.
2. Click New.

3. Configure the following:

GUI field Description
DID Rule
Rule name Enter a name for this DID setting.
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Enabled
Trunk

Schedule
Inbound caller ID

modification

Inbound fallback
action

Number Mapping

Mapping DIDs

Select to activate this DID setting.
Select the trunk used for dialing the DIDs.

Select a schedule to apply the rule. For information on
creating schedules, see “Scheduling the FortiVoice unit” on
page 132.

Select the caller ID modification configuration. For more
information on caller ID modification, see “Modifying caller
IDs” on page 120.

Select the action to take if a caller not in the caller list dialed
the DID number mapped to an extension.

For some actions, you need to enter the extension, such as
Dial voicemail.

For information on filtering callers, see “Mapping DIDs” on
page 199.

For adding a number mapping, see “Mapping DIDs” on
page 199.

Click Export to open or save the number mapping file and
Import to browse for a number mapping file.

You can map a DID number to one extension. You can also map a DID to multiple extensions
based on the callers’ phone numbers. For example, calling numbers 123-4567, 123-4568, and
123-4569 can call the DID number 222-1000 to reach extension 1234. Calling numbers
234-4567, 234-4568, and 234-4569 can call the same DID number 222-1000 to reach extension
1265. In both cases, the calling numbers will display on the extension.

If a caller outside the configured caller list dialed the mapped DID number, the FortiVoice unit
will react according to the selected fall back action. For details, see “Inbound fallback action”

on page 199.

To map DIDs

1. Go to Call Routing > Inbound > DID Mapping.

. Click New.

2
3. In Number Mapping, click New.
4

. Configure the following:
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Figure 60: DID mapping
Map Settings
DID number:
Extension:
Option: [#] Inbound
+ | Advanced Setting

Caller number:
=g MNew... i}

[¥] Outbound

Pattern String

Create Cancel

GUI field
Map Setting

DID number

Extension

Option

Description
This option allows you to map a DID number to an extension.

Enter the DID number that you want to map to an extension. The
DID number cannot be mapped to more than one extension
unless the DID is bundled with a caller number (see “Advanced
Setting” on page 201). Otherwise, an error message about
duplicate entry appears and the DID mapping configuration
cannot be saved.

Enter the extension that you want to map to the DID number.

Select Inbound to direct incoming calls to the extension through
the mapped DID. If this option is not selected, incoming calls to
this extension through the mapped DID will follow the inbound
fallback action configured in “Inbound fallback action” on

page 199. By default, this option is selected.

Select Outbound to send the DID numbers of the extensions
mapped to the DID with outgoing calls so that the DID numbers
can display on the called phones. If this option is not selected, the
extension’s DID number is not sent with outgoing calls and the
phone number displayed on the called phone could be the
FortiVoice main number (see “Main number” on page 105) or the
trunk phone number (see “Phone Number” on page 182)
associated with the extension. Alternatively, you can choose the
caller ID to display on the called phone when configuring an
extension (see “External caller ID” on page 138).

By default, both Inbound and Outbound are selected.
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Advanced Setting This option allows you to bundle caller numbers to a DID number
which can be mapped to any extension.

Caller number Click New to add the caller’s phone number or pattern in the
Pattern String field and click Create.

Repeat to add more calling numbers or patterns.

Only the caller numbers matching the numbers or patterns you
set will reach the mapped extension when they dial the DID
number.

For information on phone number patterns, see
“Pattern-matching syntax” on page 204 and “Pattern-matching
examples” on page 204.

5. Click Create.

Configuring outbound dial plans

The Call Routing > Outbound > Outbound submenu lets you configure dial plans for outgoing
calls from the FortiVoice unit.

You can configure dial plans on the FortiVoice unit to route calls made from a FortiVoice
extension to an external phone system. The external phone system can be one or more PSTN
lines or a VolIP service provider. To route calls to an external phone system, you add dial plan
rules that define the extra digits that extension users must dial to call out of the FortiVoice unit.
The rules also control how the FortiVoice unit handles these calls including whether to block or
allow the call, the destinations the calls are routed to and whether to add digits to the beginning
of the dialed number.

For example, if users should be able to dial 911 for emergencies, you should include a dial plan
rule that sends all calls that begin with 911 to an external phone system. This rule should also
override the default outgoing prefix so that users can dial 911 without having to dial 9 first.

To view the outbound dial plans, go to Call Routing > Outbound > Outbound.

Figure 61: Viewing outbound dial plans
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Match CID Call Handling
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GUI field Description

Test Select to test if the dial plan is created successfully.

For more information, see “Testing outbound dial plans” on page 203.
Enabled Select to activate this dial plan.

Name The name of the dial plan.
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Pattern

Match CID

Call handling

The phone number pattern in the dial plan that matches other numbers.
For details, see “Dialed Number Match” on page 202.

The caller ID pattern for this dial plan. For details, see “Caller ID Match”
on page 203.

The call handling action for the numbers matching the configured
number pattern and the caller IDs matching the caller ID pattern. For
details, see “Call Handling” on page 203.

To set up an outbound dial plan
1. Go to Call Routing > Outbound > Outbound.

2. Click New.

3. Configure the following:

Figure 62: Outbound dial plan

Name:

Enabled:
Emergency aal:[7]

Dialed Number Match

Ef New... | B ]

Match Pattern

| Caller ID Match

Call Handling
Ef New... | &

Strip | Prefix

Schedule

Create Cancel

GUI field
Name
Enable

Emergency call

Dialed Number
Match
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Caller ID Manipu... | Warning Message | Account Code

Description
Enter a name for this plan.
Select to activate this dial plan.

Select to allow emergency call with this plan. By default, this is
selected.

For information on setting emergency number, see “Setting PBX
location and contact information” on page 104.

With dialed number pattern matching, you can create one phone
number pattern in your dial plan that matches many different
numbers.

The dialed numbers matching this pattern will follow this dial plan
rule.

For information on adding a dialed number match, see “Creating
dialed number match” on page 204.
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Caller ID Match Click New to set the caller ID pattern following “Pattern-matching
syntax” on page 204 and “Pattern-matching examples” on page 204
for this dial plan, and click Create.

You can enter a caller’s display name string or the caller’s phone
number string as the pattern.

Callers with IDs under this pattern are subject to this plan.

Call Handling Click New to configure the call handling action for the numbers
matching the configured number pattern and the caller IDs matching
the caller ID pattern. For details, see “Configuring call handling
actions” on page 206.

4. Click Create.

Testing outbound dial plans

After you create a dial plan, you can select the dial plan and click Test to see if the dial plan
works.

For more information, see “Test” on page 201.

To test an outbound dial plan

1. Go to Call Routing > Outbound > Outbound.

2. Select the dial plan that you want to test and click Test.
The call test page appears.

3. Configure the following:

Figure 63: Testing dial plans

System Configuration Test

Test Call - Dry Run Test Call

Destination number:

From number:
Test result:

Test Reset
GUI field Description
Test Call - Dry Run Run a system outbound dial plan test without making a real

phone call.
Destination number Enter a destination number to call.

From number Enter the number from which you want to call the destination
number. The FortiVoice unit will connect this number with the
destination number for the test.
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Test Click to start the dry run test and view the Test result.
Reset Click to remove the test result in order to start a new test.

Test Call Test the outbound dial plan by making a real phone call.
Destination number Enter a destination number to call.

After call is Select the FortiVoice action once it calls the destination
established number:

¢ Play welcome message: The FortiVoice unit will play a
message to the destination number.

e Connect test call to number: In the Number field, enter the
number from which you want to call the destination
number. The FortiVoice unit will connect this number with
the destination number to test the trunk.

Test Click to start the test and view the Test result.

Reset Click to remove the test result in order to start a new test.

Creating dialed number match

You can create one extension number pattern in your dial plan that matches many different
numbers for outbound calls.

The numbers matching this pattern will follow this dial plan rule.
The FortiVoice unit supports the following pattern-matching syntax:

Table 17:Pattern-matching syntax

Syntax |Description

X Matches any single digit from 0 to 9.
Z Matches any single digit from 1 to 9.
N Matches any single digit from 2 to 9.

[15-7] |Matches a single character from the range of digits specified. In this case, the
pattern matches a single 1, as well as any number in the range 5, 6, 7.

Wildcard match; matches one or more characters, no matter what they are.

! Wildcard match; matches zero or more characters, no matter what they are.

Table 18:Pattern-matching examples

Pattern Description

NXXXXXX Matches any seven-digit number, as long as the first digit is 2 or higher.

NXXNXXXXXX | This pattern matches with areas with 10-digit dialing.
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Table 18:Pattern-matching examples

Pattern

Description

TNXXNXXXXXX

Matches the number 1, followed by an area code between 200 and 999,
then any seven-digit number. In the North American Numbering Plan calling
area, you can use this pattern to match any long-distance number.

011.

Matches any number that starts with 011 and has at least one more digit.

To create a dialed number match
1. Go to Call Routing > Outbound > Outbound.

2. Click New.

3. In Dialed Number Match, click New.
4. Configure the following:

Figure 64: Creating a number match
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Pattern String

Modification
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GUI field

Description

Match Pattern

New
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Fortinet Technologies Inc.

Strip

Click to add the number pattern in the Value field following
“Pattern-matching syntax” on page 204 and “Pattern-matching
examples” on page 204 for this dial plan. Repeat to add more
patterns.

You can manipulate the number patterns you entered.

Enter a number to omit dialing the starting part of a pattern. 0
means no action.

For example, if your Match Pattern is 9XXX and Strip is 1, you
only need to dial the last three digits for this pattern.
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Prefix

Postfix

5. Click Create.

Add a number before a pattern, such as area code.

For example, if your Match Pattern is 123XXXX and its area
code is 555, you can enter 555 for the Prefix. When you dial a
number under this pattern, you do not need to dial the area
code 555.

Add a number after a pattern.

For example, if your Match Pattern is 9XXX and the numbers
under this pattern have been upgraded to have an additional
digit 5 at the end, you can enter 5 for the Postfix. When you dial
a number under this pattern, you do not need to dial the last
digit 5.

Configuring call handling actions

Configure the call handling action for the numbers matching the configured number pattern and
the caller IDs matching the caller ID pattern.

To configure the call handling action
1. Go to Call Routing > Outbound > Outbound.

2. Click New.
3. In Call Handling, click New.
4. Configure the following:

GUI field
Call Handling

Schedule

Action
Outgoing trunk

Caller ID
modification

Fortinet Technologies Inc.

Description

Select the FortiVoice operation schedule to implement this
plan. Click Edit to modify the selected schedule or click New to
configure a new one. For more information on PBX schedule,
see “Scheduling the FortiVoice unit” on page 132.

Select the call handling action for the numbers matching the
configured number pattern and the caller IDs matching the
caller ID pattern.

Select the trunk for the outbound calls. Click Edit to modify the
selected trunk or click New to configure a new one. For more
information on trunks, see “Configuring Trunks” on page 177.

Select the caller ID modification configuration. Click Edit to
modify the selected configuration or click New to configure a
new one. For more information on caller ID modification, see
“Modifying caller IDs” on page 120.
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Warning message  If you select Allow with warning or Deny with warning in the
Action field, select the sound file for the warning. Click Edit to
modify the selected file or click New to configure a new one.
For more information on sound files, see “Managing sound files
and music on hold” on page 116.

Delay Optionally, if you want to discourage certain users for making
outbound calls, enter the call delay time in seconds.

5. Click Create.
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Setting up a Call Center

A call center allows an organization to receive or transmit a large volume of requests by
telephone in a centralized office.

You can configure a call center and operate the center on the user web portal.
This option is only available if you have purchased a call center license.
This topic includes:

¢ (Creating call queues

¢ Configuring agents

¢ Configuring IVRs

¢ Configuring surveys

e Configuring other agent information

¢ Configuring agent profiles

¢ Working with call queue statistics

¢ Configuring call center report profiles and generating reports

Creating call queues

Call queuing, or Automatic Call Distribution (ACD), enables the FortiVoice unit to queue up
multiple incoming calls and aggregate them into a holding pattern. Each call is assigned a rank
that determines the order for it to be delivered to an available agent (typically, first in first out).
The highest-ranked caller in the queue is delivered to an available agent first, and every
remaining caller moves up a rank.

With call queuing, callers do not need to dial back repeatedly trying to reach someone, and
organizations are able to temporarily deal with situations when callers outnumber agents.

Configure a call queue and add it in an inbound dial plan as a call handling action to make it
effective. For more information, see “Configuring inbound dial plans” on page 195.

Call queues consist of:

¢ Incoming calls waiting in the queue

¢ Agents who answer the calls in the queues

e A plan for how to handle the queue and assign calls to agents
¢ Music played while waiting in the queue

¢ Announcements for agents and callers

Depending on their privileges, agents can log into a queue to answer calls or transfer calls to
another queue, which can then be answered by another available agent.

Agents can be static or dynamic. Static agents are always connected to the queues, and
dynamic agents need to log into the queue in order to process calls.

To view the call queues, go to Call Center > Call Queue.
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Figure 65:Call queues
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GUI field Description

Queue ID The name of the call queue.

Display Name The queue name displaying on the queue extension.
Number The extension number for the call queue.
Department The departments of the agents enrolled in the queue.
Agents The extensions of the agents enrolled in the queue.

To create a call queue

1. Go to Call Center > Call Queue.
2. Click New and configure the following.

GUI field
Call Queue
Queue ID

Number

Show suggested
numbers

3. Click Create.

Description

Enter an ID for the queue.

Enter an extension for callers to dial and enter into a call
queue following the extension number pattern. See
“Configuring PBX options” on page 105.

This is another way to use a call queue configuration in
addition to adding it in an inbound dial plan as a call handling
action.

Even if you enter an extension, you can still add the call queue
configuration in an inbound dial plan as a call handling action.
In this case, the dial plan ignores this extension and still uses
the extension to which it is applied for call queue action.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the
Number field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and
fixing duplicate or missing numbers. Missing numbers are the
extensions that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can
click the icon and fix the numbers. For more information, see
“Fixing duplicate or missing numbers” on page 142.

4. From the call queue list, select the queue you just create.
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5. Configure the following:
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Call Queue

Queue ID:

Number: 502
Status

Display name: | TAC
Description: | TAC
Department. | —Mone-—

Queue Setting
Maximum gueue capacity: 5
Maximum gueuing time: | 1

Ring duration: 12

Music on hold: oh_greeting02

Call Distribution

Skill Based Routing | Lowest level first
Distribution policy: | Round robin

- | Additional Settings

Agent

Agent type: @ Dynamic )Static

Auto-logout time: | 7

Figure 66:Creating a call queue
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[ Scheduled Business Hour call handling ]

(Seconds)

_'Do not queue
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oK Cancel

GUI field

Call Queue

Number

Description

Enter an extension for callers to dial and enter into a call
queue following the extension number pattern. See
“Configuring PBX options” on page 105.

This is another way to use a call queue configuration in
addition to adding it in an inbound dial plan as a call handling
action.

Even if you enter an extension, you can still add the call queue
configuration in an inbound dial plan as a call handling action.
In this case, the dial plan ignores this extension and still uses
the extension to which it is applied for call queue action.
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Show suggested
numbers

Status

Display name

Description

Department

Queue Setting

Maximum queue
capacity

Maximum queuing
time

Ring duration

Music on hold

Call Distribution

Fortinet Technologies Inc.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the
Number field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and
fixing duplicate or missing numbers. Missing numbers are the
extensions that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can
click the icon and fix the numbers. For more information, see
“Fixing duplicate or missing numbers” on page 142.

Select to enable the call queue.

Enter the queue name displaying on the queue extension,
such as Support.

Enter any notes about this queue.

Select the department to which the queue belongs. For
information on creating departments, see “Creating extension
departments” on page 166.

Enter the maximum number of callers for the call queue.
When the call queue is full, other callers will be dealt with
according to the Queue Overflow call handling action you set
in “Queue Overflow” on page 217.

The maximum is 100.

Enter the maximum call queue waiting time in minutes. When
the call waiting time is due, the callers in the queue will be
dealt with according to the call handling action you set in
“Queue Timeout” on page 217.

The maximum is 720 minutes.
Enter the time in seconds to ring each agent. If a call is not

answered when the ring duration is due, the call is transferred
to the next agent. The range is between 5 to 120 seconds.

Select a sound file or music on hold file to play when a caller
is waiting. For more information, see “Managing sound files
and music on hold” on page 116.

Page 211 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Fortinet Technologies Inc.

Skill Based Routing Select and choose a call routing option. This option is based
on agent skill level scores. For more information, see
“Creating agent skill levels” on page 225.

Distribution policy

Additional Settings

Lowest level first: The call will ring the agent with the
lowest skill level score first and move up the rank if the
agent is unable to take the call, that is, the agent’s
extension is in a Not Ready status.

Highest level first: The call will ring the agent with the
highest skill level score first and move down the rank if the
agent is unable to take the call, that is, the agent’s
extension is in a Not Ready status.

Select a call Distribution policy.

This option works like following:

If Skill Based Routing is not selected, calls are distributed
according to the policy you choose.

If Skill Based Routing is selected, calls are distributed
according to the skill based call routing option you choose.
This option only applies to the situation when you have
agents with the same skill level in a queue. In such cases,
calls are distributed to these agents according to the
policy you choose.

* Ring all: rings all available agents (default).

® Round robin: rings all agents in a queue equally in
some rational order, usually from the top to the bottom
of a list and then starting again at the top of the list and
SO on.

e Sequential: rings each agent in a sequential manner
regardless of whether they have answered calls.

* Random: rings an agent at random.

e [east recent: rings the agent that least recently
received a call.

e fewest calls: rings the agent that has completed the
fewest calls in this queue.

¢ Weight random: rings a random agent, but uses the
agent’s number of received calls as a weight.

* Priority based: rings agents based on call answering
priorities for callers entering the call queue. A new call
always starts with the lowest priority. However, a queue
manager with privileges can change the priority of a call
on the agent console of the user web portal. See
“Setting caller priorities” on page 226.
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Distinctive settings Announce queue name: Select a sound file that announces

Business schedule

Announcement

the queue name. You can add a new one or modify an existing
one. For more information, see “Managing sound files and
music on hold” on page 116.

Caller ID option: Select how you want the IDs of the calls to
this queue to display. If you select Prefix, the queue Display
name is added before the caller ID on the agent’s phone. If
you select Replace, the queue Display name replaces the
caller ID on the agent’s phone.

Ring Pattern: Select a queue extension ring pattern.

Click >> and select a operation schedule for the queue. For
example, “business_hour” schedule means agents are only
available to answer the calls for this queue during business
hours. For information on scheduling, see “Scheduling the
FortiVoice unit” on page 132.

Announce holdtime: Select if you want to announce the queue
waiting time to a caller at the set interval. You may also select
to announce only once.

Announce position: Select to announce a caller’s waiting
position in the queue, such as “You are caller No. 5 in the call
queue”.

No: Do not announce a caller’s position.
Always: Always announce a caller’s position.

Abbreviated: Announce a caller’s position only once if the
caller is over the marked position and always announce once
the caller is within the marked position.

Minimal: Announce only when the caller is within the marked
position.

Mark position: Enter the benchmark for selecting Abbreviated
or Minimal setting.

For example, if you select Abbreviated and enter 5, a caller’s
position is announced when the caller becomes No. 5 in the
queue and announced only once before the caller becomes
No. 5 in the queue.

Announcement interval: Enter the announcement frequency in
seconds.

Custom announcement: You can also customize the
announcement settings.

* Mode: Select the method of greeting announcement to the
caller once the caller enters this call queue. You can also
select to diable this function.

If you select Periodic or Random, enter the announcement
frequency in seconds in Announcement interval.

e Audio: Select a greeting sound file for the announcement.
For more information, see “Managing sound files and
music on hold” on page 116.
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Service Level

Alert Settings

Callback Setting

Interval: Enter the time period in minutes for calculating the
threshold.

Threshold: Enter the call answering rate for a certain period of
time. The action triggered by the threshold being reached is
configured in “Call Handling” on page 216.

Service level low call handling: Click to configure how other
callers will be dealt with according to the Queue Overflow call
handling action you set in “Service Level Low” on page 217
when the call queue is full

Alert Event: Select the event that triggers an action which is
configured in “Call Handling” on page 216.

Send alert email: Select if you want to send an email when an
alert event is triggered. Click New to enter an email address.

Call extension/number: Select this option and an extension
number if you want a phone call when an alert event is
triggered. Click New to add an extension.

GUI popup: Select to have a popup notification on the user
web portal GUI when an alert event is triggered. This only
applies to agents with the particular privilege called Queue
alert. See Agent Console Privilege in “Configuring agent
profiles” on page 226.

Alert interval: Enter a value in minutes during which time no
alert is sent. For example, if you enter 60, you will not receive
any alerts for an hour even if an alert event is triggered. This
will be the case each time when you receive an alert
notification.

If you enter 0, you will receive notifications each time when an
event is triggered.

This option allows callers waiting in a queue to request a
callback following the recorded instructions and wait for an
agent to return their call.

Status: Select to enable this option.

Prompt voice menu: Select the method to collect the callback
number.

e System default: Select to use system defined voice file.
e User defined IVR: Select to use user configured IVR.

For more information on IVR, see “Configuring IVRs” on
page 219.
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Survey Setting

Agent

Agent type

Auto-logout time

Logout all agents
after scheduled
business hour

Wrap up time

Wrap up outgoing
call
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Callback mode:

e Agent call back manually(from call center console): Select
to allow an agent to manually call the caller using the agent
console on the user web portal.

e System call back automatically: Select to allow the
FortiVoice unit to call the caller automatically based on the
callback number collected when an agent is available.

Surveys are used to collect customer feedback to ensure that
the service delivered by your call center agents consistently
meets corporate standards and drives high customer
satisfaction.

Status: Select to enable this option.

Survey: Choose the survey configuration for the call queue.
For more information on surveys, see “Configuring surveys”
on page 223.

Select the agent login mode.

Once enrolled into the queue, static agents are always
connected to the queues while dynamic agents need to log
into the queue in order to process calls.

For information on enrolling agents into a queue, see “Agent
members” on page 216.

If you select Dynamic login mode, enter the agent login expiry
time in hours. For example, if you enter 5, the agent will be
logged out 5 hours after having logged into the queue.

Select to log out all agents in the queue when the scheduled
business hour is due.

Enter the time (in seconds) needed by agents to complete a
queue call including taking notes or record-keeping, starting
from the moment that call is hang up.

The default is 0 second.

Select if the agent needs to make an outgoing customer call
and time to take notes or record-keeping, starting from the
moment that call is hang up.

You can enter the wrap up time in the “Wrap up time”field.
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Call waiting

Agent members

Call Handling

When no logged-in
agent

Scheduled Business
Hour call handling

Non Scheduled
Business Hour call
handling

6. Click Create.

Select this option so that if an agent is on the phone when a
queue call comes in, the caller information will display on the
agent’s phone. The agent can choose to answer the call or
not. If the agent does not answer the call, after the ring
duration is due, the call is transferred to the next agent.

This option is different from the call waiting feature of a regular
extension (See “Setting extension user preferences” on

page 156). On a regular extension, the call waiting feature only
applies to the calls that directly go to the extension. On a
queue extension, the call waiting feature only applies to the
calls that go to the extension from the queue.

¢ Click to expand Agent members for enrolling agents into
the queue.

¢ In the Available field, select the agents for this queue.
e (Click -> to move it into the Selected field.
¢ Click Done.

You can type an agent’s extension or name in the Search field
and press Enter to search for the agent.

You may select to queue a caller or not if there is no agents
available.

Click to configure the business hour call handling action for
the queue. For details, see “Configuring scheduled business
hour queue call handling actions” on page 216.

Click to configure the non business hour call handling action
for the queue. For details, see “Configuring scheduled
business hour queue call handling actions” on page 216.

Configuring scheduled business hour queue call handling actions

Configure the call handling action for the queue. This action applies to all calls once they enter

into the queue.

This option is only available when you edit a queue.

To configure the call handling action
1. Go to Call Center > Call Queue.
2. Select a call queue for which you want to configure queue call handling actions and click

Edit.

3. In Call Handling, click Scheduled Business Hour call handling.

Fortinet Technologies Inc.
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4. Configure the situation upon which the FortiVoice unit can be configured to take

corresponding actions:

GUI field

Queue Overflow

Queue Timeout

Service Level Low

All Agents Logout

Unclassified

Call Processing

Schedule

Action

5. Click Create, then OK.

Description

The situation when callers exceed the maximum waiting callers
you set. See “Maximum queue capacity” on page 211.

A popup notification appears when this barometer is triggered.

Callers waiting time exceeds the maximum waiting time set in
“Maximum queuing time” on page 211.

A popup notification appears when this barometer is triggered.

Service level represents the maximum amount of time a caller
should ideally have to wait before being presented to an agent.
You need to set service level and service level interval in the
FortiVoice CLI.

For example, if service level interval is set to 60 seconds and
the service level percentage is 80 percent, that means 80
percent of the calls that came into the queue were presented to
an agent in less than 60 seconds. Any service level percentage
lower than 80 is considered to be low.

There are no agents in the queue to answer calls. The action for
this option only works if you select Do not queue for “When no
logged-in agent” on page 216.

Any reason that you need to schedule call handlings.

Click New to configure call handling action for the situation you
selected. Click Create when you finish.

For some processes that may require further actions, you need
to add one or more call processes to complete the call
handling. For example, after adding a process that contains a
Set call queue priority action, you can add another process with
a Transfer to queue action to complete the call handling. In this
case, the call will be processed again with new priority after it is
transferred to the queue.

Select the FortiVoice operation schedule to implement this call
handling action. For more information on schedules, see
“Scheduling the FortiVoice unit” on page 132.

Select the call handling action. Depending on the action
selected, further configuration may be needed. For example, if
you select Dial extension for Action, enter the extension to
which a call is transferred.

Configuring non scheduled business hour queue call handling actions

Configure the call handling action for the queue. This action applies to all calls once they enter

into the queue.
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For some processes that may require further actions, you need to add one or more call
processes to complete the call handling. For example, after adding a process that contains a
Set call queue priority action, you can add another process with a Transfer to queue action to
complete the call handling. In this case, the call will be processed again with new priority after it
is transferred to the queue.

This option is only available when you edit a queue.

To configure the call handling action
1. Go to Call Center > Call Queue.

2. Select a call queue for which you want to configure queue call handling actions and click
Edit.

3. In Call Handling, click Non Scheduled Business Hour call handling.
4. On the Call Processing page, click New to configure call handling action.

5. For Schedule, select the FortiVoice operation schedule to implement this call handling
action. For more information on schedules, see “Scheduling the FortiVoice unit” on
page 132.

6. For Action, select the call handling action. Depending on the action selected, further
configuration may be needed. For example, if you select Dial extension for Action, enter the
extension to which a call is transferred.

7. Click Create, then OK.

Configuring agents

Extensions with call center agent function enabled can be further configured with other call
center information, such as agent profile, managed departments, and skill sets. Call center
departments can also be set up to form the basis for department management.

To configure an agent
1. Go to Call Center > Agents > Agents.

All extensions with call center agent function enabled display. Clicking Extensions opens the
IP extensions configuration page. For information, see “Configuring IP extensions” on
page 135.

Select the extension you want to configure and click Edit.

Select an agent profile. For more information, see “Configuring agent profiles” on page 226.
For Managed departments, click >>.

Select the departments to be managed by this agent if required, and click Done.

o g s DN

Click Member of Queues to select the call queues to join.

e Main/Outgoing queue: This option is for collecting the outgoing calls from all queues by
this agent and displaying them in “Working with call queue statistics” on page 227. You
can select any queue of which this agent is a member for that purpose except None
which will not collect agent’s outgoing call information.

* Queues: Select the queues of which you want the extension/agent to be a member, and
click Apply.
7. Add skill sets for the agent by clicking New under Skill Sets.

8. Select the skill set for the agent, including skills and level, and click Create. For more
information about agent skills and levels, see “Adding agent skill sets” on page 225 and
“Creating agent skill levels” on page 225.

9. Click OK.
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To set up a department

1. Go to Call Center > Agents > Department.

2. Click New and configure the following:

GUI field
Department
Name

Comment

Call Center

Manager

Member

Queue

3. Click Create.

Configuring IVRs

Description

Enter a name for the department.

Click Click to edit and enter any notes you have for this
department.

From the Available extension list, select the ones to be department
managers and click Done.

Managers can view call queue reports.

From the Available extension list, select the ones to be members of
the department and click Done.

Each member can only belong to one department.

From the Available extension list, select the ones to be call queues
of the department and click Done.

Each queue can only belong to one department.

FortiVoice Interactive Voice Response (IVR) function allows it to interact with callers through the
use of voice and DTMF tones input via keypad. Callers proceed according to the IVR audio
instructions to reach the callees or get the information they need.

Based on the information collected from callers and by interacting with the backend database,
FortiVoice IVR can prioritize the calls using call queues and present callers’ information to the

agents.

FortiVoice IVR interfaces with RESTful Web service for querying caller information from the

database.
This topic includes:

e Setting up an IVR

¢ Configuring restful service

Setting up an IVR

Call Center > IVR > IVR allows you to view the existing IVR list and create new IVRs.

Fortinet Technologies Inc.
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Creating new IVRs includes configuring:

the digits collector to collect digit inputs from callers (see To configure a digit collector)

the RESTful collector to gather caller information from database (see To configure a restful

collector)

call handling to route the calls based on information gathered by digit and RESTful

collectors, and

error handling to deal with unknown errors and RESTful service errors.

To view the IVR list
1. Go to Call Center > IVR > IVR.
2. Click the Expand all icon.

The IVR tree list displays. Under each IVR name, configuration items are listed. Clicking an
item opens its configuration page.

To configure a digit collector
Go to Call Center > IVR > IVR and click the Switch icon.

1.

2
3.
4

o
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Click Create.

. Click New and type the name of the IVR and description.

. From the IVR name list, select the name you created and click Edit to open the IVR
configuration page.

For Description, select Click to edit to enter any notes you have for the IVR.

For Digit collectors, click New to configure collecting digit inputs from callers. You can create
a maximum of 10 digits collectors.

GUI field
Name

Prompt

Enable read back

Expose to

Description
Digits Settings

Min digits

Max digits

Max invalid input
allowed

Description
Enter a name for the digits collector.

Select the audio file that you want callers to listen to. You can also
create a new file or edit the selected one. For more information,
see “Managing sound files and music on hold” on page 116.

Select if you want the digit inputs to be read out to the caller.

Select Agent console if you want agents in the queues where the
IVR calls are routed to see the information that the digits collector
gathers. Enter a name for the information to display on the agent
console.

Enter any notes you have for the digits collector.

Enter the minimum digits the digits collector allows. The range is
1-30.

Enter the maximum digits the digits collector allows. The range is
1-30.

Enter the number of times a caller is allowed for inputting wrong
digits. The call will be terminated if the limit is reached. The range
is 0-10.
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7.

Timeout

Max timeout allowed

Click Create.

Enter the time limit that a caller is allowed for taking NO action
after the call is put through. The call will be terminated if the time
limit is reached. The range is 0-600 seconds.

Enter the number of timeouts a caller is allowed for taking no
action after the call is put through. The call will be terminated if the
number of timeouts limit is reached. The range is 0-10.

For example, if Timeout is set to 10 seconds and Max timeout
allowed to 3, a caller would have a total of 30 seconds timeout
time after he or she dials in and takes no action afterwards.

You can create a maximum of 10 digit collectors which are saved as variables.

To configure a restful collector

1. After configuring the digit collector, click Add restful collector to configure the database
collector for resource querying.

Fortinet Technologies Inc.

GUI field
Name

Service

Method

Parameters

Timeout

Max retry allowed

Description

New (under Fields)

Field

Query

Expose to

Description
Enter a name for the restful collector.

Select the restful service for the collector. You can also create a
new service or edit the selected one. For more information, see
“Configuring restful service” on page 223.

Choose the method to submit the information collected by the
FortiVoice IVR system to the database server (as HTTP POST or
HTTP GET) and use the value as a variable in your SQL statement.

Select Click to edit to enter query parameters to customize the
results returned from a GET or POST operation on the database,
such as sorting or filtering.

Optionally, click Add variable to insert self or system defined
variables into the parameters.

Enter the time allowed for the query to be processed. If the time
elapses before the query response is complete, partial information
may be returned. The range is 0-600 seconds.

Enter the number of database query tries allowed. The query will
be denied if the retry limit is reached. The range is 0-10.

Enter any notes you have for the restful collector.

Click to name each of the attributes returned from a database
query to present it or use it as a variable.

Enter a name for the attribute you want to define.

Enter the query parameter for the attribute you want to define.
Optionally, click Add variable to insert self or system defined
variables into the parameter.

Select Agent console if you want agents in the queues where the
IVR calls are routed to see the information of this field.
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Display name

Enter a name for the information to display on the agent console.

2. Click Create and then OK.
You can create a maximum of 10 restful collectors which are saved as variables.

To configure IVR handling

1. After configuring the digit and restful collectors, click Add IVR handling to configure call
processing using the digit and restful collector configurations.

Digit and restful collector configurations only take effect after IVR handling is set up.

GUI field

Condition

Unconditional

Variable

Operator

Value

Action

Action type

Description

Configure the conditions based on which call processing actions
are taken.

Select if you do not need to configure the conditions. In this case,
the system default condition applies.

Click Add to insert self or system defined digit or restful variable
for the condition.

This option appears if you deselect Unconditional.

Use query operators to assign a value to the variable, or perform
mathematical operations.

This option appears if you deselect Unconditional.

Enter the value assigned by the operator to the variable.
Optionally, click Add variable to insert self or system defined
variables into the value.

This option appears if you deselect Unconditional.

Click New to configure the actions to take based on the
conditions.

Select the IVR action. Depending on the action type selected,
further configuration may be needed. For example, if you select
Dial extension, enter the extension to which a call is transferred.

Click Create, Create.

You can create multiple actions.

To configure error handling

1.
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After configuring the digit and restful collectors and IVR handling, click Add error handling to
deal with unknown errors and restful service errors.

For Error Type, select Unspecified for unknown errors and Restful for restful service errors.

For Action, click New.

Select the action. Depending on the action type selected, further configuration may be
needed. For example, if you select Dial extension, enter the extension to which a call is

transferred.
Click Create, Create.

Click OK to complete the IVR configuration.
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See also

¢ Configuring restful service

Configuring restful service

FortiVoice IVR interfaces with restful web service for querying caller information from the
database.

Call Center > IVR > Restful service allows you to configure the restful web service.

To configure restful service
1. Go to Call Center > IVR > Restful service, click New and do the following:

GUI field Description

Name Enter a name for the configuration.

Protocol Select the protocol for the service.

Base URL Enter the URL of the server hosting restful service.

Click Test to validate the URL.

Authentication Select to enter the user name and password for logging onto the
restful server.

SSL verification Select if required.

Description Click Click to edit to enter any notes for the configuration.

Configuring surveys

You can use surveys to collect customer feedback to ensure that the service delivered by your
call center agents consistently meets corporate standards and drives high customer
satisfaction. You can also set survey rules.

To configure a survey

1. Go to Call Center > Survey > Survey.

2. Click New and type the name of the survey.

3. Click Create.
4

. From the survey name list, select the name you created and click Edit to open the survey
configuration page.

5. Click Add digit collector to configure collecting digit inputs from callers. You can create a
maximum of 10 digits collectors.

GUI field Description
Name Enter a name for the digits collector.
Prompt Select the audio file that you want callers to listen to. You can also

create a new file or edit the selected one. For more information,
see “Managing sound files and music on hold” on page 116.

Enable read back Select if you want the digit inputs to be read out to the caller.
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Question Enter any descriptions you have for the digits collector.

Digits settings

Max digits Enter the maximum digits the digits collector allows. The range is
1-30.

Max invalid input Enter the number of times a caller is allowed for inputting wrong

allowed digits. The call will be terminated if the limit is reached. The range
is 0-10.

Timeout Enter the time limit that a caller is allowed for taking NO action

after the call is put through. The call will be terminated if the time
limit is reached. The range is 0-600 seconds.

Max timeout Enter the number of timeouts a caller is allowed for taking no
allowed action after the call is put through. The call will be terminated if the
number of timeouts limit is reached. The range is 0-10.

For example, if Timeout is set to 10 seconds and Max timeout
allowed to 3, a caller would have a total of 30 seconds timeout
time after he or she dials in and takes no action afterwards.

6. Click Create.
The digit collector is listed under Questionnaire. You may click New to add more.
7. If you want callers to comment on the survey, select Caller Comment.

8. For Audio prompt, select the audio file that explains to callers how to comment on the
survey. Click New to create a new audio file. For more information, see “Managing sound
files and music on hold” on page 116.

9. For Description, enter any notes for the Caller Comment.
10.Click OK.

To configure survey settings

1. Go to Call Center > Survey > Setting.

2. For Survey retention month, enter the number of months that you want to keep the surveys.
3. For Max survey records, enter the maximum number of surveys you want to keep.

4. Click Apply.

Setting up queue view

You can create a queue view to let agents with privileges to view the snapshot of the key
information of queues on the user web portal, such as number of calls in queue, longest waiting
calls, and abandoned calls.

To apply the queue view configuration, you need to enable it in agent profile and apply the
profile to an agent. As a result, the agent will have a Queue Monitor icon once he or she logs
into the user web portal.

To set up a queue view
1. Go to Call Center > Monitor View.
2. Click New and configure the following:

GUI field Description
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Name Enter a name for the queue view.

Monitor ltems Click New to include the queues or agents that you want to
monitor.
Title Enter a name for the configuration.
Type Choose to monitor queues or agents.

Refresh interval Enter the refresh interval time for the monitor view in seconds.

Queue From the Available field select the queues to be included and click
->.
Click Create.
3. Click OK.

Configuring other agent information

Configure call agent skill sets, skill levels, reason codes, and global settings to be used for
configuring agent profiles.

Adding agent skill sets

Depending on the agents skill sets and the nature of your business, you can classify agents into
different groups, such as Billing, Sales, or Support.

To add an agent skill set

1. Go to Call Center > Configuration > Skill Set.
2. Click New.

3. Enter a name and description for the skill set.
4. Click Create.

Creating agent skill levels

The FortiVoice unit comes with 9 default skill levels, ranging from 10 to 90, with 10 to 30 being
junior, 40 to 60 being intermediate, and 70 to 90 being senior. You can modify the default skill
level descriptions, or create new skill levels.

To create an agent skill level
1. Go to Call Center > Configuration > Skill Level.
Click New.

2.
3. Enter the skill level and description.
4. Click Create.

Modifying agent reason code descriptions
Agent reason codes explain why agents are not able to take calls, such as due to lunch break,

meeting, or vacation. You cannot change the default reason codes, but you can modify the
code descriptions.
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To modify an agent reason code description

1. Go to Call Center > Configuration > Reason Code.
2. Double-click a reason code.

3. Enter the code description.

4. Click OK.

Setting caller priorities

You can set call answering priorities for callers entering the call queue. A new call always starts
with the lowest priority. However, a queue manager with privileges can change the priority of a
call on the agent console of the user web portal.

To set caller priorities
1. Go to Call Center > Configuration > Global Settings.

2. For Call Center Settings, enter the caller’s highest and lowest priorities.
3. Click Apply.

Configuring agent profiles

Create agent profiles to define agent privileges for processing calls. Agent profiles become
effective when they are applied to the agent extensions. For more information, see “Setting up
local extensions” on page 135.

To create an agent profile
1. Go to Call Center > Profile > Profile.

2. Click New.
3. Configure the following:

GUI field Description
Agent Select the calls an agent can make or process.

Pickup call from Select to allow the agent to answer queue calls.
queue

Ring no answer  Select the action to take when nobody answer a call in the queue.

¢ Do nothing: No action is taken and the call keeps ringing.
* Auto pause: The call is paused automatically.

e Auto logout: The agent to whom this profile applies is
automatically logged out of the queue.

e Auto hold off: The call is automatically put on hold.

Queue Select to allow an agent to prioritize the calls in the queue or
transfer calls to another queue on the agent console of the user
web portal.

If you select Caller prioritization, the Priority button appears on the
agent console of the user web portal. If you select Transfer call to
another queue, the Transfer button appears on the agent console
of the user web portal.
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Manager Privilege If the agent is a manager, select the privileges to manage the
agents using the agent console of the user web portal.

The privileges include coaching, listening, and logging in and
logging out agents, or pausing and resuming agents.

Agent Console Select Enable agent console to choose the widget and GUI popup
Privilege alert for an agent to view on the agent console of the user web
portal.

Monitoring Console  Select to enable monitoring console on the user web portal.
Privilege

Monitoring Queue

Member of Select to enable the agent to only monitor the queues of which the
queues agent is a member.
Selected Select the queues the agent is allowed to monitor by moving the

selected queues from the Available field to the Selected field. The
Available field lists all queues regardless if the agent is a member
of them.

All Select to allow the agent to monitor all call queues.

4. Click Create.

Working with call queue statistics

Go to Call Center > Statistics to view agent and queue daily summaries. You can also download
the summaries. The summaries cover a period of 30 days.

To view agent daily summary
1. Go to Call Center > Statistics > Agent Daily Summary.

GUI field Description

Date The date of the agent call summary.

Agent The agent ID.

Work Time The agent’s total work hours for the queue that the agent worked the
longest.

Talk Time The total time the agent talked on the phone in all queues combined.

N/A Time The total time the agent was away from the phone in all queues combined.

Total The total calls the agent answered in all queues combined.

Answered

Total RNA The total calls not answered by the agent in all queues combined.

Out Call The outgoing calls made by the agent. This option is dependant on your

queue management configuration in “Member of Queues” on page 144.
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Out Talk Time The total time of outgoing calls made by the agent. This option is
dependant on your queue management configuration in “Member of
Queues” on page 146.

Voicemail The number of voicemails left on the agent’s extension.

To view queue daily summary
1. Go to Call Center > Statistics > Queue Daily Summary.

GUI field Description

Date The date of the call queue summary.
Queue The queue name.

Calls The number of calls reached this queue.

Abandoned The number of calls that gave up after reaching the queue.

Overflow The number of callers exceeding the maximum waiting callers you set for
the queue. See “Maximum queue capacity” on page 211.

Talk Time The total phone talk time of the queue.
Hold Time The total time for holding calls in the queue.
Out Call The outgoing calls made by the agents in the queue. This option is

dependant on your queue management configuration in “Member of
Queues” on page 146.

Out Talk Time The total time of outgoing calls made by the agents in the queue. This
option is dependant on your queue management configuration in “Member
of Queues” on page 146.

Configuring call center report profiles and generating reports

The Call Center > Report > Report tab displays a list of call center report profiles.

A report profile is a group of settings that contains the report name, its subject matter, its
schedule, and other aspects that the FortiVoice unit considers when generating reports from
call center log data. The FortiVoice unit presents the information in tabular and graphical format.

You can create one report profile for each type of report that you will generate on demand or on
a schedule.

Generating reports can be resource intensive. To avoid phone processing performance
impacts, you may want to generate reports during times with low traffic volume, such as at
night. For more information on scheduling the generation of reports, see “Configuring report
email notifications” on page 230.
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To view and configure report profiles

1. Go to Call Center > Report > Report.

GUI field

Generate

View Reports

View supported
query

Name
Department

Schedule

Description

Select a report and click this button to generate a report
immediately. See “Generating a report manually” on page 231.

Click to display the list of reports generated by the FortiVoice unit.
You can delete, view, and/or download generated reports. For more
information, see “Viewing generated reports” on page 32.

Click to display supported query summary.

Displays the name of the report profiles.
The department to which the report belongs.

Displays the frequency with which the FortiVoice unit generates a
scheduled report. If the report is designed for manual generation,
Not Scheduled appears in this column.

2. Click New to add a profile or double-click a profile to modify it.

3. In Name, enter a name for the report profile.

Report names cannot include spaces.

4. In Department, select the department for this report.

For information on departments, see “Creating extension departments” on page 166.

5. Click the arrow next to each option, and configure the following as needed:

¢ Configuring the report query selection

e Configuring the report time period

e Configuring report email notifications

¢ Configuring the report schedule

e Generating a report manually

6. Click Create.

Configuring the report query selection

When configuring a report profile, you can select the queries that define the subject matter of

the report.

Each report profile corresponds to a chart that will appear in the generated report.

To configure the report query selection

1. Go to Call Center > Report > Report.

. Click New.

2
3. Expand Query List and click New.
4

. Configure the following:
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Figure 67: Query selection

Query List

Name: query_1

Category: Queue .
Sub category: | Detai i
Query: —~Mone— 2

Create Cancel

GUI field Description
Name Enter a name for this query.
Category Select a query type for the report profile. The report chart will

correspond to the type selected.

Sub category Select a sub query type for the report profile. The report chart will
correspond to the type selected.

Query Depending on your selection of Category and Sub category, choose
the specific report you want to generate.

Depending on the report you choose, select queues or agents for
which you want to generate reports.

5. Click Create.

Configuring the report time period

When configuring a call center report profile, you can select the time span of log messages from
which to generate the report.

To configure the report time period

1. Go to Call Center > Report > Report.

2. Expand Period.

3. Select the time span option you want. This sets the range of log data to include in the report.

e For Type, choose a relative time, such as Today, Yesterday, Last N hours, and so on. If you
select an option with an unspecified “N” value, enter the number of hours, days or weeks
in the Value field, as applicable.

¢ [f you select Not used for Type, set a specific time range. Set the start date and hour in
From field and end date and hour in To field.

Configuring report email notifications
When configuring a call center report profile, you can have the FortiVoice unit email an attached
copy of the generated report, in either HTML or PDF file format, to designated recipients.

You can customize the report email notification. For more information, see “Customizing call
report and notification email templates” on page 108.

To configure an email notification
1. Go to Call Center > Report > Report.
2. Expand Email.
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3. Enter the email address of the person who will receive the report notification in the Mail to
field. Click + to enter more email addresses if necessary, or click - to remove an address.

4. In the File format field, select the format of the generated attachment, either HTML, PDF or
CSV.

Configuring the report schedule

When configuring a call center report profile, you can select when the report will generate. Or,
you can leave it unscheduled and generate it on demand. See “Generating a report manually”
on page 231.

To configure the report schedule
1. Go to Call Center > Report > Report.

2. Expand Schedule.
3. Configure the following:

GUI field Description

Type e None: Select if you do not want the FortiVoice unit to generate
the report automatically according to a schedule. If you select this
option, the report can only be generated on demand. See
“Generating a report manually” on page 231.

e Daily: Select to generate the report each day. Also configure Hour.

¢ |Weekdays: Select to generate the report on specific days of each
week, then select those days in These weekdays. Also configure
Hour.

e Dates: Select to generate the report on specific date of each
month, then enter those date numbers in These days. Also
configure Hour.

Generating a report manually

You can always generate a report on demand whether the call center report profile includes a
schedule or not.

To manually generate a report

1. Go to Call Center > Report > Report.

2. Click to select the report profile whose settings you want to use when generating the report.
3. Click Generate.

The FortiVoice unit immediately begins to generate a report. To view the resulting report, see
“Viewing generated reports” on page 32.

Fortinet Technologies Inc. Page 231 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Working with Property Management
System

Businesses such as hotels use Property Management System (PMS) to manage their services.
The PMS can be connected to a PBX such as the FortiVoice unit to configure a customer’s room
phone by displaying the customer’s name on the phone, emptying voicemails when a new
customer checks in, logging phone calls, setting wake-up calls, and other services. You can
also set the room condition codes for room maids to record the room cleaning status using the
room phone.

This option is only available if you have purchased license.
This topic includes:

¢ Configuring hotel management settings
¢ Configuring hotel room status

Configuring hotel management settings

Hotel Management > Setting lets you configure the settings for the FortiVoice unit to
interoperate with your PMS, set the room condition codes, such as setting 1 to represent that
maid is present and 4 to represent out of service, and configure guest check in and check out
actions.

Configure your PMS settings accordingly.
To configure hotel management settings

1. Go to Hotel Management > Setting > PMS.
2. Configure the following:

GUI field Description

Enabled Select to enable the PMS.

Protocol Select the protocol used by the FortiVoice unit to communicate with the
PMS.

Port Enter the port number that connects to the PMS.

Note that you need to use an adaptor for the FortiVoice-PMS
connection. Fortinet recommends using iPocket232 by Precidia. From
the ports you configured, connect the PMS serial cable to the adaptor
and then connect the RJ45 cable from the FortiVoice unit to the adaptor.

Serial Select to connect to the PMS using a serial cable.

connection This option is only available for Micros protocol.

LRC Select to perform longitudinal redundancy check (LRC).

This option is only available for Micros protocol.
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Mode

Call billing

Network
Settings

Trusted
hosts

Data sync

3. Click Apply.

Choose to use the FortiVoice unit as server or client when connecting to
the PMS. If it is used as client, enter the server IP address in the Server
field.

This option is only available for Micros and Comtrol protocols.

Select to activate call billing.

Enter the IP address and netmask of the PMS. If the PMS uses serial
connection to an adaptor, enter the IP address and netmask of the
adaptor.

If you have multiple PMSes, you may enter multiple trusted hosts.

This option is only available for Micros and Comtrol protocols.

When the FortiVoice unit is connected to the PMS, it constantly receives
all room-based information such as guest name, room privileges, and
check in and check out times from the PMS.

Normally, you do not need to click the Data sync button since the data
synchronization is automatic. You only do so when there is a data
mismatch between the FortiVoice unit and the PMS.

Fortinet recommends performing a manual data sync at off hours
because all related operations, such as check in and check out, are
suspended during a data sync.

To configure check in and check out actions

1. Go to Hotel Management > Setting > Option.

2. Configure the following:

GUI field
Check in action

Reset

Check out action

Fortinet Technologies Inc.

Description

Set the guest information and room condition to make a room check-in
ready.

¢ Privilege: Select to enable phone call restriction (internal, local, or
long distance) and user privilege (option 1, 2, 3) for the room.
If you choose this option, select a Privilege for the room user. For
information on setting user privileges, see “Configuring user
privileges” on page 131

e Guest name: Select to display room number or guest name on the
room extension. In the Name field, enter %%NUMBER%% or %%NAME%%.

e Room condition: Select to clear any condition set for the room.
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3.

To
1.

a Db

Reset Set the guest information and room condition to make a room check-out
ready.

e Privilege: Select to enable phone call restriction (internal, local, or
long distance) and user privilege (option 1, 2, 3) for the room.
If you choose this option, select a Privilege for the room user. For
information on setting user privileges, see “Configuring user
privileges” on page 131

¢ Guest name: Select to display room number or guest name on the
room extension. In the Name field, enter %%NUMBER%% or %%NAME%%.

e Room condition: Select to clear any condition set for the room.
* Voice mail: Select to clear all voicemails for the room extension.

e Wakeup call: Select to clear all wakeup call setups for the room
extension.

Advanced Choose the order for room maids to request for room item by phone.
You can choose to dial the item code or number first.

For example, if you choose to dial code first and want to request for two
beers (code 1) and three waters (code 2), you can dial 1*2*2*3.

For information on item code, see “To set mini bar code for room maids
to order room items” on page 234.

Click Apply.

set mini bar code for room maids to order room items
Go to Hotel Management > Setting > Mini Bar Code.
Click New.

Enter the item name, for example, Beer.

Enter the item code, for example, 5.

Click Create.

A room maid can dial the code to order beer for the room using the room phone. For more
information, see “Advanced” on page 234.

Configuring hotel room status

Hotel Management > Room Status lets you set hotel room status.

Once the PMS and the FortiVoice unit is properly connected and the PMS is enabled on the
FortiVoice unit, all hotel room extensions appear on the FortiVoice unit.

To
1.

3.
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batch-configure hotel room statuses
Go to Hotel Management > Room Status.

A green dot at the top of the screen means the FortiVoice unit is connected with the PMS.
Otherwise, a red dot appears.

Select more than one room in the list.

Depending on the situations of the rooms you select, the Check in, Check out, Privilege,
Room condition, Room setting, and VIP setting buttons become active.

A green dot under Guest means this guest room’s extension is bound with the room.
Otherwise, a red dot appears. For more information, see “Guest phone” on page 235.

Click a button to batch-configure the room status and apply it to all rooms selected.
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To configure a single hotel room status

1. Go to Hotel Management > Room Status.

2. Select a room extension and click Ediit.

3. Configure the following:

GUI field

Number

Guest phone

Room

Location

Description

The extension number of the room. You can click the number and
modify it if required. For more information, see “Configuring IP
extensions” on page 135.

Select to bind the extension with the room and make the room a guest
room.

The hotel room number. You can click the number and modify it if
required.

Click to enter the room location.

If you have selected Guest phone, configure the following:

Checkin status

Guest name

Privilege

DND

VIP setting

Room condition

4. Click OK.
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Choose the room status to configure: Checked-out or Checked-in.

Enter the name of the guest for this room.

This option is available only if the Checkin status is Checked-in.

Select phone call restriction (internal, local, or long distance) and user
privilege (option 1, 2, 3) for the room. For information on setting user
privileges, see “Configuring user privileges” on page 131.

This option is available only if the Checkin status is Checked-in.

Select if the guest of the room does not want to be disturbed.

This option is available only if the Checkin status is Checked-in.

Select to set the guest as a VIP. Specific VIP treatments are determined
by each hotel.

Select the cleaning status of the room.

You can add a new code or edit the current one:

¢ Click New to add a code or select an existing code and click Edit to
modify it.

e Select the protocol for connecting to your PMS.
e Enter a code number.

e Enter the code description.

¢ Click Create.
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Configuring phone auto dialer

With the auto dialer function, the FortiVoice unit can automatically dial telephone numbers.
Once the call is answered, the FortiVoice unit plays a recorded message.

This topic includes:

Setting up an auto dialer campaign

Creating a recorded broadcast message

Adding contacts and contact groups

Viewing auto dialer reports

Configuring auto dialer settings

Setting up an auto dialer campaign

Auto Dialer > Campaign > Campaign allows you to set up an auto dialer task to broadcast a
recorded message to the dialed phone numbers.

To set up an auto dialer campaign

1. Go to Auto Dialer > Campaign > Campaign.

2. Configure the following:

Fortinet Technologies Inc.

GUI field
Name

Caller ID

Status

Sound file

Retry
Description

External
Member

Internal Member

Click Create.

Description
Enter a name for the campaign.

Enter the caller ID to be displayed on a called phone. You can also
select an extension number instead.

The current status of the campaign.

Select a recorded message that you want to broadcast. You can also
create a new one. For more information, see “Creating a recorded
broadcast message” on page 237.

Enter the number of times you want to retry calling.
Enter any notes you have for this campaign.

Select the external phone numbers you want to autodial. You can add
these numbers by going to Auto Dialer > Contact > Contact/Contact
Group. See “Adding contacts and contact groups” on page 237.

Select the internal phone numbers you want to autodial. These numbers
are the internal extensions on the FortiVoice unit.

If you want to start a campaign, in the campaign list, select one and click Start on top of the

screen.

Select a campaign start and end time.

Click OK.
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Creating a recorded broadcast message

Auto Dialer > Campaign > Audio allows you to create a sound file for the auto dialer to
broadcast.

To create a sound file

1.

2
3.
4

Go to Auto Dialer > Campaign > Audio.

. Click New.

Enter a name for the sound file.

. Select an Action:

e Upload: Click to upload a sound file. Uploaded sound file should be a WAVE file (*.wav) in
16bit PCM(8000Hz) compression format.

® Record: Click to enter a phone number and click Send. When the phone rings, pick it up
and record the message.

e Download: Once a file is uploaded or recorded, click to download it.

* Play: Once a file is uploaded or recorded, click to play it.
Click OK.

Adding contacts and contact groups

Auto Dialer > Contact > Contact/Contact Group allows you to add contacts and contact groups
that can be used in an auto dialer campaign.

To add a contact

1.
2.
3.

Go to Auto Dialer > Contact > Contact.
Click New and enter the contact information.
Click Create.

To add a contact group

1.

2
3.
4

Go to Auto Dialer > Contact > Contact Group.

. Click New.

Enter a name for the group.

. Select the members for the group.

Members are created by adding contacts. See “To add a contact” on page 237.
Click Create.

Configuring auto dialer settings

Auto Dialer > Setting allows you to

set the maximum call channels (64 by default) for campaigns. This value represents the
number of phones that can be auto dialed at the same time.

set call timeout (600 seconds by default).

These values can be modified through the CLI.
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Viewing auto dialer reports

Auto Dialer > Report allows you to view the status of the auto dialer campaigns, including
campaign IDs, call status, total number of campaigns, number of uncalled, answered,
unanswered calls, and retries, and call duration and time.
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Configuring Call Features

The Call Features menu lets you configure the settings for many call features such as
conference call, auto attendant, faxing, and much more.

This topic includes:

¢ Configuring auto attendants
e Configuring user privileges

¢ Configuring account codes
¢ Mapping speed dials

e Configuring conference calls
¢ Recording calls

¢ Creating call queues

e Configuring call parking

¢ Configuring fax

e Setting calendar reminder

¢ Modifying feature access codes

Configuring auto attendants

An auto attendant can answer a telephone line or VolP number, and can be included in the call
cascade of a local extension, remote extension or ring group.

An auto attendant can answer a call if the receptionist is away or if you do not have a
receptionist. Each auto attendant has a message with options. The message tells the caller
what the options are. You can load a professionally pre-recorded message, or can record a
message using a handset.

To view the list of auto attendants, go to Call Features > Auto Attendant > Auto Attendant.

Figure 1: Auto attendants list

EF Mew... | B2 i T =
) Page 1 j1 Records per page: | 25 w
Enabled Direct Actions
= Ah_misott 0
OttMain 3
ToOttAsterisk 0
GUI field Description
View Hierarchy Click to view the hierarchical structure of the selected auto attendant.
For more information, see “Viewing auto attendant hierarchies” on
page 242.
Delete Removes a selected auto attendant. You cannot remove an auto
attendant that is used in another auto attendant configuration.
Enabled Select to activate this auto attendant.
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Name The name of the auto attendant.

Direct Actions The number of key actions configured for the main auto attendant,
excluding the key actions for the subsidiary auto attendants. For more
information, see “Viewing auto attendant hierarchies” on page 242.

To create an auto attendant
1. Go to Call Features > Auto Attendant > Auto Attendant and click New.
2. Configure the following:

GUI field Description
Auto Attendant
Name Enter a name for the auto attendant.
Enabled Select to activate the auto attendant.
Default Select the language for the auto attendant greeting message (sound
language file). If you select Default, the greeting message will be the same as

what you set for the FortiVoice unit. For more information, see
“Setting PBX location and contact information” on page 104.

You can also select other languages. The language files are created
in “Adding prompt languages” on page 113.

Greeting If you select Simple, select a greeting message (sound file) for the
mode auto attendant. See “Greeting” on page 240.

If you select Scheduled to add a scheduled greeting, do the
following:

¢ In Scheduled Greeting Setting, click New.

¢ In the Schedule field, select a schedule for the greeting.
Scheduled are created in “Scheduling the FortiVoice unit” on
page 132.

¢ Inthe Greeting field, select a sound file. You can click New to add
a new file or Edit to modify the selected one. For more
information, see “Managing sound files and music on hold” on
page 116.

¢ Click Create.
Greeting Select a greeting message (sound file) for the auto attendant. You

can edit a selected file or create a new one. For more information,
see “Managing sound files and music on hold” on page 116.

This option is only available if you select the Simple greeting mode.

Ringing for Enter the number of seconds for the phone to ring before the auto
attendant answers with the greeting message.

Timeout after Enter the number of seconds that an auto attendant should be
allowed to wait before the caller takes further action according to the
voice instructions.
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Timeout
action

Invalid input
action

Dial Pad Key Action

Key

Action

Target

Advanced

3. Click Create.
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Select the action when the auto attendant timeout is reached.

e Dial operator: The call is transferred to an operator.

e Dial extension: The call is transferred to the extension you select.
You can edit a selected extension or create a new one. For
details, see “Configuring IP extensions” on page 135.

e Start over: The auto attendant will repeat the instructions for the
caller. Also enter the maximum times to repeat.

® Hang up: The call will be terminated.

Select the action when the caller enters an invalid input.

Configure the auto attendant keys for callers to use when navigating
through the auto attendant hierarchy. For more information, see
“Configuring key actions” on page 243.

The key that transfers a call to a resource, for example, voicemail, if
pressed.

The resource to which a call is transferred by pressing a key.

The resource target if applicable. For example, an extension number,
sound file, or external phone number that leads to a resource.

Upon finishing configuring these functions, you need to inform the
users on how to use them after they reach the auto attendant.

* Voicemail access: Enable to allow external callers to reach their
voicemail boxes by dialing the default voicemail prompt code *98
or the code you set. For more information about feature code, see
“Modifying feature access codes” on page 273.

e Dial local number: Select to enable an external caller to dial local
extensions.

e OQOverride schedule: Select to allow a system administrator to dial
a code to replace the schedule with a system schedule. For more
information, see “Configuring system capacity” on page 116.

e Call Bridge (DISA): Select an account code for external users to
dial into the FortiVoice unit and use the FortiVoice service just like
the local extensions. Callers must dial the DISA code followed by
the account code before making the calls. You can edit a selected
account code or create a new one. For more information on DISA
code, see “Modifying feature access codes” on page 273. For
more information on account code, see “Configuring account
codes” on page 249.

e Qutbound dialplans allowed for access: Select the outbound dial
plan for users to call the FortiVoice unit and through it to make
outbound calls. For details, see “Configuring outbound dial
plans” on page 201.
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Viewing auto attendant hierarchies

The FortiVoice unit provides a chart based on your auto attendant configurations to display the
layers of auto attendant hierarchy and the key actions. You can save the chart and load it later.
You can also drag the chart into the shape you want.

To view the auto attendant hierarchy
1. Go to Call Features > Auto Attendant > Auto Attendant.

2. From the auto attendant list, select the one of which you want to view its hierarchy chart.
3. Click View Hierarchy.

Figure 2: Sample auto attendant hierarchy
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This example shows the hierarchy of auto attendant 1.

e Based on the configuration, press 2 transfers the call to auto attendant 2.

e Auto attendant 2 configuration allows you to go to auto attendant 3 by pressing 3
and places you on a call queue if you press 5.

e Auto attendant 3 configuration allows you to go to the operator by pressing 8.

You can right-click an auto attendant node and select Edit to modify it or view the
snapshot of an auto attendant (other than the main one) by right-clicking it and
selecting Drill down.
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Table 1: Sample auto attendant hierarchy

Close

<<

Reset

Print preview

Show all actions

Configuring key actions

Closes the chart.

If you selected viewing the snapshot of an auto attendant (other than
the main one) by right-clicking it and selecting Drill down on the
chart, clicking << restores the full chart.

Sets the chart to its default view. All the saved and unsaved views
will be lost.

Click to preview the chart before printing it.

Select to display the total actions. Deselect to hide the end
resources to which a call is transferred by pressing a key. In this
sample, the end resources are Operator (8) and Queue extension (5).

Configure the auto attendant dial pad keys for callers to use when navigating through the auto
attendant hierarchy.

For more information, see “Dial Pad Key Action” on page 241.

To configure a key action

1. While configuring an auto attendant, click New under Dial Pad Key Action.

2. Enter the key number that transfers a call to a resource, if pressed.

3. Select an action:

Fortinet Technologies Inc.

GUI field
No action

Play announcement

Dial operator

Dial extension

Description
The call is not transferred to any resource.

Play an announcement with directions, business hours, etc.

e Select an action to follow the announcement:
* No action: The auto attendant takes no action.
e Start over: The auto attendant will repeat the announcement.
e Hang up: The call will be terminated.

e Select the sound file for the announcement. You can click Edit to
modify an existing one or New to add a new one. For information
on sound files, see “Managing sound files and music on hold” on
page 116.

The call is transferred to the operator.

The call is transferred to a specified local extension.

Select the extension. You can click Edit to modify an existing one or
New to add a new one. For more information, see “Configuring
Extensions” on page 135.
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Go voicemail

Ring group

Dial number

Call queue

Lookup name
directory

Change language

Auto attendant

Start over
Go back
Hang up
IVR

The call is transferred to a voice mailbox, allowing the caller to leave
a message.

Select the voice mailbox. You can click Edit to modify an existing
one or New to add a new one. For more information, see
“Configuring IP extensions” on page 135.

The call is transferred to the call queue of a ring group. The call is
placed on hold. The system will ring the next available extension in
the ring group.

Select the ring group. You can click Edit to modify an existing one or
New to add a new one. For more information, see “Creating
extension groups” on page 165.

The call is transferred to a specified remote extension number.

Enter the remote extension number. For more information, see
“Setting up remote extensions” on page 149.

The call is transferred to a call queue.

Enter the call queue configuration. For more information, see
“Creating call queues” on page 208.

Access the dial-by-name directory so the caller can find a user’s
extension number by entering the user’s name.

Change the auto attendant greeting language. Select the language
and a follow-up action. If you choose Auto attendant for the
follow-up action, select the auto attendant.

For Language, if you select Default, the greeting message will be the
same as what you set for the FortiVoice unit. For more information,
see “Setting PBX location and contact information” on page 104.

You can also select other languages. The language files are created
in “Adding prompt languages” on page 113.

Route the call to another auto attendant, which allows actions to be
nested into a powerful call routing system. For example, the main
auto attendant can say “Press one for English. Oprima dos para
Espafol.” Option 1 goes to the English auto attendant and option 2
goes to the Spanish auto attendant.

Select an auto attendant. For information on creating auto
attendants, see “Configuring auto attendants” on page 239.

The auto attendant will repeat the announcement.
The auto attendant will repeat the previous level announcement.
The call is terminated.

Route the call to the FortiVoice IVR system. For more information,
see “Configuring IVRs” on page 219.

4. Optionally, enter any comments about this key action.
5. Click Create.
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Configuring user privileges

A user privilege includes a collection of phone services and restrictions that can be applied to

each extension user.

The default user privilege configurations can be edited but not be deleted.

For information on extensions, see “Configuring Extensions” on page 135.

To configure a user privilege

1. Go to Call Features > User Privileges > User Privileges and click New.

2. Configure the following:

GUI field
Name
Basic Settings

Auto provisioning

List in directory

Configure
programmable
phone feature
key/PFK

Lookup directory

Lookup directory in
remote office(s)

Fortinet Technologies Inc.

Description

Enter a name for this class of service.

Select to enable auto-provisioning for the extension. For more
information, see “Configuring SIP phone auto-provisioning” on
page 111.

Once a FortiFone or supported DHCP-enabled phone
connects to the FortiVoice unit and is auto-discovered, the
FortiVoice unit assigns an IP address to the FortiFone and
sends the basic PBX setup information to it. The full PBX
configuration file will only be sent to the phone if this option is
selected in the user privilege applied to the extension
associated with the phone.

Select to put the user’s name in the dial-by-name directory
which allows a caller to find a user’s extension number, and
connect to their local extension or remote extension. This way
the caller can reach their party without speaking to the
receptionist.

Select to enable configuring the feature access codes. For
more information, see “Modifying feature access codes” on
page 273.

Select to enable a user to view the phone directory of the local
office. For more information, see “Viewing phone directories”
on page 38.

Select to enable a user to view the phone directories of remote
offices. For more information, see “Viewing phone directories”
on page 38.
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Twinning

Role Settings

Operator role

Voice Mail

Enabled

Maximum
messages

Voicemail retention
days

Music

Fax

Music on hold

Early media

Enabled

Max incoming
messages

Select to enable twinning function on an extension.

The twinning feature allows you to use an external telephone
(often a smartphone or home phone) to replicate your internal
office extension (often your desk phone), so that when your
desk phone rings, so does the “twin” phone. Once you return
to your desk, you may press the Twinning key on the phone to
terminate the twinning.

This is useful when you are away from your desk but still want
to receive calls to your desk phone.

With this feature selected, you can configure twinning. For
more information, see “Setting extension user preferences” on
page 156.

Select to enable an extension user to process phone calls
using the FortiVoice user web portal.

You can select the four options to handle calls in each
category.

When the user privilege with this option selected is applied to
an extension, an Operator Console button will appear on the
top of the extension user’s FortiVoice web portal. Clicking the
button lets the user to process phone calls on the Web.

For more information, see the online help of the user web
portal.

Select to enable the voicemail service.

Enter the number of voice mails allowed.

Enter the number of days to keep the voicemails.

Select a music on hold file. For details, see “Managing sound
files and music on hold” on page 116.

Early media is the exchange of information between the PBXes
before the establishment of a phone connection, such as the
ring tone. You can select a music file for early media. For
details, see “Managing sound files and music on hold” on
page 116.

Set the user rules for faxing. For information on fax, see
“Configuring fax” on page 262.

Select to set the fax rules for users.

Enter the number of incoming faxes allowed.

Page 246 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Max incoming fax  Enter the number of days to keep the incoming faxes.
retention days

Max outgoing Enter the number of outgoing faxes allowed.
messages

Max outgoing fax Enter the number of days to keep the outgoing faxes.
retention days

Call Restriction Select call dialing restrictions for international, long distance,
local, and internal calls.

e Forbidden: Call is not allowed.
e Allowed: Call is allowed.

e Allowed with account code: Call is allowed by entering the
system account/exempt code. For information on account
code, see “Configuring account codes” on page 249.

Not applicable to internal calls.

e Allowed with personal code: Call is allowed by entering an
extension’s account/exempt code. For more information,
see “Configuring account codes” on page 249.

Not applicable to internal calls.

Other restricted You can specify area codes to which an extension is allowed
area code or denied to make phone calls.

1. Click New.

Enter a name for this call restriction.

Select Enable to activate this restriction.

Enter the area code that you want to set restriction.

o oD

If you do not want an extension to call the area code you
set, select None for Exempt code; otherwise, select a code.
For information on exempt code, see “Configuring account
codes” on page 249.

6. Click Create.

Misc The max number of concurrent calls: Set the maximum
number of concurrent incoming and outgoing calls on the
extension. The range is 1-10. The default is 4.

Monitor/Recording Configure monitoring and recording outgoing and incoming
calls of an extension to which this user privilege is applied.

Personal recording Select to allow users to configure personal recording of their
incoming and outgoing calls on the user web interface.

Allow being barged Select to allow monitoring an extension to which this user
privilege is applied.

Allow barging Select to allow the extension to which this user privilege is
applied to monitor other extensions.

To barge a call, you need to enter your user PIN. For
information on user PIN, see “User PIN” on page 138.

Call barge option If you select Allow barging, choose a barging method.
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Hot-desking

User Portal Options

Advanced

Conference number

Hot desking enables users to log into another phone. However,
unlike using Follow Me or Call Forwarding which simply
redirect a user's calls to another user’s phone, hot desking
takes total control of another phone by applying all of the
user's own phone settings to that phone until the user logs
out. Each user can log into another phone by pressing *11 and
enter his extension number and user PIN following the
prompts. To log out, a user can press *12 and enter his
extension number and user PIN.

You can view hot desking configurations by going to “Viewing
hot desking configurations” on page 27.

e FEnable hot-desking login: Select to enable the hot-desking
login function.

¢ Automatic logout hours: Enter the time in hours for the
phone to automatically log out of hot-desking.

e Enable hosting hot-desking: Select if you want to log into a
regular phone with the hot-desking phone authentication
(by pressing *11 and enter your extension number and user
PIN following the prompts).

By doing so, the regular phone keeps its configuration and
extension number. However, outgoing calls display the
hot-desking number.

The regular phone logs out of hot-desking when the time
set in Automatic logout hours expires.

If the two phones use different programmable phone keys, the
host phone will reboot. For information on programmable
phone keys, see “Configuring phone profiles” on page 121.

Enable or disable the web portal and select the features of the
user web portal. Only the selected ones will appear for the
extension to which this user privilege is applied.

Select the permission for conference calls:

e Allow all: Select to allow the extension to join all conference
calls.

e Disallow all: Select to prohibit the extension from joining all
conference calls.

¢ Allow all with exempit: If you select this option, click New to
enter the conference call number(s) that the extension is
banned to join.

e Disallow all with exempt: If you select this option, click New
to enter the conference call number(s) that the extension is
allowed to join.

For more information, see “Configuring auto attendants” on
page 239.
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Paging/Intercom

Trusted hosts

Permit outgoing
rules

7. Click Create.

Configuring account codes

Select the permission for paging/intercom:

e Allow all: Select to allow the extension to page/intercom all
paging numbers.

e Disallow all: Select to prohibit the extension to
page/intercom all paging numbers.

e Allow all with exempt: If you select this option, click New to
enter the paging/intercom number(s) that the extension is
banned to page/intercom.

e Disallow all with exempt: If you select this option, click New
to enter the paging/intercom number(s) that the extension
is allowed to page/intercom.

For more information on paging, see “Configuring auto
attendants” on page 239.

Click New to enter the IP address and netmask of the subnet
that can register with the SIP server. Only extensions on the
specified subnet can register with the SIP server.

Select the available outbound calling rules in the Available
rules field and click -> to move them to the Selected rules field.
You can apply the rules to a user later. For more information on
calling rules, see “Configuring outbound dial plans” on

page 201.

You can set account codes to restrict long-distance and international calls, for instance. Users
must dial these codes first before making long-distance or international calls.

You apply the account codes in user privileges. For details, see “Configuring user privileges” on

page 245.

To set an account code

Click New.

No o ppoDbd2

Click Create.

Mapping speed dials

Go to Call Features > User Privileges > Account Code.

Enter a name for the account code.

Enter the account code, such as 69.

Select Shared to use this code on any extension.
Enter any notes about this code as required.

For fast and efficient dialing, use the speed dial pattern to map the phone numbers, mostly

outbound numbers.

For information on setting speed dial number pattern, see “Configuring PBX options” on

page 105.
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To map speed dials

1. Go to Call Features > Speed Dials.

2. Enter a name for the speed dial mapping.

3. For Code, enter the number based on the speed dial number pattern you set. For example,

333.

4. Enter the phone Number to map to the speed dial code.

You can enter digits 0-9, space, dash, comma, # and *.

If you want to enter an auto attendant number followed by an extension, you can use comma
(,) or semicolon (;) to pause the automatic dialing.

A comma pauses dialing for two seconds, for example, 1-123-222-1234, 5678#. In this case,
once pressing the speed dial code you set, auto attendant 1-123-1234 is reached, and after
two seconds, extension 5678 is automatically dialed.

A semicolon pauses dialing for one second, for example, 1-123-222-1234; 5678#. In this
case, once pressing the speed dial code you set, auto attendant 1-123-1234 is reached, and
after one second, extension 5678 is automatically dialed.

5. Optionally, enter a note for the mapping, such as “This is for customer A”.

6. Click Create.

Configuring conference calls

The Call Features > Conferencing > Conferencing tab lets you configure and enable conference

call settings.

Depending on your preference, you can create either a static or dynamic (calendar-based)

conference call.

To configure a static conference call

1. Go to Call Features > Conferencing > Conferencing and click New.

2. Configure the following:

GUI field
Name
Enabled

Number

Show suggested
numbers

Display name

Fortinet Technologies Inc.

Description
Enter a conference call name.
Select to activate this conference call.

Select an extension number that callers can call and enter the user
PIN to join a conference call.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the Number
field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and fixing
duplicate or missing numbers. Missing numbers are the extensions
that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can click the
icon and fix the numbers. For more information, see “Fixing
duplicate or missing numbers” on page 142.

Enter the name displaying on the conference call extension, such as
“HR”'
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User PIN

Admin PIN

Description

Music on hold

Quiet mode

Recursive
Schedules

One Time
Schedules

3. Click Create.

Enter a password for joining the conference call. A caller needs to
dial the conference call number and enter this password to join the
conference call. The default is 123456.

This password is always valid and should only be sent to the people
who need it.

Enter the PIN number to be used by the conference host to host a
conference call. The default is 123123.

This password is always valid and should only be sent to the people
who need it.

Enter any notes you have for this conference call.

Select to play background music that callers hear after the joining
message and leaving message are played.

For information on creating music on hold file, see “Managing sound
files and music on hold” on page 116.

Select to not to record and announce participate's name.

If you want conference calls on repeating schedules, select Enabled
and click New to select a schedule. Enter a password for joining the
conference call and click Create.

This option is useful if you want to limit the participants to a
particular recursive conference call only provided that they do not
have the User PIN or Admin PIN for the conference call. They can
only join the conference call during the scheduled time period and by
entering the password you set.

For information on setting up a schedule, see “Scheduling the
FortiVoice unit” on page 132.

If you want to set up a one time conference call, select Enabled and
click New to enter the start and end time. Enter a password for
joining the conference call and click Create.

This option is useful if you want to limit the participants to a
particular one time conference call only provided that they do not
have the User PIN or Admin PIN for the conference call. They can
only join the conference call during the scheduled time period and by
entering the password you set.

If the one time schedule conflicts with the recursive schedule, the
one time schedule has priority.

To configure a dynamic conference call

1. Go to Call Features > Conferencing > Conferencing and click New.

2. Configure the following:

GUI field
Name

Enabled

Fortinet Technologies Inc.

Description
Enter a conference call name.

Select to activate this conference call.
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Recording ca

Number

Show suggested
numbers

Setting

Display name

Description

Music on hold

Quiet mode

Click Create.

Select an extension number that callers can call and enter the
user PIN to join a conference call.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the
Number field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and fixing
duplicate or missing numbers. Missing numbers are the
extensions that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can click
the icon and fix the numbers. For more information, see “Fixing
duplicate or missing numbers” on page 142.

Enter the name displaying on the conference call extension, such
as “HR”.

Enter any notes you have for this conference call.

Select to play background music that callers hear after the
joining message and leaving message are played.

For information on creating music on hold file, see “Managing
sound files and music on hold” on page 116.

Select to not to record and announce participate's name.

In the conference call list, select the one you created.

Enter an extension number that callers can call and enter their user PIN to join a conference

call.

Double-click a date to schedule an event.

Click OK.

lls

For supervising and monitoring purposes, you can record incoming and outgoing calls to and
from the extensions matching the caller number patterns or dialed number patterns you set.
You can also select the recorded file format and archive the recorded calls.

Configuring call recordings

Call Features > Call Recording > Policy allows you to configure call recordings by creating,
editing, removing, saving, or viewing a recording.
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Figure 3: Call recording list

EF New... E) i e @Uiew Recordings

[} Page 1 f4| » Pl | Records per page: 25 v

Enabled Name Description

I_J Interview Rule type-+By phone number : Caller number pattern-=632 : Dialed number pattern-=.

I__i Interview-In Rule type-=By phone number : Caller number pattern-=. : Dialed number pattern-=§32

:L}_i Test_group Rule type-=By phone number : Caller number pattern-=X. : Dialed number pattern-=X.
GUI field Description

View Recordings Click to view, listen, search, or save the recordings. You can also do so

by going to Status > Storage > Recorded Calls. For details, see “Playing
recorded calls” on page 31.

Enabled Select to activate this call recording service.
Name The name of the call recording service.
Description Information of call recording configuration.

To configure call recording
1. Go to Call Features > Call Recording > Policy.
2. Click New.

Recording Policy

MName:
Enabled: [}
Type: By phone number hd

Caller number pattern:

Dialed number pattern:

File name format: [dd-mm-yyyy-hh:mm:ss].[policy-name].[caller-r ¥

Recorded calls can be found through system menu "Status’-= "Storage’

oK Cancel

GUI field Description

Recording Policy

Name Enter a name for this configuration.
Enabled Select to activate this configuration.
Type Select the category of calls you want to record: by phone

number, department, group, or trunk.

If you select By phone number for Type, configure the following:
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Caller number
pattern

Dialed number
pattern

Enter the number pattern to match the callers’ phone numbers
following the pattern:

A[0-9XNZJ[M]*$
where X=(0-9), Z=(1-9), and N=(2-9).

For more information, see “Configuring PBX options” on
page 105.

The phone calls from the numbers matching the pattern will be
recorded.

Enter the number pattern to match the dialed phone numbers
following the pattern:

A[A_][0-9XNZ\.]*$
where X=(0-9), Z=(1-9), and N=(2-9).

For more information, see “Configuring PBX options” on
page 105.

The phone calls to the numbers matching the pattern will be
recorded.

If you select By department for Type, configure the following:

Department

Select the extension department of which you want to record the
calls. You can add a new department or modify an existing one.
For more information, see “Creating extension departments” on
page 166.

If you select By group for Type, configure the following:

Group

Select the user group of which you want to record the calls. You
can add a new group or modify an existing one. For more
information, see “Creating user groups” on page 165.

If you select By trunk for Type, configure the following:

Trunk

Direction

File name format

3. Click Create.

Select the trunk of which you want to record the calls. You can
add a new trunk or modify an existing one. For more information,
see “Configuring Trunks” on page 177.

Select the direction of which you want to record the calls.

Select the format of the downloaded recorded call files generated
under this policy.

The file format is useful when you filter downloaded recorded call
files by going to Status > Storage.

Setting the recorded file format

Select the format for recording calls.

To set the recorded file format

1. Go to Call Features > Call Recording > Setting.

2. Select the format: Standard or Low rate.

Fortinet Technologies Inc.

Page 254 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

3.

Click Apply.

Archiving recorded calls

Configure the settings to archive the recorded calls.

To configure the recording archive settings

1. Go to Call Features > Call Recording > Archive.

Figure 4: Recording archive settings

Rotation Settings

Recording Archive Settings

The archived recording will rotate when either the file size or rotation time is reached.

Recording rotation size:

Recording rotation time:

500 (MB})
7 (day) Athour 0 7

Archiving options when disk quota is full: | Qverwrite ~

« | Destination Settings

Destination: Local
Local disk quota: 100
Protocol:

IP address:

User name:

Password:

Remaote directory:

Remaote cache quota:

Apply Cancel

2. Configure the following:

Fortinet Technologies Inc.

GUI field
Rotation Settings

Recording rotation
size/time

Archiving options
when disk quota is
full

Destination Settings

Destination

(GB)

(GB)

Description

Enter the recorded file rotation size and time.

When the file reaches either the rotation size or time specified,
whichever comes first, the archiving file is automatically renamed.
The FortiVoice unit generates a new file, where it continues
saving recording archives. You can access all rotated files
through search.

Specify what the FortiVoice unit should do if it runs out of disk
space. Select Overwrite to remove the oldest archived folder in
order to make space for the new archive, or select Do not archive
to stop archiving more recorded calls.

Select an archiving destination:

e [ ocal: the FortiVoice unit’s local hard drive or a NAS server.
* Remote: a remote FTP or SFTP storage server.
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Local disk quota If Local is the archiving destination, enter the disk space quota.

The total disk quota for archiving calls cannot exceed 50% of the
total data disk size. For example, if the data disk has a size of 100
GB, a maximum of 20 GB can be used for call archiving.

If this quota is met and a new call must be archived, the
FortiVoice unit either automatically removes the oldest call
archive folder in order to make space for the new archive or stops
archiving, depending on the settings you specify under “Rotation
Settings” on page 255.

If Remote is the archiving destination, configure the following:

Protocol Select the protocol that the FortiVoice unit will use to connect to
the remote storage server, either SFTP or FTP.

IP address Enter the IP address of the remote storage server.

User name Enter the user name of an account the FortiVoice unit will use to
access the remote storage server, such as FortiVoice.

Password Enter the password for the user name of the account on the
remote storage server.

Remote directory Enter the directory path on the remote storage server where the
FortiVoice unit will store archived calls, such as
/home/fortivoice/call-archives.

Remote cache Enter the FortiVoice cache quota that is allowed to be used for
quota remote host archiving. The above statement regarding the Local
disk quota also applied to the cache quota.

3. Click Apply.

Creating call queues

This option is available if you do not have the Call Center license. If you do, see “Setting up a
Call Center” on page 208.

Call queuing, or Automatic Call Distribution (ACD), enables the FortiVoice unit to queue up
multiple incoming calls and aggregate them into a holding pattern. Each call is assigned a rank
that determines the order for it to be delivered to an available agent (typically, first in first out).
The highest-ranked caller in the queue is delivered to an available agent first, and every
remaining caller moves up a rank.

With call queuing, callers do not need to dial back repeatedly trying to reach someone, and
organizations are able to temporarily deal with situations when callers outnumber agents.

Configure a call queue and add it in an inbound dial plan as a call handling action to make it
effective. For more information, see “Configuring inbound dial plans” on page 195.
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Call queues consist of:

¢ Incoming calls waiting in the queue

¢ Agents who answer the calls in the queues

e A plan for how to handle the queue and assign calls to agents
¢ Music played while waiting in the queue

¢ Announcements for agents and callers

Depending on their privileges, agents can log into a queue to answer calls or transfer calls to
another queue, which can then be answered by another available agent.

Agents can be static or dynamic. Static agents are always connected to the queues, and
dynamic agents need to log into the queue in order to process calls.

To view the call queues, go to Call Features > Call Queue.

Figure 5: Call queues
Ef New... | & i

C, Page 1 = Records per page:| 50 w

CQueue D Display Name MNumber Department

TAC TAC 502 227, 2082 222 7005

dy_test dy_test 112 112 7821, 7822, 227

GUI field Description

Name The name of the call queue.

Display Name The queue name displaying on the queue extension.
Number The extension number for the call queue.
Department The departments of the agents enrolled in the queue.
Agents The extensions of the agents enrolled in the queue.

To create a call queue

1. Go to Call Features > Call Queue.
2. Click New.

3. Configure the following:
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Figure 6: Creating a call queue

Queue

Name:

Number: 20
Status v

Display name: | 20
Description: |20

Queue Setting

Distribution policy: | Round robin
Maximum caller: |2

Queue fime: 2

Ring duration: 10

On hold music: default

~ | More Settings

Agent

Agent members: __

Call Handling

[ Configure call handling ]

ij Cancel
GUI field
Queue
Name
Number
Show suggested
numbers

Show suggested numbers

(Minutes)

(Seconds)

w

Description

Enter a name for the queue.

Enter an extension for callers to dial and enter into a call
queue following the extension number pattern. See
“Configuring PBX options” on page 105.

This is another way to use a call queue configuration in
addition to adding it in an inbound dial plan as a call handling
action.

Even if you enter an extension, you can still add the call queue
configuration in an inbound dial plan as a call handling action.
In this case, the dial plan ignores this extension and still uses
the extension to which it is applied for call queue action.

Select and click in the Number field to display the extension
numbers available for use. If it is deselected, clicking in the
Number field displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and
fixing duplicate or missing numbers. Missing numbers are the
extensions that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can
click the icon and fix the numbers. For more information, see
“Fixing duplicate or missing numbers” on page 142.
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Status

Display name

Description
Queue Setting

Distribution policy

Maximum caller

Queue time

Ring duration

On hold music

More Settings

Distinctive settings

Business schedule

Fortinet Technologies Inc.

Select to enable the call queue.

Enter the queue name displaying on the queue extension,
such as Support.

Enter any notes about this queue.

Select the method for calls in the queue to be delivered to the
agents.

Enter the maximum number of callers for the call queue.
When the call queue is full, other callers will be dealt with
according to the Overflow call handling action you set in
“Overflow” on page 261.

The maximum is 100.

Enter the maximum call queue waiting time in minutes. When
the call waiting time is due, the callers in the queue will be
dealt with according to the call handling action you set in
“Waiting Timeout” on page 261.

The maximum is 720 minutes.

Enter the time in seconds to ring each agent. If a call is not
answered when the ring duration is due, the call is transferred
to the next agent. The range is between 5 to 120 seconds.

Select a sound file or music on hold file to play when a caller
is waiting. For more information, see “Managing sound files
and music on hold” on page 116.

Announce queue name: Select a sound file that announces
the queue name. You can add a new one or modify an existing
one. For more information, see “Managing sound files and
music on hold” on page 116.

Caller ID option: Select how you want the IDs of the calls to
this queue to display. If you select Prefix, the queue Display
name is added before the caller ID on the agent’s phone. If
you select Replace, the queue Display name replaces the
caller ID on the agent’s phone.

Ring Pattern: Select a queue extension ring pattern.

Select a operation schedule for the queue. For example,
“business_hour” schedule means agents are only available to
answer the calls for this queue during business hours. For
information on scheduling, see “Scheduling the FortiVoice
unit” on page 132.
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Announcement

Agent

Agent members

Call Handling

Configure call
handling

4. Click Create.

Fortinet Technologies Inc.

Announcement holdtime: Select if you want to announce the
queue waiting time to a caller at the set interval. You may also
select to announce only once.

Announcement position: Select to announce a caller’s waiting
position in the queue, such as “You are caller No. 5 in the call
queue”.

No: Do not announce a caller’s position.
Always: Always announce a caller’s position.

Abbreviated: Announce a caller’s position only once if the
caller is over the marked position and always announce once
the caller is within the marked position.

Minimal: Announce only when the caller is within the marked
position.

Mark position: Enter the benchmark for selecting Abbreviated
or Minimal setting.

For example, if you select Abbreviated and enter 5, a caller’s
position is announced when the caller becomes No. 5 in the
queue and announced only once before the caller becomes
No. 5 in the queue.

Announcement interval: Enter the announcement frequency in
seconds.

Custom announcement: You can also customize the
announcement settings.

¢ Mode: Select the method of greeting announcement to the
caller once the caller enters this call queue. You can also
select to diable this function.

If you select Periodic or Random, enter the announcement
frequency in seconds in Announcement interval.

* Audio: Select a greeting sound file for the announcement.
For more information, see “Managing sound files and
music on hold” on page 116.

e (Click >> to expand Agent members for enrolling agents
into the queue.

¢ In the Available field, select the agents for this queue.
e (Click -> to move it into the Selected field.
¢ Click Done.

You can type an agent’s extension or name in the Search field
and press Enter to search for the agent.

Click to configure the call handling action for the queue. For
details, see “Configuring queue call handling actions” on
page 261.
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Configuring queue call handling actions

Configure the call handling action for the queue. This action applies to all calls once they enter
into the queue.

This option is only available when you edit a queue.

To configure the call handling action

1.
2.

Go to Call Features > Call Queue.

Select a call queue for which you want to configure queue call handling actions and click
Edit.

In Call Handling, click Configure call handling.

Configure the situation upon which the FortiVoice unit can be configured to take
corresponding actions:

GUI field Description

Overflow The situation when callers exceed the maximum waiting callers
you set. See “Maximum caller” on page 259.

A popup notification appears when this barometer is triggered.

Waiting Timeout Callers waiting time exceeds the maximum waiting time set in
“Queue time” on page 259.

A popup notification appears when this barometer is triggered.

Non Business Hour The option to schedule call handlings for after-hour time slots.

Click OK.

Configuring call parking

Call park is a feature for placing a call on hold and then retrieving it from any other local
extension. By default, the FortiVoice unit has 20 park orbits, 301-320.

To

To
1.
2.

Fortinet Technologies Inc.

view the parked calls, see “Viewing parked calls” on page 26.

configure call parking
Go to Call Features > Call Parking > Call Parking.
For Park call number, enter the number to dial to park a call. The default is 300.

For example, if you enter 300, depending on the phone, when a user receives a call and
wants to park it, the user may:

e Press *1300.

The FortiVoice unit selects the first available park orbit (301-320). The user hears a
confirmation indicating the caller has been parked successfully and into which park orbit.

By default, dialing *1 and then 300 parks a call.

¢ Provide the park orbit to the person with the parked call through paging or other means
(e.g. “Mary, there is a call parked for you in 301”. Mary can then pick up any phone and
dial 301 to retrieve the parked call.).

For Park line start, enter the starting park orbit. The default is 301.
For Park line end, enter the ending park orbit. The default is 320.
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For Parking time out, enter the time, in seconds, to time out the parked call. The default is 60
seconds.

For Music on hold, select the music on hold file to play while the call is place on hold. Click
Edit to modify the selected file or click New to configure a new one. For more information on
music on hold, see “Managing sound files and music on hold” on page 116.

Click Apply.

Configuring fax

The FortiVoice unit supports fax in the following ways:

Use the FortiVoice unit to send and receive faxes. The FortiVoice unit contains a full featured
fax server that is able to receive faxes and forward them in PDF format to an extension’s user
web portal or a user’s email. End users can log into their web portal to view the faxes and
upload PDF or JPEG files to send faxes. For configuration information, see “Receiving
Faxes” on page 262 and “Sending faxes” on page 264.

If you want to continue using your fax machine with the VolP phone system, connect the fax
machine to an adapter (such as OBIHAI OBi 200, Cisco SPA 112, or Grandstream HT 702)
that supports T.38 first before connecting to the FortiVoice unit. T.38 is a protocol designed
to allow fax to travel over a VolP network.

In this case, the fax machine is treated like an extension. The FortiVoice unit receives faxes
and relays them to the fax machine. Faxes sent from the fax machine will follow the fax
sending dial plans.

To use this option, you need to create and enable the fax extensions first. You then need to
configure the FortiVoice unit to receive and relay the faxes to the fax machine. See
“Configuring fax extensions” on page 152, “Receiving Faxes” on page 262 and “Sending
faxes” on page 264.

With FortiVoice 200D-T, if you want to use your existing analog phone line, connect the fax
machine directly to the FXS port. Make sure that the fax function is enabled when
configuring the analog extension. See “Modifying analog extension (200D-T, 1000E-T, and
20E2 models only)” on page 146.

Receiving Faxes

Configure the FortiVoice unit to receive faxes over the VolP network and forward the faxes to
extensions or emails. You can configure one or more faxes to meet the needs of different
departments, for example.

To configure receiving faxes

1.

Go to Call Features > Fax > eFax Account and click New.

2. Configure the following:

Fortinet Technologies Inc.
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Table 2: Fax receiving configuration

Mame:

Number:

Display name:
Enabled:

External Numbers

El New... | & ]

[] Show suggested numbers

Enabled |Incoming trunk

~| Select Fax Monitors
~| Fax to Email
~| Relay to Fax Machine

~| Archive

Description:

Create Cancel

GUI field
Name

Number
Display name

Show suggested
numbers

Enabled

External Numbers

Fortinet Technologies Inc.

DID numbers

Description
Enter a name for the receiving fax configuration.

Enter an extension for this fax. This is where the incoming faxes go
to.

Enter the name displaying on the extension.

Select and click in the Number field to display the extension numbers
available for use. If it is deselected, clicking in the Number field
displays the extension numbers already in use.

This option also serves as a diagnostic tool for finding and fixing
duplicate or missing numbers. Missing numbers are the extensions
that have user IDs but not numbers.

When there are duplicate or missing numbers, an orange
exclamation mark icon appears beside this option. You can click the
icon and fix the numbers. For more information, see “Fixing duplicate
or missing numbers” on page 142.

Select to activate this fax.

Map the DID numbers to the extension of the fax. Incoming faxes to
the DIDs will all reach the extension. For information on DID, see
“Mapping DIDs” on page 199.

To map the DID numbers:

e Click New.

e Select Enabled to activate this DID mapping.

¢ Select the trunk used for dialing the DIDs.

e Enter the DID number that you want to map to an extension.
¢ Click Create.
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Select Fax Monitors Select the users that can monitor the faxes received on this fax
extension in their FortiVoice user web portal and can choose to view,
delete, resend, forward, or download the faxes. For more
information, see the online help of the web user portal.

The selected users will also receive email notifications when a fax is
received if their extensions are linked with email addresses. The
notification will also have a PDF attachment of the fax if their
extensions are configured with email notification attachment option.
For more information, see “Setting extension user preferences” on
page 156.

This is useful if you have a fax that serves several departments.

Fax to Email Enter the email addresses to receive the faxes sent to this extension.
Users will receive the faxes in PDF format.

Relay to Fax Select the fax machines connected to the FortiVoice unit via T.38

Machine adapters. Faxes will be relayed to the selected machines.

Archive Select Fax archive to activate fax archiving. Enter the maximum
number of faxes to archive and the maximum number of days to
keep them.

To view faxes sent and received through the FortiVoice unit, see
“Viewing archived faxes” on page 31.

Description Optionally, you can enter some notes about this configuration.

3. Click Create.

Sending faxes
Configure the dial plans for sending faxes. The dialed fax numbers matching the configured
number pattern will be subject to the call handling actions.

The fax sending dial plans will not interfere with phone call dial plans since the FortiVoice unit
deals with the dial plans separately.

For information on dial plans, see “Configuring Call Routing” on page 195.

You send faxes in the user web portal. Senders will receive email notifications when a fax is sent
if their extensions are linked with email addresses. The notification will inform if the fax has been
successfully sent and have a PDF attachment of the fax if their extensions are configured with
email notification attachment option. For more information, see “Setting extension user
preferences” on page 156.

In addition, senders can always view the status of the fax sent in their FortiVoice user web
portal. For more information, see the online help of the web user portal.

To view the outbound dial plans, go to Call Features > Fax > Sending Rule.
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Figure 7: Viewing dial plans for sending faxes

=g Mew... ] > | T = 2 Test
o Page 1 /1 Records per page: 25 w
Enabled Name Pattern Call Handling
fax_out_ottawa E1330000000 343000000, any_time : pri1
fxo_fax_out_ottawa 2613000000 2343000000,  any_time : line1
GUI field Description
Test Select to test if the dial plan is created successfully.
For more information, see “Testing dial plans for sending faxes” on
page 266.
Enabled Select to activate this dial plan.
Name The name of the dial plan.
Pattern The phone number pattern in the dial plan that matches other numbers.

For details, see “Dialed Number Match” on page 266.

Call handling The call handling action for the numbers matching the configured
number pattern and the caller IDs matching the caller ID pattern. For
details, see “Call Handling” on page 266.

To set up a fax sending dial plan

1. Go to Call Features > Fax > Sending Rule.
2. Click New.

3. Configure the following:

Figure 8: Dial plan for sending faxes

Name:

Enabled: [7]

Dialed Number Match

El New,,. | B4 i

Call Handling

..| Warning Mes=sage | Account Code

GUI field Description
Name Enter a name for this plan.
Enabled Select to activate this dial plan.
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Dialed Number Match With dialed number pattern matching, you can create one
phone number pattern in your dial plan that matches many
different numbers.

The dialed numbers matching this pattern will follow this dial
plan rule.

For information on adding a dialed number match, see
“Creating dialed number match” on page 267.

Call Handling Click New to configure the call handling action for the
numbers matching the configured number pattern. For details,
see “Configuring call handling actions” on page 268.

4. Click Create.

Testing dial plans for sending faxes

After you create a dial plan, you can select the dial plan and click Test to see if the dial plan
works.

For more information, see “Test” on page 265.

To test a dial plan

1. Go to Call Features > Fax > Sending Rule.

2. Select the dial plan that you want to test and click Test.
The call test page appears.

3. Configure the following:

Figure 9: Testing dial plans

System Configuration Test

Test Call - Dry Run Test Call

Destination number:

From number:
Test result:

Test Reset
GUI field Description
Test Call - Dry Run Run a system outbound dial plan test without making a real

phone call.
Destination number Enter a destination number to call.

From number Enter the number from which you want to call the destination
number. The FortiVoice unit will connect this number with the
destination number for the test.

Test Click to start the dry run test and view the Test result.
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Reset Click to remove the test result in order to start a new test.
Test Call Test the dial plan by making a real phone call.
Destination number Enter a destination number to call.

After call is Select the FortiVoice action once it calls the destination
established number:

* Play welcome message: The FortiVoice unit will play a
message to the destination number.

e Connect test call to number: In the Number field, enter the
number from which you want to call the destination
number. The FortiVoice unit will connect this number with
the destination number to test the trunk.

Test Click to start the test and view the Test resuilt.

Reset Click to remove the test result in order to start a new test.

Creating dialed number match

You can create one extension number pattern in your dial plan that matches many different
numbers for outbound calls.

The numbers matching this pattern will follow this dial plan rule.
The FortiVoice unit supports the following pattern-matching syntax:

Table 3: Pattern-matching syntax

Syntax |Description

X Matches any single digit from 0 to 9.
Z Matches any single digit from 1 to 9.
N Matches any single digit from 2 to 9.

[15-7] |Matches a single character from the range of digits specified. In this case, the
pattern matches a single 1, as well as any number in the range 5, 6, 7.

Wildcard match; matches one or more characters, no matter what they are.

! Wildcard match; matches zero or more characters, no matter what they are.

Table 4: Pattern-matching examples

Pattern Description

NXXXXXX Matches any seven-digit number, as long as the first digit is 2 or higher.

NXXNXXXXXX | This pattern matches with areas with 10-digit dialing.

TNXXNXXXXXX | Matches the number 1, followed by an area code between 200 and 999,
then any seven-digit number. In the North American Numbering Plan calling
area, you can use this pattern to match any long-distance number.

011. Matches any number that starts with 011 and has at least one more digit.
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To create a dialed number match

1. Go to Call Features > Fax > Sending Rule.

2. Click New.

3. In Dialed Number Match, click New.

4. Configure the following:

Figure 10: Creating a number match

Match Pattern

EF New... i

Pattern String

Maodification

Strip:
Prefix
Postfic

Create Cancel

GUI field
Match Pattern

New

Modification

Strip

Prefix

Postfix

5. Click Create.

Description

Click to add the number pattern in the Value field following
“Pattern-matching syntax” on page 267 and “Pattern-matching
examples” on page 267 for this dial plan. Repeat to add more
patterns.

You can manipulate the number patterns you entered.

Enter a number to omit dialing the starting part of a pattern. 0
means no action.

For example, if your Match Pattern is 9XXX and Strip is 1, you
only need to dial the last three digits for this pattern.

Add a number before a pattern, such as area code.

For example, if your Match Pattern is 123XXXX and its area
code is 555, you can enter 555 for the Prefix. When you dial a
number under this pattern, you do not need to dial the area
code 555.

Add a number after a pattern.

For example, if your Match Pattern is 9XXX and the numbers
under this pattern have been upgraded to have an additional
digit 5 at the end, you can enter 5 for the Postfix. When you dial
a number under this pattern, you do not need to dial the last
digit 5.

Configuring call handling actions

Configure the call handling action for the numbers matching the configured number pattern.
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To configure the call handling action

1. Go to Call Features > Fax > Sending Rule.

. Click New.

2
3. In Call Handling, click New.
4

. Configure the following:

GUI field
Call Handling Action

Schedule

Action

Outgoing trunk

Caller ID
modification

Warning message

Delay

5. Click Create.

Configuring other fax settings

Description

Select the FortiVoice operation schedule to implement this
plan. Click Edit to modify the selected schedule or click New to
configure a new one. For more information on PBX schedule,
see “Scheduling the FortiVoice unit” on page 132.

Select the call handling action for the numbers matching the
configured number pattern and the caller IDs matching the
caller ID pattern.

Select the trunk for sending faxes. Click Edit to modify the
selected trunk or click New to configure a new one. For more
information on trunks, see “Configuring Trunks” on page 177.

Select the caller ID modification configuration. Click Edit to
modify the selected configuration or click New to configure a
new one. For more information on caller ID modification, see
“Modifying caller IDs” on page 120.

If you select Allow with warning or Deny with warning in the
Action field, select the sound file for the warning. Click Edit to
modify the selected file or click New to configure a new one.
For more information on sound files, see “Managing sound files
and music on hold” on page 116.

Optionally, if you want to discourage certain users for sending
faxes, enter the call delay time in seconds.

Configure the station IDs, fax header, T.38 fax options, and fax sending queue for outgoing

faxes.

To configure fax settings

1. Go to Call Features > Fax > Setting.

2. Configure the following:
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Figure 11: Fax settings

Receive || Send m

System station id: | FO200D00RDO00001

System fax header: | fortivoice e-fax
T.38 Fax

J|Initiate a T.38 reinvite if the remote end does not
V| Falback to audio (G.711) mode on T.38 failure

Send Queue

Max retry times: 3
Retry interval: 50

Wait time for an answer: | 30

Apply Cancel

GUI field

System station ID

System fax header

T.38 Fax

Initiate a T.38
reinvite if the
remote end does
not

Fallback to audio
(G.711) mode on
T.38 failure

Send Queue

Max retry times

Retry interval

Wait time for an
answer

3. Click Apply.

Archiving faxes

(Seconds)

(Seconds)

Description

Enter a station ID that shows on each fax sent from the
FortiVoice unit.

Enter a fax subject header that shows on each fax sent from
the FortiVoice unit.

Select if the fax receiving terminal does not reply to a T.38
invitation.

Select to use G.711 mode if T.38 communication fails.

Enter the maximum number of times to resend a fax. This is
useful if a fax cannot be sent due to busy lines or other
reasons.

Enter the time interval between fax sending retries.

Enter the waiting time for a “go-ahead” signal from the fax
receiving terminal. After the waiting time is over, the FortiVoice
unit will either retry to send the fax or stop sending it
depending on the Max retry times configuration.

Configure the settings to archive the faxes.

To configure archiving faxes

1. Go to Call Features > Fax > Archive.
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Figure 12: Recording archive settings

Rotation Settings

Fax Archive Settings

The archived Fax will rotate when either the file size or rotation time is reached.

Fax rotation size: 10 (MB)
Fax rotation time: 1 (day) Athour | 1 7
Archiving options when disk quota is full: | Overwrite e
« | Destination Settings
Destination: Remote -t
Local disk quota: (GB)
Protocol: FTP e
IP address: 172.20.140.117
User name: chenxhao
Password: ssssee
Remote directory: fuc-archive
Remaote cache quota: | 2 (GB)
Apply Cancel
2. Configure the following:
GUI field Description
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Rotation Settings

Fax rotation
size/time

Archiving options
when disk quota is
full

Destination Settings

Destination

Local disk quota

Enter the archived fax file rotation size and time.

When the file reaches either the rotation size or time specified,
whichever comes first, the archiving file is automatically renamed.
The FortiVoice unit generates a new file, where it continues
saving recording archives. You can access all rotated files
through search.

Specify what the FortiVoice unit should do if it runs out of disk
space. Select Overwrite to remove the oldest archived folder in
order to make space for the new archive, or select Do not archive
to stop archiving more recorded calls.

Select an archiving destination:

e [ ocal: the FortiVoice unit’s local hard drive or a NAS server.
* Remote: a remote FTP or SFTP storage server.

If Local is the archiving destination, enter the disk space quota.

The total disk quota for archiving calls cannot exceed 20% of the
total data disk size. For example, if the data disk has a size of 100
GB, a maximum of 20 GB can be used for fax archiving.

If this quota is met and a new fax must be archived, the
FortiVoice unit either automatically removes the oldest fax archive
folder in order to make space for the new archive or stops
archiving, depending on the settings you specify under “Rotation
Settings” on page 255.

If Remote is the archiving destination, configure the following:
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Protocol Select the protocol that the FortiVoice unit will use to connect to
the remote storage server, either SFTP or FTP.

IP address Enter the IP address of the remote storage server.

User name Enter the user name of an account the FortiVoice unit will use to
access the remote storage server, such as FortiVoice.

Password Enter the password for the user name of the account on the
remote storage server.

Remote directory Enter the directory path on the remote storage server where the
FortiVoice unit will store archived calls, such as
/home/fortivoice/call-archives.

Remote cache Enter the FortiVoice cache quota that is allowed to be used for
quota remote host archiving. The above statement regarding the Local
disk quota also applied to the cache quota.

3. Click Apply.

Setting calendar reminder

You can schedule daily events and send event reminders. You first create a reminder record
before setting up reminder events. One reminder record can contain multiple reminder events.

To schedule an event

1. Go to Call Features > Reminder and click New.

2. Enter a name for the reminder.

3. Enable the reminder and add notes if required.

4. Click Create.

5. In the reminder list, select the reminder record you just created.

6. Click Edit in calendar mode.

7. Click a date.

8. Configure the following:
GUI field Description
Title Enter a name for the reminder event.
Location Enter the location for the event.
Start time Specify when the event starts.
Recurrence Click None to configure recurrence settings.
Description Enter any notes as required.
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Guest

Reminder audio

Click Add to select the internal and external phone numbers to
which you want to send event reminder calls.

If you want to delete a number, select the number and click
Remove.

Configure the reminder audio that are sent to the selected guest
phones.

e Default: The reminder audio will be a beep sound.

e Create New: Click to customize the reminder audio. For
Action, click Call me to record a message from an extension;
Upload to look for an existing reminder audio; and Download
to save the audio file. For Extension, if you select Call me for
Action, select the extension on which you want to record a
message.

e C(Click Create and Create to exit.

Modifying feature access codes

By default, the FortiVoice unit defines the following codes for users to access certain features
by dialing the codes. You can go to Call Features > Feature Code > Feature Code and
double-click a feature name to modify its code and description, but that does not change the
mapping between the code and the feature. For example, if you change the DISA code from the

default ** to 12, dialing 12 still accesses the DISA feature.

Table 5: Feature access codes

GUI field

Description

Call bridge (DISA)

Direct Inward System Access (DISA) service allows external users to dial
into PBX and use PBX service just like the local extensions.

To use DISA, dial the PBX main number and then ** or the code you set.
The PBX will prompt you to enter the account code (account code set at
PBX > Class of Service > Account code). Once you pass authorization,
you can use PBX service just like a local extension.

Blind transfer

Blind transfer serves 2 purposes:

e During a call, dial *1 or the code you set and then the extension
number of a second person to transfer the call to the person without
talking to the person.

e During a call, dial *1 and then the call parking number (default is 300)
to park a call. For details, see “Configuring call parking” on page 261.

Check hot desk
login status

Hot-desking refers to the sharing of one phone by multiple users at
different time periods.

Dial *10 or the code you set to check hot desk login status including login
expiry time.

Hot desk user
login

Hot-desking refers to the sharing of one phone by multiple users at
different time periods. Each user can log into the phone by pressing *11
or the code you set and enter his extension number and voicemail PIN
following the prompts.

Fortinet Technologies Inc.

Page 273 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Table 5: Feature access codes

GUI field

Description

Hot desk user
logout

To log out hot desking, press *12 or the code you set.

Reset phone to be
'unassigned' by
admin

This code is used to remove the extension number of a FortiFone by the
administrator.

Dial *15 or the code you set on any FortiFone that connects to the
FortiVoice unit and enter the phone configuration PIN.

For information on setting the phone configuration PIN, see “Configuring
SIP phone auto-provisioning” on page 111.

Reset phone to be
'unassigned' by
user

This code is used to remove the extension number of a FortiFone by the
user.

Dial *16 or the code you set on your FortiFone that connects to the
FortiVoice unit and enter the phone configuration PIN.

For information on setting the phone configuration PIN, see “Configuring
SIP phone auto-provisioning” on page 111.

Configure phone
to extension by
administrator

This code is used to set an extension number for a FortiFone by the
administrator.

Dial *17 or the code you set on any FortiFone that connects to the
FortiVoice unit and enter the phone configuration PIN. You can then enter
an existing extension to set it as the extension of this phone.

For information on setting the phone configuration PIN, see “Configuring
SIP phone auto-provisioning” on page 111.

Configure phone
to extension by
user

This code is used to set an extension number for a FortiFone by a phone
user.

Dial *18 or the code you set on your FortiFone that connects to the
FortiVoice unit and enter the phone configuration PIN provided by the
administrator. You can then enter an existing extension to set it as the
extension of this phone.

Attended transfer

During a call, dial *2 or the code you set and then the extension number
of a second person to transfer the call to the person. Since you want to
inform the second person about the call, you can have a private
conversation with the person without the first person who made the call
hearing it.

Personal Dial *3 or the code you set to record a phone conversation.

recording Before doing so, have the agreement of the person you talk with or check
your local laws regarding phone recording.

Park Dial *4 or the code you set to park a call.

Lookup name
directory from
extension

Dial *411 or the code you set to access the phone directory where you
can look for an extension by entering a person’s name.
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Table 5: Feature access codes

GUI field

Description

Barge

Dial *5 or the code you set to monitor a call by listening to it. You also
need to enter your voicemail PIN. For details, see “Monitor/Recording’
on page 247

i

Agent login to all
queues

Dial *61 or the code you set to log into the queues of which your
extension is a member.

Agent logout from
all queues

Dial *62 or the code you set to log out of the queues of which your
extension is a member.

Agent login to a
queue

Dial *63 or the code you set and enter your voicemail password and the
queue extension to log into this queue.

The voicemail password is required only if this option is selected for your
extension. For more information, see “Call Center” on page 141.

Agentlogin from a
queue

Dial *64 or the code you set and enter your voicemail password and the
queue extension to log out of this queue.

The voicemail password is required only if this option is selected for your
extension. For more information, see “Call Center” on page 141.

Login all queue
members

Dial *65 or the code you set to login all members of a queue of which
your extension is a member. This is an action by the administrator.

Logout all queue
members

Dial *66 or the code you set to logout all members of a queue of which
your extension is a member. This is an action by the administrator.

Pause agent all
queues

Dial *67 or the code you set and enter your voicemail password and the
reason code to pause all queues of which this extension is a member.

For information on reason codes, see “Modifying agent reason code
descriptions” on page 225.

Unpause agent all
queues

Dial *68 or the code you set and enter your voicemail password and the
reason code to unpause all queues of which this extension is a member.

For information on reason codes, see “Modifying agent reason code
descriptions” on page 225.

Set call forward

Dial *71 followed by a code to set user’s call forward: 1 to enable, 0 to
disable, and 9 to change the forwarding number.

User’s quick mode
switch

Dial *72 followed by 1, 2, or 3 and enter your voicemail password to
temporarily replace the original personal schedule with one of the three
default ones. You may also modify the temporary schedule. Dial *720 to
go back to the original schedule.

User’s twinning
mode switch

Dial *73 followed by 1 to enable twinning and 0 to disable twinning. For
information on twinning, see “Twinning Setting” on page 161.
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Table 5: Feature access codes

GUI field

Description

Hotel room
condition

Dial *75 or the code you set and enter a maid code to show the room
condition.

The maid codes include:
e 1: Maid present
e 2:Clean

: Not clean

: Out of service

: To be inspected
: Occupied/clean

: Occupied/not clean

[ ]
O N O OO b~ WDN =2

e 8:Vacant/clean

©

: Vacant/not clean

For information on maid codes, see “Configuring hotel management
settings” on page 232.

Minibar
notification

Dial *76 or the code you set and enter a minibar code to order room
items.

For information on minibar codes, see “Configuring hotel management
settings” on page 232.

Wake-up call

Dial *77 or the code you set and enter a time for a wake-up call. The time
format should be in the format of hhmm. For example, 15:30 is entered as
1530.

DND on

Dial *78 or the code you set to turn on the Do Not Disturb service. Callers
will hear the busy sound when they dial your number.

DND off

Dial *79 or the code you set to turn off the Do Not Disturb service.
Otherwise, callers will hear the busy sound when they dial your number.

Pickup any ringing
extension in
pickup group

As a pickup group member, you can dial *80 or the code you set on your
phone to pick up a call from any ringing extension.

For information on pickup groups, see “Creating pickup groups” on
page 170.

Pickup group
extension

As a pickup group member, you can dial *81 or the code you set on your
phone followed by a ringing extension number to pick up a call from that
extension.

For information on pickup groups, see “Creating pickup groups” on
page 170.

System schedule
override

An administrator with the privilege can dial *82 followed by 1, 2, or 3 and
the administrator PIN to temporarily replace the original system schedule
with one of the three default ones. You may also modify the temporary
schedule. Dial *820 to go back to the original schedule. See “Configuring
system capacity” on page 116.

Intercom

Dial *92 or the code you set and an extension to intercom that extension.
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Table 5: Feature access codes

GUI field Description

Voicemail direct | Dial *97 or the code you set from your own phone and then enter your
voicemail password to directly access your voice mailbox.

Voicemail prompt |Dial *98 or the code you set from any extension and then enter your
extension number and voicemail password to access your voice mailbox.

Operator Dial 0 or the code you set to access the operator.

One key DND This is for supporting the DND key on the FortiFones. Press the DND key
on the FortiFone to turn DND on or off.

Unpark This is for supporting the Unpark key on the FortiFones. Press this key on
the FortiFone to unpark a call.
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Configuring Logs and Reports

The Log & Report menu lets you configure FortiVoice logging and reporting.

FortiVoice units provide extensive logging capabilities for voice incidents and system events.
Detailed log information provides analysis of network activity to help you identify network issues
and reduce network misuse and abuse.

Logs are useful when diagnosing problems or when you want to track actions the FortiVoice unit
performs as it receives and processes phone calls.

Reports provide a way to analyze log data without manually going through a large amount of
logs to get to the information you need.

This topic includes:

¢ About FortiVoice logging

¢ Configuring logging

¢ Configuring report profiles and generating call reports
¢ Configuring Station Messaging Detail Record (SMDR)
¢ Configuring alert email

About FortiVoice logging

FortiVoice units can log:
e system-related events, such as configuration changes and administrator login/logout
e phone call events

You can select which severity level an activity or event must meet in order to be recorded in the
logs. For more information, see “Log message severity levels” on page 279.

A FortiVoice unit can save log messages to its hard disk or a remote location, such as a Syslog
server or a FortiAnalyzer™ unit. For more information, see “Configuring logging” on page 280. It
can also use log messages as the basis for reports. For more information, see “Configuring
report profiles and generating call reports” on page 284.

This topic includes:

¢ FortiVoice log types
* |og message severity levels

FortiVoice log types
FortiVoice units can record the following types of log messages. The Event log also contains

several subtypes. You can view and download these logs from the Logs submenu of the Status
tab.
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Table 6: Log types

Log type Subtype Description
Event config Includes system and administration events, such as
admin downloading a backup copy of the configuration.
system
smtp
ha
dhcp
voicemail
monitor
Voice Includes phone calls events.
Fax Includes fax events.
DTMF Includes DTMF (Dual Tone Multi-Frequency) events.
Hotel Includes hotel management events, such as guest
check-in and check-out.
Call center [IVR Includes call center events.

extended period of time. Excessive logging frequency can cause undue wear on the hard disk

c Avoid recording highly frequent log types such as voice logs to the local hard disk for an

and may cause premature failure.

Log message severity levels

Each log message contains a field that indicates the severity level of the log message, such as

warning.

Table 7: Log severity levels

Levels

Description

0 - Emergency

Indicates the system has become unusable.

1 - Alert

Indicates immediate action is required.

2 - Critical

Indicates functionality is affected.

3 - Error

Indicates an error condition exists and functionality could be
affected.

4 - Warning

Indicates functionality could be affected.

5 - Notification

Provides information about normal events.

6 - Information

Provides general information about system operations.

6 - Debug

Provides information useful to debug a problem.

For each location where the FortiVoice unit can store log files, you can define the severity
threshold of the log messages to be stored there.
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is one possible cause of frequent logging. Excessive logging frequency can cause undue wear
on the hard disk and may cause premature failure.

Avoid recording log messages using low severity thresholds such as Information or
Notification to the local hard disk for an extended period of time. A low log severity threshold

The FortiVoice unit stores all log messages equal to or exceeding the severity level you select.
For example, if you select Error, the FortiVoice unit stores log messages whose severity level is
Error, Critical, Alert, or Emergency.

Configuring logging

The Log Settings submenu includes two tabs, Local Log Settings and Remote Log Settings,
that let you:

¢ set the severity level
e configure which types of log messages to record
e specify where to store the logs

You can configure the FortiVoice unit to store log messages locally (that is, in RAM or to the hard
disk), remotely (that is, on a Syslog server or FortiAnalyzer unit), or at both locations.

Your choice of storage location may be affected by several factors, including the following:
¢ Local logging by itself may not satisfy your requirements for off-site log storage.

¢ Very frequent logging may cause undue wear when stored on the local hard drive. A low
severity threshold is one possible cause of frequent logging. For more information on
severity levels, see “Log message severity levels” on page 279.

For information on viewing locally stored log messages, see “Viewing log messages” on
page 33.

This section includes the following topics:

¢ Configuring logging to the hard disk

e Choosing which events to log

¢ Configuring logging to a Syslog server or FortiAnalyzer unit

Configuring logging to the hard disk

You can store log messages locally on the hard disk of the FortiVoice unit.

To ensure that the local hard disk has sufficient disk space to store new log messages and that
it does not overwrite existing logs, you should regularly download backup copies of the oldest
log files to your management computer or other storage, and then delete them from the
FortiVoice unit. (Alternatively, you could configure logging to a remote host.)

You can view and download these logs from the Log submenu of the Monitor tab. For more
information, see “Viewing log messages” on page 33.

For logging accuracy, you should also verify that the FortiVoice unit’s system time is accurate.
For details, see “Configuring the time and date” on page 75.

To configure logging to the local hard disk

1. Goto Log & Report > Log Settings > Local Log Settings.

2. Select the Enable option to allow logging to the local hard disk.
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3.

6.

In Log file size, enter the file size limit of the current log file in megabytes (MB). The log file
size limit must be between 10 MB and 1000 MB.

In Log time, enter the time (in days) of file age limit.
In At hour, enter the hour of the day (24-hour format) when the file rotation should start.

When a log file reaches either the age or size limit, the FortiVoice unit rotates the current log
file: that is, it renames the current log file (elog.log) with a file name indicating its sequential
relationship to other log files of that type (elog2.log, and so on), then creates a new current
log file. For example, if you set the log time to 10 days at hour 23, the log file will be rotated
at 23 o’clock of the 10th day.

y Large log files may decrease display and search performance.

From Log level, select the severity level that a log message must equal or exceed in order to
be recorded to this storage location.

From Log options when disk is full, select what the FortiVoice unit will do when the local disk
is full and a new log message is caused, either:

¢ Do not log: Discard all new log messages.

e Qverwrite: Delete the oldest log file in order to free disk space, and store the new log
message.

In Logging Policy Configuration, click the arrow to review the options and enable the types of
logs that you want to record to this storage location. For details, see “Choosing which
events to log” on page 281.

Click Apply.

Choosing which events to log

Both the local and remote server configuration recognize the following events. Select the check
boxes of the events you want to log.
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Table 8: Events logging options

Event Log Select this check box and then select specific events. No event types
are logged unless you enable this option.

e When configuration has changed: Log configuration changes.

e Admin login/logout event: Log all administrative events, such as
logins, resets, and configuration updates.

e System activity event: Log all system-related events, such as
rebooting the FortiVoice unit.

e SMTP server event: Log SMTP relay or proxy events. This option is
for local log setting only.

® HA: Log all high availability (HA) activity.

e DHCP event: Log DHCP server events. This option is for local log
setting only.

e Voice mail event: Log voicemail events. This option is for remote log
setting only.

e Monitor: Log call recording, call barging, and traffic capture events.

Voice Log Log phone call events. This option is for local log setting only.

Fax Log Log fax events.

DTMF Log DTMF (Dual Tone Multi-Frequency) events.

Hotel Log Log hotel management events, such as guest check-in and check-out.
Call Center Log Log call center events, such as IVR events.

Configuring logging to a Syslog server or FortiAnalyzer unit

Instead of or in addition to logging locally, you can store log messages remotely on a Syslog
server or a FortiAnalyzer unit.

You can add a maximum of three remote Syslog servers.

( - Logs stored remotely cannot be viewed from the web-based manager of the FortiVoice unit. If
7 you require the ability to view logs from the web-based manager, also enable local storage.
Lt For details, see “Configuring logging to the hard disk” on page 280.

Before you can log to a remote location, you must first enable logging. For details, see
“Choosing which events to log” on page 281. For logging accuracy, you should also verify that
the FortiVoice unit’s system time is accurate. For details, see “Configuring the time and date” on
page 75.

To configure logging to a Syslog server or FortiAnalyzer unit
1. Goto Log & Report > Log Settings > Remote Log Settings.

GUI field Description
Enabled Select to enable remote storage on the server. Clear to disable
storage.
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2.

Fortinet Technologies Inc.

Profile Name
Server

Port

Level

Facility

GUI field

Log to Remote Host

Enable
Name

IP

Level

Port

Facility

CVS format

Logging Policy
Configuration

Click Create.

Displays the remote host hame.

Displays the IP of the Syslog server or FortiAnalyzer unit.
Displays the port on the Syslog server or FortiAnalyzer unit.
Displays the minimum severity level for logging purposes.

Displays the facility identifier the FortiVoice unit uses to identify itself.

Click New to create a new entry or double-click an existing entry to modify it.

Description

Select to allow logging to a remote host.
Enter a name for the remote host.

Enter the IP address of the Syslog server or FortiAnalyzer unit
where the FortiVoice unit will store the logs.

Select the severity level that a log message must equal or exceed
in order to be recorded to this storage location.

For information about severity levels, see “Log message severity
levels” on page 279.

If the remote host is a FortiAnalyzer unit, enter 514; if the remote
host is a Syslog server, enter the UDP port number on which the
Syslog server listens for connections (by default, UDP 514).

Select the facility identifier that the FortiVoice unit will use to
identify itself when sending log messages.

To easily identify log messages from the FortiVoice unit when they
are stored on a remote logging server, enter a unique facility
identifier, and verify that no other network devices use the same
facility identifier.

Enable this option if you want to send log messages in
comma-separated value (CSV) format.

Do not enable this option if the remote host is a FortiAnalyzer
unit. FortiAnalyzer units do not support CSV-formatted log
messages.

Click the arrow to review the options and enable the types of logs
you want to record to this storage location. For details, see
“Choosing which events to log” on page 281.

If the remote host is a FortiAnalyzer unit, confirm with the FortiAnalyzer administrator that the
FortiVoice unit was added to the FortiAnalyzer unit’s device list, allocated sufficient disk
space quota, and assigned permission to transmit logs to the FortiAnalyzer unit. For details,
see the FortiAnalyzer Administration Guide.
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5. To verify logging connectivity, from the FortiVoice unit, trigger a log message that matches
the types and severity levels that you have chosen to store on the remote host. Then, on the
remote host, confirm that it has received that log message.

For example, if you have chosen to record event log messages to the remote host and if they
are more severe than Information, you could log in to the web-based manager or download a
backup copy of the FortiVoice unit’s configuration file in order to trigger an event log
message.

If the remote host does not receive the log messages, verify the FortiVoice unit’s network
interfaces (see “Configuring the network interfaces” on page 41 and “About the
management IP” on page 40) and static routes (see “Configuring static routes” on page 46),
and the policies on any intermediary firewalls or routers. If ICMP ECHO (ping) is enabled on
the remote host, you can use the execute traceroute command to determine the point where
connectivity fails. For details, see the FortiVoice CLI Reference.

Configuring report profiles and generating call reports

The Log & Report > Call Report > Call Report tab displays a list of report profiles.

A report profile is a group of settings that contains the report name, its subject matter, its
schedule, and other aspects that the FortiVoice unit considers when generating reports from log
data. The FortiVoice unit presents the information in tabular and graphical format.

You can create one report profile for each type of report that you will generate on demand or on
a schedule.

Generating reports can be resource intensive. To avoid phone processing performance
impacts, you may want to generate reports during times with low traffic volume, such as at
night. For more information on scheduling the generation of reports, see “Configuring report
email notifications” on page 288.

To view and configure report profiles
1. Go to Log & Report > Call Report > Call Report.
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Figure 13: Configuration tab

EF New... & 0] View Reports V\ew supported query

< Page 1 /1 Records per page: 50 >

o None

1oz None

1201 None

1202 None

GUI field Description

Generate Select a report and click this button to generate a report

immediately. See “Generating a report manually” on page 289.

View Reports Click to display the list of reports generated by the FortiVoice unit.
You can delete, view, and/or download generated reports. For more
information, see “Viewing generated reports” on page 32.

Report Name Displays the name of the report profiles.

Schedule Displays the frequency with which the FortiVoice unit generates a
scheduled report. If the report is designed for manual generation,
Not Scheduled appears in this column.

2. Click New to add a profile or double-click a profile to modify it.
A multisection dialog appears.

Figure 14: New report configuration

Report Setting
Name:
4| Query List

Ef New.., | 2 i

Category Subcategory 0 Report column Sort column

- | Period
~ | Email
= Schedule

| Rate Setting

3. In Name, enter a name for the report profile.
Report names cannot include spaces.
4. Click the arrow next to each option, and configure the following as needed:
e Configuring the report query selection
¢ Configuring the report time period
¢ Configuring report email notifications
e Configuring the report schedule
¢ Choosing call rate
¢ Generating a report manually
5. Click Create.

Configuring the report query selection

When configuring a report profile, you can select the queries that define the subject matter of
the report.
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Each report profile corresponds to a chart that will appear in the generated report.

To configure the report query selection
Go to Log & Report > Call Report > Call Report.

1.
2
3.
4. Configure the following:

Fortinet Technologies Inc.

. Click New.

Expand Query List and click New.

Figure 15: Query selection

Query

MName:

Category: Cal_Usage aa

Subcategory: | Summary ot

Fram: Internal R

To: External Ed

Region: Any R

Report column: caller w

Sort column: Report colurmn bk

Separate table: | Default —

Create Cancel J

GUI field Description

Name Enter a name for this query.

Category Select a category for the report profile. The report chart will
correspond to the category selected.
e Call Usage: The number of calls.
* Phone Bill: The cost of making the phone calls.
e Trunk Usage: The status of the trunks being used.

Subcategory Select to have a summary or detailed report on the report category
you select.

From Select to include the source of the incoming calls: Internal, External,
or Any.

To Select to include the source of the outgoing calls: Internal, External,
or Any.

Region Select the call region, such as international or long-distance.

Report column

Select the source of the call statistics: from caller or receiver. For
details, see Figure 16 on page 287.
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Sort column Select the value for filtering the call information. The caller or receiver
with the higher value moves to the top of the table.

If you select Report column, the sort column value is equal to what
you select in the Report column field.

For details, see Figure 16 on page 287.

Separate table Depending on the query values, if a report table is too long, it can be
divided into separate tables. Selecting Default keeps the pre-defined
table settings of the query values and is recommended.

You can select to enable or disable the pre-defined table settings of
the query values, although this is not recommended.

5. Click Create.

Figure 16: Sample report with Report column as Caller and Sort column as Duration

Report column Sort column

Detailed| Calls_by_Duration

Call Usage Detailed [ Internal/External, Any Region, by Caller, Sort Duration ]

Caller Date Time | Receiver Trunk Duration | Cost{$)

"80@61" <80 | 2012-11-26 / Mon | 16:02 [ 6136978752 | freephoneline | 00:00:10 0.00

2012-11-27 / Tue | 11:16 | 6136978752 | freephoneline | 00:00:13 0.00

Total 00:00-23]—_0.00 Call duration of caller
"6819" <6819= | 2012-11-26 / Mon | 16:14 | 7817 fuc60 00:00:02 0.00 80@61 <80>

2012-11-27 / Tue | 10:23 | 7817 fuc60 00:00:02 0.00 .

— 0000001000 Call duration of caller
Total 00:00:27 0.00 6819 <6819>

Note: Since the sort column is Duration and the call time of caller 80@61 <80> is longer, this
caller is placed before caller 6819 <6819>.

Configuring the report time period

When configuring a report profile, you can select the time span of log messages from which to
generate the report.

To configure the report time period

1. Go to Log & Report > Call Report > Call Report.

2. Expand Period.

3. Select the time span option you want. This sets the range of log data to include in the report.

e For Type, choose a relative time, such as Today, Yesterday, Last N hours, and so on. If you
select an option with an unspecified “N” value, enter the number of hours, days or weeks
in the Value field, as applicable.

¢ Set a specific time range. Set the start date and hour in From field and end date and hour
in To field.
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Configuring report email notifications

When configuring a report profile, you can have the FortiVoice unit email an attached copy of
the generated report, in either HTML or PDF file format, to designated recipients.

You can customize the report email notification. For more information, see “Customizing call
report and notification email templates” on page 108.

To configure an email notification
1. Goto Log & Report > Call Report > Call Report.
2. Expand Email.

3. Enter the email address of the person who will receive the report notification in the Mail to
field. Click + to enter more email addresses if necessary, or click - to remove an address.

4. In the Format field, select the format of the generated attachment, either Html or Pdf.

Configuring the report schedule

When configuring a report profile, you can select when the report will generate. Or, you can
leave it unscheduled and generate it on demand. See “Generating a report manually” on
page 289.

To configure the report schedule

1. Goto Log & Report > Call Report > Call Report.
2. Expand Schedule.

3. Configure the following:

GUI field Description

Type e None: Select if you do not want the FortiVoice unit to generate
the report automatically according to a schedule. If you select this
option, the report can only be generated on demand. See
“Generating a report manually” on page 289.

e Daily: Select to generate the report each day. Also configure Hour.

e Weekdays: Select to generate the report on specific days of each
week, then select those days in These weekdays. Also configure
Hour.

e These dates: Select to generate the report on specific date of
each month, then enter those date numbers in These days. Also
configure Hour.

Choosing call rate

You can choose the call rate for calculating the phone bills. For information on setting the call
rates, see “Setting call rates” on page 289.
To choose the call rate
1. Goto Log & Report > Call Report > Call Report.
2. Expand Rate Setting.
3. Select an available rate and click -> to move it to the Selected rates field.
Only one call rate is allowed per report.
4. Click Create.
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Generating a report manually

You can always generate a report on demand whether the report profile includes a schedule or
not.

To manually generate a report
Go to Log & Report > Call Report > Call Report.
Click to select the report profile whose settings you want to use when generating the report.

1.
2.
3.

Click Generate.

The FortiVoice unit immediately begins to generate a report. To view the resulting report, see
“Viewing generated reports” on page 32.

Setting call rates

The Log & Report > Call Report > Rate tab lets you set call rates for calculating phone bills.

To

set call rates

1. Go to Log & Report > Call Report > Rate and click New.
2. Configure the following:

3.
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Figure 17: Setting call rate

Mame:

Trunk: —MNone—
Local 0

Long distance: | 0
International: | 0

Other rate: 0
Comment:

Create Cancel

GUI field
Name

Trunk

Local

Long distance
International
Other rate

Comment

Click Create.

Rating

(Cent)
(Cent)
(Cent)
(Cent)

Description

Enter a name for the rating profile.

Select the trunk that will use the rates.
Enter the rate for local phone calls.

Enter the rate for long-distance phone calls.
Enter the rate for international phone calls.
Enter the rate for other types of phone calls.

Enter any notes you have for this rating profile.
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Configuring Station Messaging Detail Record (SMDR)

FortiVoice SMDR component provides FortiVoice call detail records to third party devices on
certain communication and format protocols based on third party's device requirements. For
example, Property Management System (PMS) uses the FortiVoice SMDR to manage hotel
guest call charges.

Configuring FortiVoice SMDR requires advanced SMDR knowledge and should be performed

.g by advanced administrative users and field engineers.

This section contains the following topics:

¢ Configuring SMDR settings
e Setting SMDR formats

Configuring SMDR settings
Configure SMDR settings to enable the FortiVoice communications with third party devices.

To configure SMDR settings

1. Goto Log & Report > SMDR Settings > SMDR.

2. Select Enabled to activate the FortiVoice SMDR function.

3. Select a format protocol for the FortiVoice communications with the third party devices.
For information on format, see “Setting SMDR formats” on page 290.

4. For Port, enter the port number that connects to the third party devices.

5. For Max clients, enter the number of third party devices to which the FortiVoice unit provides
SMDR. The range is 1-10.

6. For Trusted hosts, enter the IP address and netmask of the third party device.
If you have multiple third party devices, you may enter up to 10 trusted hosts.
7. Click OK.

Setting SMDR formats

To communicate with third party devices, the FortiVoice SMDR format needs to be defined
based on the device requirements so that the devices can recognize the FortiVoice SMDR.

The FortiVoice unit provides example XML SMDR format files. You can modify the files to meet
with your needs. The following is an example format file:
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Figure 18: Example SMDR format file

<smdr_type id="Fortivoice" >
<discard_fitter=
<field name="Disposition” value="NO ANSWER"/>
</discard_filtar>
<formatting>
<field name="UnigueID" length="20"/>
<field name="StartTime" length="20"/=>
<field name="End Time" length="20"/>
=field name="SourceForti" length="10"/=>
<fiald name="DestinationFort" length="10"/=>
<field name="Duration"” length="8"/>
<field type="text" value="@"/>
<field type="line_break"/=
<field type="line_break"/=
</formatting=
<fsmdr_type>

An SMDR format is composed of parts as shown in the above example:

e smdr_type id: the name of the SMDR format file.
e discard_filter: the data you do not want to send to the third party devices.

e formatting: the body of the SMDR format file in the form of field values (for example, <field
name="AnswerTime"/>), plus the field lengths (for example, length="13") required by the
third party devices.

To set SMDR format
1. Goto Log & Report > SMDR Settings > Formats.
2. Select an example format file and click Edit.

3. Click Available FortiVoice SMDR field names to display the complete list of FortiVoice SMDR
field names.

4. Follow the SMDR format requirements of the third party device and the example format file
above, choose the displayed FortiVoice field names you need to set your SMDR format.

5. Click OK.

6. If errors appear, click SMDR types XML to view the Fortinet SMDR format file and correct
your format file accordingly.

Configuring alert email

The Alerts submenu lets you configure the FortiVoice unit to notify selected users (including
administrators) by email when specific types of events occur and are logged. For example, if
you require notification about system activity event detections, you can have the FortiVoice unit
send an alert email message whenever the FortiVoice unit detects a system activity event.

To set up alerts, you must configure both the alert email recipients (see “Configuring alert
recipients” on page 292) and which event categories will trigger an alert email message (see
“Configuring alert categories” on page 292).

Alert email messages also require that you supply the FortiVoice unit with the IP address of at
least one DNS server. The FortiVoice unit uses the domain name of the SMTP server to send
alert email messages. To resolve this domain name into an IP address, the FortiVoice unit must
be able to query a DNS server. For information on DNS, see “Configuring DNS” on page 47.

You can customize the alert email. For more information, see “Customizing call report and
notification email templates” on page 108.

This section contains the following topics:

e Configuring alert recipients
e Configuring alert categories
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Configuring alert recipients
Before the FortiVoice unit can send alert email messages, you must create a recipient list.

To configure recipients of alert email messages
1. Goto Log & Report > Alerts > Configuration.

Figure 19: Alert email configuration

B New... | T Test

| Alert Email Account

user! @example.com
userZ{@example.com

userHTexample.com

GUI field Description

Test Select one or more email accounts and click Test to verify that
(button) alert email is configured correctly. This sends a sample alert email
to all selected recipients.

Alert Email Account Displays the names of email accounts receiving email alerts.

2. Click New to add the email address of a recipient.
A single-field dialog appears.

3. In Email to, enter a recipient email address.

4. Click Create.

5. Repeat the previous steps to add more users.

Configuring alert categories

Before the FortiVoice unit can send alert email messages, you must specify which events cause
the FortiVoice unit to send an alert email message to your list of alert email recipients (see
“Configuring alert recipients” on page 292).

To select events that will trigger an alert email message

1. Goto Log & Report > Alerts > Categories.

2. Select one or more of the following event categories check boxes:

Table 9: Alert email category choices

GUI field Description

Critical events Send an alert email message when the FortiVoice unit detects a system
error that may affect its operation.

Disk is full Send an alert email message when the hard disk of the FortiVoice unit
is full.

HA events Send an alert email message when any high availability (HA) event
occurs.

Archive quotais  Send an alert email message when the recorded call archiving account

exceeded reaches its quota of hard disk space. For information about recorded
call archiving account quota, see “Archiving recorded calls” on
page 255.
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Table 9: Alert email category choices

GUI field

Deferred emails #
over

Description

Send an alert email message if the deferred email queue contains
greater than this number of email messages. Enter a number between 1
and 10 000 to define the alert threshold, then enter the interval of time
between each alert email message that the FortiVoice unit will send
while the number of email messages in the deferred email queue
remains over this limit.

Daily call summary Send an alert email with a daily call summary including the number of

PRI alarm
FXO alarm

Trunk lines are
saturated

Massive SIP
authentication
failure

Click Apply.

total calls, long distance calls, and international calls.

You need to enter the time for generating the summary which is for the
24 hours period prior to the time you set. For example, if you set 9 for
Schedule at hour, the summary will be for the period from 9am of the
previous day to 9am of the day when you receive the alert email.

Send an alert email when the PSTN digital line has a problem. This
option is not available for FortiVoice 200D.

Send an alert email when the PSTN analog line has a problem. This
option is not available for FortiVoice 200D.

Send an alert email when the SIP/PSTN/PRI trunk lines are fully
occupied.

SIP trunk alert only works if you select Overflow check when
configuring SIP trunk. See “Setting up VolP trunks” on page 177.

Send an alert email when big scale SIP authentication sessions fail.
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Installing firmware

Fortinet periodically releases FortiVoice firmware updates to include enhancements and
address issues. After you have registered your FortiVoice unit, FortiVoice firmware is available
for download at http://support.fortinet.com.

New firmware can also introduce new features which you must configure for the first time.

For information specific to the firmware release version, see the Release Notes available
with that release.

In addition to major releases that contain new features, Fortinet releases patch releases that
resolve specific issues without containing new features and/or changes to existing features. It
is recommended to download and install patch releases as soon as they are available.

Before you can download firmware updates for your FortiVoice unit, you must first register
your FortiVoice unit with Fortinet Technical Support. For details, go to
http://support.fortinet.com/ or contact Fortinet Technical Support.

This section includes:
¢ Testing firmware before installing it
¢ Installing firmware

¢ (Clean installing firmware

Testing firmware before installing it

You can test a new firmware image by temporarily running it from memory, without saving it to
disk. By keeping your existing firmware on disk, if the evaluation fails, you do not have to
re-install your previous firmware. Instead, you can quickly revert to your existing firmware by
simply rebooting the FortiVoice unit.

To test a new firmware image

1. Connect your management computer to the FortiVoice console port using an RJ-45 to DB-9
serial cable or a null-modem cable.

Initiate a connection from your management computer to the CLI of the FortiVoice unit.
Connect port1 of the FortiVoice unit directly or to the same subnet as a TFTP server.
Copy the new firmware image file to the root directory of the TFTP server.

a Db

Verify that the TFTP server is currently running, and that the FortiVoice unit can reach the
TFTP server.

To use the FortiVoice CLI to verify connectivity, enter the following command:
execute ping 192.168.2.99

where 192.168.2.99 is the IP address of the TFTP server.

Enter the following command to restart the FortiVoice unit:
execute reboot
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6. As the FortiVoice units starts, a series of system startup messages are displayed.
Press any key to display configuration menu........

Immediately press a key to interrupt the system startup.

\ | You have only 3 seconds to press a key. If you do not press a key soon enough, the FortiVoice
VY unit reboots and you must log in and repeat the execute reboot command.

If you successfully interrupt the startup process, the following messages appears:
[G]: Get Firmware image from TFTP server.
[F1: Format boot device.
[B]: Boot with backup firmware and set as default.
[1]: Configuration and information.
[Q]: Quit menu and continue to boot with default firmware.
[H]: Display this list of options.

Enter G,F,B,1,Q,0r H:
7. Type G to get the firmware image from the TFTP server.

The following message appears:
Enter TFTP server address [192.168.2.99]:

8. Type the IP address of the TFTP server and press Enter.
The following message appears:
Enter Local Address [192.168.2.99]:

9. Type atemporary IP address that can be used by the FortiVoice unit to connect to the TFTP
server.

The following message appears:
Enter File Name [image.out]:

10.Type the firmware image file name and press Enter.

The FortiVoice unit downloads the firmware image file from the TFTP server and displays a
message similar to the following:

Save as Default firmware/Backup firmware/Run image without
saving:[D/B/R]

Type R.

The FortiVoice image is loaded into memory and uses the current configuration, without
saving the new firmware image to disk.

11.To verify that the new firmware image has been loaded, log in to the CLI and type:
get system status

12.Test the new firmware image.

¢ [f the new firmware image operates successfully, you can install it to disk, overwriting the
existing firmware, using the procedure “Installing firmware” on page 296.

e |f the new firmware image does not operate successfully, reboot the FortiVoice unit to
discard the temporary firmware and resume operation using the existing firmware.
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Installing firmware

You can use either the web-based manager or the CLI to upgrade or downgrade the firmware of
the FortiVoice unit.

Administrators whose access profile contains Read-Write access in the Others category, such
as the admin administrator, can change the FortiVoice firmware.

Firmware changes are either:

® an upgrade to a newer version
e areversion to an earlier version

To determine if you are upgrading or reverting your firmware image, examine the firmware
version number. For example, if your current firmware version is FortiVoice-200D
2.00,build0082,120827, changing to FortiVoice-200D 2.00,build0081,120801, an
earlier build number and date, indicates that you are reverting.

Reverting to an earlier version may cause the FortiVoice unit to remove parts of the
configuration that are not valid for that earlier version. In some cases, you may lose all call data
and configurations.

When upgrading, there may also be additional considerations. For details, see “Upgrading” on
page 300.

Therefore, no matter if you are upgrading or downgrading, it is always a good practice to back
up the configuration and call data. For details, see “Backing up configuration” on page 102.

To install firmware using the web-based manager
1. Log in to the Fortinet Technical Support web site, https://support.fortinet.com/.
2. Download the firmware image file to your management computer.

3. Log in to the web-based manger as the admin administrator, or an administrator account
that has system configuration read and write privileges.

4. Install firmware in one of two ways:

e Go to Monitor > System Status > Status, and in the System Information area, in the
Firmware version row, click Update. Click Browse to locate the firmware and then click
Upload.

¢ Go to System > Maintenance > Configuration, under Restore Firmware, click Browse to
locate the firmware. Then click Restore.

Your web browser uploads the firmware file to the FortiVoice unit. The FortiVoice unit installs
the firmware and restarts. Time required varies by the size of the file and the speed of your
network connection.

If you are downgrading the firmware to a previous version, the FortiVoice unit reverts the
configuration to default values for that version of the firmware. You must either reconfigure
the FortiVoice unit or restore the configuration file.

5. Clear the cache of your web browser and restart it to ensure that it reloads the web-based
manager and correctly displays all changes.

6. To verify that the firmware was successfully installed, log in to the web Ul and go to
Monitor > System Status > Status. Text appearing in the Firmware version row indicates the
currently installed firmware version.

To install firmware using the CLI

1. Log in to the Fortinet Technical Support web site, https://support.fortinet.com/.

2. Download the firmware image file to your management computer.
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10.

11.

12.

Fortinet Technologies Inc.

Connect your management computer to the FortiVoice console port using an RJ-45 to DB-9
serial cable or a null-modem cable.

Initiate a connection from your management computer to the CLI of the FortiVoice unit, and
log in as the admin administrator, or an administrator account that has system configuration
read and write privileges.

Connect port1 of the FortiVoice unit directly or to the same subnet as a TFTP server.
Copy the new firmware image file to the root directory of the TFTP server.

Verify that the TFTP server is currently running, and that the FortiVoice unit can reach the
TFTP server.
To use the FortiVoice CLI to verify connectivity, enter the following command:
execute ping 192.168.2.99
where 192.168.2.99 is the IP address of the TFTP server.
Enter the following command to download the firmware image from the TFTP server to the
FortiVoice unit:
execute restore image tftp <name_str> <tftp_ipvs>
where <name_str> is the name of the firmware image file and <tftp_ipv4> is the IP

address of the TFTP server. For example, if the firmware image file name is image.out and
the IP address of the TFTP server is 192.168.2.99, enter:

execute restore image tftp image.out 192.168.2.99

One of the following messages appears:
This operation will replace the current firmware version!
Do you want to continue? (y/n)

or:
Get image from tftp server OK.
Check image OK.
This operation will downgrade the current Ffirmware version!
Do you want to continue? (y/n)

Typey.

The FortiVoice unit downloads the firmware image file from the TFTP server. The FortiVoice
unit installs the firmware and restarts. Time required varies by the size of the file and the
speed of your network connection.

If you are downgrading the firmware to a previous version, the FortiVoice unit reverts the
configuration to default values for that version of the firmware. You must either reconfigure
the FortiVoice unit or restore the configuration file.

If you also use the web-based manager, clear the cache of your web browser and restart it to
ensure that it reloads the web-based manager and correctly displays all tab, button, and
other changes.

To verify that the firmware was successfully installed, log in to the CLI and type:

get system status
If you have downgraded the firmware version, reconnect to the FortiVoice unit using its
default IP address for port1, 192.168.1.99, and restore the configuration file. For details, see

“Reconnecting to the FortiVoice unit” on page 298 and “Restoring the configuration” on
page 299.

If you have upgraded the firmware version, to verify the conversion of the configuration file,
see “Verifying the configuration” on page 300. If the upgrade is unsuccessful, you can
downgrade the firmware to a previous version.

Page 297 FortiVoice Phone System 5.3.0 Administration Guide


http://www.fortinet.com/

Reconnecting to the FortiVoice unit

After downgrading to a previous firmware version, the FortiVoice unit reverts to default settings
for the installed firmware version, including the IP addresses of network interfaces through
which you connect to the FortiVoice web-based manager and/or CLI.

If your FortiVoice unit has not been reset to its default configuration, but you cannot connect
to the web-based manager or CLI, you can restore the firmware, resetting the FortiVoice unit
to its default configuration in order to reconnect using the default network interface IP
address. For more information, see “Clean installing firmware” on page 301.

To reconnect using the CLI

1.

serial cable or a null-modem cable.

Select the following port settings and click OK:
Table 10: Port settings

Bits per second 9600
Data bits 8
Parity None
Stop bits 1
Flow control None

The login prompt appears.

The following prompt appears:

Welcome!

Fortinet Technologies Inc.

Press Enter to connect to the FortiVoice CLI.

Type admin and press Enter twice.

Page 298

Connect your management computer to the FortiVoice console port using an RJ-45 to DB-9

Start HyperTerminal, enter a name for the connection and click OK.

Configure HyperTerminal to connect directly to the communications (COM) port on your
computer and click OK.
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7.

Enter the following command:

set system interface <interface_str> mode static ip <address_ipv4>
<mask_ipv4>

where:

¢ <interface_str> is the name of the network interface, such as portl

e <address_ipv4>is the IP address of the network interface, such as 192.168.1.10
e <mask_ipv4> is the netmask of the network interface, such as 255.255.255.0

Enter the following command:
set system interface <interface_str> config allowaccess
<accessmethods_str>
where:

e <interface_str> is the name of the network interface configured in the previous step,
such as portl

e <accessmethods_str>is a space-delimited list of the administrative access protocols
that you want to allow on that network interface, such as ping ssh https

The network interface’s IP address and netmask is saved. You can now reconnect to either
the web Ul or CLI through that network interface. For information on restoring the
configuration, see “Restoring the configuration” on page 299.

Restoring the configuration

You can restore a backup copy of the configuration file from your local PC using either the
web-based manager or CLI. For information about configuration backup, see “Backing up
configuration” on page 102.

If you have just downgraded or restored the firmware of the FortiVoice unit, restoring the
configuration file can be used to reconfigure the FortiVoice unit from its default settings.

To
1.

To
1.

2.

3.

Fortinet Technologies Inc.

restore the configuration file using the web Ul

Clear your browser’s cache. If your browser is currently displaying the web-based manager,
also refresh the page.

Log in to the web-based manager.
Go to System > Maintenance > Configuration.

Under Restore Configuration, click Browse to locate and select the configuration file that you
want to restore, then click Restore.

The FortiVoice unit restores the configuration file and reboots.Time required varies by the
size of the file and the speed of your network connection.

After restoring the configuration file, verify that the settings have been successfully loaded.
For details on verifying the configuration restoration, see “Verifying the configuration” on
page 300.

restore the configuration file using the CLI

Initiate a connection from your management computer to the CLI of the FortiVoice unit, and
log in as the admin administrator, or an administrator account that has system configuration
read and write privileges.

Connect a network interface of the FortiVoice unit directly or to the same subnet as a TFTP
server.

Copy the new firmware image file to the root directory of the TFTP server.
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4. Verify that the TFTP server is currently running, and that the FortiVoice unit can reach the
TFTP server.

To use the FortiVoice CLI to verify connectivity, enter the following command:
execute ping 192.168.2.99
where 192.168.2.99 is the IP address of the TFTP server.
5. Enter the following command:
execute restore config tftp <file_name> <tftp_ipv4>
The following message appears:
This operation will overwrite the current settings!
(The current admin password will be preserved.)
Do you want to continue? (y/n)
6. Entery.

The FortiVoice unit restores the configuration file and reboots. Time required varies by the
size of the file and the speed of your network connection.

7. After restoring the configuration file, verify that the settings have been successfully loaded.
For details on verifying the configuration restoration, see “Verifying the configuration” on
page 300.

Verifying the configuration

After installing a new firmware file, you should verify that the configuration has been
successfully converted to the format required by the new firmware and that no configuration
data has been lost.

In addition to verifying successful conversion, verifying the configuration also provides
familiarity with new and changed features.

To verify the configuration upgrade
1. Clear your browser’s cache and refresh the login page of the web-based manager.
2. Log in to the web-based manager using the admin administrator account.

Other administrator accounts may not have sufficient privileges to completely review the
configuration.

3. Review the configuration and compare it with your configuration backup to verify that the
configuration has been correctly converted.

Upgrading

If you are upgrading, it is especially important to note that the upgrade process may require a
specific path. Very old versions of the firmware may not be supported by the configuration
upgrade scripts that are used by the newest firmware. As a result, you may need to upgrade to
an intermediate version of the firmware first, before upgrading to your intended version.
Upgrade paths are described in the Release Notes.

Before upgrading the firmware of the FortiVoice unit, for the most current upgrade
information, review the Release Notes for the new firmware version. Release Notes are
available from http://support.fortinet.com when downloading the firmware image file.

Release Notes may contain late-breaking information that was not available at the time this
guide was prepared.
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Clean installing firmware

>

Clean installing the firmware can be useful if:

e you are unable to connect to the FortiVoice unit using the web-based manager or the CLI

¢ you want to install firmware without preserving any existing configuration

¢ a firmware version that you want to install requires that you format the boot device (see the
Release Notes accompanying the firmware)

Unlike upgrading or downgrading firmware, clean installing firmware re-images the boot device.
Also, a clean install can only be done during a boot interrupt, before network connectivity is
available, and therefore requires a local console connection to the CLI. A clean install cannot
be done through a network connection.

Back up your configuration before beginning this procedure, if possible. A clean install resets
the configuration, including the IP addresses of network interfaces. For information on
backups, see “Backing up configuration” on page 102. For information on reconnecting to a
FortiVoice unit whose network interface configuration has been reset, see “Reconnecting to
the FortiVoice unit” on page 298.

If you are reverting to a previous FortiVoice version, you might not be able to restore your
previous configuration from the backup configuration file.

To clean install the firmware

1. Download the firmware file from the Fortinet Technical Support web site,
https://support.fortinet.com/.

2. Connect your management computer to the FortiVoice console port using an RJ-45 to DB-9
serial cable or a null-modem cable.

3. Initiate a local console connection from your management computer to the CLI of the
FortiVoice unit, and log in as the admin administrator, or an administrator account that has
system configuration read and write privileges.

4. Connect port1 of the FortiVoice unit directly to the same subnet as a TFTP server.
5. Copy the new firmware image file to the root directory of the TFTP server.

6. Verify that the TFTP server is currently running, and that the FortiVoice unit can reach the
TFTP server.

To use the FortiVoice CLI to verify connectivity, if it is responsive, enter the following
command:

execute ping 192.168.2.99
where 192.168.2.99 is the IP address of the TFTP server.

7. Enter the following command to restart the FortiVoice unit:
execute reboot

or power off and then power on the FortiVoice unit.

8. As the FortiVoice units starts, a series of system startup messages are displayed.
Press any key to display configuration menu........
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9. Immediately press a key to interrupt the system startup.

\ | You have only 3 seconds to press a key. If you do not press a key soon enough, the FortiVoice
VY unit reboots and you must log in and repeat the execute reboot command.

If you successfully interrupt the startup process, the following messages appear:
[G]: Get Firmware image from TFTP server.
[F1: Format boot device.
[B]: Boot with backup firmware and set as default.
[1]: Configuration and information.
[Q]: Quit menu and continue to boot with default firmware.
[H]: Display this list of options.

Enter G,F,B,1,Q,0r H:

10.If the firmware version requires that you first format the boot device before installing
firmware, type F. (Format boot device) before continuing.

11.Type G to get the firmware image from the TFTP server.

The following message appears:
Enter TFTP server address [192.168.2.99]:

12.Type the IP address of the TFTP server and press Enter.

The following message appears:
Enter Local Address [192.168.1.188]:

13.Type a temporary IP address that can be used by the FortiVoice unit to connect to the TFTP
server.

The following message appears:
Enter File Name [image.out]:

14.Type the firmware image file name and press Enter.

The FortiVoice unit downloads the firmware image file from the TFTP server and displays a
message similar to the following:

Save as Default firmware/Backup firmware/Run image without
saving:[D/B/R]

15.Type D.

The FortiVoice unit downloads the firmware image file from the TFTP server. The FortiVoice
unit installs the firmware and restarts. Time required varies by the size of the file and the
speed of your network connection.

The FortiVoice unit reverts the configuration to default values for that version of the firmware.

16.Clear the cache of your web browser and restart it to ensure that it reloads the web-based
manager and correctly displays all tab, button, and other changes.

17.To verify that the firmware was successfully installed, log in to the CLI and type:
get system status

The firmware version number appears.

18.Either reconfigure the FortiVoice unit or restore the configuration file from a backup. For
details, see “Restoring the configuration” on page 299.
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Appendix A: Installing Click-to-Dial
software

If you use MicroSoft Outlook, you can install the FortiVoice Click-to-Dial plugin to dial the phone
numbers of your contacts.

For information on installing the software, go to FortiVoice Click-to-Dial Software Installation.

Step 4 in the instructions is specific to FortiVoice 40/70/100 models. For FortiVoice
200D/200D-T, do the following:

e System IP Address: Enter the FortiVoice IP address. For details, see “Configuring the
network interfaces” on page 41.

e User Extension #: Enter the user ID of the extension. For details, see “Configuring IP
extensions” on page 135.

¢ Password: Enter the password used for configuring your SIP phone from the phone or the
Web. For details, see “Configuring IP extensions” on page 135.
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